Разработчики

Учебное пособие
Компьютерные Телекоммуникационные Сети

HOME

E-MAIL

CREATORS

Введение

Описание
Особенности

Материал

Предмет ТКС
Курс усвоения

ИДЕЙНЫЙ СОЮЗ!

Пособие было разработано выпускниками Башкирского Строительного Колледжа как дипломный проект. Для правильного построения материала использовался тематический курс данных предметов и консультации учебного комитета по дипломной практике. Учебное пособие разработано в помощь преподавателю для правильного и интересного построения лекций, и будет интересно не только узкому кругу лиц, а также массовому пользователю как источник повышения знаний в данных областях.

МЫ РАДЫ, ЕСЛИ ВЫ ВИДИТЕ ЭТО!


Описание

Учебное пособие
Компьютерные Телекоммуникационные Сети

HOME

E-MAIL

CREATORS

Введение

Описание
Особенности

Материал

Предмет ТКС
Курс усвоения

ВВЕДЕНИЕ!

За последние десятилетия наблюдается существенное увеличение объемов и сложности учебных материалов, изучаемых в средней и высшей школах. При этом во многих учебных заведениях наблюдается недостаток высококвалифицированных преподавательских кадров. Большие трудности часто возникают при оперативной подготовке, изготовлении и распространении учебных пособий различных видов. Указанные факторы негативно сказываются на качестве подготовки обучаемых. В связи с этим большое внимание уделяется применению прогрессивных методик обучения, в том числе предполагающих использование вычислительной техники.

Лишь очень немногие из тех, кто работает в области создания таких программ, намереваются создать средство, предназначенное для замены учителя в классной аудитории. Самое большое, на что можно реально рассчитывать, - это надеяться, что эти системы облегчат труд учителя, освободив его от функций которые учитель и так почти не может выполнить, а именно на протяжении всего курса предмета, на каждом этапе немедленно после усвоения материала контролировать результат. Тогда у учителя будет больше возможностей для выполнения задач, которые под силу только человеку-учителю и в выполнении которых никакая машина не может его заменить.


Особенности

Учебное пособие
Компьютерные Телекоммуникационные Сети

HOME

E-MAIL

CREATORS

Введение

Описание
Особенности

Материал

Предмет ТКС
Курс усвоения

НАШИ ОСОБЕННОСТИ!

Принципы обучения имеют прямое отношение к разработке автоматизированных обучающих систем и поэтому мы постарались выделить наиболее яркие моменты, послужившие построению структуры учебного пособия:

1. Обучение идет быстрее и усваивается глубже, если учащийся проявляет активный интерес к изучаемому предмету.

2. Поскольку обучение само по себе индивидуально, процесс обучения следует организовать так, чтобы каждый ученик мог проходить программу соответственно своим индивидуальным особенностям. По ряду причин одни усваивают материал быстрее других, поэтому обучение тех и других в одной группе затруднительно.

3. Процесс обучения должен укладываться в отведенные часы, поэтому будет актуальным правильное распределение времени.


Организация tkc

Учебное пособие
Компьютерные Телекоммуникационные Сети

HOME

E-MAIL

CREATORS

Введение

Описание
Особенности

План проведения лекций по предмету:
Телекоммуникационные Компьютерные Сети
(в часах).

Раздел 1. Основы работы сетей (20 /4 часов)
1.1 История возникновения сетей. 2
1.2 Назначение сети. Основные функции сети и предоставляемые ею услуги. 2
1.3 ЛВС – назначение и типы. 2
1.4 Топология локальной сети.2
1.5 Преимущества и недостатки. 2
1.6 Региональные и глобальные сети. 2
1.7 Принцип построения дерева каталогов. 2
1.8 Назначение и создание дерева каталогов. 2
1.9 Иерархия прав доступа к дереву каталогов. 2
1.10 Команды для работы с деревом каталогов. 2
1.11 Вход, перемещение, объединение элементов дерева каталогов. 2
1.12 Основы работы сетей. 2

Раздел 2. Установка (инсталляция) сети (6/2 часов)
2.1 Этапы установки сети. 2
2.2 Hardware или устройства, необходимые для создания сети. 2
2.3 Software или программное обеспечение, необходимое для инсталляции сетевых программных продуктов. 2
2.4 Установка (инсталляция) сети. 2

Раздел 3. Организация сети (24/4 часов)
3.1 Организация информации на сервере. 2
3.2 Иерархическая структура информации на диске.
3.3 Структура каталогов.
3.4 Права доступа к файлам и каталогам. 2
3.5 Приемы выбора правильной комбинации прав доступа.
3.6 Совладелец и его права на файлы.
3.7 Права групп пользователей.
3.8 Организация систем защиты. 2
3.9 Структура каталогов и прав доступа к нему. 2
3.10 Разделяемые базы данных. 2
3.11 Управление печатью. 2
3.12 Перенаправление вывода на печать.
3.13 Сценарии входа. 2
3.14 Организация сети. 2

Раздел 4. Управление сетью (6/0 часа)
4.1 Управление сетью с рабочей станции. 2
4.2 Управление сетью с консоли сервера. Сетевой этикет и сетевая безопасность. 2
4.3 Аппаратное обеспечение сетей. Модем. Типы модемов и их назначение. 2

Раздел 5. Расширение сети (3/2 часа)
5.1 Создание «меню». Совместное использование ПО. 2
5.2 Совместное использование CD ROM, PRN, Сканера и другого сетевого оборудования.
5.3 Сравнительные характеристики ТКСетей.
5.4 Управление сетью. Расширение сети. 2

Раздел 6. Итоговые занятия (10 часов)
6.1 Э К З А М Е Н 10
Всего по дисциплине: 85 ЧАСОВ.


Образец теста, созданного JSTB

В.В.Путин - президент какой страны?

Армения
Россия
Соединенные Штаты Америки
Украина

Где размещен сайт Преподаватель-2000?

На сервере Кубанского государственного технологического университета
На сервере Атласа krasnodar.ru
На сервере Кубаньэлектросвязь kuban.ru
На Чертовых Куличках

Как зовут автора программы Java Script Text Builder Шутилова Ф.В.?

Василий Иванович
Валерий Федорович
Федор Валериевич

Вам нравится сайт "Преподаватель-2000" и Вы хотите скачать программу?

Да, конечно!
Подумаю....
Нет, ни за что!

Нажми на кнопку для завершения теста:

Подведем итоги. Если Вы набрали:

  • 0 баллов Вы иностранец, и впервые на сайте? Лови спонсора!
  • до 1 балла Да, Вы здесь явно случайно. Хоть из России, и то хорошо
  • 2-3 балла Неплохо, но нужно быть внимательнее, чаще заходить на сайт
  • 4 балла Отлично! Вы частый гость нашего сайта, наверняка отличник:-)

Тест создан программой Java Script Test Builder (C) Преподаватель-2000. Пишите: e-mail


Образец теста, созданного JSTB

?В.В.Путин - президент какой страны?
Армения
+Россия
Соединенные Штаты Америки
Украина

?Где размещен сайт Преподаватель-2000?
На сервере Кубанского государственного технологического университета
На сервере Атласа krasnodar.ru
На сервере Кубаньэлектросвязь kuban.ru
+На Чертовых Куличках

?Как зовут автора программы Java Script Text Builder Шутилова Ф.В.?
Василий Иванович
Валерий Федорович
+Федор Валериевич

?Вам нравится сайт "Преподаватель-2000" и Вы хотите скачать программу?
+Да, конечно!
Подумаю....
Нет, ни за что!

=0 баллов Вы иностранец, и впервые на сайте? Лови спонсора!
=до 1 балла Да, Вы здесь явно случайно. Хоть из России, и то хорошо
=2-3 балла Неплохо, но нужно быть внимательнее, чаще заходить на сайт
=4 балла Отлично! Вы частый гость нашего сайта, наверняка отличник:-)


Проверочное тестирование по ТКС

Название локальной сети?

LAN
NET
Internet
IE

Локальная сеть это ... ?

Вечно спотыкающиеся о провода люди
Связанные между собой модемом несколько независмых ПК
Несколько независимых ПК, связанные между собой какими-то проводами
Несколько ПК, предназначенные для решения однотипных задач

Для чего нужны локальные сети?

Для разделения дорогостоящих ресурсов
Для совместного использования дисковой памяти и печатающих устройств
Все ответы верны
Для совместного использования программных продуктов

Как называется ПК, предназначенный для управления печатью?

Выделенный сервер
Рабочая станция сети
Нет правильного ответа
Принт-сервер

Преимущества локальной сети?

Разделение аппаратных ресурсов (PRN, HDD, МЛ, DVD, сканеры и др.)
Все ответы верны
Разделение данных (БД, совместное использование документов, Эл.таблиц и др.)
Разделение программных продуктов
Разделение ресурсов МП

Локальная сеть необходима при ... ?

Совместном использовании одной БД несколькими ПК
Усложнении работы на одном ПК
Упрощении работы на ПК
Нет правильного ответа

Сеть на шнурках это ?

2 ПК, предназначенные для параллельной игры
2 башмака, связанные между собой
Сервер и клиент, отстоящие друг от друга на 2-3 метра
Нет правильного ответа

Одной из первых одноранговых сетевых систем была система ... ?

NET WARE Lite фирмы Novell
Lantastic
PC LAN фирмы IBM
Windows for Workgroups

К сетевым ОС относятся ?

Unix
Windows NT
Windows 98
Все перечисленные системы

Начало развития мультимедии и графики?

Начало 80 - х годов
Начало 90 - х годов
Начало 70 - х годов

Нажми на кнопку для завершения теста:


Компоненты сети

Одноранговая сеть это ... ?

Сеть с равноправными узлами
Сеть, для совместного использования файлов и БД
Все ответы верны
Сеть, для совмест-го использ-я дорогостоящих периферийных устройств
Нет правильного ответа

Для работы ПК в локальной сети необходимо?

Не все ответы верны
Установить в ПК коммуникационную аппаратуру
Установить сетевое ПО
Все ответы верны
Соединить ПК между собой кабелем

Компьютерная сеть должна включать в себя ...?

Некоторые из ответов верны
ПК в качестве рабочей станции
Высокопроизводительный ПК в качестве servera
Все ответы верны
Каждый ПК оснащен сетевым адаптером
Все ПК связаны между собой сетевым кабелем

Сеть должна включать в себя программные компоненты ... ?

Некоторые из ответов верны
Сетевую ОС
Все ответы верны
Сетевые приложения и утилиты (эл.почта, текстовые процессоры,эл.табл и др.)
Бизнес-приложения, реализующие бизнес-функции компании

Какая топология ЛВС является наиболее быстродействующей?

Кольцо
Общая шина
Звезда
Комбинированная
Нет правильных ответов

На какие 2 сети делилась ApraNet?

Token Ring, Arknet
MilNet, Apranet
Ethernet, Internet

Выберите номер неправильного ответа?

Соединение квадрат
Общая шина
Кольцо
Соединение звезда

Для чего нужен Internet?

Для работы
Для переписки
Для развлечений
Для поиска информации
Все перечисленное

Кому принадлежат права на Internet?

Фирме IBM
Фирме Microsoft
Никому
Бил Гейтсу

Как называются сети для игр?

E-mail
FidoNet
BatleNet
Games

Какой корпорацией создана сеть SPRINTNET?

SPRINT INTERTAIMENT
SPRINT INTERNATIONAL
SPRINT&NET
RELCOM

Что представляет собой сеть Internet?

Компьютерная сеть
Рыбацкая сеть
Локальная сеть
Информационная сеть

Что имеет каждый сайт или сервер в сети Internet?

Кличку (прозвище)
Уникальное имя
Фамилию Имя Отчество
Имя фирмы

Выделенный текст с подчеркиванием в Web-страницах это?

Гипертекстовая ссылка
Теги (команды)
Гипертекстовые странички
Сайт

Взаимосвязанный набор гипертекстовых страничек, размещенный на одном сервере?

Web-браузер
Web-сервер
Web-конференции

Что такое FidoNet?

Поисковая ситема в InterNet
Бесплатная общедоступная компьютерная сеть
Тип глобальной сети с пропускной способностью 2-10 Мbps

Server в сети это ...?

Удаленный ПК-сервер, выполняющий роль Кэша
ПК-хранящий Web-сайты
Постоянно подключенный в сеть ПК

Нажми на кнопку для завершения теста:


Internet. Глобальные компьютерные сети

Что такое рабочая станция или client-server?

ПК, пользующийся услугами, предоставляемыми серверами приложений и баз данных
ПК, которые выделяют свои ресурсы в сеть
ПК, которые потребляют ресурсы и выделяют в сеть свои ресурсы
Мощный ПК, для решения сложных математических задач

Для чего предназначен маршрутизатор?

Для обмена данными между отдельными ПК в ЛВС
Для пересылки пакетов данных из одной ЛВС в другую
Для обмена электронной почтой между ПК в Internete
Для участия в телеконференциях

Как называется обмен почтовыми сообщениями с любым абонентом сети Internet?

Сеть
Все перечисленные варианты верны
Электронная почта

Что означает WWW?

Сетевой протокол
Всемирная сеть
Всемирная паутина
Электронная почта
Все перечисленные варианты верны

Для чего нужен Internet?

Для работы
Для переписки
Для развлечений
Все перечисленное
Для поиска информации

Можно ли в сети разговаривать?

Нет
Да
Да - на английском языке
Да - по русски

В каком году создана компания Infonet?

1992 г
1970 г
1980 г
1961 г

Как называется электронный бюллетень новостей сети RELCOM?

The Telepuzing Hoteline
Newsbytes
The Teleputing Hoteline
News Network

В какаой сети оплате подлежит только информация, направленная за рубеж?

GlassNet
Rambler
Fidonet
DASNET

Что такое E-MAIL?

Название международной сети
Электронная почта
ОС отвечающая за хранение инфомации на сетевом диске
ОС отвечающая за передачу инфомации на сетевой диск

Что такое банер?

Кнопка выхода из сайта
Кнопка-ссылка на поисковую систему Yandex
Кнопка-ссылка на другую интернет-страничку
Система обмена данных в Internet

Как раньше назывался сервер?

Hst-компьютер
Hаst-компьютер
Hоst-компьютер
Hist-компьютер

Протокол, используемый для передачи сообщений?

SLIP
PPP
SMTP
POP3

Разовый объем пересылаемой информации в протоколе IP?

1000 символов
1500 символов
2000 символов
1750 символов

Какой протокол используется для приема сообщений?

SLIP
PPP
POP3
SMTP

Сколько символов информации можно переслать в одном пакете?

до 4000
до 3000
до 1500
до 256

Где находится почтовый ящик?

На рабочем компьютере
В Internet
На почтовом сервере

Выберите правильную учетную запись почтового ящика?

@rusradio.mail.ru
mail.ru@rusradio
rusradio@mail.ru
rusradio.mail.ru@

Чему равен максимальный размер почтового сообщения?

256 Кб
128 Кб
64 Кб
32 Кб

Как правильно расшифровывается аббревиатура ICQ?

Поиск нужной информации
Давай с тобой познакомимся
Я ищу тебя
Бюро занятости населения

Что такое Cisco?

Указатель, содержащийся в гипертексте Cisco
Разьем для подключения дополнительных устройств
Маршрутизатор, разработанный Cisco Systems
Фирма, специализирующаяся на выпуске серверов

Что такое DNS?

Имя Host компьютера
Доменная система имен
Язык обмена информацией между ПК

Что такое UDP?

Проткол с негарантированной доставкой почты
Протокол с гарантированной доставкой почты
Многозадачный режим работы в Internet

Что такое TCP/IP?

Протокол с негарантированной доставкой почты
Протокол с гарантированной доставкой почты
Адресная книга в сети Internet

Узел в сети это ...?

ПК в сети, выбирающий кратчайший путь
ПК в сети, выполняющий основные сетевые функции
ПК хранящий Web-сайты
Удаленный ПК-сервер, выполняющий роль Кэша

Шлюз это ...?

Компьютер в сети, выбирающий кратчайший путь к данным
ПК в сети, предоставляющий свои ресурсы пользователям
Станция связи с внешней или другой сетью
ПК в сети, выполняющий основные сетевые функции

Нажми на кнопку для завершения теста:


Установка сети

Протокол - это…?

Список пользователей сети
Изложенное на бумаге суть преступления
Набор соглашений о взаимодействии

Сколько уровней протоколов существует?

7
10
15
Нет правильного ответа

На каком уровне определяются электронные, механические, функциональные и процедурные параметры для физической связи в системах?

Канальном
Сетевом
Физическом
Нет правильного ответа

На каком уровне устанавливается связь в вычислительной сети между двумя абонентами?

Физическом
Сеансовом
Сетевом
Нет правильного ответа

Уникальный 32-битный адрес каждого ПК в сети Internet?

TCP-адрес
IP-адрес
Host
Нет правильного ответа

Desktop - это..?

Некоторые ответы верны
Рабочий стол Windows
Кнопка управления
Доска объявлений
Нет правильного ответа
Лежачий системный блок

Протокол "почтовый оффис"?

PPP
POP
TCP
Нет правильного ответа

Что позволило соединить ПК в Internet?

Мощный сервер
Большое количество желающих общаться друг с другом
Указ президента
Протокол IP

Совместное использование данных позволяет...?

Снизить затраты на их хранение
Снизить затраты на прикладное программное обеспечение
Снизить суммированную производительность отдельных ПК
Некоторые ответы верны
Все ответы верны

Какого типа сети более популярны?

Одноранговые
Все ответы верны
Клиент-сервер

Минимальный набор компонентов сети?

Источник
Приемник
Все ответы верны
Среда передачи или канал
Сообщение
Некоторые ответы верны

Что является непосредственным продолжением Internet в нашей стране?

Usenet
Fidonet
Relcom
Все ответы верны

Что такое Proxy?

Удаленный доступ
Главный сервер
Язык программирования
Удаленный ПК-сервер, выполняющий роль КЭШа

Сколько уровней имеет Х25-протокол?

3
4
5
6

Проект, который привел к созданию сети Internet?

Проект Applle
Проект Darpa
Нет правильного ответа

Файл содержащий параметры конкретного устройсва вывода информации?

Desktop
Profile
Temp
Нет правильного ответа

Тип локальной сети с пропускной способностью 2-10 Mbps?

Ethernet
Internet
Apranet

Программа для просмотра страницы Internet?

Java Script
Clipart
Browser
Все ответы верны

Нажми на кнопку для завершения теста:


Установка сети

Витая пара при длине кабеля до 1000 м. позволяет передавать информацию со скоростью:?

20 Мбит/с
100 Мбит/с
200 Мбит/с
Все ответы верны

Что такое Bridge?

Устройство обеспечивающая связь между сетями
Соединитель локальных и глобальных сетей
Маршрутизатор

Что такое Whois?

Многозадачная ОС
Стандартная системная шина
Адрестная книга в сети Internet

Как переводится термин ISO?

Информационная сформированная организация
Международноя организация по стандартизации
Биториентированноя передача информации

Какие компоненты непосредственно оказывают влияние на дальнейшее развитие информационных коммуникаций?

Компьютерноя технология
Монтаж систем обработки информации
Защита данных и безопастность от несанкционированного доступа
Все ответы верны

Основной элемент сети?

Утилиты
"Шнурки"
Файл-сервер
Жесткий диск

Что такое Топология локальных сетей?

ЛВС, в которой объединены в одну сеть участки типа "общая шина" и "звезда"
Все ответы верны
Конфигурация ЛВС

Что такое Internet?

Новая технология телекоммуникации
Сеть сетей
Текст, являющийся проводником в мире информации
Электронная почта

Как называется глобальная интернациональная сеть?

MILNET
APRANET
GLOBONET
INTERNET

Какой самый лучший кабель для сети?

Витая пара
Коаксиал
Оптоволоконный
Нет правильного ответа

Типы сетей?

Все ответы верны
Локальные сети
Некоторые ответы верны
Региональные сети
Многоранговые сети

Какое минимальное количество компьютеров требуется для создания ЛВС?

4 Компьютера
3 Компьютера
2 Компьютер
Все ответы верны
Некоторые ответы верны

Сколько жил в витой паре?

8
4
2
Все ответы верны

Какой вид соединения в ЛВС надежнее?

Коаксиал
Шина
Витая пара
Звезда

Каким образом осуществляется передача данных в Интернет?

С помощью пластиковых пакетов
Файлами
С помощью пакетов
Все ответы верны
Нет правильных ответов

Как называется компьютер, пользующийся услугами сервера?

Рабочее место
Hub
Router
Рабочая станция

С какой скоростью передаются данные в витой паре?

до 56 Мбит/с, при длинне до 500 м
до 56 Кбит/с, при длинне до 1000 м
до 100 Мбит/с, при длинне до 1000 м
до 100 Мбит/с, при длинне до 2000 м

Какие характеристики у толстого коаксиального кабеля без повторителя?

100 Ом до 500 м, с общей длинной до 1500 м
50 Ом до 500 м, с общей длинной до 3000 м
25 Ом до 1000 м, с общей длинной до 3000 м
50 Ом до 100 м, с общей длинной до 1000 м

Какие характеристики у тонкого коаксиального кабеля без повторителя?

25 Ом, до 500 м, с общей длинной до 1000 м
100 Ом, до 100 м, с общей длинной до 1000 м
50 Ом, до 185 м, с общей длинной до 1000 м
74 Ом, до 85 м, с общей длинной до 1000 м

Какой из перечисленных топологий не существует?

Звезда
Кольцо
Пружина
Шина

Как правильно пишется TCP/IP адрес ПК?

ZX5Q.PX2.Q11.1
192.168.111.212
192.1683.54.2
212X.3QPE.X25

Нажми на кнопку для завершения теста:


Установка сети

Какие существуют формы связи?

Все ответы верны
Нет правильных ответов
Графическая
Передача данных
Текстовая

Как называется сеть с равноправными узлами?

Сеть на "шнурках"
Глобальная сеть
Нет правильного ответа
Одноранговая сеть

Назовите всемирные сети?

Internet
Usenet
Decnet
Все ответы верны
Некоторые ответы верны

Какая сеть наиболее защищена от отказов системы?

Шина
Кольцо
Звезда
Снежинка

Какие сферы человеческой деятельности не могут существовать без компьютерных сетей?

Наука
Энергетика
Финансовая система
Все ответы верны
Некоторые ответы верны

В какой из топологий ЛВС есть концентратор Hub?

Звезда
Дерево
Снежинка
Общая шина
Кольцо
Все ответы верны
Некоторые ответы верны

Как называется сеть с выделенным сервером?

MAN - Metropolitan Area Network
Lan - local Area Network
Novel NetWare

Устройство, служащее для увеличения сети?

Fail server
Hub
Bridge

Чем соединяются локальные и глобальные сети?

Gateway
Bridge
Router

Сколько основных программных компонентов включает в себя сеть?

3
6
4

Как называется сеть, в которой каждый из компьютеров имеет доступ к ресурсам другого?

MAN-Metropolitan Area Network
PEEP-TO-PEEP Networks
WAN-Wide Area Network

Для чего служат сетевые протоколы?

Для обмена данными между ПК в сети
Для замены картриджа в принтере
Нет правильного ответа

В чем измеряется скорость обмена информации между ПК в ЛВС посредством сетевый адаптеров?

Mbps
Kbps
Бод
Некоторые ответы верны
Нет правильного ответа

Можно ли любому количеству компьютеров использовать один принтер посредством сетевой карты?

Нет
Да, если не более 5 шт.
Да
Нет правильного ответа

Сколько ПК в сети на "шнурках" можно объединить?

2
Сколько угодно
5

Количество ПК может быть в одноранговой сети?

2-10
10-15
15-20
Неограниченно

DATABASE SERVER - это…?

Сервер баз данных
Сервер даты
Сервер, отвечающий за работу сетевого принтера
Нет правильного ответа

Какой сетевой кабель наиболее быстрый?

Витая пара
Коаксиальный кабель
Оптоволоконный кабель

Три основных программных компонента сети?

Сетевые приложения и утилиты, бизнес приложения, графический редактор
Сетевая операционная система, бизнес приложения, сетевое приложение и утилиты
Бизнес приложения, сетевая операционная система, Microsoft Office

Главное свойство одноранговой сети?

Нет сервера
Быстродействие
Надежность
Некоторые ответы верны
Дешевизна

Нажми на кнопку для завершения теста:


10_1_TKC

USENET

В эпоху больших универсальных ЭВМ (mainframe), когда информационные системы создавались и велись на этих машинах, а о персональных компьютерах еще никто не знал, существовало разделение на системы информационного обмена и системы информационного обеспечения. К первым относили системы коммуникаций "пользователь-пользователь", а ко вторым собственно информационные системы (базы данных, информационно-поисковые системы и т.д.). Существенным в этой классификации было то, что в информации обмена участвовали сами пользователи, а информационное обслуживание осуществляли специальные группы администрации баз данных. По мере развития средств вычислительной техники в эту классификацию была внесена некоторая сумятица, так как на персональном компьютере разработка, ведение и использование осуществляется одним и тем же лицом. Средства телекоммуникаций позволили эти персональные системы сделать общедоступными для пользователей компьютерных сетей.
Однако по мере освоения новых технологий и разработки новых программных средств, "старое" разделение стало воспроизводится. При чтении обзоров по технологиям Internet можно обнаружить разделение систем по принципам функционального назначения аналогичным тем, которые обсуждались раньше.

Принцип организации и система групп Usenet

Usenet -- это система телеконференций Internet. Вообще говоря, термин телеконференция не очень удачен. В Internet есть другие средства, которые также реализуют принцип телеконференций. Ветераны Usenet предлагают придерживаться термина "newsgroup" или просто "group", который можно перевести как "группа новостей" или просто "группа". В сети существует несколько информационных ресурсов аналогичных Usenet. Это и Listserv, и BBS, однако ни один из них не организован как распределенная информационная система. Последнее значит, что в случае BBS или Listserv для каждой тематики выделена специальная машина, к которой обращаются пользователи со всего света. Аналогичным образом в сети ARPA были построены почтовые списки. В Usenet же нет центрального места хранения, и информация осуществляет постоянный круговорот в сети от сервера к серверу, от сервера к клиенту, от клиента к серверу. В Usenet следует различать смысловую и техническую стороны. С точки зрения информационного ресурса система организована как большой иерархический каталог. Узлы этого каталога -- группы новостей. Группа новостей -- это постоянно изменяющийся набор сообщений пользователей, которые интересуются предметной областью данной группы. Сообщения в группе обычно не задерживаются более нескольких дней (стандартное значение по умолчанию -- 5). Существует порядка десятка групп верхнего уровня, которые имеют свои подгруппы. Проиллюстрировать такую организацию можно на примере группы "comp" (компьютеры и компьютерные технологии).
Пользователь может выбрать одну или несколько подгрупп и осуществить на них подписку. Подписка подразумевает процедуру оповещения пользователя о появлении новых статей по интересующей его теме. Естественно, что пользователь и сам может отправить свое мнение, оформленное в виде сообщения, в группу. Сообщение оформляется в соответствии со стандартом почтового сообщения Internet (RFC-822). Фактически Usenet выполняет функции периодического издания. В настоящее время существует несколько тысяч групп -- от достаточно серьезных и профессионально-ориентированных до групп посвященных играм, шуткам и просто всякой всячине.

В настоящее время система серверов Usenet организована следующим образом:

организации Usenet вызывает некоторую путаницу. Объясняется она тем, что, с одной стороны, в системе используются почтовые сообщения Internet, а с другой стороны, многие пользуются услугами Usenet только по почте. Для того чтобы разобраться в этом вопросе, сделаем небольшой экскурс в историю развития Usenet. Пользователь осуществляет подписку на одном из серверов Usenet, который ближе для данного пользователя, обычно это машина, на которой расположены все информационные ресурсы организации или учебного заведения. По мере поступления новых сообщений от пользователей, серверы обмениваются между собой этой новой информацией. Пользователь может подписаться на любом сервере на любую группу новостей. Последний факт принципиально отличает Usenet от систем BBS и Listserv, где подписка осуществляется на машине, которая реально ведет списки сообщений. Каждый сервер ведет список подписчиков и список телеконференций, на которые осуществлена подписка. При поступлении статьи, сервер информирует известные ему серверы о том, что появилась новая информация и в случае запроса передает ее. Это взаимодействие осуществляется посредством протокола NNTP.

Новости USENET

USENET - это мировые электронные новости и одновременно клубы по интересам - так называемые ``newsgroups''( у нас принято говорить - "телеконференции"). Многое по развитию Linux делается через Internet и USENET, так что не удивляет существование ряда телеконференций USENET, посвященных Linux.
Первоначально была создана телеконференция alt.os.linux, чтобы вынести дискуссии по Linux из comp.os.minix. Но скоро трафик alt.os.linux вырос настолько, что в феврале 1992 года было проведено голосование о включении конференции в иерархию "comp" и создана телеконференция comp.os.linux.
comp.os.linux быстро стала одной из наиболее популярных (и шумных) телеконференций USENET, более популярной, чем другие группы иерархии comp.os. В декабре 1992, в результате голосования группа была разбита, чтобы уменьшить об'емы трафика, но только comp.os.linux.announce прошла тогда по голосованию. В июле 1993 , наконец-то группа была разбита на иерархию групп. За это проголосовало около 2000 человек - одно из самых больших голосований в истории USENET.
Если у вас нет прямого доступа к USENET, но имеется возможность посылать и получать письма по e-mail, то в Internet существуют шлюзы, через которые можно получать телеконференции:
comp.os.linux.announce
это моделируемая (контролируемая) телеконференция, содержащая объявления и важные сообщения относительно Linux (например, сообщения об ошибках, существенные исправления и т.п.). Если вы вообще собираетесь читать телеконференции Linux - эту читайте обязательно. Часто важные сообщения этой конференции не дублируются в другие. Также в этой же телеконференции бывают важные оперативные сообщения.
Любое сообщение в этой группе должно быть одобрено модераторами Matt Welsh и Lars Wirzenius. Если вы хотите выставить свое сообщение в этой группе, вы обычным порядком посылаете его в телеконференцию. Оно автоматически будет направлено для одобрения модератору. Но если ваша система новостей не настроена, можно направить статью электронной почтой по адресу linux-announce@tc.cornell.edu. Все остальные телеконференции этой иерархии linux, перечисленные ниже - немодерируемые.
comp.os.linux.help
Это наиболее популярная телеконференция Linux. Она предназначена для вопросов и ответов по использованию, установке и другим вопросам эксплуатации Linux. Если у вас проблемы с Linux - пишите в эту группу и с большой вероятностью получите ответ от кого-нибудь, способного вам помочь. Но очень желательно ознакомиться со всеми доступными вам материалами, прежде, чем задавать вопрос.
comp.os.linux.admin
Здесь обсуждаются вопросы эксплуатации Linux (обычно в многопользовательском режиме) Обсуждается работа администратора системы Linux (например, сохранение системы, работа с пользователями и т.п.).
comp.os.linux.development
Эта телеконференция для обсуждения проблем развития Linux. Вопросы, касающиеся ядра, системных библиотек и системных программ.. Эта конференция предназначена также для обсуждения целей и направления развития Linux, как это описывалось в Разделе 1.6.
Следует заметить, что эта телеконференция для обсуждения проблем разработки собственно Linux. Прикладное программирование в Linux обсуждается в других телеконференциях.
comp.os.linux.misc
Эта телеконференция для обсуждения проблем, не подходящих для других групп. Особенно для "защитников" Linux (для статей типа "Linux против Windows NT"). Всякие нетехнические окололинуксовские споры могут происходить здесь.
Следует заметить, что телеконференция comp.os.linux была заменена иерархией телеконференций. Если у вас есть доступ к comp.os.linux и нет доступа к другим телеконференциям этой иерархии, вдохновите администратора их завести.

Программное обеспечение Usenet

Для работы по протоколу NNTP разработано довольно много программ просмотра новостей. Это nn, rn, trn, xrn и другие. Как правило программы используют для просмотра меню и реализуют просмотр новостей в режиме скроллинга. Для пользователей MS-DOS существует довольно удобный интегрированный пакет min-uet. Minuet был разработан в университете штата Миннесота и включает в себя прием почты по протоколу popmail (109 порт TCP), отправку почты по протоколу SMTP (порт 25), доступ к базам данных Gopher (70 порт TCP) и просмотр новостей по протоколу NNTP (119 порт TCP). Программа выполнена в стандартном для PC полноэкранном варианте с падающими меню. Работает программа через пакетный драйвер. Такой же по внешнему виду является и программа PINE, которая также предназначена для работы с почтой и чтения новостей. У PINE и Minuet есть аналоги и для Unix-платформ. Не смотря на такой прогресс в развитии, до последнего времени наиболее популярным методом доступа в Usenet остается электронная почта. Подготавливая почтовое сообщение пользователь фактически записывает сценарий диалога с сервером NNTP, который затем будет выполнен почтовым роботом Usenet.
Завершая разговор о Usenet хочется еще раз обратить внимание на направление развития системы от системы двух машин к системе типа "STOP-GO" и далее к распределенной системе, работающей в режиме on-line. Такая тенденция прослеживается и в развитии системы электронной почты Internet, и в других информационных процедурах. Далее путь лежит к распределенным системам rеal-time, но это уже другой тип систем в соответствии с классификацией, введенной в начале раздела.

Тестирование


11_1_TKC

Этапы установки сети

Аппаратное обеспечение:

Для работы в ЛВС необходимо:
- иметь настольный ПК, подключенный к сети (его называют "клиен-том", или "рабочей станцией", или "клиент-сервером", реже автома-тизированными рабочими местами или сетевыми станциями)
- иметь выделенный сервер с HDD большой емкости. (Он играет роль центрального узла, на котором пользователи ПК могут хранить свою информацию, печатать файлы и обращать к его сетевым средствам)
- совместно используемые периферийные устройства (HDD, PRN, цветные и слайд-принтеры, CD ROM, плоттеры, сканеры и др.)
- соединить имеющиеся компьютеры посредством к-либо коммуника-ционной аппаратуры (сетевые адаптеры, платы, вставляемые в сво-бодный слот ПК. Для построения сетей применяют 8-, 16-, 32-битовые сетевые платы)
- запустить сетевое программное обеспечение
- соединить адаптеры между собой кабелем и доп.оборудованием (на-пример, адаптером Arcnet-Arcnet, Ethernet-Ethernet, но не Arcnet-Ethernet.
Тип сетевого кабеля:
- Витая пара (twisted pair) -позволяет передавать информацию со скоростью до 100 Мбит/с, при длине кабеля до 1000 м
- Коаксиальный кабель (толстый Ethernet) с волновым сопротивле-нием 50 Ом до 500 м без повторителя, с общей длиной до 3000 м
- Коаксиальный кабель (тонкий Ethernet) 50 Ом, до 185 м, с общей длиной до 1000 м.
- Оптоволоконные линии - наиболее дорогой тип кабеля, до 50 км.)
Программное обеспечение:
Сеть включает в себя ТРИ основных программных компонента:
- Сетевую операционную систему, которая управляет функционирова-нием сети. ОС состоит из серверного ПО и клиентского ПО (напри-мер Windows NT)
- Сетевые приложения и утилиты - программы инсталлируемые и вы-полняемые на сервере, сетевые приложения разработаны для приме-нения в сетях (Internet Explorer, Outlook Express, Access, Arch и др.)
- Бизнес приложения - это программы, реализующие в компании кон-кретные бизнес-функции.

Тестирование


12_1_TKC

Волоконно-оптический кабель.

Структурированная кабельная система является основополагающей базой на протяжении всего времени существования информационной сети. Правильно спроектированная, смонтированная и администрируемая кабельная система снижает расходы на эксплуатацию на всех фазах своей жизни.
Кабельная система является компонентом сети с самым продолжительным временем жизни, дольше которого существует только каркас здания. Кабельная система, созданная на основе стандартов, гарантирует долговременное функционирование сети и поддержку многочисленных приложений, обеспечивая отдачу инвестиций на всем протяжении ее существования.

Техническая характеристика.

Компания MELCO выпустит 2 модели модулей: LSM-OP-G1000S и LSM-OP-G1000L. Модель LSM-OP-G1000S оснащена портом 1000BASE-SX, позволяющим поддерживать оптико-волоконное соединение на расстояние до 550 метров. LSM-OP-G1000L с интерфейсом 1000BASE-LX делает возможным создание высокоскоростного оптико-волоконного соединения на расстояние до 5 км. Цены LSM-OP-G1000L и LSM-OP-G1000S составят 412 долларов и 742 доллара соответственно.

Технические характеристики LSM-OP-G1000S

Интерфейс локальной сети – стандарт IEEE802.3z (1000BASE-SX)
Скорость передачи данных - 1 Гбит в секунду
Способ кодировки в линии - 8B10B
Способ доступа - CSMA/CD
Кабель – оптико-волоконный кабель (multimode)
Размеры – Ш72хВ91хД24 мм
Масса – 50 грамм

Волоконно-оптические системы.

Волоконно-оптические линии связи (ВОЛС) - системы передачи, при которых информация передается по оптическим диэлектрическим волноводам, известным под названием "оптическое волокно".
Передача информации по ВОЛС имеет целый ряд достоинств перед передачей по медному кабелю:
скорость передачи информации.
значительная протяженность волоконно-оптических линий связи.
низкие потери при передаче сигнала.
хорошая помехозащищенность.
легкость прокладки
долгие сроки работы кабеля практически в любых условиях
Оптическое волокно изготавливается из кварца, основу которого составляет двуокись кремния, широко распространенного, а потому недорогого материала, в отличие от меди.
Важное свойство оптического волокна - долговечность. Время жизни волокна, то есть сохранение им своих свойств в определенных пределах, превышает 25 лет, что позволяет проложить оптико-волоконный кабель один раз и, по мере необходимости, наращивать пропускную способность канала путем замены приемников и передатчиков на более быстродействующие.

Витая пара.

Витая пара" (twisted pair) - это кабель на медной основе, объединяющий в оболочке одну или более пар проводников. Каждая пара представляет собой два перевитых вокруг друг друга изолированных медных провода. Кабели данного типа зачастую сильно отличаются по качеству и возможностям передачи информации. Соответствия характеристик кабелей определенному классу или категории определяют общепризнанные стандарты (ISO 11801 и TIA-568). Сами характеристики напрямую зависят от структуры кабеля и применяемых в нем материалов, которые и определяют физические процессы, проходящие в кабеле при передаче сигнала.
Помимо скорости распространения сигнала выделяют и другие важные характеристики кабеля типа "Витая пара". Одной из таких является погонное затухание (attenuation), характеризующей величину потери мощности сигнала при передачи. Характеристика вычисляется как отношение мощности полученного на конце линии сигнала к мощности сигнала, поданного в линию. Поскольку величина затухания изменяется с ростом частоты, она должна измеряться для всего диапазона используемых частот. Сама величина выражается в децибелах на единицу длины.

Коаксиальный кабель.

Раньше этот кабель был самым распространенным, в наше время от этого кабеля переходят га другие: витую пару или оптоволокно.
Коаксиальный кабель имеет значительно более широкую полосу пропускания, чем обычная витая пара, но меньшую, чем оптико-волоконный кабель. Он состоит из одного медного проводника, находящегося в центральной оси кабеля, который отделен от внешнего проводника, выполняющего роль экрана, изолятором из вспененного материала или другого диэлектрика. Благодаря такой конструкции коаксиальный кабель имеет широкую полосу пропускания, достаточную для передачи сигналов десятков телевизионных каналов (а каждый канал при этом занимает полосу частот 6 МГц). К большому сожалению использование коаксиальных кабелей имеет определенные ограничения, прежде всего базирующиеся на свойствах самого кабеля (например, каждый конец кабеля должен быть подключен на согласованную нагрузку, с кабелем при монтаже необходимо обращаться осторожно, чтобы при изгибе не повредить изоляцию между проводниками кабеля и не изменить его электрические характеристики), что оказывает свое влияние на использование таких кабелей.

Доступ в Интернет.

Оптико-волоконные и волоконно-коаксиальные системы изначально создавались для кабельного телевидения и передачи видеосигнала. Благодаря тому, что эти системы по определению являются широкополосными, разрабатывалась именно такая технология, которая позволила бы использовать данное преимущество для высокоскоростной передачи данных, в основном для организации доступа в Интернет частных пользователей.
Оптико-волоконные кабели, безусловно, можно считать наилучшим носителем для высокоскоростной передачи данных. В то время как обычные медные кабели позволяют использовать полосу частот в несколько мегагерц, системы передачи по оптико-волоконному кабелю могут использовать частоты в миллион раз выше. Это является еще одним подтверждением того, что основная разница между электромагнитными и световыми волнами заключается в частоте. Совершенно обычной для нашего времени уже является скорость передачи в 10 Гбит/с. При такой скорости передачи Большая Советская Энциклопедия может быть передана за считанные секунды. Конечно же, проложить оптико-волоконный кабель, относительно одного километра, значительно дороже, чем проложить медный кабель. Однако, если пересчитать эту стоимость относительно возможностей кабеля (полоса частот, скорость передачи данных, количество передаваемых каналов - телефонных, телевизионных и других), то оптическое волокно находится вне конкуренции.

Доступ в Интернет.

Витая пара телефонных проводов является главным (в нашем случае единственным) носителем, который в настоящее время используется для подключения всех абонентов (независимо от их юридического статуса) к оборудованию телефонной сети. Одно только это должно вызывать здоровый энтузиазм у разработчиков систем высокоскоростной передачи данных по данному носителю.
Каждый абонент телефонной сети имеет отдельную физическую пару проводов в кабеле, идущем от телефонной станции, которая соединяет его телефонный аппарат с коммутационным оборудованием, установленным на телефонной станции. Каждая пара в кабеле является витой (т.е. провода пары свиты друг с другом), что позволяет снизить нежелательные помехи. При осуществлении обычной телефонной связи каждая пара кабеля на абонентском участке кабельной сети поддерживает один голосовой канал. Также витые пары проводов используются для соединения персональных компьютеров в ЛВС (локальных сетях).
Существует три основных решения при организации доступа в сеть Интернет по витой паре абонентских телефонных проводов. Речь идет об аналоговых модемах, предназначенном специально для передачи по телефонным каналам, о ISDN и о технологиях, объединенных под общим названием xDSL.

Разводка кабеля витая пара

для соединения двух компьютеров напрямую

Кабель витая пара может быть как четырех проводный, так и восьмипроводный. Для монтажа на кабель используются вилки RJ-45. Монтаж вилки на кабель должен осуществляться при помощи специального инструмента.
"Cross-over" ("нуль-хабный") кабель
одна сторона | цвет провода | другая сторона
1 | бело/оранж | 3
2 | оранжевый | 6
3 | бело/синий | 1
6 | синий | 2
Для восьмипроводного кабеля (четыре пары):
"нуль-хабный" кабель
одна сторона | цвет провода | другая сторона
1 | бело/зеленый | 3
2 | зеленый | 6
3 | бело/оранж | 1
4 | синий | 4
5 | бело/синий | 5
6 | оранжевый | 2
7 | бело/коричн. | 7
8 | коричневый | 8

Или, например, другой вариант.
"нуль-хабный" кабель
одна сторона | цвет провода | другая сторона
1 | бело/зеленый | 3
2 | зеленый | 6
3 | бело/оранж | 1
4 | синий | 7
5 | бело/синий | 8
6 | оранжевый | 2
7 | бело/коричн. | 4
8 | коричневый | 5

T-Connector (Tee Adapter)
foto
Предназначен для подключения устройств к сегменту сети на основе 10 Base-2(тонкий Ethernet).

При отключении устройства Т-коннектор необходимо оставлять в сети, чтобы не нарушать ее работоспособность. Или заменять Т-коннектор на прямой соединитель (I-connector).

Терминатор

Это разъем (папа) с запаяным в нем, между центральным и внешним контактами, резистором. Сопротивление резистора должно равняться волновому сопротивлению кабеля. Для сетей типа 10Base-2 или тонкий Ethernet эта величина составляет 50 Ом. Только один терминатор в сегменте 10Base2 может быть заземлен. Для заземления используется терминатор с цепочкой и контактом на ее конце. Для 10Base5 заземление одного и только одного из терминаторов (точнее, одной из точек сегмента) обязательно.
Если не удается купить терминаторы, их можно сделать из обычных отечественных разъемов типа, впаяв со стороны кабеля, между центральным контактом и корпусом, резистор на 50 Ом. (Подойдет стандартный резистор на 51 Ом).

Разъемы Thin Ethernet

Розетка (мама)

Разъем, расположенный на сетевой карте.

Вилка прямая (папа)

на коаксиальный кабель

Разъем под пайку.
(типа СР-50-74-ПВ)
Разъем на кабель обжимной.
Требуется специальный инструмент ( crimping tool ).
Разъем на кабель навинчивающийся (twist-on). Инструмент для установки не требуется

Hub (хаб)

Hub или концентратор - это многопортовый репитер. Наиболее распространенное применение - сети на основе витой пары 10Base-T или 100Base-TX/T4. Но бывают также хабы для сетей 10Base-2 на основе коаксиального кабеля и для сетей 10Base-F на основе волоконной-оптики. Многие 10Mbit хабы имеют разъемы как под витую пару, обычно называемый (RJ-45), так и под коаксиальный кабель (BNC) или AUI. Что позволяет использовать сегменты коаксиального или оптического кабеля в качестве главной магистрали (Backbone) между хабами.
В хабах под витую пару используются порты MDI-X типа, что позволяет подключать компьютеры напрямую. Для соединения хабов между собой один из его портов имеет разводку MDI. Этот порт каким-либо образом выделен на корпусе устройства. Применяются различные названия: "Cascading" или "In", или "Cross-over", или "Uplink". Нередко имеется переключатель, позволяющий переключать режим порта из MDI в MDI-X и наоборот, что позволяет использовать этот порт не для каскадирования, а для подключения обычных компьютеров. Если на вашем хабе отсутствует переключатель режима порта (MDI - MDI-X) , а все другие порты заняты и вам необходимо подключить еще один компьютер, то вы легко можете это сделать просто использовав для этого "cross-over" кабель. Такой кабель применяется для соединения двух компьютеров напрямую без хаба. Но учтите, что часто этот порт является просто cross-over вариантом одного из обычных портов, в таком случае одновременное подключение к разъемам этих портов недопустимо.
Для соединения хабов по кабелю "витая пара" между собой провод (не cross-over) включается в обычный разъем (MDI-X) на одном хабе и в разъем для каскадирования на другом.

Пример 5-ти портового 10Base-T Hub-а.

Передняя панель | Foto
Задняя панель. 6-й порт используется для каскадирования и имеет обозначение "In" (в, внутрь, вход). Этот порт параллелен 5-му порту, поэтому их нельзя одновременно использовать. | Foto
Вид сверху, без крышки | Foto
Тестирование


13_1_TKC

Программное обеспечение необходимое для сетей

Операционные системы

Операционная система -это программа, которая управляет аппаратными и программными средствами компьютера, предназначенными для выполнения задач пользователя. ЭВМ предоставляет различные ресурсы для решения задачи, но чтобы сделать эти ресурсы легко доступными для человека и его программ, требуется операционная система. Она скрывает от пользователя сложные и ненужные подробности и предоставляет ему удобный интерфейс для работы. Операционная система осуществляет загрузку в оперативную память всех программ, передает им управление в начале их работы, выполняет различные действия по запросу выполняемых программ и освобождает занимаемую программами оперативную память при их завершении. Кроме перечисленного выше операционные системы могут предоставлять и другие возможности, делающие ЭВМ еще более удобной для использования: одновременное выполнение множества различных программ (мультизадачность); средства защиты информации, хранящейся на дисках ЭВМ; работа нескольких пользователей на одной ЭВМ (многопользовательский режим); возможность подключения ЭВМ к сети, а также объединение вычислительных ресурсов нескольких машин и совместное их использование (кластеризация). Загрузчик операционной системы --это специальная программа, предназначенная для инициирования процесса загрузки операционной системы.

MS DOS

MS DOS -- первая операционная система для персональных компьютеров, которая получила широкое распространение. Со временем она была практически вытеснена новыми, современными операционными системами, типа Windows и Linux, но в ряде случаев MS DOS остается удобной и единственно возможной для работы на ЭВМ (устаревшая техника, давно написанное программное обеспечение и т. п.)
Работа пользователей с операционной системой DOS осуществляется с помощью командной строки, ведь собственный графический интерфейс у нее отсутствует. Предпринималось множество попыток упростить общение с системой и самое удачное решение предложил Питер Нортон (Pеter Norton). У многих пользователей работа в операционной системе DOS ассоциируется именно с его программой -- Norton Commander. Оболочка NC скрывает от пользователя множество неудобств, возникающих при работе с файловой системой MS DOS, например, такие, как необходимость набирать команды из командной строки. Простота и удобство в использовании -- вот что делает оболочки типа NC популярными и в наше время (к ним можно отнести QDos, PathMinder, XTree, Dos Navigator, Volkov Commander и др.). В MS DOS используется файловая система FAT. Одним из ее недостатков являются жесткие ограничения на имена файлов и каталогов. Имя может состоять не более чем из восьми символов. Расширение указывается после точки и состоит из не более чем трех символов. Присутствие расширения в имени файла не является обязательным, оно добавляется для удобства, так как расширение позволяет узнать, какая программа создала его и тип содержимого файла. DOS не делает различий между одноименными строчными и прописными буквами. Кроме букв и цифр имя и расширение файла могут состоять из следующих символов: -, _, $, #, &, @, !, %, (, ), {, }, ', ^ . Примеры имен файлов в MS DOS: doom.exe, referat.doc.
Так как MS DOS была создана довольно давно (известно, как стремительно развиваются и устаревают компьютеры и, как следствие, программы для них), она совершенно не соответствует требованиям, предъявляемым к современным операционным системам. Она не может напрямую использовать большие объемы памяти, устанавливаемые в современные ЭВМ, плохо поддерживаются разные устройства типа звуковых карт, видео-ускорителей и т. д.
В MS DOS совершенно не реализована мультизадачность, т. е. она не может естественным образом выполнять несколько задач (работающих программ) одновременно. Поэтому она не может использоваться в качестве основной операционной системы для полноценной многопользовательской работы в сети. MS DOS не имеет никаких средств контроля и защиты от несанкционированных действий программ и пользователя, что привело к появлению огромного количества так называемых вирусов.

Microsoft Windows

На смену операционной системе MS DOS с ее графическими оболочками Windows 3.1 и Windows 3.11 пришли полноценные операционные системы семейства MS Windows (сначала Windows 95, затем Windows 98 и Windows 2000). Их запуск, в отличие от Windows 3.1 и Windows 3.11, производится автоматически после включения компьютера (в том случае, если установлена только одна эта система).
В MS Windows для хранения файлов используется модификация файловой системы FAT - VFAT. В ней длина имен файлов и каталогов может достигать 256 символов. При указании имен прописные и заглавные буквы различаются.
В операционной системе Windows при работе с окнами и приложениями широко применяется манипулятор мышь. Обычно мышь используется для выделения фрагментов текста или графических объектов, установки и снятия флажков, выбора команд меню, кнопок панелей инструментов, манипулирования элементами управления в диалогах, "прокручивания" документов в окнах.
В Windows активно используется и правая кнопка мыши. Поместив кончик указателя над интересующим вас на экране объектом и сделав щелчок правой кнопкой мыши, вы можете раскрыть так называемое "контекстное меню", содержащее наиболее употребительные команды, применимые к данному объекту.
Ярлыки обеспечивают доступ к программе или документу из различных мест, не создавая при этом нескольких физических копий файла. На рабочий стол можно поместить не только пиктограммы (значки) приложений и отдельных документов, но и папок. Папки -- еще одно название каталогов (directories).
Существенным нововведением в Windows 95 стала Панель задач (Taskbar). Несмотря на небольшие функциональные возможности, она делает наглядным механизм многозадачности и намного ускоряет процесс переключения между приложениями по сравнению с предыдущими версиями Windows. Внешне панель задач представляет полосу, обычно располагающуюся в нижней части экрана, на которой размещены кнопки приложений и кнопка Пуск (Start). В правой ее части обычно присутствуют часы и небольшие пиктограммы программ, активных в данный момент.
Рабочий стол Windows сконструирован так, чтобы максимально облегчить работу пользователя-новичка и в то же время предоставить максимальные возможности его настройки в соответствии с конкретными нуждами опытных пользователей.
При завершении работы нельзя просто выключить компьютер, не завершив работу системы по всем правилам - это может привести к потере некоторых несохраненных данных. Для правильного завершения работы необходимо сделать следующее.
1. Сохранить данные во всех приложениях, с которыми вы работали.
2. Завершить работу всех ранее запущенных DOS-приложений.
3. Открыть меню кнопки Пуск и выбрать команду Завершение работы - на экране появится диалоговое окно.
4. Выбрать нужный вариант действий и нажать кнопку Да

Операционная система Linux

Linux -- это операционная система для IBM-совместимых персональных компьютеров и рабочих станций. Это многопользовательская ОС с сетевой оконной графической системой X Window System. ОС Linux поддерживает стандарты открытых систем и протоколы сети Интернет и совместима с системами Unix, DOS, MS Windows. Все компоненты системы, включая исходные тексты, распространяются с лицензией на свободное копирование и установку для неограниченного числа пользователей.
Разработал эту операционную систему в начале 90-х годов тогда еще студент университета Хельсинки (Финляндия), Линус Торвальд при участии пользователей сети Интернет, сотрудников исследовательских центров, различных фондов и университетов.
Будучи традиционной операционной системой, Linux (произносится "линукс", с ударением на первом слоге) выполняет многие из функций, характерных для DOS и Windows. Однако следует отметить, что эта ОС отличается особой мощью и гибкостью. Система Linux разрабатывалась как ПК-версия операционной системы Unix, которая десятилетиями используется на мэйнфреймах и мини-ЭВМ и является основной ОС для рабочих станций. Linux предоставляет в распоряжение пользователя ПК скорость, эффективность и гибкость Unix, используя при этом все преимущества персональных машин. При работе с мышью активно используются все три кнопки, в частности средняя кнопка используется для вставки фрагментов текста.
С экономической точки зрения Linux обладает еще одним весьма существенным достоинством -- это бесплатная система. Linux распространяется по генеральной открытой лицензии GNU в рамках фонда свободного программного обеспечения (Free Software Foundation), что делает эту ОС доступной для всех желающих.
От Unix операционной системе Linux достались еще две замечательные особенности: она является многопользовательской и многозадачной системой. Многозадачность означает, что система может выполнять несколько задач одновременно. Многопользовательский режим означает, что в системе могут одновременно работать несколько пользователей, каждый из которых взаимодействует с ней через свой терминал. Еще одним из достоинств этой ОС является возможность ее установки совместно с Windows на один компьютер.
Linux способен любую персональную машину превратить в рабочую станцию. В наше время Linux является операционной системой для бизнеса, образования и индивидуального программирования. Университеты по всему миру применяют Linux в учебных курсах по программированию и проектированию операционных систем. Он стал незаменим в широких корпоративных сетях, а также для организации Интернет-узлов и Web-серверов.
Современный Linux предоставляет возможность использовать несколько разновидностей графического интерфейса: KDE (K Desktop Environment), GNOME (GNU Network Model Environment) и другие. В каждой из этих оболочек пользователю предоставляется возможность работы сразу с несколькими рабочими столами (в то время как в MS Windows всегда один рабочий стол, который приходится загромождать окнами).

Сетевые операционные системы

Сетевая операционная система является самым важным компонентом компьютерной сети, сама же сеть - неотъемлемая часть компании и важнейшее условие успешного бизнеса. Она почти незаметна для пользователей, но выполняет огромную работу.
Несколько лет назад администраторы мечтали иметь единую стандартизованную сетевую ОС, которая сочетала бы в себе надежный сервер файлов и печати и сервер приложений. Такая воображаемая ОС должна была быть не только идеальной сетевой платформой, но и обеспечивать надежную поддержку оставшимся в наследство приложениям клиент-сервер, дабы осуществить безболезненный переход на новую сетевую архитектуру. Иными словами, идеальная сетевая ОС должна показывать превосходную производительность, простое администрирование и легко интегрироваться в существующую сеть.

Решение на базе IntranetWare

IntranetWare занимает такое положение на рынке благодаря тому, что компания Novell уже давно сделала вывод: службы файловой системы и печати имеют первостепенное значение, а в их основе лежат быстрые сетевые операции ввода-вывода. Благодаря системе NetWare 3.12 компании удалось захватить львиную долю рынка сетевых ОС, опередив своих ближайших конкурентов в 4 раза.
NetWare 4 приобрела 32-битное ядро и службу каталогов Novell Directory Services (NDS). А с ней появилась и единая централизованная база данных, в которой хранится вся информация о сетевых ресурсах. Эта база данных может практически неограниченно расширяться и сама себ проецировать на другие серверы сети.
Несмотря на эти усовершенствования, далеко не все компании, использующие NetWare 3.x, перешли на новую версию просто потому, что не все они являются достаточно крупными организациями. Для небольших фирм, имеющих всего один офис и, возможно, только один сервер, преимущества, которые обеспечивает NDS, оказались не столь очевидными. Однако с ростом популярности Internet, которая со всей очевидностью иллюстрирует преимущества модели компьютерной среды с сетью в центре, у Novell появилась вполне обоснованная надежда, перевести оставшуюся часть своих заказчиков на новую сетевую ОС.
В IntranetWare Novell добавила функцию автоматического распознавания оборудования, встроенную поддержку TCP/IP, сделала службу каталогов более быстрой и простой в обслуживании, а также улучшила поддержку клиентских платформ. Кроме того, компания включила в комплект поставки сетевой ОС Web-сервер собственной разработки, интегрированный с NDS; средства доступа к Internet, в том числе многопротокольный маршрутизатор; а также поддержку сетей WAN, протокола Dynamic Host Configuration Protocol (DHCP) и шлюз IPX/IP.

Решение на базе OS/2 Warp Server

OS/2 Warp Server 4.0 SMP Feature компании IBM - это универсальная операционная система, предназначенная для решения тех же задач, что и система Windows NT производства Microsoft.
Система имеет все, что необходимо для подключения к Internet: исчерпывающий набор средств TCP/IP, серверы DHCP и DNS. Чтобы сделать свою ОС более конкурентоспособной, IBM также предлагает продукт Internet Connection Server, который бесплатно распространяется вместе с системой в течение долговременной кампании по продвижению ОС Warp Server.
Будущее системы Warp Server SMP можно охарактеризовать двумя словами: Internet и Java. TCP/IP станет "родным" протоколом, а операционная среда Java начнет поставляться уже в первом квартале этого года. Во втором квартале IBM планирует выпустить интегрированный полнофункциональный сервер HTTP.

Решение на базе Solaris

Sun Microsystems предложили сетевую ОС, получившую название Solaris.
В качестве службы каталогов Solaris 2.5.1 использует NIS +. Эта служба по своей архитектуре напоминает NDS, однако она единственная из всех современных служб каталогов позволяет управлять доступом к учетным данным пользователей на уровне отдельных полей, давая, таким образом, администраторам более низкого уровня возможность назначать ограниченный доступ к информации о пользователях (например вводить или менять номера телефонов, не имея при этом возможности манипулировать более важными полями учетной записи).
Достоинства Solaris - надежность и масштабируемость, которая относится к поддерживаемым процессорам и пользователям сети. Одна и та же копия Solaris может устойчиво функционировать на настольном компьютере с одним процессором и на сервере класса мэйнфрейма, оборудованном 64 процессорами, который обрабатывает базу данных, измеряемую в терабайтах и управляет колоссальным сетевым трафиком. Недостаток же системы в том, что ее трудно использовать: загадочный Unix - это страшная вещь. Однако это очень мощная ОС, которая, не требуя больших усилий, дает большой эффект. Причем это заложено в гениальной архитектуре самой системы. Ключ к будущему Solaris - создание пользовательского интерфейса, который предоставит администраторам доступ к мощным возможностям системы, не позволяя им проникать во все ее тайны.

Решение на базе Windows NT Server

Когда Microsoft говорит о NT говорят эта система по замыслу разработчиков должна стать единственной истинной многоцелевой сетевой ОС.
Начиная с NT 3.1 (1993 г.) Microsoft непрерывно улучшала и службы файлов, и печать, и службы приложений, что позволило ей получить достаточно большой парк установленных систем, в котором к настоящему времени насчитывается более 1 млн. пользователей. Возможно, единственное, что выпадает из политики глобального наступления NT, это недальновидность в отношении средств администрирования корпоративного уровня. Доменная архитектура, на которой основана NT, превращает администрирование распределенной сети в трудноразрешимую проблему. Novell же со своей NDS тем временем набирает очки.
Когда грянул всеобщий бум по поводу Internet, Microsoft не сразу решилась реализовать представившиеся ей возможности, но в какой-то момент она взялась за Internet так активно, словно эту сеть создал сам Билл Гейтс. В систему Windows NT Server 4.0 Microsoft включила обширный набор средств и приложений, позволяющих рассматривать ее как законченное и внушительное Internet-решение. Включив в свою систему Internet Information Server, или IIS, пользователи NT могут обслуживать HTTP, FTP и Gopher с помощью единого, отличающегося простотой применения пакета. Кроме того, в комплект NT входит недавно приобретенный пакет FrontPage, позволяющий создавать узлы Internet/intranet и управлять ими. Microsoft продолжает работать над созданием развитой службы каталогов.


Оценка сетевых операционных систем.

Решение | Решение на базе IntranetWare | Решение на базе OS/2 Warp Server | Решение на базе Solaris | Решение на базе Windows NT Server
 | IntranetWare Novell, Inc. | OS/2 Warp Server 4.0 SMP Feature IBM | Solaris 2.5.1 Sun Microsystems, Inc. | Windows NT Server 4.0 Microsoft Corp.
Реализация | Очень хорошо 0.8 Почти гладкий переход с сервера NetWare 3.12 омрачает только неспособность IntranetWare переносить со старого сервера пароли пользователей. Программа установки IntranetWare не столь хороша, как в Windows NT. | Плохо 0.2 В отличие от своих соперников, Warp Server оказался неспособен обслужить наших клиентов NetWare естественным для них образом. Нам удалось импортировать пользователей и данные с сервера NetWare, однако необходимость устанавливать новое клиентское ПО вылилась во вполне реальную проблему. | Удовлетворительно 0.4 Хотя пакет Solstice NWServer и не включает никаких средств, облегчающих перенос учетных данных пользователей, информации и принтеров на новый сервер, он делает это лучше, чем Warp Server, - хотя бы потому, что обеспечивает отличную поддержку существующих клиентов NetWare. | Хорошо 0.6 Переход с NetWare 3.12 довольно легко было выполнить. К сожалению, некоторые досадные помехи отняли у нас очень много времени. Всего несколько небольших модернизаций имеющихся средств могли бы сделать переход к NT с NetWare столь же простым, как и в IntranetWare.
Службы управления приложениям | Удовлетворительно 0.6 Управление несколькими приложениями в IntranetWare означает использование командной строки сервера - не особенно дружественный интерфейс. Однако хорошая поддержка NDS производителями ПО позволяет интегрировать отдельные функции защиты приложений с системой безопасности IntranetWare. | Удовлетворительно 0.6 Интеграция с приложений в систему Warp Server ограничивается службами NetFinity, поставляемыми в комплекте с сервером. Несмотря на то что NetFinity обеспечивает ряд преимуществ для рабочих станций, единственным плюсом серверной части является возможность контроля за количеством лицензий, для которого требуются совместимые с NetFinity приложения. | Хорошо 0.9 Как и в случае с NetWare, лучший способ управления приложениями в Solaris - использование командной строки вместо графического интерфейса. Однако это не какая-то базовая командная строка: это сеанс Unix, в котором, однажды научившись и затрачивая минимальные усилия, можно делать практически все. | Хорошо 0.9 NT обеспечивает более тесную интеграцию с приложениями, чем IntranetWare, но все же в этом смысле продукт далеко не идеален. Performance Monitor - это единственное средство, позволяющее администрировать несколько приложений. Для управления приложениями необходима центральная консоль.
Службы файловой системы и печати | Очень хорошо 1.2 IntranetWare лишний раз подтверждает, что традиционно сильные службы файловой системы и печати системы NetWare являются лучшими в сетевой отрасли. Иерархическая модель администрирования и более мощные возможности делегирования полномочий могли бы существенно упростить управление большими сетями. IntranetWare продолжает быть лучшим файл-сервером и сервером печати. | Хорошо 0.9 Подобно другим сетевым ОС, Warp Server обеспечивает полный диапазон служб файловой системы и печати, включая защиту на уровне файлов и на уровне каталога. Продвинутые услуги печати очень внушительны, хотя большинству сетей NetWare такие дополнительные возможности не требуются. | Удовлетворительно 0.6 Solaris имеет полный набор служб файловой системы и печати, но горе тому, кто попытается управлять ими, не имея полной подготовки по Unix. Задание и совместное использование принтера выполняется легко - особенно если под рукой есть документация, - но все же значительно затруднено по сравнению с другими ОС. | Хорошо 0.9 Единственный способ обеспечить иерархическое администрирование в NT состоит в том, чтобы создать раздельные домены с односторонними доверительными отношениями, с чем чаще всего связано больше неудобств, чем преимуществ. Администрирование служб файловой системы и печати выполняется очень просто; задание новых принтеров в NT оказалось наиболее простым из всех рассмотренных ОС.
Службы каталогов | Очень хорошо 1.6 Из всех рассмотренных систем IntranetWare имеет самую сильную службу каталога. Отсутствие поисковых средств в клиентском ПО и отсутствие возможности редактирования отдельных полей учетных записей пользователей разными администраторами - только два недостатка, мешающие NDS стать действительно идеальной службой каталога. | Хорошо 1.2 С помощью службы Directory and Security Services (DSS) можно выполнять раздельное администрирование доменов; для группы доменов может быть разрешено иерархическое администрирование. К сожалению, в отличие от NDS, структура учетной записи пользователя не расширяема, отсутствуют также какие-либо средства для поиска ресурсов. | Хорошо 1.2 NIS+, службе каталога системы Solaris, явно не уделяется того внимания, которого она заслуживает. Это развитая служба каталога с возможностью репликации. Однако она не так проста в администрировании, как NDS, а ее отдельные объекты не расширяемы, хотя приложения могут добавлять новые таблицы. Права доступа могут устанавливаться на уровне атрибутов. | Плохо 0.4 В отличие от других сетевых ОС, NT не имеет объектной модели для пользователей, принтеров, директорий и т. д. Все, что здесь имеется можно назвать "вещью в себе", и нет никакого простого, стандартного способа задавать дополнительные атрибуты. Элементарные возможности просмотра ресурсов - единственный компенсирующий фактор.
Пригодность к работе | Очень хорошо 1.2 IntranetWare обеспечивает серверы DNS, DHCP, NFS, Web, FTP и LPD, но, подобно NT, их использование несколько затруднено из-за ограниченной интеграции. В отличие от предыдущих версий NetWare, здесь имеется возможность создавать сети, работающие только по протоколу TCP/IP. Это единственная из рассматриваемых сетевая ОС, в комплект которой входит шлюз IPX-IP. | Хорошо 0.9 Warp Server подходит клиентам intranet, однако возможности сервера ограничены. Хотя Warp Server поддерживает DHCP, DNS и Dynamic DNS, в нем отсутствуют серверы Web, FTP, Gopher, NFS и LPD. Таким образом этот продукт наименее пригоден к работе в Internet из всех рассмотренных ОС. | Очень хорошо 1.2 Solaris будет чувствовать себя "как дома" в любой сети intranet и в качестве клиента, и в качестве сервера. Полные реализации серверов DHCP, DNS, Web и FTP, наряду с естественной поддержкой LPD и NFS, делают эту систему наиболее сильной из всех Internet/intranet-совместимых сетевых ОС. | Очень хорошо 1.2 Отсутствие поддержки NFS и интеграции между DNS и DHCP не позволяет назвать NT идеальной платформой для Internet. Имеющиеся в комплекте серверы Web, Gopher и FTP - это большой плюс, ровно как и встроенная поддержка туннелирования и совместимость с Line Printer/Line Printer Daemon.
Совместимость | Отлично 1.0 IntranetWare поддерживает NFS, AppleTalk, NetWare Core Protocol, TCP/IP и IPX, словом, большее количество клиентов, чем любая из конкурирующих ОС. IntranetWare может удовлетворить потребности практически любой сети. | Удовлетворительно 0.4 Нет поддержки клиентов Macintosh и Unix. Отсутствие поддержки существующих клиентов NetWare еще больше ограничивает межплатформенные возможности Warp Server. | Удовлетворительно 0.4 Поддержка приложений имеется для множества платформ, но поддержка файлов и печати не столь широка. Поддержка для Warp Server обеспечивается с помощью отдельного пакета, поддержка Macintosh отсутствует совсем. | Очень хорошо 0.8 NT обеспечивает хорошую поддержку приложений для ряда клиентов, включая AppleTalk, OS/2 и Unix. Службы файловой системы доступны почти на каждой платформе, однако отсутствие поддержки NFS препятствует полноценной интеграции Unix-клиентов.
Поддержка | Удовлетворительно 0.4 Поддержку по телефону получить достаточно трудно; технические специалисты хорошо осведомлены, но нуждаются в некоторой помощи. Прекрасный Web-узел Novell с поисковым механизмом оказался более полезен, чем поддержка по телефону, поскольку технические специалисты все равно ссылаются на него. | Хорошо 0.6 Возможно из-за того, что Warp Server завоевал репутацию системы, трудной в установке, его телефонная техническая поддержка представляется более сильной, чем у других производителей. Однако Web-узел IBM содержит очень ограниченное количество рекомендаций по устранению проблем. | Очень хорошо 0.8 Телефонная служба технической поддержки отвечала быстро и продемонстрировала хорошую осведомленность в отношении Solaris, чего нельзя сказать о NWServer и взаимодействии с клиентами NetWare. Техническая информация имеется на Web-узле, однако можно было бы увеличить количество документов по решению технических проблем. | Хорошо 0.6 Несмотря на то что телефонная поддержка оценивалась где-то между "удовлетворительно" и "хорошо", багодаря сильному Web-узелу Microsoft она стала практически ненужной.
Цена | Удовлетворительно 0.2 Стоимость IntranetWare - 22 240 долл. в расчете на четыре сервера плюс техническая поддержка - вероятно, приемлема для крупных организаций. | Удовлетворительно 0.2 Warp Server стоит 23 628 долл., приближаясь по этому показателю к другим системам. Но из-за отсутствия совместимости с NetWare реальная стоимость продукта оказывается выше. | Удовлетворительно 0.2 Серверная конфигурация и поддержка Solaris стоит 24 311 дол. - больше, чем для всех остальныех продуктов, хотя и не намного. | Хорошо 0.3 Цена NT, равная 19 747 долл. в расчете на объединенный пакет, состоящий из серверов и поддержки. Таким образом, эта разработка наименее дорогая из всех рассмотренных решений.
Итоговая оценка | 7.0 | 5.0 | 5.7 | 5.7


14_1_TKC

Организация информации на сервере

Принципы работы терминалов K-Systems Termin

При работе в среде Windows 2000 доступ к серверу в терминальном режиме обеспечивается посредством службы терминалов Windows 2000 Terminal Services – одного из компонентов Windows 2000 Server. Для подключения к терминальному серверу используется Remote Desktop Protocol (RDP) через TCP/IP.
Каждому пользователю, обращающемуся в терминальном режиме к серверу, служба терминалов выделяет собственную виртуальную среду, которую клиент воспринимает как полноценный компьютер на базе Windows 2000 Workstation. При этом на самом терминале должны функционировать только базовые службы для доступа к сети и специальное клиентское программное обеспечение для общения со службой терминалов.
Никакой дополнительной настройки не требуется: всю вычислительную нагрузку несет не терминал, а сервер. Служба терминалов расширяет модель распределенных вычислений, позволяя работать в серверной вычислительной среде и обеспечивая выполнение всех клиентских приложений, обработку и хранение данных на сервере.
Приложения, пользовательские рабочие столы, ввод символов с клавиатуры, движения мыши, вывод на печать передаются по сети и отображаются посредством программного обеспечения терминала. Пользователь видит только свой собственный сеанс, работа в котором происходит под управлением операционной системы, установленной на сервере, независимо от любых других клиентских сеансов.

Технические характеристики

Программное обеспечение:
Windows CE.Net с поддержкой RDP 5.1 и ICA-протоколов;
Microsoft Internet Explorer 5.5
Процессор:
Eden ESP5000
Память:
64 MB SDRAM, 32 MB DiskOnChip
Видео:
разрешение: 1024 х 768, 800 х 600, 640 х 480;
количество цветов – до 32 бит;
частота кадровой развертки: до 85 Hz @ 1024 x 768;
подключение: 15 pin VGA
Аудио:
16 бит стерео, AC97
Сеть:
VT3065 Fast Ethernet 10/100 Мбит
Порты:
параллельный (DB-25);
RS232 (DB-9);
USB;
мышь PS/2;
клавиатура PS/2
Размер корпуса:
250 х 200 х 50 мм
Питание:
110—240 В;
50—60 Hz

Динамическое управление сетью (D.N.A.)

Динамическое управление сетью (D.N.A.) в системе "Consono" представляет собой гибкое, масштабируемое средство, обладающее широким диапазонам функций, которые упрощают и рационализируют управление сетью связи, обеспечивая низкую стоимость эксплуатации, высокую производительность и повышенную доступность сети для деловых потребителей.
Сервер Хранения Управленческой Информации D.N.A. (Management Repository Server) представляет собой основной прикладной сервер D.N.A., базирующийcя на операционной системе Windows NT.
Все прикладные программы DNA., работающие с Сервером Хранения Управленческой Информации, сочетают в себе сложные функциональные средства с чрезвычайным удобством в обращении, что делает их исключительно полезными инструментами управления.

Работа DNS

В работе DNS участвуют три основных компонента: клиенты DNS, или программы разрешения имен (resolvers), серверы имен и пространство имен домена.
В простейшем случае DNS-клиент посылает запросы серверу имен. Сервер возвращает либо требуемую информацию, либо указание на другой сервер имен, либо сообщение об отказе, если запрос не может быть удовлетворен.
Доменная система имен — это система управления иерархической распределенной базой данных, использующая технологию клиент-сервер. DNS работает на прикладном уровне (application layer) и использует LJDP и TCP/IP как нижележащие протоколы.
Задача базы данных DNS — транслировать имена компьютеров в IP-адреса, что показано на следующей иллюстрации. DNS-клиентов часто называют ресолверами (resolvers), серверы — серверами имен (name servers).
Зона ответственности (zone of authority) — это часть пространства имен домена, за которую отвечает конкретный сервер имен. Сервер имен хранит IP-адреса для всех имен из зоны его ответственности и обслуживает все запросы клиентов к этим именам.

Зона ответственности сервера имен охватывает, как минимум, один домен, который называют корневым доменом зоны (zone root domain). Зона ответственности может включать и поддомены корневого домена этой зоны. Однако в одну зону не обязательно входят все поддомены, расположенные ниже корневого домена этой зоны.
На приведенной далее иллюстрации домен microsoft.com не укладывается в одной зоне. Часть домена выделена в отдельную зону dev.microsoft.com. Разбиение домена на несколько зон необходимо для раздельного управления группами в домене или для эффективного тиражирования данных.
Один DNS-сервер может управлять несколькими зонами. Каждая зона подчинена конкретному домену, который называют корневым доменом зоны. DNS (Domain Name System) - это распределенная база данных, которая содержит информацию о компьютерах, включенных в сеть Internet. Характер данных зависит от конкретной машины, но чаще всего информация включает имя машины, IP-адрес и данные для маршрутизации почты. Для удобства,большинство компьютеров имеют имена. Доменная система имен выполняет несколько задач, но основная ее работа - преобразование имён компьютеров а IP-адреса и наоборот. Пространство имен DNS имеет вид дерева доменов, с полномочиями, возрастающими по мере приближения к корню дерева. Корень дерева имеет имя "."; под ним находятся домены верхнего уровня (корневые домены). По историческим причинам существует два вида доменов верхнего уровня. В США домены верхнего уровня отражают организационную структуру, и как правило имеют трехбуквенные имена: .gov - государственные учреждения,
.mil - военные учреждения,
.com - коммерческие организации,
.net - поставщики сетевых услуг,
.org - бесприбыльные организации,
.edu - учебные заведения;
Для доменов вне США, в соответствии с территориальным расположением используются двухбуквенные коды стран ISO. Например:
www.spm.ru - в России
www.berlin.de - а Германии
www.hotex.nl - в Нидерландах
и т.д.
Вы можете работать в Internet с помощью специальных программ. Вот некоторые из них:
ping - позволяет определить время прохождения пакета до хоста.
traceroute - показывает путь прохождения пакетов по сети. (в Win95 и NT - tracert.exe)
nslookup - позволяет просматривать содержимое DNS серверов.
telnet - устанавливает соединение с удаленной машиной (23 порт)и позволяет вам работать в режиме удаленного терминала.
ftp - позволяет передавать файлы между машинами по протоколу FTP (File Transfer Protocol) (21 порт).
finger - показывает информацию о пользователях находящихся в данный момент на какой-либо машине.


Организация систем защиты

Проблемы, связанные с безопасностью

Как было установлено ранее, Интернет страдает от серьезных проблем с безопасностью. Организации, которые игнорируют эти проблемы, подвергают себя значительному риску того, что они будут атакованы злоумышленниками, и что они могут стать стартовой площадкой при атаках на другие сети. Даже те организации, которые заботятся о безопасности, имеют те же самые проблемы из-за появления новых уязвимых мест в сетевом программном обеспечении(ПО) и отсутствия мер защиты от некоторых злоумышленников.

Некоторые из проблем безопасности в Интернете - результат наличия уязвимых мест из-за ошибок при проектировании в службах( и в протоколах, их реализующих) , в то время как другие - результат ошибок при конфигурировании хоста или средств управления доступом, которые или плохо установлены или настолько сложны, что с трудом поддаются администрированию. Кроме того: роль и важность администрирования системы часто упускается при описании должностных обязанностей сотрудников, что при приводит к тому, что большинство администраторов в лучшем случае нанимаются на неполный рабочий день и плохо подготовлены. Это усугубляется быстрым ростом Интернета и характера использования Интернета; государственные и коммерческие организации теперь зависят от Интернета( иногда даже больше: чем они думают) при взаимодействии с другими организациями и исследованиях и поэтому понесут большие потери при атаках на их хосты. Следующие главы описывают проблемы в Интернете и причины, приводящие к их возникновению.

Инциденты с безопасностью в Интернете

В доказательство того, что описанные выше угрозы реальны, три группы инцидентов имели место в течение нескольких месяцев друг после друга. Сначала, началось широкое обсуждение обнаруженных уязвимых мест в программе UNIX sendmail( это транспортная почтовая программа на большинстве хостов с Unix. Это очень большая и сложная программа, и в ней уже несколько раз были найдены уязвимые места, которые позволяют злоумышленнику получить доступ в системы, в которых запущена sendmail). Организациям, которые не имели исправленных версий программы, пришлось срочно исправлять эти ошибки в своих программах sendmail до того, как злоумышленники используют эти уязвимые места для атаки на их сети. Тем не менее, из-за сложности программы sendmail и сетевого ПО в целом три последующие версии sendmail также содержали ряд уязвимых мест[CIAC94a]. Программа sendmail широко использовалась, поэтому организациям без брандмауэров, для того чтобы ограничить доступ к этой программе, пришлось быстро регировать на возникавшие проблемы и обнаруживаемые уязвимые места.

Во-вторых, обнаружилось, что популярная версия свободно распространяемого FTP-сервера содержала троянского коня, позволявшего получить привилегированный доступ к серверу. Организациям, использовавшим этот FTP-сервер, не обязательно зараженную версию, также пришлось быстро реагировать на эту ситуацию[CIAC94c]. Многие организации полагаются на хорошее качество свободного ПО, доступного в Интернете, особенно на ПО в области безопасности с дополнительными возможностями по протоколированию, управлению доступом и проверке целостности, которое не входит в состав ОС, поставляемой ее производителем. Хотя это ПО часто очень высокого качества, организации могут оказаться в тяжелом положении, если в ПО будут найдены уязвимые места или с ним возникнут другие проблемы, и должны будут полагаться только на его авторов.( Справедливости ради, стоит отметить, что даже ПО, сделанное производителем ОС, может страдать от таких же проблем и его исправление может оказаться более продолжительным).

Третья проблема имела самые серьезные последствия: [CERT94] и [CIAC94b] сообщили, что злоумышленники проникли в тысячи систем во всем Интернете, включая шлюзы между большими сетями и установили анализаторы пакетов для перехвата в сетевом траффике имен пользователей и статических паролей, вводимых пользователями для подключения к сетевым системам. Злоумышленники также использовали другие известные технологии для проникновения в системы, а также перехваченные ими пароли. Одним из выводов, которые можно поэтому сделать является то, что статические или повторно используемые пароли не должны использоваться для управления доступом. Фактически, пользователь, подключающийся к сетевой системе через Интернет, может неумышленно подвергнуть эту систему риску быть атакованной злоумышленниками, которые могли перехватить сетевой траффик, идущий к этой удаленной системе.

Следующие разделы более детально описывают проблемы с безопасностью в Интернете. [Garf92], [Cur92],[ Bel89], [Ches94] и [Farm93] являются книгами, где вы найдете более детальную информацию.

Слабая аутентификация

Группы улаживания инцидентов считают, что большинство инцидентов произошло из-за использования слабых, статических паролей. Пароли в Интернете могут быть "взломаны" рядом способов, но двумя самыми распространенными являются взлом зашифрованной формы пароля и наблюдение за каналами передачи данных с целью перехвата пакетов с паролями. ОС Unix обычно хранит пароли в зашифрованной форме в файле, который может быть прочитан любым пользователем. Этот файл паролей может быть получен простым копированием его или одним из других способов, используемых злоумышленниками. Как только файл получен, злоумышленник может запустить легко-доступные программы взлома паролей для этого файла. Если пароли слабые, то есть меьше, чем 8 символов, являются словами, и т.д., то они могут быть взломаны и использованы для получения доступа к системе.

Друная проблема с аутентификацией возникает из-за того, что некоторые службы TCP и UDP могут аутентифицировать только отдельный хост, но не пользователя. Например, сервер NFS(UDP) не может дать доступ отдельному пользователю на хосте, он может дать его всему хосту. Администратор сервера может доверять отдельному пользователю на хосте и дать ему доступ, но администратор не может запретить доступ других пользователей на этом хосте и поэтому автоматически должен предоставить его всем пользователям или не давать его вообще.

Легкость наблюдения за передаваемыми данными

Следует отметить, что когда пользователь установил сеанса с удаленным хостом, используя TELNET или FTP, то пароль пользователя передается по Интернету в незашифрованном виде. Поэтому другим способом проникновения в системы является наблюдение за соединением с целью перехвата IP-пакетов, содержащих имя и пароль, и последующее использование их для нормального входа в систему. Если перехваченный пароль является паролем администратора, то задача получения привилегированного доступа становится гораздо легче. Как уже ранее отмечалось, сотни и даже тысячи систем в Интернете были скомпрометированы в результате перехвата имен и паролей.

Электронная почта, а также содержимое сеансов TELNET и FTP, может перехватываться и использоваться для получения информации об организации и ее взаимодействии с другими организациями в ходе повседневной деятельности. Большинство пользователей не шифруют почту, так как многие полагают, что электронная почта безопасна и с ее помощью можно передавать критическую информацию.

Система X Windows, становящаяся все более популярной, также уязвима перехвату данных. X позволяет открывать несколько окон на рабочей станции для работы с графическими и мультимедийными приложениями( например, WWW-браузером Netscape). Злоумышленники могут иногда открывать окна на других системах и перехватывать текст, набираемый на клавиатуре, который может содержать пароли и критическую информацию.

Легкость маскировки под других

Как уже отмечалось в части 1.2.1, предполагается, что IP-адрес хоста правильный, и службы TCP и UDP поэтому могут доверять ему. Проблема заключается в том, что используя маршрутизацию IP-источника , хост атакующего может замаскироваться под доверенного хоста или клиента. Коротко говоря, маршрутизация IP-источника - это опция, с помощью которой можно явно указать маршрут к назначению и путь, по которому пакет будет возвращаться к отправителю. Это путь может включать использование других маршрутизаторов или хостов, которые в обычных условиях не используются при передаче пакетов к назначению. Рассмотрим следующий пример того, как это может быть использовано для маскировки системы атакующего под доверенный клиент какого-то сервера:

  1. Атакующий меняет IP-адрес своего хоста на тот, который имеет доверенный клиент.
  2. Атакующий создает маршрут для маршрутизации источника к этому серверу, в котором явно указывает путь, по которому должны передаваться IP-пакеты к серверу и от сервера к хосту атакующего, и использует адрес доверенного клиента как последний промежуточный адрес в пути к серверу.
  3. Атакующий посылает клиентский запрос к серверу, используя опцию маршрутизации источника.
  4. Сервер принимает клиентский запрос, как если бы он пришел от доверенного клиента, и возвращает ответ доверенному клиенту.
  5. Доверенный клиент, используя опцию маршрутизации источника, переправляет пакет к хосту атакующего.

Многие хосты Unix принимают пакеты с маршрутизацией источника и будут передавать их по пути, указанному в пакете. Многие маршрутизаторы также принимают пакеты с маршрутизацией источника, в то время как некоторые маршрутизаторы могут быть сконфигурированы таким образом, что будут блокировать такие пакеты.

Еще более простым способом маскировки под клиента является ожидание того момента времени, когда клиентская система будет выключена, и последующая маскировка под нее. Во многих организациях сотрудники используют персональные ЭВМ с сетевой математикой TCP/IP для подключения к хостам с Unixом и используюют машины с Unix как серверы ЛВС. ПЭВМ часто используют NFS для получения доступа к директориям и файлам на сервере(NFS использует только IP-адреса для аутентификации клиентов). Атакующий может сконфигурировать по окончании работы свой ПЭВМ таким образом, что он будет иметь то же самое имя и IP-адрес, что и другая машина, а затем инициировать соединение с Unixовским хостом, как если бы он был доверенным клиентом. Это очень просто сделать и именно так поступают атакующие-сотрудники организации.

Электронную почту в Интернете особенно легко подделать, и ей вообще нельзя доверять, если в ней не применяются расширения, такие как электронная подпись письма[NIST94a]. Например, давайте рассмотрим взаимодействие между хостами Интернета при обмене почтой. Взаимодействие происходит с помощью простого протокола, использующего текстовые команды. Злоумышленник может легко ввести эти команды вручную, используя TELNET для установления сеанса с портом SMTP( простой протокол передачи почты). Принимающий хост доверяет тому, что заявляет о себе хост-отправитель, поэтому можно легко указать ложный источник письма, введя адрес электронной почты как адрес отправителя, котоырй будет отличаться от истинного адреса. В результате, любой пользователь, не имеющий никаких привилегий, может фальсифицировать электронное письмо.

В других сервисах, таких как DNS, также можно замаскироваться под другую машину, но сделать это несколько сложнее, чем для электронной почты. Для этих сервисов до сих пор существуют угрозы, и их надо учитывать тому, кто собирается пользоваться ими.

Недостатки служб ЛВС и взаимное доверие хостов друг к другу

Хосты тяжело поддерживать в безопасном состоянии и это занимает много времени. Для упрощения управления хостами и большего использования преимуществ ЛВС, некоторые организации используют такие сервисы, как NIS(Network Information Service) и NFS(Network File system). Эти сервисы могут сильно уменьшить время на конфигурирование хостов, позволяя управлять рядом баз данных, таких как файлы паролей, с помощью удаленного доступа к ним и обеспечивая возможность совместного использования файлов и данных. К сожалению, эти сервисы небезопасны по своей природе и могут использоваться для получения доступа грамотными злоумышленниками. Если скомпрометирован центральный сервер, то другие системы, доверяющие центральной системе, также могут быть легко скомпрометированы.

Некоторые сервисы, такие как rlogin, позволяют хостам "доверять" друг другу для удобства работы пользователей и облегчения совместного использования систем и устройств. Если в систему было совершено проникновение или ее обманули с помощью маскарада, и этой системе другие системы, то для злоумышленника не составит труда получить доступ к другим системам. Например, пользователь, зарегистрированный на нескольких машинах, может избавиться от необходимости вводить пароль, сконфигурировав себя на этих машинах так, что они будут доверять подключению с основной системы пользователя. Когда пользователь использует rlogin для подключения к хосту, то машина, к которой подключаются, не будет спрашивать пароль, а подключение будет просто разрешено. Хотя это и не так уж плохо, так как пароль пользователя не передается и не сможет быть перехвачен, это имеет тот недостаток, что если злоумышленник проникнет на основную машину под именем пользователя, то злоумышленник легко сможет воспользоваться rlogin для проникновения в счета пользователя на других системах. По этой причине использование взаимного доверия хостов друг к другу не рекомендуется[Bel89][Ches94].

Сложность конфигурирования и мер защиты

Системы управления доступом в хостах часто сложны в настройке и тяжело проверить, правильно ли они работают. В результате неправильно сконфигурированные меры защиты могут привести к проникновению злоумышленников. Несколько крупных производителей Unix все еще продают свои системы с системой управления доступом, сконфигурированной так, что пользователям предоставлен максимальный ( то есть наименее безопасный) доступ, который может привести к неавторизованному доступу, если не будет произведена переконфигурация.

Ряд инцидентов с безопасностью произошел в Интернете отчасти из-за того, что злоумышленники обнаружили уязвимые места( позднее их обнаружили пользователи, группы компьютерной безопасности и сами производители) . Так как большая часть современных вариантов Unix позаимствовала свой сетевой код из версии BSD, и так как исходный код этой версии широко доступен, злоумышленники смогли изучить его на предмет ошибок и условий, при которых их можно использовать для получения доступа к системам. Отчасти ошибки существуют из-за сложности программ и невозможности проверить их во всех средах, в которых они должны работать. Иногда ошибки легко обнаруживаются и исправляются, но бывает и так, что надо, как минимум, переписать все приложение, что является последним средством( программа sendmail тому пример).

Безопасность на уровне хостов не масштабируется.

Безопасность на уровне хостов плохо шкалируется: по мере того, как возрастает число хостов в сети, возможности по обеспечению гарантий безопасности на высоком уровне для каждого хоста уменьшаются. Учитывая то, что администрирование даже одной системы для поддержания безопасности в ней может оказаться сложным, управление большим числом таких систем может легко привести к ошибкам и упущениям. Важно также помнить, что зачастую важность работы системных администраторов не понимается и эта работа выполняется кое-как. В результате некоторые системы могут оказаться менее безопасными, чем другие, и именно эти системы станут слабым звеном, которое в конечном счете приведет к появлению уязвимого места в системе безопасности.

Если обнаруживается уязвимость в сетевом ПО, сети, которая не защищена брандмауэром, нужно срочно исправить ошибку на всех системах, где она обнаружена. Как уже говорилось в пункте 1.3.2, некоторые уязвимые места позволяют получить легкий доступ с правами суперпользователя Unix. Организация, имеющая много Unix-хостов, будет особенно уязвима к атакам злоумышленников в такой ситуации. Заделывание уязвимых мест на многих системах за короткий промежуток времени просто невозможно, и если используются различные версии ОС, может оказаться вообще невозможным. Такие сети будут просто-таки напрашиваться на атаки злоумышленников.

Насколько уязвимы сети организаци в Интернете?

Как уже отмечалось в предыдущих разделах, ряд служб TCP и UDP плохо обеспечивают безопасность в современной среде в Интернете. При миллионах пользователей, подключенных к Интернету, и при том, что правительства и промышленность зависят от Интернета, недостатки в этих службах, а также легкодоступность исходного кода и средств для автоматизации проникновения в системы могут сделать сети уязвимыми к проникновениям в них. Тем не менее, настоящий риск при использовании Интернета трудно оценить, и непросто сказать, насколько уязвима сеть к атакам злоумышленников. Такой статистики не ведется.

Координационный Центр по групп расследования происшествий с компьютерной безопасностью(CERT/CC) ведет некоторую статистику о числе инцидентов, которые они расследовали после его создания в 1988 году. Числа в этой статистике увеличиваются скачкообразно каждый год, но следует помнить, что и число машин в Интернете также растет. В некоторых случаях CERT считает несколько проникновений одного и того жн типа одним происшествием, поэтому одно происшествие может состоять из нескольких сотен проникновений в ряд систем. Трудно сказать, насколько пропорциональны число инцидентов и число проникновений. Эта проблема также осложняется тем, что чем больше людей знают о существовании групп по расследованию инцидентов, тем больше вероятность того, что они сообщат о происшествии, поэтому на самом деле непонятно, то ли происходит все больше происшествий, то ли сообщается о все большем их проценте.

NIST считает, что Интернет, хотя и является очень полезной и важной сетью, в то же самое время очень уязвим к атакам. Сети, которые соединены с Интернетом, подвергаются некоторому риску того, что их системы будут атакованы или подвергнуты некоторому воздействию со стороны злоумышленников, и что риск этого значителен. Следующие факторы могут повлиять на уровень риска:

  • число систем в сети
  • какие службы используются в сети
  • каким образом сеть соединена с Интернетом
  • профиль сети, или насколько известно о ее существовании
  • насколько готова организация к улаживанию инцидентов с компьютерной безопасностью

Чем больше систем в сети, тем труднее контролировать их безопасность. Аналогично, если сеть соединена с Интернетом в нескольких местах, то она будет более уязвима чем сеть с одним шлюзом. В то же самое время, то, насколько готова к атаке организация, или то, насколько она зависит от Интернета, может увеличить или уменьшить риск. Сеть, имеющая привлекательный для злоумышленников профиль, может подвергнуться большему числу атак с целью получения информации, хранящейся в ней. Хотя, стоит сказать, что "молчаливые" мало посещаемые сети также привлекательны для злоумышленников, так как им легче будет скрыть свою активность.

NIST заявляет, что сети, которые используют рекомендованные процедуры и меры защиты для повышения компьютерной безопасности, будут подвергаться значительно меньшему риску атак. Брандмауэры в сочетании с одноразовыми паролями, которые устойчивы к их перехвату, могут увеличить общий уровень безопасности сети и сделать использование Интернета достаточно безопасным. Следующие главы содержат более детальное описание брандмауэров и того, как они могут использованы для защиты от многих угроз и уязвимых мест, описанных в этой главе.

Почему именно брандмауэры?

Оснвоной причиной использования брандмауэров является тот факт, что без брандмауэра системы подсети подвергаются опасности использования уязвимых мест служб, таких NFS и NIS, или сканирования и атак со стороны хостов в Интернете. В среде без брандмауэра сетевая безопасность целиком зависит от безопасности хостов и все хосты должны в этом случае взаимодействовать для достижения одинаково высокого уровня безопасности. Чем больше подсеть, тем труднее поддерживать все хосты на одном уровне безопасности. Ошибки и упущения в безопасности стали распространенными, проникновения происходят не в результате хитроумных атак, а из-за простых ошибок в конфигурировании и угадываемых паролей.

Подход с использованием брандмауэра имеет многочисленные преимущества для сетей и помогает повысить безопасность хостов. Следующие разделы кратко описывают выгоды использования брандмауэра.

Защита от уязвимых мест в службах

Брандмауэр может значительно повысить сетевую безопасность и уменьшить риски для хостов в подсети путем фильтрации небезопасных по своей природе служб. В результате подсеть будет подвергаться гораздо меньшему числу опасностей, так как только через брандмауэр смогут пройти только безопасные протоколы.

Например, брандмауэр может запретить, чтобы такие уязвимые службы, как NFS, не использовались за пределами этой подсети. Это позволяет защититься от использования этих служб посторонними атакующими, но продолжать использовать их внутри сети, не подвергаясь особой опасности. Поэтому можно будет спокойно использовать такие удобные службы, как NFS и NIS, специально разработанные для уменьшения затрат на администрирование в локальной сети.

Брандмауэры также могут обеспечить защиту от атак с использованием маршрутизации, таких как маршрутизация источника и попыток изменить маршруты передачи данных с помощью команд перенаправления ICMP. Брандмауэр может заблокировать все пакеты с маршрутизацией источника и перенаправленя ICMP, а затем информировать администраторов об инцидентах.

Управляемый доступ к систем сети

Брандмауэр также предоставляет возможности по управлению доступом к хостам сети. Например, некоторые хосты могут быть сделаны достижимыми из внешних сетей, в то время как доступ к другим системам извне будет запрещен. Сеть может запретить доступ к своим хостам извне, за исключением особых случаев, таких как почтовые сервера или информационные сервера.

Эти свойства брандмауэров требуются при политике управления доступом, построенной по принципу: не предоставлять доступ к хостам или службам, к которым доступ не требуется. Другими словами, зачем давать доступ к хостам и службам, которые могут использоваться атакующими, когда на самом деле он не нужен или не требуется? Если, например, пользователю не нужно, чтобы кто-то в сети мог получить доступ к его рабочей станции, то брандмауэр как раз и может реализовать этот вид политики.

Концентрированная безопасность

Брандмауэр может на самом деле оказаться недорогим для организации из-за того, что большинство или все изменения в программах и дополнительные программы по безопасности будут установлены на системе брандмауэра, а не распределены по большому числу хостов. В частности, системы одноразовых паролей и другие дополнительные программы усиленной аутентификации могут быть установлены только на брандмауэре, а не на каждой системе, которой нужно обращаться к Интернету.

Другие подходы к сетевой безопасности, такие как Kerberos[NIST94c] требуют модификации программ на каждой системе в сети. Поэтому, хотя Kerberos и другие технологии также должны рассматриваться из-за их преимуществ и могут оказаться наиболее подходящими, чем брандмауэры в определенных ситуациях, все-таки брандмауэры проще в реализации, так как специальные программы требуются только на брандмауэре.

Повышенная конфиденциальность

Конфиденциальность очень важна для некоторых организаций, так как то, что обычно считается безобидной информацией, может на самом деле содержать полезные подсказки для атакующего. Используя брандмауэр, некоторые сети могут заблокировать такие службы, как finger и доменную службу имен. finger дает информацию о пользователях, такую как время последнего сеанса, читалась ли почта, и другие данные. Но finger может дать атакующему информацию о том, как часто используется система, работают ли сейчас в этой системе пользователи, и может ли быть система атакована, не привлекая при этом внимания.

Брандмауэры также могут быть использованы для блокирования информации DNS о системах сети, поэтому имена и IP-адреса хостов в сети не станут известны хостам в Интернете. Некоторые организации уже убедились в том, что блокируя эту информацию, они скрывают ту информацию, которая была бы полезна для атакующего.

Протоколирование и статистика использования сети и попыток проникновения

Если все доступ к Интернету и из Интернета осуществляется через брандмауэр, то брандмауэр может протоколировать доступ и предоставить статистику об использовании сети. При правильно настроенной системе сигналов о подозрительных событиях (alarm), брандмауэр может дать детальную информацию о том, были ли брандмауэр или сеть атакованы или зондированы.

Важно собирать статистику использования сети и доказательства зондирования по ряду причин. Прежде всего нужно знать наверняка, что брандмауэр устойчив к зондированию и атакам, и определить, адекватны ли меры защиты брандмауэра. Кроме того, статистика использования сети важна в качестве исходных данных при проведении исследований для формулирования требований к сетевому оборудованию и программам и анализе риска.

Претворение в жизнь политики

И наконец, самое важное - брандмауэр предоставляет средства реализации и претворения в жизнь политики сетевого доступа. Фактически, брандмауэр обеспечивает управление доступом для пользователей и служб. Поэтому, политика сетевого доступа может быть реализована с помощью брандмауэра, в то время как без него, такая политика зависит целиком от доброй воли пользователей. Организация может зависеть от своих пользователей, но не должна зависеть от доброй воли всех пользователей Интерне


16_1_TKC

Управление файлами и печатью

Назначение общей папки

В окне Мой компьютер или в проводнике Windows выберите папку, которую требуется сделать общей.
В меню Файл выберите команду Свойства.
Выберите вкладку Доступ, а затем выберите параметр Общий ресурс.
Выберите тип доступа в группе Тип доступа и, при необходимости, введите пароль.
Примечания
Если вкладка Доступ отсутствует, необходимо включить службы общего доступа к файлам и принтерам. Этот же способ применяется при назначении общих дисков.

Управление доступом к папкам и принтерам

В окне Мой компьютер или в окне проводника выберите общую папку или принтер, доступ к которым требуется ограничить.
В меню Файл выберите команду Свойства.
Выберите вкладку Доступ.
Если применяется управление доступом на уровне пользователей, нажмите кнопку Добавить для указания пользователей, совместно с которыми следует использовать принтер или папку.
Если применяется управление доступом на уровне ресурсов, введите пароль для доступа к папке или принтеру.

Архивация файлов на сервере NetWare или Windows NT

Пользователь имеет возможность автоматически архивировать на сетевом сервере файлы с жесткого диска с помощью сетевой службы, которую называют агентом архивации. Должен использоваться агент архивации, установленный администратором сети на сетевом сервере, либо ARCserve, либо Backup Exec.
Периодичность выполнения архивации задается администратором сети. Пользователь указывает, какие файлы следует архивировать.

Открытие общей папки на другом компьютере

Дважды щелкните значок Сетевое окружение, а затем дважды щелкните значок компьютера, на котором находится.
Для вывода имен других компьютеров дважды щелкните значок Вся сеть.
Дважды щелкните значок папки, к которой следует подключиться.
Примечание
Если папка используется часто, удобно сопоставить ей имя диска.

Управление доступом с помощью списка имен

Откройте диалоговое окно Сеть.
Выберите вкладку Управление доступом, а затем выберите параметр На уровне пользователей.
В поле Взять список пользователей и групп с сервера введите имя компьютера или сетевого домена, в котором на сохраняется список имен.
Например, если список имен пользователей и групп сохраняется на компьютере или в домене с именем "Marketing", введите:
marketing
Примечание
Управление доступом на уровне пользователей доступно только в том случае, когда такая возможность задается в конфигурации сети. Если вы не уверены, поддерживается ли в вашей сети управление доступом на уровне пользователей, обращайтесь к администратору сети.

Установка принтера

Нажмите кнопку Пуск, выберите команды Настройка и Панель управления, а затем дважды щелкните значок Установка принтера.
Выполняйте выводящиеся на экран инструкции.
Если требуется напечатать пробную страницу, включите принтер и приведите его в состояние готовности.
Примечание
Чтобы воспользоваться сетевым принтером, найдите его в папке Сетевое окружение, щелкните значок принтера, а затем выберите в меню Файл команду Установить

Использование сетевого принтера

Дважды щелкните значок Сетевое окружение и найдите компьютер, на котором находится принтер.
Дважды щелкните значок компьютера, а затем дважды щелкните значок принтера.
Для установки принтера выполняйте выводящиеся на экран инструкции.
Примечания
После установки сетевого принтера печать на нем выполняется так же, как и на принтере, присоединенном к компьютеру.
Чтобы увидеть, к каким компьютерам подключены , выберите в меню Вид команду Таблица и просмотрите описания компьютеров в столбце Заметки.

Назначение общего принтера

Нажмите кнопку Пуск, выберите команду Настройка, а затем выберите Принтеры.
Щелкните значок принтера, который требуется сделать общим.
В меню Файл выберите команду Свойства.
Выберите вкладку Доступ, а затем выберите параметр Общий ресурс.
Примечания
Если вкладка Доступ отсутствует, необходимо включить службы общего доступа к файлам и принтерам. Пользователь имеет возможность назначить общим только принтер, который присоединен к его компьютеру

Просмотр доступных сетевых принтеров и папок

Дважды щелкните значок Сетевое окружение.
Для просмотра всех доступных сетевых принтеров и папок дважды щелкните значок Вся сеть.
Дважды щелкните значок компьютера, которого требуется просмотреть.
Примечание
Если не удается увидеть сетевой ресурс, то возможно, у вас отсутствуют разрешения на доступ к этому ресурсу


17_1_TKC

WWW - всемирная паутина

Введение

WWW (World Wide Web) - всемирная паутина.
Технологи World Wide Web, Web – технологи была изобретена в начале 90-х годов. Решение оказалось очень удачным, и сегодня почти все посетители Интернета используют эту технологию для информационного обмена.
Потенциально она является наиболее мощным средством поиска. Гипертекст соединяет различные документы на основе заранее заданного набора слов. Например, когда в тексте встречается новое слово или понятие, система, работающая с гипертекстом, дает возможность перейти к другому документу, в котором это слово или понятие рассматривается более подробно.

Основные понятия

Использование технологий WWW для обеспечения доступа к каким-либо информационным ресурсам подразумевает существование следующих компонент IP - сети с поддержкой базового набора услуг по передаче данных с единой политикой нумерации и маршрутизации, работающим сервисом имен DNS. Выделенного информационного сервера - WWW-сервера, обеспечивающего предоставление гипертекстовых документов через IP - сеть в ответ на запросы WWW - клиентов. Передаваемые гипертекстовые документы оформляются в стандарте HTML - языке описания гипертекстовых документов. Эти документы могут либо храниться в статическом виде (совокупность файлов на диске), либо динамически компоноваться в зависимости от параметров запроса специальным программным обеспечением. Для динамической компоновки HTML-документов, WWW-сервер использует специальным образом оформленные программы- CGI-программы.

Использование WWW

Поскольку концепция паутины включает в себя основные принципы организации INTERNET’а, это хорошая печка, от которой можно сегодня танцевать в поисках чего-то нового. Чтобы использовать WWW эффективно, можно запросить использование графического клиента типа Internet Explorer или Netscape Communicator. Можно, конечно, использовать WWW в текстовом режиме (режим линейного поиска), но при этом теряется функциональность графического режима. Internet Explorer или Netscape Communicator являются графическим пользовательским интерфейсом WWW, который позволяет пользователю указывать, выбирать и осуществлять переходы в INTERNET с использованием гипертекстовых связей, называемых URL (Universal Resource Locators – универсальные локаторы ресурсов). Большое число организаций, школ и людей создают собственные элементы WWW, так называемые Home Pages (домашние страницы), которые могут иметь гипертекстовые связи с информацией, находящейся на том же компьютере, или которая может быть найдена на любом компьютере в INTERNET.

WWW - сервер NCSA HTTPD

Одним из ключевых элементов технологии WWW является WWW-сервер. Стандартом де-факто для Unix-систем стало программное обеспечение (ПО) WWW-сервера Национального Центра по Суперкомпьютерным Приложениям (NCSA) Иллинойского Университета. Все вновь создаваемые продукты поддерживают полную совместимость с ПО NCSA по режимам работы и форматом данных. Cервер NCSA является постоянно совершенствуемым продуктом, отражающим последние веяния WWW-технологии. Созданная относительно недавно "Apache Group" разрабатывает свое программное обеспечение WWW - сервера на базе продукта NCSA HTTPD.

Ограничения доступа в WWW серверах

Ограничить доступ по IP адресам клиентских машин; ввести идентификатор получателя с паролем для данного вида документов. Такого рода ввод ограничений стал использоваться достаточно часто, т.к. многие стремятся в Internet, чтобы использовать его коммуникации для доставки своей информации потребителю. С помощью такого рода механизмов по разграничению прав доступа удобно производить саморассылку информации на получение которой существует договор. Ограничения по IP адресам Доступ к приватным документам можно разрешить, либо наоборот запретить используя IP адреса конкретных машин или сеток, например: 123.456.78.9 123.456.79. В этом случае доступ будет разрешен (или запрещен в зависимости от контекста) для машины с IP адресом 123.456.78.9 и для всех машин подсетки 123.456.79. Ограничения по идентификатору получателя. Доступ к приватным документам можно разрешить, либо наоборот запретить используя присвоенное имя и пароль конкретному пользователю, причем пароль в явном виде нигде не хранится. Рассмотрим такой пример: Агенство печати предоставляет свою продукцию, только своим подписчикам, которые заключили договор и оплатили подписку. WWW Сервер находится в сети Internet и общедоступен.

ЗАЩИТА WEB-СЕРВЕРОВ

Наряду с обеспечением безопасности программной среды важнейшим будет вопрос о разграничении доступа к объектам Web-сервиса. Для решения этого вопроса необходимо уяснить, что является объектом, как идентифицируются субъекты и какая модель управления доступом - принудительная или произвольная - применяется. В Web-серверах объектами доступа выступают универсальные локаторы ресурсов (URL - Uniform (Universal) Resource Locator). За этими локаторами могут стоять различные сущности - HTML-файлы, CGI-процедуры и т.п. Как правило, субъекты доступа идентифицируются по IP-адресам и/или именам компьютеров и областей управления. Кроме того, может использоваться парольная аутентификация пользователей или более сложные схемы, основанные на криптографических технологиях. В большинстве Web-серверов права разграничиваются с точностью до каталогов (директорий) с применением произвольного управления доступом. Могут предоставляться права на чтение HTML-файлов, выполнение CGI-процедур и т.д. Для раннего выявления попыток нелегального проникновения в Web-сервер важен регулярный анализ регистрационной информации. Разумеется, защита системы, на которой функционирует Web-сервер, должна следовать универсальным рекомендациям, главной из которых является максимальное упрощение. Все ненужные сервисы, файлы, устройства должны быть удалены. Число пользователей, имеющих прямой доступ к серверу, должно быть сведено к минимуму, а их привилегии - упорядочены в соответствии со служебными обязанностями. Еще один общий принцип состоит в том, чтобы минимизировать объем информации о сервере, которую могут получить пользователи. Многие серверы в случае обращения по имени каталога и отсутствия файла index.HTML в нем, выдают HTML-вариант оглавления каталога. В этом оглавлении могут встретиться имена файлов с исходными текстами CGI-процедур или с иной конфиденциальной информацией. Такого рода “дополнительные возможности” целесообразно отключать, поскольку лишнее знание (злоумышленника) умножает печали (владельца сервера).

Пакет Web - Oracle - Web

Пакет WOW является свободно-распространяемым программным средством, предназначенным для создания интерактивных WWW-интерфейсов с СУБД Oracle. Пакет WOW был первым и наиболее простым средством, выпущенным фирмой Oracle. В настоящее время существует набор продуктов, развивающих функциональность WOW'а - Oracle Web Server версий 1, 2, Oracle Web Arcitecture. Все перечисленные продукты позволяют использовать процедурное расширение языка SQL - PL/SQL, разработанное фирмой Oracle для динамического создания гипертекстовых документов. Высокая скорость разработки достигается за счет резкого упрощения доступа к БД - программы на PL/SQL исполняются самим сервером Oracle. Предлагаемый пакет WOW был переработан в Новосибирском областном центре НИТ с целью поддержки нескольких русскоязычных кодировок. Основной областью использования WOW является обработка запросов от WWW-сервера к SQL-серверу Oracle в среде Unix. В предложенных сценариях пакет WOW позволит организовать эффективный WWW доступ к информационному хранилищу, построенному на базе сервера баз данных Oracle.

Схема шлюза Internet

Пусть мы решили установить у себя в организации несколько общедоступных серверов для предоставления информационных услуг. Это могут быть, например, серверы World Wide Web, FTP или другие информационные серверы. Поскольку такие системы обособлены от работы всей остальной сети организации, для них часто выделяют свою собственную подсеть, имеющую выход в Internet через шлюз. Поскольку в предыдущем примере локальная сеть была уже защищена, то все, что нам надо сделать, это просто разрешить соответствующий доступ в выделенную подсеть. Это делается с помощью одной дополнительной строки в редакторе правил, которая здесь показана. Такая ситуация является типичной при изменении конфигурации FireWall-1. Обычно для этого требуется изменение одной или небольшого числа строк в наборе правил доступа, что, несомненно, иллюстрирует мощь средств конфигурирования и общую продуманность архитектуры FireWall-1

Заключение

WWW часто используется в качестве интерфейса к базам данных WAIS, но отсутствие гипертекстовых связей ограничивает возможности WWW до простого просмотра, как у Gopher. Пользователь со своей стороны может задействовать возможность WWW работать с гипертекстом для связи между своими данными и данными WAIS и WWW таким образом , чтобы собственные записи пользователя как бы интегрировались в информацию для общего доступа. На самом деле этого, конечно, не происходит, но воспринимается именно так. WWW - это относительно новая и динамично развивающаяся система. Установлены несколько демонстрационных серверов, в том числе Vatican Exibit в библиотеке Конгресса США и мультфильм о погоде "Витки спутника" в Мичиганском государственном университете. В качестве демонстрационных также работают серверы into.funet.fi (Финляндия); into.cern.ch. (Швейцария) и eies2.njit.edu (США). Практически все услуги сети построены на принципе клиент-сервер. Сервером в сети Internet называется компьютер способный предоставлять клиентам (по мере прихода от них запросов) некоторые сетевые услуги. Взаимодействие клиент-сервер строится обычно следующим образом. По приходу запросов от клиентов сервер запускает различные программы предоставления сетевых услуг. По мере выполнения запущенных программ сервер отвечает на запросы клиентов.

Программы для создания сайтов

Язык HTML

Как уже говорилось выше, веб-страницы кодируются на языке гипертекстовой разметки — HTML. Вообще говоря, чтобы написать HTML-файл, достаточно иметь любой текстовый редактор, лишь бы он умел не добавлять в текст свои специальные символы. Самый простой вариант — это редактор Notepad (Блокнот), входящий в стандартную поставку Windows. Однако в очень простых текстовых редакторах типа Блокнота весь HTML-текст приходится писать вручную, а многим хотелось бы какую-то часть работы автоматизировать. Учитывая это желание, разработчики создали специализированные средства, призванные облегчить труд веб-программиста (как иногда называют тех, кто пишет код HTML, в отличие от веб-дизайнеров, которые придумывают внешний вид и иногда даже пытаются воплотить его, используя программы работы с графикой).

Adobe Golive 5.0(ENG) and HTML Editor

Одна из программ для создания Web сайтов это программа Adobe Golive 5 версии. Программа была создана фирмой Adobe. Очень удобный интерфейс, довольно легко обращаться с этой программой Программа HTML Editor специально создана для создания WEB сайтов в неё уже встроены основные функции Красивый дизайн, удобные кнопки

Microsoft WORD

По идее с помощью такой программы как Microsoft Word тоже можно создавать Интернет странички, но в ней нельзя Создавать специальные спецэффекты такие как бегущая строка, или различные анимированные рисунки. В Microsoft Word можно создавать красивые надписи и вставлять их в Word, а затем сохранять как HTML страницу Таким образом можно создать самый простенький сайт. Но чтобы создать более крутой сайт необходима такая программа как FrontPage.

Internet Explorer

На сегодняшний день наиболее популярной программой просмотра веб-страниц является браузер Microsoft Internet Explorer, которым пользуется примерно половина всех бродящих по Интернету. MS Internet Explorer версии 5 поддерживает большинство требований HTML 4.0 Программа Internet Explorer поддерживает в качестве сценарного языка не только язык JavaScript,но и изобретенный компанией Microsoft язык VBScript, который происходит от языка Visual Basic. Поскольку веб-страницы, написанные с использованием VBScript, реально существуют, то только использование браузера Internet Explorer позволяет сегодня адекватно отобразить их содержимое.

Magellan Explorer

Magellan Explorer – это мощный менеджер для работы с файлами, независимо от того находятся ли они на вашем диске или в Интернете . Программа позволяет скачивать Интернет сайты, работает с архивами, работает с FTP серверами, позволяет просматривать картинки и многое другое, очень красивый интерфейс. Это программа лучше чем Internet Explorer.

Netscape Navigator

Вторым по популярности броузером в мире является Netscape Navigator. В отличие от MS Internet Explorer, эта программа реализована для многих платформ, включая OS/2 и UNIX с ее клонами. На “He-Win.dows-компью-терах” Netscape Navigator продолжает оставаться наиболее популярной программой просмотра веб-страниц. Вышел второй предварительный релиз шестой версии Netscape Navigator В этой версии также реализована поддержка многих требований HTML 4.0, однако не в такой полной мере, как в MS Internet Explorer 5. В частности, на пользовательские действия по-прежнему могут реагировать далеко не все элементы веб-страницы. Программу Netscape Navigator можно бесплатно получить, обратившись по адресу www.netscape.com. В предыдущей версии этой программы (четвертой) не поддерживались новые теги, предложенные в четвертой версии Internet Explorer (например BUTTO>), что очень затрудняло написание динамических страниц, совместимых одновременно и с Internet Explorer, и с Netscape Navigator.


Управление Web-сайтом

Вы неплохо потрудились, планируя и разрабатывая ваш Web-сайт, и вот, наконец, работа подошла к завершению. Вы приступаете к этапу воплощения идеи в реальность, но что-то вас смущает. Как со всем этим справиться? Как обеспечить постоянную поддержку сайта? Как убедиться, что все работает, прежде чем размещать сайт в сети? Можете ли вы быть уверены, что какой-нибудь доброжелатель, любящий совать свой нос в чужие дела, не залезет в сайт и не испортит все?

Множество подобных вопросов может прийти вам в голову на любой стации разработки вашего сайта, особенно, если команда Web-разработчиков в вашей компании или организации достаточно велика. Но даже если эта команда состоит из одного человека, все равно приходится учитывать большое количество административных проблем, связанных с организацией сайта. Прежде чем эти беспокойные мысли превратятся в страшную головную боль, прочтите эту главу и вы увидите, насколько Frontpage упрощает администрирование сайта.

И если вы задумываетесь об администрировании Web-сайта, вспомните о Проводнике. Проводник Frontpage — это прекрасный инструмент для решения большинства ваших задач администрирования: с его помощью вы можете планировать мероприятия по разработке и поддержке ваших сайтов, решать проблемы с Proxy-серверами, устанавливать полномочия пользователей и многое другое. В этой главе объясняется, как Frontpage поможет вам справиться с этими задачами. Начнем с рассмотрения проблем защиты информации.

Защита

На Диком Западе защита ассоциировалась с крутым парнем и его командой стрелков. Сегодня, когда информация передается по воздуху и по телефонным и спутниковым линиям связи, обеспечить ее безопасность стало намного сложнее. Особенно, когда 12-летний хакер из Небраски находит спо-собы Прерваться даже через самые совершенные меры защиты. Так что, когда дело дойдет до безопасности вашего Web-сайта и ограничения доступа к нему, в?ам будет приятно узнать, что Frontpage может предоставить в ваше распоряжение очень надежные средства защиты.

Использование SSL

Протокол безопасных соединений (Secure Sockets Layer, SSL) - это протокол, который обеспечивает безопасную связь между сервером и клиентом. SSL не закрывает доступ к передаваемым данным, а просто их шифрует. Для правильной работы SSL необходимо, чтобы его поддерживали и сервер, и клиент. Frontpage и Microsoft Internet Explorer, а также Netscape Navigator поддерживают SSL. Frontpage также позволяет создавать ссылки, начинающиеся с https:// вместо http://; такие ссылки означают безопасное соединение по протоколу SSL.

Прежде чем двигаться дальше, вы должны выяснить, поддерживает ли SSL сервер, с которым вы собираетесь работать. Сделать это можно несколькими способами:

- Узнайте это у администратора сервера. Администратор может отключить поддержку SSL, так что желательно выяснить это заранее

- Если вы используете Microsoft Internet Information Server или один из серверов Netscape (Commerce Server, FastTrack Server или Enterprise Server), то вам, скорее всего, беспокоиться не о чем. Однако и в данном случае вам не повредит выяснить это у администратора (имейте в виду, что Microsoft Personal Web Server не поддерживает SSL)

- Если вы хотите проверить это самостоятельно, то создайте новый сайт в Проводнике Frontpage, как было описано в главе 3. Укажите сервер, задайте имя сайта и установите флажок Connect Using SSL. Если Проводник откроет сайт без сообщения об ошибке, то поддержка SSL на вашем сервере установлена

Если на сервере и в Frontpage активизирован SSL, то связь между клиентом Frontpage и сервером, включая любые команды от Проводника или Редактора, является безопасной. Это означает, что весь поток информации между Frontpage и Web-сервером, где бы они ни были расположены, шифруется. Такая защита удобна в нескольких ситуациях:

- Если вы находитесь в пути и вам нужно внести изменения в сайт, находящийся на сервере у вас дома, то вы можете открыть сайт, сделать необходимые изменения и сохранить их на сервере

- Если ваша организация имеет более одного офиса и только один Web-сервер, то можно вносить изменения в сайт из удаленного офиса

- Если ваш корпоративный или персональный Web-сайт расположен на сервере провайдера услуг Internet (как правило, такие серверы обслуживают несколько Web-сайтов), то вы сможете производить изменения в вашем сайте при помощи Frontpage, не опасаясь, что информация по пути будет перехвачена и просмотрена каким-либо хакером, поскольку все передаваемые данные зашифрованы

Полномочия

Полномочия дают вам как разработчику Web-сайта возможность установки прав доступа к вашему сайту. С их помощью вы можете определять круг лиц, имеющих привилегии просмотра, авторства или администрирования сайта независимо от того, для какой сети — intranet или Internet — вы разрабатываете сайт. Если вы установили разрешение доступа только для зарегистрированных пользователей, то очевидно, незарегистрированный пользователь доступа к вашему сайту иметь не будет. Например, вы можете счесть необходимым ограничить доступ на время разработки сайта; когда ваш сайт будет готов, то вы просто измените полномочия пользователей и предоставите доступ к сайту всем желающим.

Если вы размещаете сайты Frontpage на сервере Internet, то определять полномочия и разграничивать доступ различных пользователей ко всем сайтам вы можете прямо в Проводнике. Если же вы создаете ваш сайт и сохраняете его в виде файлов на локальном или сетевом диске, то у вас нет возможности использовать Проводник для установки полномочий. В таких сайтах для управления доступом вам придется использовать средства файловой системы.

Администратор может управлять полномочиями в Проводнике с помощью команды Permissions (Полномочия) меню Tools. По умолчанию все Web-сайты, находящиеся на сервере, используют права доступа, установленные для корневого сайта. Однако вы можете для каждого отдельного сайта установить свои разрешения. Далее будут описаны обе эти возможности.

Установка и изменение полномочий для корневого Web-сайта

Установка и изменение полномочий для корневого Web-сайта производится следующим образом. Откройте существующий сайт Frontpage в Проводнике, выбрав в меню File пункт Open Frontpage Web. В диалоговом окне Open Frontpage Web введите или выберите Web-сервер. Нажмите кнопку List Webs, выберите из списка сайтов <Root Web> и нажмите кнопку ОК. Для того чтобы открыть диалоговое окно Permissions, показанное на рис. 5.1, выберите в меню Tools команду Permissions.

Рис. 5.1. Диалоговое окно Permissions

На вкладке Users (первой вкладке диалогового окна) перечислены все имеющиеся в настоящее время пользователи корневого сайта, а также их текущие уровни доступа. На этой вкладке вы можете добавлять, редактировать или удалять бюджета пользователей, как объяснено в приведенном ниже списке. Еще здесь присутствует переключатель, имеющий два положения - Everyone has browse access (Все имеют доступ на просмотр) и Only registered users have browse access (Доступ на просмотр имеют только зарегистрированные пользователи).

- Для того чтобы добавить бюджет пользователя, нажмите кнопку Add и задайте его имя и права доступа

- Для редактирования прав доступа пользователя выберите имя нужного пользователя из списка и нажмите кнопку Edit. На экране появится диалоговое окно Edit Users, показанное на рис. 5.2, в котором вы сможете изменить уровень его привилегий

- Для того чтобы удалить бюджет пользователя, выберите его имя в списке и нажмите кнопку Semove

Вторая вкладка, Groups (Группы), содержит список всех групп, установленных в настоящее время для корневого Web-сайта, и текущий уровень доступа каждой группы. Это также дает вам возможность добавлять, редактировать или удалять бюджеты групп аналогично тому, как это делается на вкладке Users.

Рис. 5.2. Диалоговое окно Edit Users

Предупреждение

При удалении бюджетов администраторов или авторов из списка полномочий удостоверьтесь, что выделены именно те, которые вы хотите удалить, т. к. Frontpage не станет спрашивать у вас подтверждения ваших действий.

Установка и изменение полномочий для указанного Web-сайта

Чтобы устанавливать и изменять полномочия для конкретного сайта, сначала откройте в Проводнике существующий сайт, выбрав пункт Open Frontpage Web в меню File. В диалоговом окне Open Frontpage Web введите или выберите Web-сервер. Нажмите кнопку List Webs и выбрав сайт, щелкните по кнопке ОК. Далее в меню Tools выберите команду Permission. На экране появится диалоговое окно Permissions, содержащее три вкладки, каждая из которых относится к определенному уровню доступа. На рис. 5.3 показано диалоговое окно Permissions сайта Project One. Это окно имеет 3 вкладки:

- На вкладке Settings (Параметры настройки) находится переключатель, одно из положений которого устанавливает для текущего сайта те же самые полномочия, что и для корневого, а другое позволяет вам устанавливать для текущего сайта свои собственные полномочия. Выбор каждой из этих опций сопровождается описанием ее в нижней части диалогового окна. Если вы хотите назначить определенным лицам привилегии администратора, автора и/или конечного пользователя только для этого сайта, но не для корневого, то выберите вторую опцию. Иначе выберите первую опцию и внесите необходимые изменения в полномочия для корневого сайта, как было описано в этой главе ранее

- Следующие две вкладки относятся к пользователям группам (вкладки Users и Groups соответственно). Установка полномочий пользователей групп работает точно так же, как и в случае корневого сайта. Имейте в виду, что при удалении пользователей или групп Frontpage не запросит вас о подтверждении ваших действий

Рис. 5.3. Диалоговое окно Permissions сайта Project One

После того как вы закончите модификацию полномочий, нажмите кнопку ОК, чтобы вернуться в Проводник.

Примечание

Если вы вносите изменения в параметры настройки на вкладке, то перед переходом к другой вкладке для сохранения параметров следует нажать Apply (Применить).

Установка полномочий на сервере

Web-серверы часто имеют встроенные механизмы регулирования полномочий, позволяющие вам ограничивать доступ на основе имени/пароля пользователя, маски IP-адреса или их комбинации.

Примечание

Microsoft Internet Information Server, Microsoft Personal Web Server и Windows NT Workstation Peer Web Services ограничивают доступ, используя стандартную систему безопасности Windows NT, и не поддерживают ограничение доступа через маски адреса IP.

Адрес IP содержит четыре числа, разделенные точками, каждое из которых меньше 256, например, 150.200.45.65. Маска адреса IP используется для того, чтобы создать модель приемлемого адреса IP, используя комбинацию фактических значений и звездочек (известных также как групповые символы (wild cards)). Маски используются для того, чтобы определить, имеет ли компьютер доступ к Internet, например, к сайту Frontpage. Примером адресной маски, которая разрешает соединение с вышеприведенным адресом IP, может служить 150.200.*.*. Компьютеры с IP-адресами, начинающимися на 150.200, будут иметь доступ к сайту Frontpage, а компьютерам с другими IP-адресами доступ будет закрыт. Если установлена маска IP, то для доступа к сайту Frontpage администратор, автор или пользователь должны работать на компьютере, который имеет доступ к местоположению сайта, а также иметь соответствующие полномочия. По умолчанию доступ к сайтам Frontpage открыт всем компьютерам.

За более подробной информацией относительно установки полномочий на сервере обращайтесь к документации вашего сервера.

Пароли

Для изменения и администрирования сайтов Frontpage вам необходимо иметь пароль, но вводить его придется не очень часто (это зависит от используемого вами Web-сервера); опция Change Password меню Tools Проводника может даже быть недоступна.

Если Frontpage попросит вас ввести имя пользователя и пароль, то это может быть вызвано одной из следующих причин:

- Некоторые Web-серверы требуют обязательного ввода имени пользователя и пароля, независимо от пользователя или ситуации

- Вы пытаетесь обращаться, вносить изменения или управлять сайтом на сервере, не имея на то соответствующих прав

При установке Frontpage предложит вам указать имя пользователя и пароль для администратора, единственного для всех создаваемых вами сайтов. Чтобы предоставить другим лицам права административного, авторского и пользовательского доступа к вашим сайтам, воспользуйтесь командой Проводника Permissions.

Смена паролей

С некоторыми Web-серверами Microsoft смена паролей во Frontpage окажется невозможной. Microsoft Internet Information Server, Microsoft Personal Web Server и Windows NT Workstation Peer Web Services обращаются к списку бюджетов пользователей (user accounts) Windows NT, a Frontpage не способен позволить вам создавать, удалять или редактировать бюджеты пользователей. Изменение вашего пароля аналогично изменению вашего бюджета в Windows NT, поэтому Windows NT посчитает это нарушением защиты.

Так, если, используя один из этих серверов, вы попытаетесь командой Проводника Permissions изменить права доступа, то увидите, что пароли пользователей вам изменить не удастся, и теперь вы знаете, почему. По этой же причине может быть недоступна команда Change Password меню Tools. При использовании этих серверов Frontpage проверяет имя и пароль пользователя по списку бюджетов системы Windows NT. Следовательно, в Windows NT вы должны изменять пароли на уровне системы. За информацией о том, как изменять пароли при использовании этих серверов Microsoft, обратитесь к документации по серверу или сети.

Если Microsoft Personal Web Server у вас запущен под управлением Windows 95, то редактирование параметров и паролей пользователей можно производить с помощью средств администрирования этого сервера. Чтобы до них добраться, щелкните дважды на значке Personal Web Server в панели управления Windows (Windows Control Panel). Более подробно об этом написано в главе 11.

При использовании других Web-серверов благодаря тому, что список бюджетов пользователей сервера полностью независим от списка бюджетов пользователей операционной системы, вы можете свободно добавлять, удалять или изменять пароли без опасения нарушения защиты. Вы можете сделать это при помощи диалогового окна Change Password, которое вы можете вызвать, выбрав в меню Tools Проводника команду Change Password. Более подробно этот момент освещен в главе 3.

Proxy-серверы

Proxy-сервер (Proxy server) защищает сеть из несанкционированного доступа снаружи. Frontpage позволяет легко работать с Proxy-серверами в любом направлении, как извне — в случае подключения снаружи через Proxy-сервер к вашему внутреннему серверу, так и изнутри — когда ваш внутренний сервер через Proxy-сервер устанавливает соединение с каким-либо внешним сервером. Все обращения к сайту разрешаются только Proxy-сервером, что предотвращает доступ к вашей системе незваных гостей.

Если в вашей локальной сети установлен Proxy-сервер, то его следует указать в Проводнике Frontpage. Для того чтобы задать Proxy-сервер для вашей машины или сервера, соединение с которыми происходит непосредственно, без участия Proxy-сервера, проделайте нижеследующее:

1. Выберите в меню Tools Проводника команду Options, а затем в диалоговом окне Options выберите вкладку Proxies (рис. 5.4).

2. В текстовом поле HTTP Proxy введите имя Proxy-сервера и порта; например, itgproxy.1000.

3. Если ваша организация имеет серверы, которые находятся внутри брандмауэра, то их список отображается в текстовом поле List of Hosts without Proxy (Список хостов без Proxy-сервера). Связь с этими серверами осуществляется без использования Proxy-сервера. Номера портов вы можете задавать произвольно, и в списке они должны отделяться запятыми; например, jeffserver.345, deborahserver.222. Для того чтобы удалить Proxy-сервер или любые другие серверы из списка, выделите соответствующее имя и нажмите клавишу <Del>.

Если вы хотите иметь доступ ко всем серверам внутри Proxy-сервера, установите флажок Do not use proxy server for local (intranet) addresses (He

использовать Proxy-сервер для локальных адресов (intranet)).

4. После внесения изменений в диалоговом окне Proxies нажмите кнопку ОК.

Рис. 5.4. Вкладка Proxies

диалогового окна Options

Frontpage сохраняет информацию о Proxy-сервере и использует ее при всех следующих подключениях, так что вам не придется вводить эту информацию каждый раз. Всякий раз, когда вы запрашиваете подключение к серверу (например, следуя по ссылке), Frontpage проверяет, не установлен ли флажок По not use proxy server for local (intranet) addresses, и при необходимости проверяет список хостов без Proxy-сервера. Если сервер доступен изнутри, то Frontpage осуществляет подключение непосредственно. В противном случае Frontpage сначала соединяется с Proxy-сервером и далее устанавливает соединение Proxy-сервера с тем сайтом, к которому вы обратились. Это означает, что после того, как вы ввели информацию о Proxy-сервере, все обращения через него Frontpage обеспечивает автоматически, а вы можете даже и не знать об использовании Proxy-сервера.

Тестирование вашего сайта

Рано или поздно процесс разработки вашего сайта подойдет к концу, и хотя вы можете быть уверены, что он будет работать без сучка, без задоринки, не мешает это проверить. Тестирование может предотвратить, скажем, следующую ситуацию: наступает день, когда вы собираетесь представить заказчикам законченную работу. Ваш сайт невелик, но вы им очень гордитесь. Однако один из ваших коллег, давно завидующий вашим успехам и красному спортивному автомобилю, задержавшись накануне в офисе, входит на ваш сайт и слегка изменяет в нем одну из ссылок. И вместо того чтобы по кнопке See Profile перейти, как было задумано, на страницу профиля компании, вы прямиком отправляетесь на сайт бюро ритуальных услуг "Нимфа".

Для того чтобы проверить ваши ссылки, существует три метода:

- Вы можете проверить их по отдельности в Редакторе. Это весьма медленный способ проверки ссылок, но если вы уже запустили Редактор и хотите удостовериться, что ссылки работают, то поместите курсор на ссылку и нажмите <Ctrl> одновременно со щелчком на ссылке. В Редактор будет загружена соответствующая страница

- Вы можете исследовать ваш сайт с помощью какого-нибудь браузера типа Microsoft Internet Explorer или Netscape Navigator и проверить каждую из ссылок. Этим способом вы сможете воочию убедиться в том, что ваши ссылки, включая ссылки на другие сайты Internet, работают как нужно

- Вы можете заставить Frontpage автоматически проверить все ваши ссылки в один прием, задав в Проводнике команду Tools, Verify Hyperlinks. Эта процедура была подробно разобрана главе 3. Эта команда, однако, проверяет только существование адресов назначения всех ссылок, но не их правильность! Если вы хотите сэкономить время, то вы можете проверить состояние ваших ссылок в протоколе состояния гиперссылок (Hyperlinks Status View) Проводника. О нем было рассказано в главе 3

Наконец, вы можете проверить правильность расположения изображений на вашей странице. Обязательно сделайте это как в Редакторе, так и в различных браузерах. При проверке изображений обращайте внимание на такие вещи, как время их загрузки и качество. Более детально тема графики рассмотрена в главе 8.

Самый простой способ проверить ваш сайт в браузере — это использовать команду Preview in Browser (Предварительный просмотр .в браузере) из меню File Редактора. Эта команда позволяет вам выбрать любой из установленных браузеров и проверить работу вашего сайта при различных значениях разрешения экрана. Более подробно о команде Preview in Browser читайте в главе 7.

Нередко при тестировании одного и того же сайта на локальном компьютере, в сети и в Internet результаты существенно отличаются. Это происходит из-за различных факторов, которые могут влиять на быстродействие и передачу информации. Проверьте, по возможности, работу вашего сайта как можно большим количеством способов, такими как:

- Локально, на вашем собственном компьютере

- В сети

- В удаленном режиме, в Internet

- Используя модемы и другие устройства связи при различных скоростях

- Под различными операционными системами

- В различных браузерах и при различных параметрах экрана (таких, как разрешающая способность)

Выход в сеть

Не каждая организация может позволить себе устроить всенародные торжества по случаю появления на свет нового Web-сайта. Но, тем не менее, явление сайта народу, глобального ли или сайта intranet, является достаточно значительным событием, и когда придет время, вы должны знать, как это делается.

Существует несколько способов сделать ваш сайт доступным для аудитории. Один распространенный путь — строить сайт прямо на том сервере, на котором он и будет размещен в сети, и открыть к нему свободный доступ. При таком варианте очень полезны пиктограммы Under Construction (Ведутся работы), т. е. они дают понять посетителям, что страница еще не завершена. Frontpage может добавить эти пиктограммы, если вы используете мастер создания сайта.

Если вы не хотите, чтобы кто-нибудь видел еще не законченный сайт или если у вас просто недостаточно информации, заслуживающей внимания, то вы можете сделать одно из двух: либо разрабатывайте свой сайт на локальном уровне, либо ограничьте доступ к нему пользователей.

Локальная разработка сайта

Microsoft Personal Web Server, Frontpage Personal Web Server и Microsoft Internet Information Server очень хорошо подходят для локальной разработки. Они дают вам возможность разрабатывать и проверять ваши intranet или Internet Web-сайты на вашем собственном компьютере или в локальной сети. Когда ваш сайт будет полностью готов, и вы будете готовы представить его всеобщему обозрению, вы сможете скопировать его на Web-сервер одним нажатием кнопки на панели инструментов Проводника, используя команду Publish. При помощи этой команды вы сможете скопировать сайт на любой из наиболее популярных Web-серверов. Более подробно о команде Publish читайте в главе 3.

Обновление сайта

Всемирная Паутина, будучи зеркалом информационных технологий, находится в постоянном развитии. Сегодня вы отправите другу по электронной почте адрес понравившегося вам сайта, а на следующий день, может статься, ваш друг уже не увидит то, что видели вы, т. к. сайт уже в корне изменился. Эта тенденция к изменчивости касается даже сетей intranet. Одной из причин такой изменчивости является простота модификации сайтов. Для того чтобы заменить графику, изменить ссылки или даже добавить новую страницу, особых усилий не требуется.

Другая причина быстрого изменения сайтов — это требования аудитории. Вам необходимо постоянно насыщать сайт свежей информацией, в противном случае больше одного раза никто на него возвращаться не захочет. Посещение сайта подобно перевертыванию игральной карты, если ваши зрители увидят ту же самую картинку еще раз, то они будут играть в другую игру.

Однако большие изменения не следует вносить слишком часто. Если у вас много постоянных пользователей, то не стоит запутывать их, ежемесячно меняя расположение кнопок навигации или названия разделов сайта; плохо, если они не смогут найти то, что ищут. Помните, что хороши регулярные изменения содержания, такие как изменения текста и изображений, но изменение структуры может быть реальным ударом для ваших постоянных пользователей.

Модифицирование больших сайтов может отнимать много времени, и тем больше, чем обширнее сайт и чем чаще происходит обновление. Вы должны составить план модифицирования вашего сайта еще до того даже, как начнете его. Если именно сейчас вы занимаетесь планированием сайта или у вас назрела необходимость в составлении плана его обновления, то прочтите несколько полезных советов по этому поводу.

Обновление содержания

Обновление содержания происходит тем же путем, что и сбор первоначальной информации, однако этот процесс наверняка можно рационализировать. Например, если в первый раз это заняло слишком много времени, попробуйте собирать информацию в другом порядке или устранить какой-нибудь не очень важный этап, например, редактируйте материал не дважды, а только один раз. А также проверьте расписания сотрудников, чтобы быть уверенным в том, что папка с вашими материалами не осядет на столе у человека, уехавшего отдыхать на Таити.

Если вашей компании требуется, чтобы ваш материал проходил через юридический отдел, то, скорее всего, не обязательно отдавать туда весь материал, ведь часть его наверняка уже где-нибудь используется. Если вам удастся сократить объем излишние передвигаемого материала, то вы сохраните время и энергию, которые пригодятся для более полезных дел.

Никогда не забывайте планировать вперед. Если ваш сайт подлежит ежемесячному обновлению и для свежего материала у вас предусмотрен тестовый сайт, то не жалейте времени на работу с ним. Например, если первый ваш выход в сеть состоялся в мае, а обновление запланировано на июнь, то оставьте достаточно времени для разработки и тестирования обновлений до наступления 1 июня. Это означает, что все содержание для июньского выпуска должно быть завершено к середине мая, чтобы у вас было достаточно времени для проверки сайта и устранения найденных ошибок.

Оцените время, которое потребуется вам и/или вашей группе для написания, редактирования и одобрения содержания. Вам потребуется информация из различных отделов вашей компании, и даже если вы или ваш помощник любите сами посещать сотрудников для уточнения каждой мелочи, убедитесь, что для сбора материала вы вьщелили достаточно времени.

Удаленное обновление сайта

Удаленное обновление — одна из самых сильных сторон Frontpage. Существует не так много других средств разработки Web-сайтов, предлагающих подобную возможность. Это делается просто:

- Вы должны иметь возможность соединиться с Web-сервером, содержащим сайт, который вы хотите модифицировать. Желательно, чтобы на сервере были установлены Серверные расширения Frontpage

- На используемом вами компьютере должен быть установлен Frontpage

- Удаленный компьютер и пользователь должны иметь для редактирования сайта права автора или администратора

Если вы готовы ответить утвердительно на эти три требования, то идите к своему шефу и убеждайте его в необходимости перенести ваше рабочее место в ваше любимое кафе.

Одновременное редактирование

Frontpage делает изменение содержания вашего сайта простой задачей, выполнять которую могут одновременно несколько авторов. Однако, если вы модифицируете содержание и работаете над какой-нибудь его частью, в то же время над этой же частью может работать кто-то другой. Опасность, конечно, возникает, когда двое или более авторов пытаются делать изменения на одной и той же странице одновременно.

Чтобы помочь избежать такой ситуации, Frontpage выдает предупреждение в случае, когда кто-то пытается записать страницу, которую уже редактирует кто-то другой. Если вы получите такое предупреждение, то вам придется решать, какое из изменений оставить. Если вы оставите свои изменения, то будут потеряны правки, сделанные вашим коллегой. В будущем координируйте свою работу с другими таким образом, чтобы в одно и то же время над одной страницей не работало несколько человек.

Чтобы избежать таких осложнений, шире используйте в своей работе перечень заданий (Tasks View) Проводника. В перечне заданий каждой задаче назначается только один автор. Если обстоятельства изменились, то вы всегда сможете переназначить задачу. Даже если авторы, работающие над сайтом, географически удалены друг от друга, то все равно все они будут иметь дело с одним и тем же перечнем заданий. Таким образом исключается одновременное редактирование одной страницы несколькими авторами.

Повышение пропускной способности

Готов ли ваш сайт к высокому графику? Если он станет популярным, то для обработки запросов вам потребуется мощный Web-сервер. Frontpage при помощи команды Publish Frontpage Web Проводника позволяет упростить процедуру переноса сайта с одного сервера на другой. Так, если используемый вами сервер не справляется, и у вас есть более мощный сервер, способный справиться с увеличившимся потоком информации, то вы можете просто переместить ваш сайт на новый сервер. Эта операция предельно проста и осуществляется с помощью команды Publish Frontpage Web, которая была описана в главе 3. Чтобы побольше узнать о Web-серверах и Серверных расширениях Frontpage (Frontpage Server Extensions), загляните в главу 11.

Ранние было сказано, что сайт можно представить в виде: потолка, головы, тела и пола. Так оно и на самом деле. Самый первый открывающий тег <html> бдет потолком, затем идет тег <head>и его закрывающий тег </head> это будет у нас голова , дальше у нас идет тело <body> и </body>, а на последок у нас будет пол, и это </html>.

Теперь мы поговорим серьёзно. Весь сайт открывается и закрывается двумя тегами <html> и </html>. Эти теги не имеют атрибутов. Затем, как мы говорили идет так называемая голова, а т.е. <head> и </head> . А этот тег как раз то имеет атрибуты. Этих атрибутов несколько, но мы поговорим только об одном, и это теги <title> и </title>. Этот тег показывает заголовок. У меня например заголовок "Все для WEB програмиста".

И так, опробуем всё выше сказанное на практике.

<html>

<head>

<title>Ну а сюда пишем, что прейдет вам в голову</title>

</head>

<body>

Это мой первый сайт. Он пока прост, но я пройдя курс стану великим WEB дизайнером

</body>

</html>

"Интернет" - штуковина развивающаяся: вроде бы совсем недавно появилась

"Мозаика", первую версию Netscape только прошлой зимой увидели, а вот,

глядишь, уже и к виртуальной реальности подобрались. Причем к настоящей

- с трехмерной графикой, со звуком. Язык даже специальный создали - VRML,

Virtual Reality Modeling Language, А вот как это начиналось. Весной 1994 года

на первой всемирной конференции по World Wide Web, проводившейся в Женеве,

Тим Бернес-Ли (Tim Berners-Lee) и Дэйв Рэггет (Dave Raggett) показали нечто,

названное Birds-of-a- Feather (BOF), что достойно открыло дискуссию на

тему интерфейса виртуальной реальности WWW. Надо сказать, зрителям эта

демонстрация понравилась, было отмечено, что пора бы заняться виртуальной

реальностью в "Интернете" вплотную. После окончания конференции был создан,

скажем так, специальный сервер (хотя это и не совсем точно), где велось

обсуждение будущего стандарта. При разработке этого языка сразу было решено,

что он не будет простым расширением HTML (Hyper Text Markup Language),

поскольку, по мнению разработчиков, HTML был создан для работы с текстом, а

не с графикой. Кроме того, еще на стадии подготовки проекта было решено, что

первая версия языка не будет поддерживать интерактивное поведение, так как это

вызовет очень большую нагрузку на сеть.

Среди требований, предъявленных к разработчикам, были также: независимость от

платформы, расширяемость, возможность работы в сетях с низкой пропускной

способностью.

Поначалу VRML, по аналогии с HTML, назывался Virtual Reality Markup Language.

Слово Markup было заменено на Modeting значительно позже, для отражения

графического характера VRML.

Попробуем все же дать определение этому языку. Итак, Virtual Reality Modeling

Language - это язык для описания многомерных интерактивных моделей, виртуальных

миров, создаваемых в "Интернете" с использованием WWW. Все аспекты доступа и

взаимодействия с этими виртуальными мирами могут быть описаны при помощи VRML.

Сейчас, благодаря усилиям разработчиков, VRML становится стандартом интерактив-

ного моделирования в WWW.

Пока VRML позволяет создавать виртуальные миры лишь с ограниченным интерактивным

управлением. Они могут содержать объекты, которые, в свою очередь, могут

заключать в себе гипертекстовые ссылки на другие миры, документы в формате

HTML, а также любые объекты, представленные в стандарте MIME.

Этот язык дает возможность описания трехмерных сцен, создавая при этом

гипертекстовые связи, - иначе говоря, это аналог HTML, но в трех измерениях.

По мнению разработчиков, VRML постепенно придет на смену HTML.

Так что все-таки представляет из себя VRML. Говоря образно, VRML дает

возможность объектам самим рисовать себя. Теоретически объекты могут включать

в себя все, что угодно, - трехмерную и обычную графику, MID)-файлы, текст...

Эти объекты получили название ноды (nodes). Пода имеет следующие характеристики:

- тип объекта: йода может быть кубом, сферой, текстовой картой,

преобразованием и т.д.;

- параметры, отличающие ее от поды того же типа: например, каждая сферическая

нода должна иметь свой радиус; эти параметры называются полями (fields);

каждая нода имеет О или больше полей; любая нода имеет свое имя, однако это

имя неуникально.

VRML - язык объектно-ориентированный, и в нем, как и в любом подобном языке,

есть наследование объектов.

Сейчас активно обсуждается новая версия VRML, в которой больше внимания уделено

интерактивности. В данный момент на рассмотрение выставлен формат, предложенный

фирмой BE. Поэтому он так и называется - BEF (BE Format). В основу разработки

заложена интересная идея - включить описание возможного поведения объектов

непосредственно в данные. BEF является расширением, а не модификацией VRML 1.0,

поэтому любой объект, описанный нa VRML I.0, является допустимым , просто не

имеющим поведенческой реакции. BEF поддерживает определение поведения различных

объектов. С помощью этого языка можно моделировать поведение различных

физических систем, определять взаимодействие с пользователем, а также многое

другое.

Уже не раз высказывалось мнение, что основными двигателями в развитии

компьютерной техники являются военные разработки и игры. Как обстоят дела с

виртуальной реальностью в "Интернете" у военных я не знаю, а вот игры такие

появились. Фирма World Inc. представила свою версию VRML - VRML+.

Отличие этого языка от ранее описанных заключается в том, что с его помощью

создаются многопользовательские виртуальные миры. То есть теперь вы не просто

перемещаетесь по виртуальному миру, но и общаетесь с другими людьми. Ныне

существует несколько подобных игр, в одну из них, Worlds Chat, я даже поиграл.

Кстати, когда я увидел эту "игрушку" в первый раз, она повергла меня, мягко

говоря, в шок. Привык, что все интернетовские игры текстовые, ну, в лучшем

случае, написаны на HTML, а тут - трехмерная графика, полная интерактивность:

катаешь мышку по коврику - двигаешься по виртуальному миру. Потом, конечно

понимаешь что это игра ничем принципиально не отличается от IRC - то же самое

общение - только вместо каналов - красивые комнаты. Но сделано - красиво!

Если захочется посмотреть, клиентское программное обеспечение можно найти по

адресу; http:// www.words.net.

Напоследок замечу, что для работы со веет опиcанными программами необходимо

IP-соединение, или, выражаясь в новой терминологии "Релкома" - инфолинии.


19_1_TKC

Одно-ранговая сеть

Как организована сеть

В случае, когда требуется просто объединить автоматизированные рабочие места в составе одной структурной единицы предприятия, используется простая рабочая группа. При этом рабочие станции объединяются в рабочую группу в составе домена. Это позволяет упорядочить логическую структуру сети и упростить ее администрирование и поиск данных. Следует отметить, что в локальной сети предприятия, насчитывающей свыше 100 рабочих мест или более 15 структурных единиц, рекомендуется хотя бы часть рабочих групп комплектовать собственными серверами. Это позволяет снять часть нагрузки с головного сервера и оптимизировать сетевой траффик. Рабочая группа с собственным сервером используется в случае, если : рабочей группе требуется повышенная информационная безопасность рабочей группе требуется дисковое пространство, размещение которого на головном сервере предприятия представляется нецелесообразным (в этом случае к серверу рабочей группы может подключаться дополнительный дисковый массив) рабочая группа использует сетевое приложение (в этом случае сервер рабочей группы является также сервером приложения) Рабочая группа с собственным сервером является обособленной в составе сети предприятия и, как правило, выделяется в отдельный домен. Взаимоотношения с основным доменом устанавливаются исходя из целей и задач, решаемых рабочей группой.В качестве сервера рабочей группы используется либо малый сервер, либо сервер приложений.

Сеть под Win9X

Cеть под Win9x - самое распространенное и само собой напрашивающееся решение. К тому же чрезвычайно простое. Загружайте Win9x. Система обнаружит новое устройство и потребует драйвера под него. Потом потребуется обратиться к дистрибутиву. ( Если вы не знаете, что такое дистрибутив Win9x - то можете дальше не читать, лучше позовите к компьютеру человека, который знает что это такое). После этого появится окно NETWORK с закладками Configutation, Identification и Access Control. А если окно не появится, то откройте его сами - Панель управления - Сеть. Для того, чтобы работала сеть, в окне Configutation должны находиться следующие объекты: А если их там нет, то тогда надо воспользоваться кнопкой ADD и добавить недостающие обьекты. У каждого обьекта есть свойства, которые требуют вашего вмешательства: Client for Microsoft networks --- там не надо ставить галочку "Log on to Windows NT domain", если у вас нет сервера WINDOWS NT. Client for Netware networks --- ( когда будете добавлять его, то ставьте Microsoft Client for Netware networks) , если у вас нет сервера NETWARE, то и Клиент Нетвари не особо нужен и настройки его пофигу. XXXXX XXXXX LAN Adapter --- драйвер сетевой карты; если карта P'n'P, то там все хорошо, а если нет - то надо выставить параметры (адрес и прерывание) на закладке RESOURCES. Для NE2000 - карточек у Win9x есть собственные драйвера, "производитель" -- Novell/Anthem. IPX/SPX - compatible protocol --- протокол, который поддерживают практически все мультиплеер-игры. Обязательно надо выставить одинаковый тип кадра в закладке Advanced: Frame Type -- Ethernet 802.3 например. NetBEUI --- самонастраивающийся протокол, не требует вмешательства. File and printer sharing for Microsoft network --- там тоже не надо ничего делать. Служба эта должна присутствовать в сетевых настройках для того, чтобы компьютер мог предоставлять свои ресурсы ( диски, каталоги и принтеры) для других. Компьютер, в сетевых настройках которого нет этой службы, НЕ БУДЕТ ВИДЕН В Сетевом Окружении ! В закладке Identification надо проставить уникальное имя компьютера и общее имя рабочей группы. ПЕРЕЗАГРУЗИТЬСЯ ОБЯЗАТЕЛЬНО ДОЖДАВШИСЬ ПОЛНОГО ВЫКЛЮЧЕНИЯ КОМПЬЮТЕРА !!! Выгружаться Win9x будет долго - 2-3 минуты и НЕЛЬЗЯ нажимать RESET для ускорения! Иначе сетевые настройки не сохранятся.

Поддержка режима удалённой консоли

В случае возникновения нештатной ситуации на рабочей станции пользователя администратору или сотруднику отдела технической поддержки зачастую приходится разбираться с проблемой на месте, на что тратится значительное количество драгоценного времени. С другой стороны, как показывает практика, львиная доля нештатных ситуаций скорее связана с ошибками самих пользователей, нежели с некорректной работой программного обеспечения. В ряде случаев на место происшествия оперативно прибыть вообще не представляется возможным, хотя для исправления ситуации достаточно беглого взгляда на настройки системы или воспроизведения действий пользователя, приведших к неожиданному поведению программного обеспечения. В такой ситуации возможность осуществить удалённый доступ к рабочей станции пользователя оказывается весьма полезной. Network Monitor позволяет получать статистику о состоянии сети, перехватывать и анализировать сетевые пакеты В версия SMS 1.2 режим удалённой консоли может быть установлен для операционных систем: MS-DOS, Windows 3.1x, Windows95 и Windows NT.

Удаленный доступ к компьютеру

Организация удаленного доступа к компьютерам требует выполнения на них ряда предварительных операций. В частности: разрешения удаленного доступа, удаленной перезагрузки, передачи файлов на удаленный компьютер и т.п. Программное обеспечение для удаленного доступа и диагностики устанавливается как часть процесса установки клиентских компонент SMS. На рисунке 62 приведен пример настроек для компьютера под управлением Windows NT. При поступлении на компьютер запроса на удаленное администрирование пользователь компьютера получает уведомление об этом и на своё усмотрение может разрешить или запретить доступ к своему компьютеру. Однако поскольку на станциях и серверах NT режимом удалённой консоли заведует сервис, исполняющийся на данной машине, доступ к ней может быть осуществлён без наличия пользователя на консоли и без уведомления пользователя о факте установления удаленного сеанса. Удаленное управление может выполняться при доступе через локальные или глобальные сети по любому из поддерживаемых сетевых протоколов. В момент установления соединения подбор протокола производится автоматически. Для компьютеров под управлением DOS/Windows/Windows95 дополнительно можно просмотреть важнейшие параметры системы, как-то: доступная память, список процессов и т.п. Внешний вид программы удаленной диагностики приведен на рисунке 63 (в Windows NT встроенная утилита диагностики позволяет просматривать системные ресурсы удаленного компьютера).

Разговоры с пользователем

В процессе удаленного администрирования может возникнуть необходимость в поддержании диалога между пользователем и оператором. Для осуществления этой возможности предусмотрена функция Remote Chat, позволяющая пользователю с администратором перекинуться несколькими фразами, не прерывая сеанса. На рисунке 64 приведен пример диалога администратора с пользователем станции Windows95.

Интеграция с системами управления сетью

Хотя в круг задач, для решения которых разрабатывался SMS, изначально не входила поддержка протокола сетевого управления SNMP, созданного в основном для управления сетевым оборудованием и его активного мониторинга, в последнюю версию SMS ограниченная поддержка этого протокола была введена. Реализуется эта поддержка двояко: на серверах и рабочих станциях Windows NT как составляющая клиентской части SMS может исполняться сервис Event to Trap Translator, преобразующий события Windows NT, помещаемые в системный журнал, в прерывания SMNP. С помощью файлов настройки можно передавать дополнительную информацию о станции, посылающей конкретное прерывание программе наблюдения за сетью; на site-сервере может быть установлен сервис, называемый SMNP Trap Receiver, принимающий прерывания от сетевых устройств. Это могут быть как станции и сервера SMS исполняющие Event to Trap Translator, так и любые прочие устройства, включая мосты, коммутаторы и маршрутизаторы. Входящие прерывания SMNP могут фильтроваться по ряду параметров, как-то: IP-адресу источника, типу, индексу и т.п. Отфильтрованные прерывания сохраняются в базе данных SMS и по этой информации в дальнейшем можно выполнять выборки и, следовательно, ассоциировать с результатами запроса предупреждение SMS. Прерывания, генерируемые сервисом Event to Trap Translator могут быть направлены для обработки и анализа в любой из пакетов сетевого управления, таких как HP OpenView, IBM NetView for AIX и SUN NetManager. Продукты фирм HP и IBM имеют дополнения, дающие возможность принимать и обрабатывать информацию от SMS.

Продукты, расширяющие функциональность SMS

В настоящее время на рынке присутствуют продукты ряда поставщиков, значительно расширяющие базовые возможности SMS как в области инвентаризации так и в области поддерживаемых операционных систем. Все они используют возможность SMS создавать и обрабатывать объекты новой архитектуры. Остановимся подробнее на наиболее полезных продуктах: Inventory +Pack фирмы Computing Edge расширяет возможности сбора информации о клиентах и настройках операционных систем. Такие параметры как настройка ODBC драйверов, Internet Information Server, настройка принтеров и т.п. инспектируются автоматически и заносятся в базу данных. Для предопределенных типов информации в свойствах рабочей станции на административной консоли отображаются соответствующие иконки. Модифицированная версия агента на клиенте поддерживает возможности исполнения инвентаризационных сценариев из которых можно читать содержимое registry и *.INI файлов. Установка данного пакета выполняется как обычное задание SMS.


История сети Internet

В 1961 году Defence Advanced Research Agency (DARPA) по заданию министерства обороны США приступило к проекту по созданию экспериментальной сети передачи пакетов. Эта сеть, названная ARPANET, предназначалась первоначально для изучения методов обеспечения надежной связи между компьютерами различных типов. Многие методы передачи данных через модемы были разработаны в ARPANET. Тогда же были разработаны и протоколы передачи данных в сети - TCP/IP. TCP/IP - это множество коммуникационных протоколов, которые определяют, как компьютеры различных типов могут общаться между собой.

Эксперимент с ARPANET был настолько успешен, что многие организации захотели войти в нее, с целью использования для ежедневной передачи данных. И в 1975 году ARPANET превратилась из экспериментальной сети в рабочую сеть. Ответственность за администрирование сети взяло на себя Defence Communication Agency (DCA), в настоящее время называемое Defence Information Systems Agency (DISA). Но развитие ARPANET на этом не остановилось; Протоколы TCP/IP продолжали развиваться и совершенствоваться.

В 1983 году вышел первый стандарт для протоколов TCP/IP, вошедший в Military Standards (MIL STD), т.е. в военные стандарты, и все, кто работал в сети, обязаны были перейти к этим новым протоколам. Для облегчения этого перехода DARPA обратилась с предложением к руководителям фирмы Berkley Software Design - внедрить протоколы TCP/IP в Berkley (BSD) UNIX. С этого и начался союз UNIX и TCP/IP.

Спустя некоторое время TCP/IP был адаптирован в обычный, то есть в общедоступный стандарт, и термин Internet вошел во всеобщее употребление. В 1983 году из ARPANET выделилась MILNET, которая стала относиться к Defence Data Network (DDN) министерства обороны США. Термин Internet стал использоваться для обозначения единой сети: MILNET плюс ARPANET. И хотя в 1991 году ARPANET прекратила свое существование, сеть Internet существует, ее размеры намного превышают первоначальные, так как она объединила множество сетей во всем мире. Рисунок 1 иллюстрирует рост числа хостов, подключенных к сети Internet с 4 компьютеров в 1969 году до 3,2 миллионов в 1994. Хостом в сети Internet называются компьютеры, работающие в многозадачной операционной системе (Unix, VMS), поддерживающие протоколы TCP\IP и предоставляющие пользователям какие-либо сетевые услуги.

Из чего состоит Internet?

Это довольно сложный вопрос, ответ на который всё время меняется. Пять лет назад ответ был прост: Internet – это все сети, которые, взаимодействуя с помощью протокола IP, образуют «бесшовную» сеть для своих коллективных пользователей. Сюда относятся различные федеральные сети, совокупность региональных сетей, университетские сети и некоторые зарубежные сети.

В последнее время появилась заинтересованность в подсоединении к Internet сетей, которые не используют протокол IP. Для того чтобы предоставлять клиентам этих сетей услуги Internet, были разработаны методы подключения этих «чужих» сетей (например, BITNET, DECnets и др.) к Internet. Сначала эти подключения, названные шлюзами, предназначались просто для пересылки электронной почты между двумя сетями, но некоторые из них выросли до возможности обеспечения и других услуг на межсетевой основе. Являются ли они частью Internet? И да и нет – всё зависит от того, хотят ли они того сами.

В настоящее время в сети Internet используются практически все известные линии связи от низкоскоростных телефонных линий до высокоскоростных цифровых спутниковых каналов. Операционные системы, используемые в сети Internet, также отличаются разнообразием. Большинство компьютеров сети Internet работают под ОС Unix или VMS. Широко представлены также специальные маршрутизаторы сети типа NetBlazer или Cisco, чья ОС напоминает ОС Unix.

Фактически Internet состоит из множества локальных и глобальных сетей, принадлежащих различным компаниям и предприятиям, связанных между собой различными линиями связи. Internet можно представить себе в виде мозаики сложенной из небольших сетей разной величины, которые активно взаимодействуют одна с другой, пересылая файлы, сообщения и т.п.

Кто управляет Internet?

Во многих отношениях Internet похожа на религиозную организацию: в ней есть совет старейшин, каждый пользователь сети может иметь своё мнение о принципах её работы и принимать участие в управлении сетью. В Internet нет ни президента, ни главного инженера, ни Папы. Президенты и прочие 1целом же в Internet нет единственной авторитарной фигуры.

Направление развития Internet в основном определяет «Общество Internet», или ISOC (Internet Society). ISOC – это организация на общественных началах, целью которой является содействие глобальному информационному обмену через Internet. Она назначает совет старейшин, который отвечает за техническое руководство и ориентацию Internet.

Совет старейшин IAB (Internet Architecture Board или «Совет по архитектуре Internet») представляет собой группу приглашённых лиц, которые добровольно изъявили принять участие в его работе. IAB регулярно собирается, чтобы утверждать стандарты и распределять ресурсы (например, адреса). Internet работает благодаря наличию стандартных способов взаимодействия компьютеров и прикладных программ друг с другом. Наличие таких стандартов позволяет без проблем связывать между собой компьютеры производства разных фирм. IAB несёт ответственность за эти стандарты, решает, нужен ли тот или иной стандарт и каким он должен быть. Если возникает необходимость в каком-нибудь стандарте, IAB рассматривает проблему, принимает этот стандарт и объявляет об этом по сети. Кроме того, IAB следит за разного рода номерами (и другими вещами), которые должны оставаться уникальными. Например, каждый компьютер Internet имеет свой уникальный 32-х разрядный адрес; такого адреса больше ни у одного компьютера нет. Как присваивается этот адрес, решает IAB. Точнее, сам этот орган присвоением адресов не занимается, он устанавливает правила присвоения адресов.

У каждого пользователя в Internet имеется своё мнение относительно того, как должна функционировать сеть. Пользователи Internet выражают свои мнения на заседаниях инженерной комиссии IETF (Internet Engineering Task Force). IETF – ещё один общественный орган; он собирается регулярно для обсуждения текущих технических и организационных проблем Internet. Если возникает достаточно важная проблема, IETF формирует рабочую группу для дальнейшего её изучения. (На практике «достаточно важная» означает, как правило, что находится достаточно добровольцев для создания рабочей группы.) Посещать заседания IETF и входить в состав рабочих групп может любой; важно, чтобы он работал. Рабочие группы выполняют много различных функций – от выпуска документации и принятия решений о том, как сети должны взаимодействовать между собой в специфических ситуациях, до изменения значений битов в определённом стандарте. Рабочая группа обычно составляет доклад. Это может быть либо предоставляемая всем желающим документация с рекомендациями, которым следовать не обязательно, либо предложение, которое направляется в IAB для принятия в качестве стандарта.

Тестирование


42

20


20_1_TKC

Сети с выделенным сервером - Novell NetWare или Сети клиент-сервер (Client-server NetWorks)

Основным элементом сети является файл-сервер. Основной его задачей является обеспечение совместного использования дисковых систем, подключенных к нему. Кроме того, файл-сервер является центральным звеном управления всей остальной сетью.
Сети NetWare имеют достаточно мощную систему управления правами доступа к ресурсам сети, позволяют совместно использовать HDD большой емкости, PRN, плоттеры, сканеры, модемы и др.
Потребление аппаратных ресурсов компьютера здесь значительно выше, чем у описанных выше сетей и при этом достигаются более высо-кие показатели работы сети. При этом на сервере меньше чувствуется замедление работы пользователя при повышении загрузки сети.


21_1_TKC

Поиск информации в Internet

Введение

Путь к огромному информационному багажу человечества, хранящемуся в библиотеках, фонотеках, фильмотеках, лежит через карточки каталогов. В Интернете существуют аналогичные механизмы для нахождения требуемой информации. Речь идет о поисковых серверах, служащих отправной точкой для пользователей Сети. С содержательной точки зрения о них можно говорить как о специальной службе Интернета, хотя они используют механизмы Всемирной Паутины и с технической точки зрения не выходят за ее рамки. Поисковые сервера достаточно многочисленны и разнообразны. Принято различать поисковые индексы и каталоги, но сейчас стали появляться поисковые серверы смешанного типа.

Поисковая система, поисковая машина, сервера - индексы (Search engine)

Поисковая система - в Интернет -специальный вэб-сайт, на котором пользователь по заданному запросу может получить ссылки на сайты, соответствующие этому запросу. Поисковые системы состоят из трех основных частей:
1. Spider (он же Crawler, он же Bot, он же Robot) - программа, которая посещает веб-страницы, считывает (индексирует) полностью или частично их содержимое и далее следует по ссылкам, найденным на данной странице. Spider возвращается через определенные периоды времени (например, каждый месяц) и индекисрует страницу снова.
2. Все, что находит и считывает Spider, попадает в индексы поисковой системы. Индексы системы представляют собой гигантское вместилище информации, где хранятся копии текстовой составляющей всех посещенных и проиндексированных Spider-ом страниц.
3. Третья часть - это программа, которая в соответствии с запросом пользователя перебирает индексы поисковой системы в поисках информации, интересующей пользователя, и выдает ему на гора в порядке убывания релевантности найденые документы.

Сервер - каталог

Каталоги выросли из списков интересных ссылок, закладок (bookmarks). По сути дела они представляют собой многоуровневую смысловую классификацию ссылок, построенную по принципу "от общего к частному". Иногда ссылки сопровождаются кратким описанием ресурса. Как правило, возможен поиск в названиях рубрик (категориях) и описаниях ресурсов по ключевым словам. Каталогами пользуются тогда, когда не вполне четко знают, что именно ищут. Переходя от самых общих категорий к более частным, можно определить, с каким именно ресурсом Сети следует ознакомиться. Ведение поисковых каталогов частично автоматизировано, но до сих пор классификация ресурсов осуществляется главным образом вручную. Поисковые каталоги бывают общего назначения и специализированные. Поисковые каталоги общего назначения включают в себя ресурсы самого разного профиля. Специализированные каталоги объединяют только ресурсы, посвященные определенной тематике. Им часто удается достичь лучшего охвата ресурсов из своей области и построить более адекватную рубрикацию.

История поисковой системы

История поисковых служб начинается в середине 90-х годов. В 1994 году два аспиранта Стэндфордского Университета, Дэвид Фило и Джерри Янг, начали работу над созданием каталога Yahoo (http://www.yahoo.com/; англ. "yahoo" - "йеху" из "Путешествий Гулливера" Джонатана Свифта). Они преследовали простую цель: организовать собственные ссылки. Чтобы сделать это эффективным образом, им пришлось построить специальную систему с использованием базы данных. Она могла одновременно выдерживать обращения тысяч пользователей. И эти обращения не замедлили последовать. В начале 1995 года Марк Андрессен, один из сооснователей корпорации Netscape Communications, предложил создателям уже завоевавшего огромную популярность Yahoo перенести систему с кампуса Стэндфордского Университета на сервера Netscape. Огромная нагрузка с университетской сети была снята, а Yahoo стал коммерческим проектом. Сегодня его создатели - мультимиллионеры; над ведением каталога трудятся тысячи специалистов в самых разных областях знания. Один из первых индексирующих поисковых серверов, AltaVista ("вид с высоты") корпорации Digital (теперь Compaq), появился в 1995 году. Нескольким служащим корпорации-производителя суперкомпьютеров пришла в голову мысль использовать новейшие сервера для считывания содержимого Всемирной Паутины в базу данных и осуществления поиска по ней. Сервер AltaVista, расположенный по адресу http://altavista.digital.com/, - один из крупнейших поисковых серверов сегодняшней Сети. В последнее время поисковые каталоги общего назначения и индексирующие поисковые сервера интенсивно интегрируются. Yahoo уже не только каталог, но и поисковый сервер. AltaVista, как и многие другие поисковые сервера, исходно предлагавшие исключительно поиск по базе данных, сегодня включает в выдачу результатов поискового запроса еще и список рубрик, соответствующих теме запроса.

Работа с поисковыми серверами

Работа с поисковыми серверами не составляет большого труда. Вы заходите на свой любимый поисковый сервер, в строке запроса набираете на нужном языке ключевые слова или фразу, соответствующие ресурсу или ресурсам Сети, которые вы хотите найти. Затем нажимаете мышью на кнопку c английской надписью "Search" или русской надписью "Поиск", и через несколько секунд в рабочем окне браузера появляются результаты поиска. Обычно поисковый сервер выдает результаты поиска небольшими порциями, например, по 10 на одну страницу выдачи. Поэтому часто они занимают больше одной страницы. Тогда под списком рекомендуемых ссылок будет находиться ссылка, предлагающая перейти к следующей "порции" результатов поиска. В идеальном случае тот ресурс, который вы ищете, поисковый сервер поместит на первую страницу результатов поиска, и вы сразу распознаете нужную ссылку по краткому описанию. Однако часто приходится просмотреть несколько ресурсов, прежде чем обнаруживается подходящий.

Международные поисковые системы

Поисковая машине AltaVista Самая, пожалуй, известная и самая старая из ныне существующих лидеров поисковых машин, хоть и не самая удобная. Способна искать на тридцати или около того языках и переводить с одного на другой "на лету" (не на все, правда). Очень быстро индексировала страницы, обычно в течение двух-трех дней, что считается очень неплохим результатом. В ноябре 99 года была полностью переделана так, чтобы приобрести более "портальный" вид. Одновременно был переделан и сам поисковый механизм машины, но при этом из индекса загадочным образом "пропало" до 30% зарегистрированных ресурсов. В результате, обиженные веб-мастера кинулись регистрироваться заново и пробиться к странице регистрации практически невозможно.

Google Поисковые технологии не стоят на месте. Традиционные индексирующие сервера искали в базе данных документы, содержащие ключевые слова из поискового запроса. При таком подходе очень сложно оценить значение и качество ресурса, выдаваемого пользователю. Альтернативный подход искать такие веб-страницы, на которые ссылаются другие ресурсы по данной тематике. Чем больше ссылок на страницу существует в Сети - тем больше шансов, что вы ее найдете. Такой своеобразный мета-поиск осуществляет поисковый сервер Google (http://www.google.com/), появившийся совсем недавно, но уже отлично себя зарекомендовавший.

Русские поисковые системы и каталоги

Поисковая система "Яндекс" Она прекрасно понимает русский язык и в состоянии образовать и понять любую словоформу русского языка - это означает, что если сделаете запрос "думать", то машина выдаст вам результаты поиска также и по словам: "думал", "подумавши" и даже "разум". Вы можете ввести просто нужную вам фразу, например: "как сделать сайт" и машина вам выдаст осмысленные результаты. Oчень редко возникает необходимость уточнять результаты или дополнять их с помощью другого поисковика. С точки зрения веб-мастера этот робот удобен также тем, что регистрация нового ресурса происходит в течение одного-двух дней, а быстрый "паук" регулярно обходит практически все поле Рунета и регулярно вносит изменения в индекс. Форма для регистрации располагается по адресу: http://www.yandex.ru/addurl.html

Поисковая машина "Апорт" Очень своеобразная машина. С недавнего времени был полностью переделан внешний вид сайта и, по словам разработчиков, также и обновлена база данных робота. Несколько позже был запущен новый механизм поиска и индексации "Апорт 2000", обладающий большими и интересными возможностями, такими, например, как поиск сайтов, а не страниц, индекс цитируемости, учет доступности и пр. недавно появился механизм поиска картинок, как обещают, более совершенный, чем простой поиск по полю alt. Эта машина претендует (и, надо сказать, довольно успешно) на роль не просто поисковой машины, но русскоязычного портала в Интернете, пытаясь вытеснить из этой ниши "Рамблер", "Инфоарт" и "Яндекс". Любопытно, что, благодаря новому механизму поиска "Апорт 2000" это может получиться. Эта машина не очень удобна, тем более, что довольно часто в качестве результатов поиска выпадает сбой робота, что довольно таки неприятно. Ко всему, сервер очень неторопливо загружает головную страницу, как назло, именно тогда, когда нужно срочно что-либо найти, а найти нужно обычно именно срочно. Тем не менее, этот робот уверенно входит в лидирующую тройку поисковых машин Рунета и сдавать свои позиции видимо не собирается. Форма для регистрации располагается по адресу: http://www.aport.ru/WINP/addurl.htm

Поисковая машина "Рамблер" "Рамблер" - это монстр Рунета. Колоссальная поисковая машина соединенная вместе с самым популярным рейтингом и гигантским развлекательным центром "Чертовы Куличики" - все это вместе без сомнения является самым популярным комплексом в Рунете, причем суммарная посещаемость настолько велика, что сравняться с ней практически нереально. К сожалению, поисковая машина "Рамблер" игнорирует мета-теги, поэтому работать с ней сложно и неудобно. Наибольшее значение в определении релевантности страницы имеют выделенные конструкции (заголовки, подзаголовки, жирный текст и пр.), а также непосредственно сам текст страницы. Соответственно для того чтобы зарегистрироваться в этом поисковике необходимо заполнить длинную форму, и это еще полбеды, так нужно еще чтобы в ней не повторялись слова, все поля были заполнены и т.д., а чуть что не так - переделывай. У этой машины неудобный вывод результатов, неудобный механизм поиска, не очень качественный (по сравнению с "Яндексом") отбор, неудобная регистрация. Форма для регистрации располагается по адресу: http://www.rambler.ru/new/add_site.shtml

Глоссарий терминов по поисковым системам и каталогам

Boolean search: Поиск с использованием операндов булевой алгебры, таких, например, как AND, NOT и OR. Использование операндов существенно увеличивает эффективность поиска. Если мы введем в поисковую систему запрос: (мокрый OR склизкий) AND водяной AND (NOT сантехник) то получим страницы отвечающие следующим критериям:- содержат слово(а) "водяной": - содержат либо "мокрый" либо "склизкий":- не содержат слова "сантехник": Детально язык и синтаксис запросов изложен в help каждой поисковой системы.

Bridge Page (redirect page, enter page, редирект-страницы): Страницы, созданные специально для получения высокого рейтинга в поисковых системах. Веб-мастер создает целый набор подобных страниц, каждая из которых оптимизирована под определенную поисковую систему и определенные ключевые слова. Такие страницы являются промежуточными и перенаправляют посетителя уже непосредственно на веб-сайт. Некоторые поисковые системы считают подобные действия спамом и игнорируют редирект-страницы.

Classification (классификация): Процесс определения того, к какой категории принадлежит тот или иной документ, веб-сайт и т.д. Case sensitivity (чувствительность к регистру): Некоторые поисковые системы чувствительны к запросам с учетом регистра, другие - нет. Например, чувствительная к регистру поисковая система Yandex при запросе "лебедь" выдаст Вам все страницы, содержащие слово "лебедь", где буквы могут быть в любом регистре, т.е. надет Вам страницы и про птицу и про небезызвестного генерала. Но при запросе "Лебедь" - только страницы, содержащие это слово с заглавной первой буквой, скорее всего это будет именно фамилия или предложения где это слово стоит первым.

Concept search (концептуальный поиск): Поиск документов, имеющих прямое отношение к указанному поисковому слову, а не просто содержащих его.

Document (документ): Информационный объект, который желает найти и получить пользователь. Это может быть текстовый файл, html-файл, картинка и т.д.

Index (индекс): Индекс поисковой системы представляет собой гигантский информационный массив, где хранятся преобразованные особым образом текстовые составляющие всех посещенных и проиндексированных роботом html-страниц и текстовых файлов. Робот не только пополняет массив новыми поступлениями, но и регулярно обновляет уже имеющиеся в индексах документы.

Full-text search engine (полнотекстовая поисковая система): Полнотекстовые поисковые системы индексируют все слова на веб-странице (иногда за исключением стоп-слов) и учитывают порядок их расположения. В отличие от них, абстрактные поисковые системы по определенному алгоритму создают некий экстракт проиндексированной страницы.

Keyword search (поиск по ключевым словам): Поиск документов, которые содержат указанные пользователем ключевые слова.

Phrase search (поиск по словосочетаниям): Поиск документов, которые содержат в точности указанное пользователем словосочетание, предложение, отрывок текста.

Proximity search (поиск с расстоянием): Поиск, при котором пользователь указывает, на каком расстоянии между собой должны располагаться ключевые слова в документе. Например, для поисковой системы

Яндекс при запросе: “мокрый /3 сантехник" Вы требуете найти документы, в которых содержится и слово "мокрый", и слово "сантехник", и расстояние между ними должно быть не более трех слов.

Query (запрос): Набор слов и служебных символов, характеризующий информацию, которую хочет найти пользователь.

Query-By-Example (find similar, найти подобные): Данной полезной функцией обладают лишь часть поисковых систем. При просмотре результатов первоначального поиска Вы выбираете документ или группу документов, наиболее близких к тому, что Вы ищете и даете системе команду "найти подобные документы".

Query Expansion (расширенный запрос): Процесс построения нового запроса на базе предыдущего. Например, AltaVista позволяет разрядить многотысячный список с результатами поиска путем удаления оттуда документов по определенным критериям.

Relevancy (релевантность документа): Мера того, насколько полно тот или иной документ отвечает критериям, указанным в запросе пользователя. Разумеется, далеко не всегда документ, признанный поисковой системой наиболее релевантым, будет таким по мнению самого пользователя.

Search by Field (поиск в определенных полях): Некоторые системы позволяют производить поиск не только по всему html-документу, но и выборочно, по определенным полям. Например, можно искать по заглавию документа (title), в этом случае учитываются только ключевые слова, встречающиеся именно в заглавии документа. Существует поиск по полю ALT тега IMG, таким поиском пользуются, когда хотятнайти в Интернете изображение на определенную тему. Есть поиск по текстам в гиперссылках, адресах, заголовках разделов. Например, в системе Рамблер по запросу "$TITLE: реклама and $URL: ресурсы" система найдет все страницы, содержащие слово "реклама" в заголовке, и помимо этого хотя бы одну имеющуюся на странице ссылку, содержащую слово "ресурсы".

Search Engine (поисковая система): Содержит в себе три компонента: - робот, который обходит веб-сайты и заносит страницы в индексы системы; - индекс системы, где хранятся преобразованные особым образом текстовые составляющие всех посещенных и проиндексированных роботом html-страниц и текстовых файлов; - и, наконец, система поиска - программа, которая обрабатывает запрос пользователя, находит в индексе документы, отвечающие критериям запроса, и выводит список найденных документов в порядке убывания релевантности. О том, каким образом поисковые системы определяют релевантность страниц можно прочитать здесь.

Spider (Crawler, Bot, Robot, робот поисковой системы): Неотъемлемая составляющая поисковой системы - программа, которая посещает веб-страницы, считывает (индексирует) полностью или частично их содержимое и далее следует по ссылкам, найденным на данной странице. Робот возвращается через определенные периоды времени (например, каждый месяц) и индексирует страницу снова. Вся информация заносится роботом в индексы поисковой системы.

Stemming (морфологический поиск): Возможность системы искать слово в документах не только в строго заданном виде, но и во всех его морфологических формах. Например, не только "идти", но и "идет", "шел" и т.д.

Stop words (стоп-слова): Для экономии места и увеличения производительности некоторые поисковые системы не включают в индексы слова, встречающиеся на веб-страницах очень большое кол-во раз. Например, "www", артикли "а", "the" и т.д.

Thesaurus (тезариус): Список синонимов для ключевого слова, которые может использовать система при поиске.

Weighting (весовой коэффицент): Увеличивать релевантность документа может не только кол-во содержащихся в нем ключевых слов, но и их расположение в документе. Больший "вес" имеют слова в заголовке страницы (заголовок - это то, что указанно между парным тегом


22_1_TKC

Сетевой Этикет или как правильно говорить в сети

Правила сетевого этикета

В чате, форуме, гостевой книге общается большое количество разных людей, с разными мнениями и интересами. Следует быть тактичным и корректным в своих высказываниях. Не нападайте на человека только из-за того, что его мнение не совпало с вашим. Будь сильным и разумным настолько, чтобы не использовать свою анонимность для оскорбления других участников общения. Если вас всё-таки оскорбили или чем-то умышленно или неумышленно обидели - не поддавайтесь на провокацию и не разводите флейм (англ. flame - пламя, пожар). Поверьте, другим участникам чата совсем не интресно читать словесные препирательства, ругательства и оскорбления. Не допускайте флейма или прекратите его первым. Помните - кто-то должен быть умнее. Текст написанный всеми прописными буквами или с большим количеством восклицательных знаков (например, "ПОМОГИТЕ!!!! СПАСИТЕ!!!!") воспринимается и интерпретируется как громкий крик, поэтому не нужно злоупотреблять этим средством выделения своих сообщений. Сами по себе текстовые сообщения скупы в передаче эмоций. Для компенсации этого недостатка используют "смайлики" (англ. smile - улыбка). Смайлик, если посмотреть на него, повернув голову на 90 градусов - рожица, сложенная из цифр, букв, знаков препинания и других клавиатурных символов. Вот примеры наиболее распространённых смайликов (несложно догадаться, что каждый смайлик имеет определённый смысл и передаёт определённую эмоцию): :-) (или) :) - улыбка, радость; ;-) - лукавая улыбка; ;-P - высунутый язык; ;-( - огорчение; ;-\ - задумчивость, недовольство; Придумайте и используйте свой "фирменный" смайлик. (Любимый смайлик сетевого координатора - Ж8-) )

In come

Службы Internet, такие как электронная почта, были созданы для общения пользователей, но у этих служб есть небольшая особенность- недостаток визуального общения. Разговаривая воочию люди передают друг другу дополнительную информацию на уровне сознания и подсознания от мимики собеседника. Общаясь посредством электронной почты, человек лишен очевидного приемущества: при чтении электронного письма мимику увидеть нельзя. Поскольку при обычном разговоре мимика отражает эмоции и переживания человека, очень легко неправильно понять человека при ее отсутсвии. К счастью, для того чтобы хоть как-то заменить отсутствующую визуальну состовляющую, в интернет приняты некоторыесоглашения, называемые сетевым этикетом. Добавить дополнительную выразительность фразе можно, заключив ее в звездочки, например, "Я *в самом деле* так считаю". Использование заглавных букв рассматривается как крик. Чтобы выразить свои эмоции, нужно просто записать их в конце фразы. Для этого используются смайлики. Cмайлики- это картинка, составленная из букв и специальных символов, которая выражает какое-то чувсиво или настроение. Например, такая рожица :-) по-английски называется smiley- отсюда и происходит жаргонное слово смайлик

Правила общения по е-mail

Всего несколько лет тому назад по электронной почте можно было лишь обмениваться текстовыми сообщениями, причем только написанными латинским шрифтом. В те времена было, пожалуй, лишь одно правило этикета, касавшееся электронной почты: не писать целые предложения большими буквами, пытаясь привлечь внимание к своим мыслям. Теперь по электронной почте можно пересылать практически любую информацию, которую можно представить в виде компьютерного файла. Но, как это часто бывает, технический прогресс принес кроме удобств еще и проблемы. Технические возможности различных пользователей internet по приему больших объемов информации существенно различаются. Кто-то имеет доступ к глобальной компьютерной Сети на работе по цифровой линии, да еще за счет фирмы. Другим повезло жить в районе, где установлена современная АТС и проложены современные кабели, что обеспечивает высокую скорость обмена информацией по телефонным линиям. А третьей категории пользователей, увы, пока наиболее многочисленной, приходится довольствоваться связью через морально устаревшую АТС и кабели, проложенные много десятилетий тому назад. Для них получение большого объема информации требует значительных затрат времени и, кроме того, затруднено из-за постоянных срывов связи. Компании, обеспечивающие доступ в 1п{егпе1, обычно берут плату за время работы либо берут помесячную плату без учета времени. Но так как второй вариант оплаты обычно не по карману большинству пользователей, то с большой долей вероятности можно утверждать, что чем больший объем информации вы посылаете адресату, тем больше времени уйдет у него на прием этой информации, и, соответственно, ему придется больше заплатить. Применительно к простым электронным письмам эта проблема несущественна, но вот если вы пересылаете изображение или звуковую запись, то могут возникнуть проблемы. К сожалению, популярные программы электронной почты не позволяют выкидывать любые нежелательные письма из вашего электронного почтового ящика. В принципе есть способы удаления таких писем, но они доступны далеко не у всех провайдеров и требуют определенных знаний. Поэтому все письма, которые вы отсылаете адресату, обычно полностью передаются на его компьютер, что может оказаться просто разорительным. Довольно часто бывает, что один из пользователей, имея хороший и дешевый доступ в internet и искренне желая осчастливить своего друга, пересылает ему красивую картинку или звуковой файл с целой песней, а у друга доступ в Сеть по плохой телефонной линии, и вместо радости получаются сплошные мучения. Совсем уж неприлично посылать по электронной почте файл, полностью заполняющий собою почтовый ящик, при этом адресату, которого подобным образом "осчастливили", другие пользователи уже не смогут присылать электронную почту до полной очистки ящика. Для того чтобы ваши "подарки" не вызывали у других пользователей трудностей, нужно придерживаться несложного правила: каждую пересылку файла объемом более 200 Кбайт следует предварять запросом к адресату и посылать файл только с его согласия. По крайней мере такой запрос нужно сделать хотя бы в первый раз, когда вам еще ничего не известно о технических возможностях доступа в 1п1егпе1, имеющихся у адресата.

10 основных правил

Netiquette - "сетевой" этикет. Так называются правила, принятые в Сети или, если хотите, киберпространстве. Конечно, здесь, как и в реальном мире, эти правила признаются далеко не всеми. Одни просто забывают о них, другие считают себя достаточно опытными, чтобы игнорировать эти правила, третьи почему-то убеждены, что netiquette - это еще одна попытка ограничить свободу личности в Internet. Вступление
Правило 1: Помните, что Вы говорите с человеком
Правило 2: Придерживайтесь тех же стандартов поведения, что и в реальной жизни
Правило 3: Помните, где Вы находитесь в киберпространстве
Правило 4: Уважайте время и возможности других
Правило 5: Сохраняйте лицо
Правило 6: Помогайте другим там, где Вы это можете делать
Правило 7: Не ввязывайтесь в конфликты и не допускайте их
Правило 8: Уважайте право на частную переписку
Правило 9: Не злоупотребляйте своими возможностями
Правило 10: Учитесь прощать другим их ошибки


23_1_TKC

Модем. Типы модемов и их назначение

Приручаем модем

Чтобы переслать приятелю файл, сразиться с живым противником в любимой игрушке и, конечно же, подключиться к Internet, нужно обеспечить компьютеру возможность связи с себе подобными. Самым простым, дешевым и распространенным способом сделать это является установка модема.
Как это работает Модем позволяет связать два компьютера с помощью обычной телефонной линии, которая имеется в каждом доме.
Поскольку машины обмениваются цифровыми данными, а телефон предназначен для передачи голоса, то прямая связь компьютеров по телефонной линии невозможна. Модем является посредником, преобразующим цифровую информацию в набор звуков, которые не очень приятны на слух, зато могут быть переданы по телефонной линии. Преобразованный в звук сигнал передается через телефонную сеть получателю, модем которого производит обратное превращение и отправляет данные компьютеру.

Подсоединение модема

Для успешной установки необходимо разместить компьютер поблизости от телефона или телефонной розетки, чтобы можно было подсоединить модем к телефонной сети. На время проведения всех операций по установке нужно отключить компьютер и обесточить его. Процесс подключения нового модема различается для внешних и внутренних модемов.

Начальная настройка модема

В зависимости от типа модема и операционной системы настройки и конфигурирование может происходить по-разному. Если модем - современная PCI-модель с поддержкой стандарта Plug'n'Play, а операционная система принадлежит к семейству Windows, то установка и настройка пройдет автоматически и конфликты маловероятны. Сразу после этого создается в папке "Удаленный доступ к сети" новое соединение и теперь подключается к Internet-провайдеру, связь с друзьями или BBS (электронными досками объявлений) осуществляется с помощью программы HyperTerminal. В других операционных системах, например в DOS или Linux, работает не каждый модем. Большинство программных модемов не имеют драйверов для работы с этими системами, а значит, эксплуатация таких моделей невозможна. Что касается полноценных, аппаратных модемов, то они в большинстве случаев требуют минимальной настройки. Например, в "Терминале" из пакета Norton Commander, для настройки модема достаточно войти в программу через меню "Команды", нажать Alt-P и установить режим доступа "прямой", способ выбора "по номеру порта", а номер порта - "COM2". Остальные настройки и в этой программе, и в других подобных обычно менять не надо.

Характеристики модемов

Основной характеристикой модема является максимальная поддерживаемая скорость связи, выраженная в битах в секунду. Например, цифра 33 600 означает, что за секунду модем передает и принимает 33 600 бит или 4,1 Кбайта информации. Та же цифра бывает записана в иной форме, с суффиксом "k", например 56k, 33,6k. Все современные модемы имеют скорость 56k, для более старых характерны скорости 33,6k, 28,8k, 14,4k. Помимо скорости, важны также дополнительные возможности модема - наличие функций факса и передачи голоса. Подавляющее большинство современных модемов являются факс-модемами, то есть при наличии специальной программы реализуют функцию пересылки и приема факсов. Соответствующее программное обеспечение есть в Windows, можно приобрести такую программу отдельно, удачные примеры - VentaFax и Symantec WinFax Pro.

Голосовые функции

Голосовые функции позволяют использовать компьютер с модемом в качестве интеллектуального центра связи - прямо с компьютера, применяя его звуковую карту и модем (при наличии колонок и микрофона), можно звонить по телефону, передавать и принимать факсы, использовать автоответчик. Как правило, все эти функции объединяются в общей многоцелевой коммуникационной программе. Обычно такая программа поставляется с модемом, хорошим примером сторонних разработок является все тот же WinFax Pro. Помимо этого, голосовой модем допускает разговор с абонентом, одновременно передавая данные. Впрочем, такая возможность требует наличия голосового модема у обоих собеседников и применяется крайне редко. Для Internet-телефонии наличие голосового модема необязательно. Чтобы пообщаться голосом через Internet, достаточно иметь обычный модем, звуковую карту и специальное программное обеспечение.

Виды модемов

Виды модемов. По методу подключения к компьютеру модемы можно разделить на внешние и внутренние, по особенностям реализации - на аппаратные и программно-аппаратные (последние еще называют Softmodem, Winmodem, в дальнейшем начнем называть их просто "программные").

Внешний модем

Внешний модем Необходимо соединить выключенный компьютер и модем с помощью кабеля, входящего в комплект поставки вашего нового приобретения. В системном блоке для этого обычно применяется разъем последовательного порта COM2 (обычно это широкий разъем с 25 штырьками). Более подробную информацию читайте в руководстве пользователя модема. Затем необходимо подсоединить модем к электрической сети и к телефонной линии. Для подключения к телефонной сети берут стандартный европейский телефонный разъем (phone jack), обычно он отсоединяется от телефона и устанавливается в модем, на котором для этого есть соответствующий вход, помеченный, как правило, словом Line или Telco. Сам телефон при этом подключается к другому входу модема, помеченному Phone. Это соединение осуществляется с помощью короткого телефонного шнура, поставляемого с модемом.

Внутренний модем

Внутренний модем выполняется в виде платы расширения, которая вставляется в один из свободных слотов материнской платы компьютера, поэтому ни отдельного питания, ни дополнительных кабелей внутреннему модему не требуется, и для его инсталляции нужно будет снять крышку системного блока компьютера. Внимание! Если вы не имеете опыта в таких операциях, лучше доверить ее квалифицированному специалисту! Неосторожное обращение с модемом или содержимым системного блока приводит к серьезным поломкам оборудования, которые не подлежат бесплатному устранению по гарантии! Естественно, такая реализация удешевляет модем и освобождает место возле компьютера. Платой за эти удобства является сложность установки и невозможность напрямую контролировать состояние модема.

Аппаратные модемы

Аппаратные модемы несут на себе полный набор модулей, необходимых для функционирования, для пользования таким модемом нужна лишь высокоуровневая программа связи, например Telemate, Telix или "Терминал" из Norton Commander. Для работы с этим устройством в Windows достаточно простейшего драйвера, входящего в комплект поставки операционной системы, хотя более предпочтительным является применение Фирменных драйверов. В последнее время появились так называемые AMR/CMR-модемы, использующие ресурсы материнской платы для своей работы. Они также относятся к классу программных модемов.

Звуковое сопровождение во время установки связи

По умолчанию модем настроен так, что весь процесс соединения с другим модемом транслируется через небольшой контрольный динамик. Это сделано для того, чтобы можно было проверить, на какой стадии находится процесс и не требуется ли вмешательство. Опытные пользователи даже по звуку предсказывают скорость, на которой будет установлено соединение. Сначала вы услышите обыкновенный длинный гудок АТС, потом серию щелчков, сопровождающих набор номера. Когда линия занята, после нескольких коротких гудков модем должен самостоятельно повесить трубку. Если этого не произошло через 5-10 с, значит сигнал "занято" не был распознан, и разрывать связь придется вручную. После успешного дозвона и при условии, что на другом конце трубку поднял модем, а не человек, модемы начнут обмениваться неприятным "визгом". Этот процесс называется "рукопожатием" (handshake). Его длительность зависит от типа модемов и качества линии связи, как правило, вся процедура занимает менее минуты. По окончании рукопожатия происходит переключение в режим передачи данных и звуковое сопровождение отключается. Если звуковое сопровождение мешает вам, его громкость понижается или же вообще выключается звук. На большинстве внешних модемов для этого есть обыкновенный регулятор громкости, внутренние модемы управляются программно. В Windows эта регулировка доступна в свойствах модема (вызывается через иконку "Модемы" панели управления) на закладке "Модем". В терминальных программах DOS регулировка громкости обычно не предусмотрена, но можно дополнить соответствующей командой строку инициализации модема.


Содержание:

Из чего состоит Internet?

Это довольно сложный вопрос, ответ на который всё время меняется. Пять лет назад ответ был прост: Internet – это все сети, которые, взаимодействуя с помощью протокола IP, образуют «бесшовную» сеть для своих коллективных пользователей. Сюда относятся различные федеральные сети, совокупность региональных сетей, университетские сети и некоторые зарубежные сети.

В последнее время появилась заинтересованность в подсоединении к Internet сетей, которые не используют протокол IP. Для того чтобы предоставлять клиентам этих сетей услуги Internet, были разработаны методы подключения этих «чужих» сетей (например, BITNET, DECnets и др.) к Internet. Сначала эти подключения, названные шлюзами, предназначались просто для пересылки электронной почты между двумя сетями, но некоторые из них выросли до возможности обеспечения и других услуг на межсетевой основе. Являются ли они частью Internet? И да и нет – всё зависит от того, хотят ли они того сами.

В настоящее время в сети Internet используются практически все известные линии связи от низкоскоростных телефонных линий до высокоскоростных цифровых спутниковых каналов. Операционные системы, используемые в сети Internet, также отличаются разнообразием. Большинство компьютеров сети Internet работают под ОС Unix или VMS. Широко представлены также специальные маршрутизаторы сети типа NetBlazer или Cisco, чья ОС напоминает ОС Unix.

Фактически Internet состоит из множества локальных и глобальных сетей, принадлежащих различным компаниям и предприятиям, связанных между собой различными линиями связи. Internet можно представить себе в виде мозаики сложенной из небольших сетей разной величины, которые активно взаимодействуют одна с другой, пересылая файлы, сообщения и т.п.

Кто управляет Internet?

Во многих отношениях Internet похожа на религиозную организацию: в ней есть совет старейшин, каждый пользователь сети может иметь своё мнение о принципах её работы и принимать участие в управлении сетью. В Internet нет ни президента, ни главного инженера, ни Папы. Президенты и прочие 1целом же в Internet нет единственной авторитарной фигуры.

Направление развития Internet в основном определяет «Общество Internet», или ISOC (Internet Society). ISOC – это организация на общественных началах, целью которой является содействие глобальному информационному обмену через Internet. Она назначает совет старейшин, который отвечает за техническое руководство и ориентацию Internet.

Совет старейшин IAB (Internet Architecture Board или «Совет по архитектуре Internet») представляет собой группу приглашённых лиц, которые добровольно изъявили принять участие в его работе. IAB регулярно собирается, чтобы утверждать стандарты и распределять ресурсы (например, адреса). Internet работает благодаря наличию стандартных способов взаимодействия компьютеров и прикладных программ друг с другом. Наличие таких стандартов позволяет без проблем связывать между собой компьютеры производства разных фирм. IAB несёт ответственность за эти стандарты, решает, нужен ли тот или иной стандарт и каким он должен быть. Если возникает необходимость в каком-нибудь стандарте, IAB рассматривает проблему, принимает этот стандарт и объявляет об этом по сети. Кроме того, IAB следит за разного рода номерами (и другими вещами), которые должны оставаться уникальными. Например, каждый компьютер Internet имеет свой уникальный 32-х разрядный адрес; такого адреса больше ни у одного компьютера нет. Как присваивается этот адрес, решает IAB. Точнее, сам этот орган присвоением адресов не занимается, он устанавливает правила присвоения адресов.

У каждого пользователя в Internet имеется своё мнение относительно того, как должна функционировать сеть. Пользователи Internet выражают свои мнения на заседаниях инженерной комиссии IETF (Internet Engineering Task Force). IETF – ещё один общественный орган; он собирается регулярно для обсуждения текущих технических и организационных проблем Internet. Если возникает достаточно важная проблема, IETF формирует рабочую группу для дальнейшего её изучения. (На практике «достаточно важная» означает, как правило, что находится достаточно добровольцев для создания рабочей группы.) Посещать заседания IETF и входить в состав рабочих групп может любой; важно, чтобы он работал. Рабочие группы выполняют много различных функций – от выпуска документации и принятия решений о том, как сети должны взаимодействовать между собой в специфических ситуациях, до изменения значений битов в определённом стандарте. Рабочая группа обычно составляет доклад. Это может быть либо предоставляемая всем желающим документация с рекомендациями, которым следовать не обязательно, либо предложение, которое направляется в IAB для принятия в качестве стандарта.

Протоколы сети Internet.

Основное, что отличает Internet от других сетей - это ее протоколы - TCP/IP. Вообще, термин TCP/IP обычно означает все, что связано с протоколами взаимодействия между компьютерами в Internet. Он охватывает целое семейство протоколов, прикладные программы, и даже саму сеть. TCP/IP - это технология межсетевого взаимодействия, технология Internet. Сеть, которая использует технологию internet, называется "internet". Если речь идет о глобальной сети, объединяющей множество сетей с технологией internet, то ее называют Internet.

Свое название протокол TCP/IP получил от двух коммуникационных протоколов (или протоколов связи). Это Transmission Control Protocol (TCP) и Internet Protocol (IP). Несмотря на то, что в сети Internet используется большое число других протоколов, сеть Internet часто называют TCP/IP-сетью, так как эти два протокола, безусловно, являются важнейшими.

Как и во всякой другой сети в Internet существует 7 уровней взаимодействия между компьютерами: физический, логический, сетевой, транспортный, уровень сеансов связи, представительский и прикладной уровень. Соответственно каждому уровню взаимодействия соответствует набор протоколов (т.е. правил взаимодействия).

Протоколы физического уровня определяют вид и характеристики линий связи между компьютерами. В Internet используются практически все известные в настоящее время способы связи от простого провода (витая пара) до волоконно-оптических линий связи (ВОЛС).

Для каждого типа линий связи разработан соответствующий протокол логического уровня, занимающийся управлением передачей информации по каналу. К протоколам логического уровня для телефонных линий относятся протоколы SLIP (Serial Line Interface Protocol) и PPP (Point to Point Protocol). Для связи по кабелю локальной сети - это пакетные драйверы плат ЛВС.

Протоколы сетевого уровня отвечают за передачу данных между устройствами в разных сетях, то есть занимаются маршрутизацией пакетов в сети. К протоколам сетевого уровня принадлежат IP (Internet Protocol) и ARP (Address Resolution Protocol).

Протоколы транспортного уровня управляют передачей данных из одной программы в другую. К протоколам транспортного уровня принадлежат TCP (Transmission Control Protocol) и UDP (User Datagram Protocol).

Протоколы уровня сеансов связи отвечают за установку, поддержание и уничтожение соответствующих каналов. В Internet этим занимаются уже упомянутые TCP и UDP протоколы, а также протокол UUCP (Unix to Unix Copy Protocol).

Протоколы представительского уровня занимаются обслуживанием прикладных программ. К программам представительского уровня принадлежат программы, запускаемые, к примеру, на Unix-сервере, для предоставления различных услуг абонентам. К таким программам относятся: telnet-сервер, FTP-сервер, Gopher-сервер, NFS-сервер, NNTP (Net News Transfer Protocol), SMTP (Simple Mail Transfer Protocol), POP2 и POP3 (Post Office Protocol) и т.д. К протоколам прикладного уровня относятся сетевые услуги и программы их предоставления.

О том, как работает Internet.

Перемещая биты с одного места на другое.

Современные сети создаются по многоуровневому принципу. Передача сообщений в виде последовательности битов начинается на уровне линий связи и аппаратуры, причём линии связи не всегда высокого качества. Затем добавляется уровень базового программного обеспечения, управляющего работой аппаратуры. Следующий уровень программного обеспечения позволяет наделить базовые программные средства дополнительными необходимыми возможностями. Расширение функциональных возможностей сети путём добавления уровня за уровнем приводит к тому, что Вы в конце концов получаете по-настоящему дружественный и полезный инструментарий.

Сети с коммутацией пакетов.

Когда Вы пытаетесь представить себе, что же такое Internet и как она работает, вполне естественно, что у Вас возникают ассоциации с телефонной сетью. В конце концов, обе эти структуры используют электронные средства передачи, обе позволяют устанавливать соединение и передавать информацию; кроме того, в Internet в основном используются выделенные телефонные линии. К сожалению, это неверное представление, и оно является причиной непонимания принципов работы Internet. Телефонная сеть – это сеть с коммутацией каналов. Когда Вы производите вызов, Вам выделяется некоторая часть это сети. Даже если Вы не используете ее (например, находитесь в режиме удержания), она остается недоступной для других абонентов, которым в этот момент нужно позвонить. Это приводит к тому, что такой дорогой ресурс, как сеть, используется неэффективно.

Более соответствующая действительному положению вещей модель Internet – почтовое ведомство США. Почтовое ведомство представляет собой сеть с коммутацией пакетов. Здесь у Вас нет выделенного участка сети. Ваша корреспонденция смешивается с другими письмами, отправляется в почтовое отделение и сортируется. Несмотря на то, что технологии абсолютно разные, служба доставки почты представляет собой удивительно точный аналог сети; мы будем продолжать пользоваться этой моделью во всех остальных разделах данной главы.

Межсетевой протокол (IP).

С помощью линий связи обеспечивается доставка данных из одного пункта в другой. Но Вы уже знаете, что Internet может доставлять данные во многие точки, разбросанные по всему земному шару. Как это происходит?

Различные участки Internet связываются с помощью системы компьютеров (называемых маршрутизаторами) соединяющих между собой сети. Это могут быть сети Internet, сети с маркерным доступом, телефонные линии (см. рис.2).

Рисунок 2. Аппаратные средства Internet.

Телефонные линии и сети Ethernet эквивалентны автомобилям и самолетам службы доставки почты. Маршрутизаторы – это почтовые подстанции; они принимают решения о том, куда направлять данные («пакеты»), так же, как почтовая подстанция решает, куда направлять конверты с почтой. Каждая подстанция, или маршрутизатор, не имеет связи с остальными станциями. Если Вы опустили письмо в почтовый ящик в Нью-Хэмпшире, а адресат живет в Калифорнии, то местное почтовое отделение не будет бронировать самолет, чтобы доставить Ваше письмо в Калифорнию. Местное почтовое отделение посылает письмо на подстанцию, подстанция посылает его на другую подстанцию и так далее, пока письмо не дойдет до адресата. Таким образом, каждой подстанции нужно знать только, какие имеются соединения и какой из «следующих скачков» будет лучшим для перемещения пакета ближе к пункту назначения. Похожая ситуация складывается и в Internet: маршрутизатор смотрит, куда адресованы Ваши данные, и решает, куда их посылать.

Откуда Internet знает, куда следует направить Ваши данные? Если Вы отправляете письмо, то, просто опустив его в почтовый ящик без конверта, Вы не можете рассчитывать, что корреспонденция будет доставлена по назначению. Письмо нужно вложить в конверт, написать на конверте адрес и наклеить марку. Точно так же, как почтовое отделение следует по правилам, которые определяют порядок работы почтовой сети, определенные правила регламентируют порядок работы Internet. Эти правила называют протоколами. Межсетевой протокол (Internet Protocol, IP) отвечает за адресацию, т.е. гарантирует, что маршрутизатор знает, что делать с Вашими данными, когда они поступят. Следуя нашей аналогии с почтовым ведомством, можно сказать, что межсетевой протокол выполняет функции конверта.

Некоторая адресная информация приводится в начале Вашего сообщения. Она даёт сети достаточно сведений для доставки пакета данных.

Internet - адреса состоят из четырёх чисел, каждое из которых не превышает 256. При записи числа отделяются одно от другого точками, например:

192.112.36.5

128.174.5.6

Адрес фактически состоит из нескольких частей. Поскольку Internet – это сеть сетей, то начало адреса содержит информацию для маршрутизаторов о том, к какой сети относится Ваш компьютер. Правая часть адреса служит для того, чтобы сообщить сети, какой компьютер должен получить этот пакет.[1] Каждый компьютер в Internet имеет свой уникальный адрес. Здесь нам опять поможет аналогия со службой доставки почты. Возьмем адрес «50 Kelly Road, Hamden, CT». Элемент «Hamden, CT» похож на адрес сети. Благодаря этому конверт попадает в необходимое почтовое отделение, то, которое знает об улицах в определенном районе. Элемент «Kelly Road» похож на адрес компьютера; он указывает на конкретный почтовый ящик в районе, который обслуживает данное почтовое отделение. Почтовое ведомство выполнило свою задачу, доставив почту в нужное местное отделение, а это отделение положило письмо в соответствующий почтовый ящик. Аналогичным образом, Internet выполнила свою задачу, когда ее маршрутизаторы направили данные в соответствующую сеть, а эта локальная сеть – в соответствующий компьютер.

По целому ряду технических причин (в основном это аппаратные ограничения) информация, посылаемая по IP- сетям, разбивается на порции, называемые пакетами. В одном пакете обычно посылается от одного до 1500 символов информации. Это не дает возможности одному пользователю монополизировать сеть, однако позволяет каждому рассчитывать на своевременное обслуживание. Это также означает, что в случае перегрузки сети качество ее работы несколько ухудшается для всех пользователей: она не умирает, если ее монополизировали несколько солидных пользователей.

Одно из достоинств Internet состоит в том, что для работы на базовом уровне достаточно только межсетевого протокола. Сеть будет не очень дружественной, но если Вы будете вести себя достаточно разумно, то решите свои задачи. Поскольку Ваши данные помещаются в IP- конверт, то сеть имеет всю информацию, необходимую для перемещения этого пакета из Вашего компьютера в пункт назначения. Здесь, однако, возникает сразу несколько проблем.

· Во-первых, в большинстве случаев объем пересылаемой информации превышает 1500 символов. Если бы почта принимала только открытки, Вас бы это, естественно, разочаровало.

· Во-вторых, может произойти ошибка. Почтовое ведомство иногда теряет письма, а сети иногда теряют пакеты или повреждают их при передаче. Вы увидите, что в отличие от почтовых отделений Internet успешно решает такие проблемы.

· В-третьих, последовательность доставки пакетов может быть нарушена. Если Вы послали по одному адресу одно за другим два письма, то нет никакой гарантии, что они пойдут по одному маршруту или придут в порядке их отправления. Такая же проблема существует и в Internet.

Поэтому следующий уровень сети даст нам возможность пересылать более крупные порции информации и позаботиться об устранении тех искажений, которые вносит сама сеть.

Протокол управления передачей (ТСР).

Для решения упомянутых выше проблем используется «протокол управления передачей» (Transmission Control Protocol, TCP), который часто упоминают вместе с протоколом IP. Как следовало бы поступить в случае, если Вы хотите послать кому-нибудь книгу, а почта принимает только письма? Выход один: вырвать из книги все страницы, вложить каждую в отдельный конверт и бросить все конверты в почтовый ящик. Получателю пришлось бы собирать все страницы (при условии, что ни одно письмо не пропало) и склеивать обратно в книгу. Вот эти задачи и выполняет ТСР.

Информацию, которую Вы хотите передать, ТСР разбивает на порции. Каждая порция нумеруется, чтобы можно было проверить, вся ли информация получена, и расположить данные в правильном порядке. Для передачи этого порядкового номера по сети у протокола есть свой собственный «конверт», на котором «написана» необходимая информация . Порция Ваших данных помещается в конверт ТСР. Конверт ТСР, в свою очередь, помещается в конверт IP и передается в сеть.

На принимающей стороне программное обеспечение протокола ТСР собирает конверты, извлекает из них данные и располагает их в правильном порядке. Если каких-нибудь конвертов нет, программа просит отправителя передать их еще раз. После размещения всей информации в правильном порядке эти данные передаются той прикладной программе, которая использует услуги ТСР.


25_1_TKC

Host, Маршрутизатор, Мост
и другие понятия в Internet.

Концентраторы.
Повторители.
Мосты.
Коммутаторы.
Рейтинг коммутаторов
Маршрутизаторы.
Сравнительная характеристика некоторых хабов.

Концентраторы (ХАБ)

Как только в сети 10Base-T становится больше двух компьютеров или возникает необходимость перехода от сети на коаксиальном кабеле к технологии 10Base-T, придется использовать концентратор. Правда, при введении хаба в сеть на витой паре она становится аналогично 10Base-2 и 10Base-5 со всеми вытекающими отсюда последствиями. Концентратор представляет собой устройство, имеющее, как правило, некоторое количество портов для подключения отдельных компьютеров (режим MDI-X) и порт, выделяемый каким-либо образом, для соединения с другими хабами (режим MDI). Зачастую имеется переключатель режима порта. На переднюю панель концентратора выводится информация о состоянии сети (перегрузка сети или отдельного порта, включение питания, коллизии). Концентраторы подразделяют на 10-, 100— и 10/100-Мбит, активные и пассивные. Многие 10-Мбит хабы имеют разъемы и под витую пару (RJ-45), и под коаксиальный кабель (BNC или AUI). Отличие активного хаба от пассивного заключается в том, что первый усиливает передаваемый сигнал, а второй — нет. С помощью пассивного хаба можно решить проблему нехватки портов, но нельзя увеличить максимальный радиус сети. Преодолеть это ограничение поможет репитер. Существуют концентраторы для витой пары, для коаксиального кабеля и волоконной оптики. Ценовой диапазон хабов колеблется в широких пределах. На него влияют скорость концентратора, количество и тип портов, фирма производитель и многое другое. Средняя цена составляет $30-70.

Новый 5-портовый хаб от LinkPro

Тайваньская корпорация Toplink C&C, владелец известной в России марки LinkPro, выпустила новый 5-портовый концентратор для локальных сетей. Модель TL-5505ds SOHODual Hub обеспечивает скорость передачи данных до 10/100 Мбит/с и, как и все современные устройства, поддерживает технологию автоопределения скорости NWay auto-negotiation. В компании особенно акцентируют внимание на том, что TL-5505ds эффективно решает актуальную на сегодняшний день проблему передачи данных между разноскоростными сегментами. Основные спецификации TL-5505ds: технология передачи CSMA/CD (Carrier Sense Multiple Access/Collision Detection, множественный доступ, чувствительность к несущей частоте, обнаружение коллизий. При такой технологии осуществлять передачу может одновременно только одно устройство, все остальные в это время принимают) 5 двухскоростных 100/10 разъемов, 1 разъем Uplink для каскадирования хабов максимальное расстояние для подключения по Uplink - 5м энергопотребление - 7,5 В, 500 мА, адаптер постоянного тока внешний размеры 118 х 88 х 30 мм вес 0,35 кг без адаптера.

Повторители

Повторитель предназначен для соединения разнородных сегментов сети Ethernet и преодоления ограничения длины кабеля. Правда, при этом не обеспечивается логическая изоляция сегментов. Повторители представляют собой устройства с двумя портами. Выпускаются с любым сочетанием портов (двумя портами AUI, портом Thinnet и портом AUI, одним оптоволоконным портом ST и одним портом AUI). Не стоит увлекаться увеличением протяженности сети при помощи большого количества повторителей, т. к. поддержание ее работоспособности превратится в этом случае в сущий ад.

Мосты

В случае, если ваша сеть достигла приличных размеров, то неизбежен тот момент, когда ее производительность станет неприлично низкой. Преодоление проблемы возможно несколькими способами. Один из них — введение в состав сети устройства под названием мост. Мост представляет собой концентратор, усовершенствованный добавлением процессора и памяти, и позволяет объединять между собой физически несовместимые сегменты Ethernet. Это замечательно, но как же мост позволяет увеличить производительность? Очень просто: вся сеть разбивается на отдельные сегменты. Полученные сегменты соединяются с помощью мостов. Мост Определяет, осуществляется ли обмен между различными сегментами или же внутри одного. В случае внутрисегментного обмена информация не проходит в другие. Таким образом и достигается уменьшение загрузки сети. В случае, если же обмен осуществляется между разными сегментами, то мост не дает никаких преимуществ. Он также не влияет на производительность внутри локальной области. К минусам данного устройства следует отнести то, что не осуществляется контроль доступа и вряд ли удастся через него подключиться к Internet или другой глобальной сети.

Коммутаторы

Другой способ повысить производительность ЛВС — это установить коммутатор. Данное устройство в отличие от моста, который соединяет входной сегмент со всеми выходными, позволяет соединить два сегмента, не подключая остальные. Такое возможно за счет того, что каждый порт коммутатора представляем собой отдельный независимый сегмент производительностью 10 (или 100) Мбит/с. С помощью коммутатора можно построить иерархическую структуру, аналогичную структуре, создаваемой на концентраторах. Подразделяются на коммутаторы узлов (node switches) и коммутаторы сегментов (segment switches). Первые позволяют подключать непосредственно к портам отдельные компьютеры, а вторые — концентраторы. В домашних сетях данные устройства почти не используются, т. к. их стоимость исчисляется сотнями и тысячами долларов.

Рейтинг Коммутаторов

Маршрутизаторы

Нам осталось познакомиться только одним устройством — маршрутизатором. Применяются они главным образом в крупных центрах коммутации компаний и Internet-провайдеров. Причина этому очень высокая цена (несколько тысяч долларов). Хотя, например, компании Cisco Systems предлагает ряд устройств для небольших фирм и рынки SOHO. Маршрутизатор может понадобиться, если есть необходимость подключится к сети, безопасность работы с которой не контролируется, если таблицы физических адресов, используемые мостами и коммутаторами для идентификации принадлежности физических адресов и сегментов сети, стали чрезмерно большими и не управляемыми, а также для соединения двух различных сетей, не имеющих физической совместимости. Маршрутизатор функционирует на сетевом уровне, что и позволяет использовать его для вышеуказанных действий. Функционирующие на канальном уровне мосты и коммутаторы могут объединять только сети, использующие одни физические характеристики (например, различные версии сети Ethernet — на тонком коаксиальном кабеле, витой паре и оптическом волокне).


2_1_TKC

Основные сведения

Локальная сеть представляет собой набор компьютеров, периферийных устройств (принтеров и т. п.) и коммутационных устройств, соединенных кабелями. В качестве кабеля используются "толстый" коаксиальный кабель, "тонкий" коаксиальный кабель, витая пара, волоконно-оптический кабель. "Толстый" кабель, в основном, используется на участках большой протяженности при требованиях высокой пропускной способности. Волоконно-оптический кабель позволяет создавать протяженные участки без ретрансляторов при недостижимой с помощью других кабелей скорости и надежности. Однако стоимость кабельной сети на его основе высока, и поэтому он не нашел пока широкого распространения в локальных сетях. В основном локальные компьютерные сети создаются на базе "тонкого" кабеля или витой пары. Первоначально сети создавались по принципу "тонкого" Ethernet. В основе его - несколько компьютеров с сетевыми адаптерами, соединенные последовательно коаксиальным кабелем, причем все сетевые адаптеры выдают свой сигнал на него одновременно. Недостатки этого принципа выявились позже. С ростом размеров сетей параллельная работа многих компьютеров на одну единую шину стала практически невозможной: очень велики стали взаимные влияния друг на друга. Случайные выходы из строя коаксиального кабеля (например, внутренний обрыв жилы) надолго выводили всю сеть из строя. А определить место обрыва или возникновения программной неисправности, "заткнувшей" сеть, становилось практически невозможно. Поэтому дальнейшее развитие компьютерных сетей происходит на принципах структурирования. В этом случае каждая сеть складывается из набора взаимосвязанных участков - структур. Каждая отдельная структура представляет собой несколько компьютеров с сетевыми адаптерами, каждый из которых соединен отдельным проводом - витой парой - с коммутатором. При необходимости развития к сети просто добавляют новую структуру. При построении сети по принципу витой пары можно проложить больше кабелей, чем установлено в настоящий момент компьютеров. Кабель проводится не только на каждое рабочее место, независимо от того, нужен он сегодня его владельцу или нет, но даже и туда, где сегодня рабочего места нет, но возможно появление в будущем. Переезд или подключение нового пользователя в итоге потребует лишь изменения коммутации на одной или нескольких панелях. Структурированная система несколько дороже традиционной сети за счет значительной избыточности при проектировании. Но зато она обеспечивает возможность эксплуатации в течение многих лет. Для сетей, построенных по этому принципу, появляется необходимость в специальном электронном оборудовании. Одно из таких устройств - хаб - является коммутационным элементом сети. Каждый хаб имеет от 8 до 30 разъемов (портов) для подключения либо компьютера, либо другого хаба. К каждому порту подключается только одно устройство. При подключении компьютера к хабу оказывается, что часть электроники сетевого интерфейса находится в компьютере, а часть - в хабе. Такое подключение позволяет повысить надежность соединения. В обычных ситуациях, помимо усиления сигнала, хаб восстанавливает преамбулу пакета, устраняет шумовые помехи и т. д. Хабы являются сердцем системы и во многом определяют ее функциональность и возможности. Даже в самых простых хабах существует индикация состояния портов. Это позволяет немедленно диагностировать проблемы, вызванные плохими контактами в разъемах, повреждением проводов и т. п. Существенным свойством такой структурированной сети является ее высокая помехоустойчивость: при нарушении связи между двумя ее элементами, остальные продолжают сохранять работоспособность. Задача соединения компьютерных сетей различных организаций, зачастую созданных на основе различных стандартов, вызвала появление специального оборудования (мостов, маршрутизаторов, концентраторов и т. п.), осуществляющего такое взаимодействие.

Тестирование


Даешь ЛВС! или Не так страшна Ethernet, как ее спецификации...

Может быть, кто-то сочтет этот материал несвоевременным — действительно, в то время как «весь цивилизованный мир» переходит на Gigabit Ethernet, мы вдруг выпускаем материал, посвященный 100-мегабитовым сетям на витой паре. Однако не будем спешить с выводами. Цивилизованный мир — это, конечно, хорошо, однако если посмотреть на ЛВС в компьютеризованном офисе «среднестатистической» отечественной компании, то сразу понимаешь одно: «Ученье — свет, а неученых — ...».

Каждому специалисту, ответственному за локальную сеть (или, в частном случае, за ее создание «с нуля»), неоднократно приходится отвечать на непростой вопрос: справляется (справится) ли она с возложенными на нее задачами? Будет ли соответствовать новым задачам, которые мы когда-нибудь захотим на нее возложить? Как застраховать себя от необходимости дорогостоящей модификации сети хотя бы на несколько лет? Каким образом обеспечить возможность ее модернизации «малой кровью»? Когда все работает как часы, труд сетевого администратора как надсмотрщика и регулировщика трафика между пользователями — необременителен и довольно прост. Но с появлением проблем именно он часто оказывается сидящим на горячих углях...

В этом материале мы попытались встать на позицию человека, имеющего представление о том, что такое «компьютерное железо», но в сетях разбирающегося, мягко говоря, поверхностно. Ведь далеко не каждый сетевой администратор начинает свою деятельность после окончания соответствующего факультета вуза, прохождения сертификационных курсов и последующей полугодичной стажировки под началом «старших товарищей, умных и чутких». У нас в стране, увы, до сих пор самая популярная IT-профессия — «компьютерщик»: «Да, у нас есть программист... Да, картриджи в принтере он тоже меняет... Да, ОС и ПО при необходимости установит. Что говорите? Не «программист»? Знаете, по правде сказать, я их всех так называю...». И когда количество находящихся в офисе компьютеров становится больше трех, именно перед такими «молодыми специалистами» (как кстати пришелся тут термин из советских времен!) дирекция компании зачастую ставит задачу: «Сделать сеть. Быстро. Дешево. И надежно!». И оказываются они в положении котенка, попавшего не то что в омут, а в самую середину водоворота...

ЛВС: что же это такое?

Для начала полезно ознакомиться с «каноническим» определением. Итак, локальная вычислительная сеть — это распределенная система, построенная на базе локальной сети связи и предназначенная для обеспечения физической связности всех компонентов системы, расположенных на расстоянии, не превышающем максимальное для данной технологии. По сути, ЛВС реализует технологию комплексирования и коллективного использования вычислительных ресурсов. Главные преимущества таких распределенных систем состоят в следующем: высокая производительность обработки данных, повышенная модульность и расширяемость, надежность, живучесть, постоянная готовность и низкая стоимость. Также подобное определение нельзя считать полным без ориентации на простоту реконфигурации и минимизацию затрат на дальнейшую модернизацию.

«По верхам»

В реальности типичная «среднестатистическая малая ЛВС» состоит из трех условных классов устройств:

  • компьютеров с установленными в них сетевыми адаптерами;
  • «кабельного хозяйства», к которому мы отнесем собственно сетевые кабели, патчи, патч-панели и (опционально) шкафы или стойки;
  • активного сетевого оборудования, которое также может быть размещено в шкафах или стойках, в том числе в тех же, что и патч-панели (как правило, это коммутаторы и/или концентраторы).

Опять-таки, в самом простом случае все компьютеры в сети просто подключены к одному концентратору или коммутатору (напрямую или через патч-панель — нас пока не интересует). В более сложном случае несколько концентраторов или коммутаторов соединены между собой через разъем Uplink (так называемое «каскадирование»). В еще более сложном — несколько концентраторов (коммутаторов) образуют сегменты сети, «сводимые воедино» еще одним, выделенным коммутатором (а вот тут уже «или концентратором» можно не добавлять — грамотный сетевой администратор, как правило, в данном качестве их использовать избегает). На этом список самых простых и распространенных вариантов построения ЛВС мы пока что закончим.

К слову — специалистам-сетевикам кажется уместным напомнить, что в данном материале нам приходится идти на многие упрощения в связи с его ориентацией на самый широкий круг читателей. Конечно, следование канонам и четкость определений — это неплохо, но все же не хочется ставить потенциального начинающего сетевого администратора в положение героя Марка Твена, который как-то сказал: «До тех пор пока мне на уроке геометрии не объяснили, что круг — это совокупность точек, находящихся на одинаковом расстоянии от центра, — я хорошо знал, что такое круг!».

Сеть «на коленке»

На заре «сетевой эры» нередко при построении отечественных ЛВС допускались отклонения от стандартов на кабельные сети. Зачастую причиной тому была бедность (оптоволоконная кабельная система и оборудование хоть и существенно подешевели, но не сравнялись по стоимости с «медными» решениями), иногда небрежность, а в большинстве случаев — элементарная техническая неграмотность. И если с первой причиной (недостаток денег) все же иногда приходится мириться, то две следующие вполне возможно устранить, так как обусловлены они исключительно «человеческим фактором».

Впрочем, как ни странно, сети, построенные с нарушением стандартов, до поры до времени... работали! Однако только до поры. К примеру, пока не приходилось заменять какое-нибудь сетевое устройство (сетевой адаптер, концентратор и пр.). И вот тут, после замены, всю сеть вдруг начинало непредсказуемым образом «лихорадить»... При этом она могла работать нормально со всеми приложениями, кроме одного, и попытка администратора «прижать его к стене» стоила и времени, и, особенно, нервов. А виновато было не приложение и не сетевая карта, а вся сеть. Вернее — те, кто выбирал оборудование, монтировал кабель и сдавал систему в эксплуатацию, не задумываясь (или не подозревая?) о стандартах. Еще более серьезные проблемы возникали при попытках перевода построенной «с отклонениями» сети с Ethernet на Fast Ethernet. Ведь при высоких скоростях ЛВС становится намного требовательнее к качеству кабельной системы, и те допущения, которые «прощались» на 10 Mbps, часто повергают 100-мегабитовую сеть просто «в состояние ступора».

А если все же «по уму»?

Таким образом, прежде всего стоит раз и навсегда запомнить, что проектирование и инсталляция любой ЛВС подразумевают прежде всего четкое следование соответствующим стандартам и рекомендациям, что и обеспечивает ее нормальное функционирование не в «некоторых», а во всех предусмотренных этими стандартами случаях.

  • Современные проводные ЛВС реализуются на базе витых пар и оптоволоконных кабелей.
  • Топология определяет общую структуру взаимосвязей между элементами и характеризует сложность интерфейса.
  • Методы доступа к физической среде подразделяются на случайный и детерминированный и зависят от топологии сети.

Для начала — немного истории. Сложилось так, что для организации взаимодействия узлов в локальных сетях, построенных на базе классических технологий (Ethernet, Token Ring, FDDI), разработанных еще 15--20 лет назад, применяются разделяемые между группой компьютеров каналы связи (общая шина, кольцо), доступ к которым предоставляется по специальному алгоритму (как правило — метод случайного доступа или метод с передачей маркера доступа по кольцу), т. е. основанные на принципе использования разделяемых сред либо поддерживающие его.

Напротив, современные стандарты и технологии локальных сетей настаивают на частичном или полном отказе от использования разделяемой среды передачи данных и переходе на применение индивидуальных каналов связи компьютера с коммуникационными устройствами сети. То есть так же, как это делается в привычных нам телефонных сетях, где каждый телефонный аппарат соединен с коммутатором на АТС индивидуальной линией. Технологиями, ориентированными на применение индивидуальных линий связи, являются Fast- и Gigabit Ethernet, 100VG-AnyLAN, ATM и коммутирующие (switching) модификации уже упомянутых классических технологий. Заметим, что некоторые из них, например l00VG-AnyLAN, так и остались в сознании отечественных «сетестроителей» не более чем звучной экзотикой.

Fast Ethernet как развитие классической Ethernet

Основы наиболее популярной на данный момент технологии построения локальных вычислительных сетей — Ethernet — были разработаны специалистами Palo Alto Research Center (PARC) корпорации Xerox в середине 1970-х гг. К промышленной реализации ее спецификации были подготовлены членами консорциума DIX (DEC, Intel, Xerox) и приняты за основу при разработке стандарта IEEE 802.3 в 1980 г. Обратите внимание на даты! По сути, можно констатировать, что изменилось с тех времен не так уж и много...

10-мегабитовая Ethernet устраивала большинство пользователей на протяжении около 15 лет. Однако в начале 90-х г. стала ощущаться ее недостаточная пропускная способность, и следующим существенным шагом развития классической технологии Ethernet стала Fast Ethernet. В 1992 г. группа производителей сетевого оборудования, включая таких лидеров, как SynOptics, 3Com и ряд других, образовали объединение Fast Ethernet Alliance для разработки стандарта на новую технологию, которая бы подытожила и обобщила достижения отдельных компаний в области Ethernet-совместимого высокоскоростного стандарта. Одновременно были начаты работы в институте IEEE по стандартизации новой технологии. Переломав кучу копий, в мае 1995 г. комитет IEEE принял спецификацию Fast Ethernet в качестве стандарта 802.3u (добавив в базовый документ 802.3 главы с 21 по 30). Это и сыграло решающую роль в дальнейшей судьбе технологии, так как обеспечивало преемственность и согласованность сетей 10Base-T и 100Base-T.

От 10- к 100Base-T
Отличия на физическом и канальном уровне стека протоколов модели OSI

Из рисунка (в терминах и категориях семиуровневой модели OSI) видно, что отличия Fast Ethernet от Ethernet сосредоточены на физическом уровне. Стандарт 100Base-T (802.3u) установил три различные спецификации для физического уровня для поддержки следующих типов кабельных систем:

  • 100Base-TX для двухпарного кабеля на неэкранированной витой паре UTP Cat. 5 или экранированной витой паре STP Type 1;
  • 100Base-T4 для четырехпарного кабеля на неэкранированной витой паре UTP Cat. 3, 4 или 5;
  • 100Base-FX для многомодового оптоволоконного кабеля.

Физические интерфейсы стандарта Fast Ethernet IEEE 802.3u и их основные характеристики

Физический интерфейс | 100Base-FX | 100Base-TX | 100Base-T4***
Порт устройства | Duplex SC | RJ-45 | RJ-45
Среда передачи | Оптическое волокно | Витая пара UTP Cat.5 (5e) | Витая пара UTP Cat. 3,4,5
Сигнальная схема | 4B/5B | 4B/5B | 8B/6T
Битовое кодирование | NRZI | MLT-3 | NRZI
Число витых пар/волокон | 2 волокна | 2 витых пары | 4 витых пары
Протяженность сегмента* | До 412 м (МмВ), до 2 км, дуплекс (МмВ)**, до 100 км (ОмВ)*** | До 100 м | До 100 м

* ОмВ — одномодовое оптоволокно, МмВ — многомодовое оптоволокно.

** Расстояние может быть достигнуто только при дуплексном режиме связи.

*** В нашей стране распространения не получил ввиду принципиальной невозможности поддержки дуплексного режима передачи.

Полнодуплексный режим

Новым в этом стандарте (для узлов сети, поддерживающих спецификации FX и TX) также стала рекомендация относительно обеспечения возможности полнодуплексной работы (full-duplex mode) при соединении сетевого адаптера с коммутатором или же при непосредственном соединении коммутаторов между собой. Специфика работы заключается в том, что каждый узел одновременно передает и принимает кадры данных по каналам Tx и Rx. Скорость обмена до 200 Mbps. На сегодня многие производители декларируют выпуск как сетевых адаптеров, так и коммутаторов с поддержкой этого режима. Однако, увы — из-за разного понимания механизмов его реализации, в частности способов управления потоком кадров, эти продукты не всегда корректно работают друг с другом. Кстати, для тех, кто привык читать статьи «по диагонали»: обратите внимание на то, при каком способе соединения каких устройств между собой становится возможной работа сетевых карт в полнодуплексном режиме. Подсказка: концентраторы (хабы) — в этом списке отсутствуют. И не зря.

Концентраторы и коммутаторы

Наиболее «близкая» нам сеть Fast Ethernet, построенная на основе концентратора (на жаргоне сетевиков — «хаб», от английского hub) и объединяющая несколько десятков пользователей, часто оказывается «недееспособной» в том смысле, что скорость передачи данных в ней будет неприемлемо низкой, а некоторым клиентам может быть вообще отказано в доступе к сетевым ресурсам. Это происходит вследствие роста числа коллизий (см. глоссарий) и увеличения времени ожидания доступа. Ведь концентратор — это обычный усилитель (приемопередатчик-повторитель) электрического сигнала, иногда даже производители по старинке маркируют его как «(Fast) Ethernet repeater». Получив сетевой пакет от одного порта (т. е. от компьютера, который подключен к данному порту), он транслирует его на все остальные порты одновременно (принцип можно грубо определить как «я передал всем, значит, до того, кому надо, тоже дойдет»).

Коммутатор (он же в простонародии «свитч», от англ. switch) — более интеллектуальное устройство: он имеет свой процессор, внутреннюю высокопроизводительную шину и буферную память. Если концентратор просто передает пакеты от одного порта ко всем остальным, то коммутатор выполняет целенаправленную пересылку пакетов между двумя портами на основе MAC-адреса получателя. Это позволяет увеличить производительность сети, так как сводит к минимуму возможность возникновения коллизий, позволяет обслуживать пересылку пакетов между несколькими портами одновременно и т. д.

Заметив, что в последнее время стоимость коммутаторов для сетей Fast Ethernet постепенно приближается к стоимости концентраторов времен начала прошлого года, кратко подытожим преимущества сетей, построенных с их использованием:

  • Увеличивается производительность сети путем ее деления на адресно (логически) связанные между собой сегменты.
  • Исключается возможность перехвата паролей и прочей передаваемой/принимаемой информации третьей стороной (напомним, что в случае использования концентратора любой пакет транслируется на все подключенные к нему компьютеры).

Если и можно назвать какую-либо (кроме консервативности владельца сети) причину, ограничивающую широкое распространение коммутаторов, то это все же их более высокая стоимость, чем у хабов. Хотя справедливости ради стоит заметить, что скоро у нас, похоже, не будет выбора: все большее количество производителей сетевого оборудования просто-напросто отказываются от концентраторов, предпочитая выпускать новые, более дешевые модели коммутаторов или снижать цены на уже производимые.

Gigabit в конце туннеля?

Конечно, на дворе 2002 год, и даже в нашей стране все больше корпоративных заказчиков уже серьезно присматриваются к Gigabit Ethernet в качестве базового стандарта для своих сетей. Но все-таки в плане массовости именно технология Fast Ethernet (предмет нашего сегодняшнего внимания) продолжает удерживать лидирующие позиции. Более того, отечественные эксперты пророчат долгую жизнь даже «стареньким» сетям Ethernet (10 Mbps), прогнозируя постепенную их модернизацию до 100 Mbps «старшего брата», скоростными возможностями которого типичная офисная сеть будет вполне удовлетворена, наверное, еще не один год. Разумеется, если не планируется проведение телеконференций с десятками участников. Однако по этому поводу у нас в процессе подготовки материала даже родилась одна техническая «шуточка»: стоимость оборудования, которое позволит загрузить сеть на основе Gigabit Ethernet работой, зачастую даже превышает стоимость развертывания этой самой сети. Кроме того, стоит заметить, что проектирование, инсталляция и развертывание сети Gigabit Ethernet — это вряд ли именно то, с чего нужно начинать «практические опыты обустройства ЛВС».

Из истории Ethernet (для интересующихся)

Мало кто знает, что появление Ethernet неразрывно связано с такими краеугольными камнями современной компьютерной индустрии, как Fabless и Core Logic. Эти два понятия трудно перевести на русский, сохранив лаконизм английского языка.

В те времена, когда существовало заблуждение, что дизайн контроллеров (по сути — Core Logic) — удел полупроводниковой индустрии, не без помощи героя нашего рассказа — Гордона Кемпбелла (Gordon A. Campbell) — материализовалась идея самостоятельной разработки, размещенной на мощностях сторонних производителей. С тех пор «безлошадность» (читай — Fabless) в компьютерном мире не считается грехом, а почитается достоянием острого ума.

Для взаимного понимания разработчиков и производителей с благословения Гордона Кемпбелла возник и развился язык описания внутренней структуры чипа — VHDL (Very High Definition Language). Да и само понятие чипа по праву занимает почетное место в чуть ли не бесконечном списке гениальных инициатив мистера Кемпбелла.

Кроме вышеперечисленных, заслуги Гордона Кемпбелла в кратком изложении выглядят так:

  • идея перепрограммируемых контроллеров, таких, как EEPROM;
  • идея и реализация PC-on-chip;
  • организационные работы по становлению Palm Corp.;
  • разработка первого IBM-совместимого видеоконтроллера;
  • основополагающие работы в области 3D-графики;
  • участие в основании компании 3Dfx Interactive.

Настало время назвать компанию, «причастную» к успехам Мистера Кемпбелла — им, к слову, и организованную: Chips & Technologies Inc. В тесном сотрудничестве с Novell более десяти лет назад родился продукт, надолго определивший структуру современных сетевых технологий, — Novell Eagle. Сегодня аббревиатура NE2000 известна всем, кто связан с сетевыми технологиями.

Novell разрабатывала программную модель драйверной поддержки Ethernet, а Chips & Technologies взялась за программирование полупроводниковой логики. Производство было поручено National Semiconductor. Так появился чипсет, состоящий из трех составляющих:

  • DP8990 (Network Interface Controller, NIC) — интерфейс для подключения к локальной шине персонального компьютера;
  • DP8991 (Serial Network Interface, SNI) — сериализация данных с использованием манчестерского кодирования и механизм обслуживания коллизий;
  • DP8992 (Coaxial Transceiver Interface, CTI) — прием и передача данных по коаксиальному кабелю.

Интересный факт: вездесущий Кемпбелл для производства комплектующих Ethernet, в том числе и контроллеров 8992, основал собственную компанию SEEQ Technology.

Позже технология Chipernet (так предварительно именовалась Ethernet) была дополнена возможностями передачи данных по неэкранированной витой паре проводников — UTP (Unshielded Twisted Pair). Важно подчеркнуть, что Ethernet задумывалась как недорогая и эффективная альтернатива в ряду прочих сетевых решений. Поэтому совершенно логично выглядит и расширение возможностей с помощью витой пары.

Одним из лидеров по производству недорогих сетевых контроллеров, использующих Ethernet, стала «Западная Цифровая корпорация», более известная как Western Digital. Это происходило в то время, когда жесткие диски еще не стали «коронным номером» WDC (впоследствии из-за смены интересов разработка сетевых технологий была продана компании SMC). С тех пор знаменитая троица — SMC, 3Com, Intel — правит миром давно уже не NE2000-совместимых сетевых адаптеров.

В мире совместимых с NE2000 устройств акценты расставили три другие компании — Realtek (60% рынка всех сетевых контроллеров), VIA Tehnologies, Winbond Electronics. Последний больше знаком потребителям по торговой марке Compex.

Практика

Три источника, три составные части...

По темпам совершенствования своих характеристик, например, увеличению верхней граничной частоты тракта передачи и пропускной способности, кабельные системы практически не уступают современным процессорам с их растущими тактовыми частотами. Уже один этот факт дает основание утверждать, что данное направление относится к числу наиболее динамично развивающихся на рынке информационных технологий. Как и в любой другой области с высокими темпами развития, на этом рынке существуют свои проблемы технического, организационного и маркетингового плана, а в процессе классификации элементов структурированной кабельной системы (СКС), в которую «вписывается» современная компьютерная сеть, сталкиваются различные, часто непримиримые подходы и школы.

Но на сколько бы основных групп и классов «отцы сетестроения» не делили бы компоненты современной сети, для распространения сигналов в ней, помимо устройств доступа, отвечающих за физический интерфейс, требуются как минимум еще две немаловажные детали, участвующие в образовании физической среды передачи, — кабели (мы сознательно ограничимся рассмотрением подсистемы рабочего места и горизонтальной подсистемы «на меди») и разъемы для их соединения. Эти компоненты современной СКС многократно описаны, но необходимость небольшого «попурри» на эту тему обусловлена тем фактом, что, например, невзирая на общее снижение цен на достаточно качественные медные кабели Cat.5e, пользователям зачастую навязывается широкий ассортимент откровенно «базарной» продукции (пригодной разве что для создания домашней сетевой структуры). В более серьезном случае это становится одним из источников постоянной головной боли обслуживающего персонала сетей, которому в большинстве своем приходится обходиться (увы!) без дорогостоящих профессиональных сетевых анализаторов, позволяющих определить почти все неполадки в сети одним нажатием кнопки.

О кабелях языком стандартов и рекомендаций

Для применения в качестве базового UTP определен одножильный 4-парный кабель с диаметром проводника 0,51 мм (24 AWG). По другим канонам допускается также использование одножильного кабеля с диаметром проводника 0,64 мм (22 AWG). Для многожильного патч-корда (UTP, те же 100 Ом) актуальна задача обеспечения длительного срока службы, несмотря на частые неминуемые изгибы в процессе эксплуатации. Тут же отметим, что несмотря на определенную «лояльность» стандартов в отношении многожильных кабелей для кроссовых шнуров и подключающих (пользовательских) кабелей (для них стандарт допускает на 20--50% большее затухание в зависимости от того, какому стандарту следуют — американскому или международному), во всем остальном они должны отвечать минимальным требованиям к рабочим характеристикам кабеля горизонтальной системы.

Должна присутствовать маркировка рабочих характеристик для обозначения соответствующей категории. Эти метки не должны заменять собой метки класса безопасности. В качестве примера приведем маркировку, нанесенную на кабель нашей тестовой системы.

Маркировка кабеля

Произ водитель | Категория | Тип | Система сертификации, тип и материал оболочки | Кол-во пар | Диаметр проводника | Коэффициент укорочения волны в кабеле* | Код и дата выпуска | Метка длины и число погонных метров
Molex Premise networks | PowerCat.5e | UTP | IEC 332.1 FR-PVC | 4PR | 24 AWG | NVP=69% | 0575-01/5 01.10.31 | * 80429 m.

* NVP (Nominal Velocity of Propagation) — номинальная скорость распространения — коэффициент укорочения волны в кабеле. Он показывает, во сколько раз скорость распространения сигнала по витым парам меньше скорости света в вакууме.

О цветовом кодировании и правильности терминирования

При таком порядке подключения пар, указано в таблице, обеспечиваются гарантированные производителем величина и знак распределения задержек распространения сигнала.

Варианты обжима разъемов RJ-45

Вариант 1 T568A |  | Вариант 2 T568B
Белый/голубой — голубой | Пара 1 | Зеленый — красный
Белый/оранжевый — оранжевый | Пара 2 | Черный — желтый
Белый/зеленый — зеленый | Пара 3 | Голубой — оранжевый
Белый/коричневый — коричневый | Пара 4 | Коричневый — серый

Стандарты терминирования соединителей
Варианты «A» и «B»

Последнее объясняется просто — с целью уменьшения перекрестных наводок между парами и исключения возможных резонансных явлений при неполном согласовании с нагрузкой неиспользуемых пар (а в некоторых сетевых адаптерах мы обнаружили в гнезде только четыре контакта вместо восьми) проводники свиваются попарно с разным шагом (количеством скруток на единицу длины). По этой же причине желательно также учитывать, что соединение между гнездом и штекером коннектора осуществляется через восемь близко расположенных параллельных контактов, что обусловливает емкостную связь между ними. Степень этого влияния также зависит от способа подключения контактов к соответствующим парам кабеля (см. рисунок). В варианте 568 А пара 2 разъединена парой 1, в последовательности 568 В — пара 3 парой 1.

Стандарт RJ45 (можно встретить название соединителя 8Р8С) пришел в мир компьютерных сетей из телефонии. Он предусматривает несимметричное разъемное соединение. Модульные соединители семейства RJ выпускаются в двух вариантах, ориентированных на кабели с различным типом жилы. Забегая немного вперед, укажем на то, что у гибких коммутационных шнуров (плоских модульных двух-, четырех-, шести- или восьмижильных Cat.3 и четырех витых пар Сат.5) жила состоит из нескольких проволок. Поэтому для изготовления таких кабелей необходимо использовать соединитель с контактом, врезающимся в тело жилы. У монтажного кабеля жила выполнена из монолитного медного проводника, поэтому для монтажа этих кабелей используются соединители с разрезным контактом. Соответственно, если соединитель не предназначен для данного типа кабеля, то и добиться качественного контакта не удастся.

Существует несколько вариантов взаимного расположения проводников относительно контактов коннектора. Для подсоединения всех четырех пар проводников (напомним, что Fast Ethernet использует для работы две пары, четыре вам понадобятся при переходе на гигабитовую сеть) распространены TIA-T568A, TIA-T568B (см. таблицу).

Подключение пар к контактам с несоблюдением стандартов может привести к так называемому разделению пар, т. е. к ситуации, когда соединитель подключается таким образом, что пара состоит из проводов от двух разных скрученных пар. Такая конфигурация иногда позволяет сетевым устройствам обмениваться данными, но часто становится источником трудно диагностируемой проблемы — она подвержена не только избыточным переходным помехам, но и менее устойчива к внешним, в том числе периодически появляющимся в силу специфики расположения кабеля. Результат — ошибки при передаче данных. Такие разделенные пары позволяют выявить кабельные тестеры.

В общем, если опустить ранее сделанные замечания, допускается использовать оба указанных варианта. Однако приведем цитату для тех, кто пытается воспринимать таблицу вариантов как рекомендацию для изготовления crossover-кабелей: «...при условии, что оба конца терминированы по одному и тому же варианту разводки».

Коммутационные шнуры: «прямой» и Crossover

Основные правила прокладки кабеля

Некоторые правила монтажа кабельных UTP-систем, в справедливости которых мы убедились на собственном опыте.

  • Во избежание растяжения сила натяжения для 4-парных кабелей не должна превышать 110 Н (усилие примерно в 12 кг). Как правило, усилие свыше 250 Н приводит к необратимым изменениям параметров UTP-кабеля.
  • Радиусы изгиба установленных кабелей не должны быть менее четырех (некоторые производители настаивают на восьми) диаметров для кабелей UTP горизонтальной системы. Допустимый изгиб в ходе монтажа не менее 3--4 диаметров.
  • Следует избегать излишней нагрузки на кабели, обычно вызываемой их перекручиванием (образование «барашков») во время протяжки или монтажа, чрезмерным натяжением на подвесных участках трасс, туго затянутыми узкими кабельными хомутами (или «пристреленными» скобами).
  • Кабели горизонтальной системы должны использоваться в сочетании с коммутационным оборудованием и патч-кордами (или перемычками) той же или более высокой категории рабочих характеристик.
  • И, пожалуй, главное, о чем следует помнить на протяжении всех инсталляционных работ, — качество собранной кабельной системы в целом определяется по компоненту линии с наихудшими рабочими характеристиками.

Распределительные панели и абонентские розетки

Патч-панель служит для удобной и быстрой коммутации между собой различных портов и оборудования. С ее помощью можно моментально отконфигурировать рабочие порты для передачи данных, звука и видео. Горизонтальные кабели проходят от розеток на рабочих местах к патч-панелям коммутационного узла, где они представлены как порты пользователей. Соответствующие порты пользователей затем могут быть коммутированы с портами LAN, видеопортами и портами телефонной станции. Однако в условиях малой сети патч-панель приобретает совершенно другой смысл, служа в основном даже не столько средством упорядочивания сетевого хозяйства и быстрой реконфигурации, сколько способом избавить себя от дополнительных проблем при последующей модернизации сети и ее расширении. Понятно, что если, к примеру, купленный изначально концентратор рассчитан на 8 портов, а компьютеров в офисе стало 12 — то это «морока». Как минимум придется покупать еще один концентратор и каскадировать их, как максимум — приобретать коммутатор на 16 или даже 24 порта. Однако если изначально для коммутации была использована достаточно «вместительная» патч-панель (на те же 16 или 24 порта) — то удастся избежать мороки гораздо большей — перекраивания кабельного хозяйства. Патч-панели различаются между собой количеством портов, стандартами, способом коммутации. По количеству портов наиболее распространены 12-, 24- и 48-портовые. Обычно они имеют монтажную ширину 19" (формфактор большинства стандартных шкафов), в них предусматривается место для маркировки каналов.

Следующий и наиболее часто видимый с точки зрения клиента элемент кабельной системы — абонентская розетка. Конструкция модуля минимизирует действия монтажника при подключении к кабелю, позволяет сохранить необходимый радиус изгиба кабеля, не требует применения каких-либо инструментов при размещении модуля в коробке. Контакты розетки могут быть дополнительно прикрыты специальной шторкой, предотвращающей попадание внутрь пыли.

Монтажные шкафы предназначены для размещения в них коммутационного и активного оборудования. Шкафы могут комплектоваться системой охлаждения и вентиляции, стеклянными и металлическими дверями, подвижным плинтусом на четырех колесах с тормозами, замками на двери. Вдоль боковых стенок шкафов обычно имеется достаточно места для укладки пучков проводов и вентиляции. Впрочем, для малых сетей монтажный шкаф все-таки является скорее элементом шика, чем реальной необходимостью. Хотя если есть деньги и желание «сделать красиво»...

Какой инструмент может понадобиться

Для работы с кабелем UTP-типа создана целая гамма достаточно удобного комбинированного инструмента, выполняющего резку кабеля, нормированную кольцевую подрезку для снятия верхней изоляции и зачистку отдельных жил (если это требуется для данного типа оборудования, ведь современные способы монтажа, основанные на технологии врезного контакта, не требуют зачистки).

Не затрагивая специализированный инструмент и оснастку, рекомендуемые для терминирования жил кабеля на коммутационные и распределительные панели (с ними можно познакомиться на сайтах их производителей), мы решили остановиться на инструменте, предназначенном для «повседневных» работ, — обжима вилки на кабеле RJ-45. Его многочисленные варианты различаются как по диапазону выполняемых функций и типов обжимаемых разъемов, так и (достаточно существенно) по срокам службы и цене.

Для мелкого ремонта можно попытаться использовать экономичный пластмассовый инструмент. Однако он пригоден лишь для минимального объема эпизодически выполняемых монтажных работ, и, как показывает практика, для модернизации сети объемом в сотню портов его ресурса может хватить не более чем на полгода-год.

Металлический профессиональный инструмент обеспечивает движение пуансонов строго перпендикулярно к поверхности разъема, что благоприятно сказывается на качестве работы. Как правило, такие инструменты имеют многошарнирный механизм с «трещоткой» для снижения и нормирования прикладываемого к рукояткам усилия. В состав универсальных комплектов, позволяющих обжимать различные типы соединителей, могут входить сменные и дополнительные, расширяющие функциональность матрицы и пуансоны.

Промежуточную по качеству и параметрам позицию занимают простые одношарнирные металлические приспособления, достаточно широко представленные на отечественном рынке. Они имеют упрощенную механическую схему и ограниченный (но все же в 3--10 раз больший, чем у пластмассового) срок службы по причине быстрого износа пуансона. Универсальность подобных инструментов обеспечивается не сменными комплектами, а наличием нескольких поверхностей на их рабочих органах (2 в 1 и 3 в 1).

К слову о тестировании и мониторинге...

Мы не сомневаемся, что в элементарной одноранговой сети из пяти машин вряд ли возникнет задача ежедневного углубленного статистического анализа и еженедельного превентивного тестирования. Однако проводимый в ходе работы над статьей неформальный блиц-опрос в отношении мониторинга, диагностики и тестирования участников разделил владельцев и администраторов сетей на несколько групп, позволив нам сформулировать две крайние точки зрения отнюдь не технического и не финансового плана:

  1. Интерес к проведению анализа и аудита сети прямо пропорционален количеству обслуживаемых рабочих станций и вне зависимости от топологии и выполняемых задач асимптотически приближается к нулю (вплоть до полного безразличия), если число клиентов не превышает 15--20. В этом случае чаще всего основными применяемыми на протяжении всей жизни сети «инструментами» являются примитивный кабельный тестер и виртуозное владение утилитами типа ping и tracert. Правда, некоторые респонденты этой группы признают необходимость измерения количественных показателей кабельной системы на момент сдачи в эксплуатацию.
  2. Другая крайность — когда большая и богатая компания идет на покупку дорогостоящих средств управления, диагностирования и тестирования сети, но в своей работе ее сетевые администраторы их практически не используют либо используют некоторые наиболее простые из заложенных в них возможностей по причине того, что у них либо «нет времени», либо «у нас и так все работает», и вообще они не понимают, «зачем им это надо», либо на их аппаратной платформе или в существующей конфигурации данные инструменты периодически «виснут», «не все показывают» или «врут». Не хотелось, но придется добавить — зачастую такая ситуация оказывается обусловленной тем, что возможности имеющихся инструментов... просто-напросто превосходят квалификацию тех, кто ими пользуется.

При этом часто понятия диагностики и тестирования сети отождествляются, что на самом деле в корне неверно. Но под диагностикой принято понимать измерение характеристик и мониторинг показателей работы сети в процессе ее эксплуатации, без остановки работы пользователей. Диагностикой сети является, в частности, измерение числа ошибок передачи данных, степени загрузки (утилизации) ее ресурсов или времени реакции прикладного ПО. То есть та работа, которую, на наш взгляд, администратор сети должен выполнять ежедневно.

Тестирование — это процесс активного воздействия на сеть с целью проверки ее работоспособности и определения потенциальных возможностей по передаче сетевого трафика. Как правило, оно проводится с целью проверить состояние кабельной системы (соответствие качества требованиям стандартов), выяснить максимальную пропускную способность или оценить время реакции прикладного ПО при изменении параметров настройки сетевого оборудования или физической сетевой конфигурации. Такие измерения обычно рекомендуется делать, отключив либо заменив работающих в сети пользователей на агентов теста, что, как правило, в реальной жизни приводит к довольно продолжительному блокированию «нормальной работы офиса». К тому же продолжительность процедуры зависит от того, производятся при этом первичные измерения и анализ параметров или сравнение некоторых требуемых параметров с первичными результатами эталонных (паспортных, сертификационных) тестов. Однако в любом случае чаще всего это приводит к тому, что как сама процедура, так и ее исполнители становятся «малопопулярными» и среди рядовых работников, и среди руководящего звена.

Хоть это и выходит за технические рамки, хочется также отметить, что проведение диагностики или тестирования сети часто напрямую зависит от... степени опытности сетевого администратора. «Молодые и зеленые», как правило, диагностируют и тестируют сеть часто и с удовольствием — ибо при этом не столько исправляют или предотвращают проблемы, сколько занимаются самообучением. Впоследствии, когда все эти «игры» (как и любые другие) приедаются, приступить к процессу диагностирования администратора сети могут заставить только действительно серьезные неполадки в ее работе. Ну и, наконец, с появлением по-настоящему серьезного опыта сетевой администратор опять «возвращается» к диагностике и тестированию, но уже не столько в силу юношеского задора и любопытства, сколько в силу понимания необходимости время от времени проводить эту процедуру в качестве профилактики.

Глоссарий

Сетевой адаптер (сетевая карта) — карта расширения, устанавливаемая в рабочую станцию, сервер или другое устройство сети, позволяющая обмениваться данными в сетевой среде. Операционная система через соответствующий драйвер управляет работой сетевого адаптера. Объем задействованных при этом ресурсов адаптера и центрального процессора системы может изменяться от реализации к реализации. На сетевых картах обычно имеется микросхема (либо гнездо для ее установки) «перешиваемой» памяти для удаленной загрузки (Remote Boot), которая может быть использована для создания бездисковых станций.

Коллизия (collision) — искажение передаваемых данных в сети Ethernet, которое появляется при попытке одновременной передачи несколькими сетевыми устройствами. Коллизии — обычные ситуации, возникающие в процессе нормальной работы сетей Ethernet или Fast Ethernet, но неожиданный рост их числа может свидетельствовать о появлении проблем с каким-либо сетевым устройством, особенно когда это не связано с увеличением трафика сети в целом. В общем случае вероятность столкновения пакетов увеличивается при добавлении в домен новых устройств и удлинении сегментов (увеличении физических размеров сети).

Коллизионный домен (конкурирующий домен) — совокупность устройств, соперничающих между собой за право доступа к среде передачи. Задержка распространения сигнала между любыми двумя станциями, которые принадлежат данной области, не должна превышать установленного значения (часто называемого диаметром коллизионного домена и выражаемого в единицах времени). При подключении устройства к коммутатору число коллизионных устройств в домене, соответственно, всегда сокращается до двух.

Горизонтальный кабель предназначен для использования в горизонтальной подсистеме на участке от коммутационного оборудования (например, в кроссовой этажа) до информационных розеток (на рабочих местах).

Кабель для коммутационных (кроссовых) и оконечных (пользовательских) шнуров обычно также состоит из четырех витых пар и по конструкции очень похож на «обычный» UTP-кабель, используемый в горизонтальной подсистеме. Основные отличия между ними заключаются в том, что для придания устойчивости к многократным изгибам и продления срока эксплуатации проводники выполняются многожильными, а изоляция может иметь несколько бoльшую по сравнению с горизонтальным кабелем толщину (около 0,25 мм). Внешняя изоляционная оболочка изготавливается из материала с повышенной гибкостью. На нее должны наноситься такие же маркирующие и идентифицирующие надписи и метки длины.

Утилизация канала связи сети (network utilization) — процент времени, в течение которого канал связи передает сигналы, или иначе — доля пропускной способности канала связи, занимаемой кадрами, коллизиями и помехами. Параметр «Утилизация канала связи» характеризует степень загруженности сети и эффективность использования ее потенциальных возможностей.

Коммутатор (Switch) — многопортовое устройство канального уровня, устанавливающее на время пересылки пакета адресное соединение между отправителем и получателем на основании построенной и сохраненной в нем коммутационной таблицы MAC-адресов. Проще говоря, коммутатор эмулирует соединение принимающего и передающего устройств между собой «напрямую». Однако не следует забывать, что некоторые (чаще всего — примитивные неуправляемые) коммутаторы при перегрузке в сети, т. е. когда проходящий через них трафик превышает их возможности, могут фактически на время «превращаться» в концентраторы.

Автосогласование (Auto Negotiation) — процесс, инициируемый сетевыми устройствами, имеющий целью автоматически настроить соединение для достижения максимальной в данной среде общей скорости. Приоритеты следующие: 100Base-ТХ — полнодуплексная, 100Base-ТХ — полудуплексная, 10Base-T — полнодуплексная и 10Base-T — полудуплексная. Автосогласование определяется стандартом IEEE 802.3 для Ethernet и выполняется за несколько миллисекунд.

Полудуплекс (Half Duplex) — режим, при котором связь осуществляется в двух направлениях, но в каждый момент времени данные могут передаваться лишь в одном из них. В сети (сегменте) на базе концентраторов все устройства могут работать только в полудуплексном режиме, в отличие от сети на базе коммутаторов, которые могут осуществлять передачу как в полнодуплексном, так и в полудуплексном режиме.

Полный дуплекс (Full Duplex) — двунаправленная передача данных. Способность устройства или линии связи передавать данные одновременно в обоих направлениях по одному каналу, потенциально удваивая пропускную способность.

Скорость физического соединения (Wire Speed) — для Ethernet и Fast Ethernet эта величина обычно приводится как максимальное количество пакетов, которое может быть передано через данное соединение. Скорость физического соединения в сетях Ethernet составляет 14 880, а в сетях Fast Ethernet — 148 809 пакетов в секунду.

MAC-адрес (MAC address — Media Access Control address) — уникальный серийный номер, назначаемый каждому сетевому устройству для идентификации его в сети и управления доступом к среде. Для сетевых устройств адреса устанавливаются во время изготовления (специфицируются IEEE), хотя обычно могут быть изменены с помощью соответствующей программы. Именно благодаря тому, что каждая сетевая карта имеет уникальный MAC-адрес, она может эксклюзивно забирать предназначенные ей пакеты из сети. Если MAC-адрес не является уникальным, то не существует способа провести различие между двумя станциями. MAC-адреса имеют длину 6 байт и обычно записываются шестнадцатеричным числом, первые три байта адреса определяют производителя.

Тестирование

Тестовый стенд

Поскольку такое крупномасштабное тестирование сетевого оборудования для нашей лаборатории внове (да и, к слову, в других компьютерных масс-медиа эта тема затрагивается, прямо скажем, чрезвычайно редко), мы пошли, если так можно выразиться, «по пути наименьшего сопротивления», переложив максимум работы на плечи хорошо себя зарекомендовавших отечественных поставщиков готовых решений и системных интеграторов. Так, гипотетические «офисные компьютеры» в нашей «референсной ЛВС» представляют собой серийные модели ПК Bravo от компании K-Trade, сервер является действительно сервером, специально подобранным путем проведения консультаций с сотрудниками киевского офиса Intel и системного интегратора — компании Ulys Systems, а кабельное хозяйство (коммутационные шнуры с обжатыми разъемами, патч-корды, патч-панель и пр.) было предоставлено в готовом для развертывания виде компанией ProNet.

Для тестирования использовались ПК Bravo с процессором AMD Duron 1100 MHz, 256 MB PC133 SDRAM, материнской платой AOpen AK73A (VIA Apollo KT133A), 40 GB HDD (Maxtor D540X), видеокартой PowerColor GeForce2 MX400 (32 MB) и ОС Windows 2000 Pro (SP3).

Сервером выступала система Dell PowerEdge 2500 (процессор Pentium III 1.26 GHz c возможностью установки второго CPU; чипсет ServerWorks HE-SL; 512 MB PC133 ECC SDRAM; контроллер Adaptec AIC-7899 Dual channel Ultra3 (Ultra160)/LVD SCSI; двухканальный SCSI RAID-контроллер с кэш-буфером 128 MB; три SCSI-винчестера (10000 об/мин), объединенных в массив RAID 5; интегрированный Ethernet-контроллер Intel PRO/100+ Server; интегрированная видеоподсистема на базе ATI-Rage XL 8 MB SDRAM; OC Windows 2000 Server). Подобная конфигурация сервера позволила нам уйти от главной проблемы — влияния быстродействия наиболее «нагруженной» дисковой подсистемы на результаты тестирования (ведь в процессе проведения многих тестов все четыре ПК работали с сервером одновременно). Наличие же достаточно высокопроизводительного процессора и сравнительно большого объема памяти на ПК подстраховывали от влияния нежелательных побочных факторов со стороны «рабочих станций». Управление сервером и ПК осуществлялось с единой консоли оператора, функционирующей через KVM-switch Raritan (предоставленный фирмой «Юстар»).

А вот так все это выглядело в собранном виде

Для проведения тестов сетевых адаптеров был собран стенд, позволяющий имитировать работу устройств в пределах одного коллизионного домена. Он построен с использованием оборудования для структурированных кабельных систем фирмы Molex Premise Networks уровня горизонтальной подсистемы ЛВС и включает в себя четыре фрагмента кабеля Molex PN PowerCat.5E UTP длиной 2 x 15 м и 2 x 75 м, подсоединенных к врезным контактам 24-портовой патч-панели Molex Cat.5E.

Схема стенда

Кабели жгутовались и без коробов подвешивались на крюки в стене. Как уже говорилось, в электропроводных системах приходится учитывать не только затухание, но и наводки. В нашем случае, благодаря тому что кабельные фрагменты при их монтаже оказались сложенными вдвое, наводимые низкочастотные помехи от люминесцентных ламп, пролегающих в непосредственной близости от силовых, сигнальных кабелей и т. п., как мы и предполагали, уменьшились (синфазность воздействующей на жгут кабелей помехи).

В процессе создания сегмента было принято решение отказаться от стандартных абонентских розеток. Для имитации их влияния мы раcкроссировали на патч-панели короткие (и, по причинам, уже объясненным выше, крайне «вредные») отрезки того же кабеля длиной 8--10 см.

Таким образом, вместо требуемой для полноты эксперимента одной пары разъемных контактов мы получили возможность подсоединить еще две, включив их в разрыв цепи от концентратора до машины дополнительным коммутационным шнуром. В Тестовой лаборатории обычно не принято доверять даже известным брэндам без соответствующего инструментального подтверждения, поэтому сразу после инсталляции была не только проверена правильность подключения и распределения кабельных жил, но и измерены количественные параметры каждого из отрезков с помощью портативного анализатора OMNIScanner II от Fluke Network.

Fluke OMNIScanner II собственной персоной

Показатели 75-метрового сегмента

Показатели 15-метровых сегментов

Показатели короткого «гнутого» отрезка

Методика

Так как на всех четырех ПК поочередно устанавливались одинаковые сетевые карты, нас, естественно, интересовало создание по возможности разных условий для их функционирования. В конечном итоге мы остановились на той конфигурации, которую можно видеть на схеме стенда — два «длинных» сегмента по 75 и 90 метров, одно «идеальное подключение» (коммуникационный кабель от компьютера напрямую включен в концентратор) и одно короткое «неудобное» соединение через небольшой отрезок перегнутого кабеля. Забегая вперед, отметим, что наши предположения во многом подтвердились — некоторые модели сетевых карт действительно вели себя по-разному в зависимости от длины сегмента, на которой им приходилось работать. Сервер был «отнесен» от концентратора на 15 метров, что вполне соответствует максимальному из реально встречающихся вариантов (в рамках разумного).

Быть может, некоторые удивятся тому, что мы выбрали в качестве устройства, объединяющего абонентов сети, именно концентратор, а не коммутатор. Ответ довольно прост: дело в том, что для создания нагрузки собственно на предмет тестов, т. е. на сетевые карты, коммутатор в сети из четырех клиентов и одного сервера просто-напросто непригоден. Фактически мы специально усложнили задачу, увеличив количество коллизий в сети до того максимального уровня, который вообще реально было получить, с целью выявить слабые места в работе сетевых контроллеров. В случае же использования коммутатора все тесты фактически превратились бы... в исследование производительности его самого. Несколько слов о концентраторе. Как ни странно, мы остановили свой выбор на довольно простой и дешевой модели LG, сделанной на базе чипов Realtek. Произошло это по двум причинам: во-первых, компании уровня Intel, 3Com или Cisco сейчас практически отказались от выпуска концентраторов, а во-вторых, проведенные в рабочем порядке тесты с использованием других моделей (3Com Office Connect и CompuShack 5DT Desktop) показали, что никакого влияния на результаты тестов замена именно этого устройства в нашем случае не оказывала.

Тесты включали в себя исследование производительности с помощью популярного (насколько вообще можно говорить о популярности подобного ПО) пакета eTestingLabs NetBench 7.02 (модифицированный скрипт NIC_nb702, в котором были оставлены размеры пакетов 512, 4K, 16K и 64K), измерения загрузки CPU штатной утилитой Windows 2000 Performance Monitor во время копирования файла объемом 512 MB с одного из клиентов на сервер, а также измерения скорости «встречного» копирования двух файлов объемом 1 GB между двумя клиентами, соединенными crossover-кабелем (проверка корректности и результативности функционирования полнодуплексного режима).

Характеристики адаптеров Fast Ethernet

Производитель | Модель | Светодиодные индикаторы | Wake-On-LAN | IC Boot ROM | Сетевой чип | Ориентировочная цена, $ | Гарантия, лет
3Com | 3C905CX-TX-M | 10-100/Link/Activity | Разъем/кабель в комплекте | Предустановлена | 3Com 920-ST06 | 43 | 5
 | Home Connect 3C450 | 10-100/Link/Activity | Не поддерживается | Не поддерживается | 3Com/Lucent 40-04834 | 22 | 1
Allied Telesyn | AT-2500TX | 10-100/Activity | Поддерживается | Кроватка | Realtek RTL8139C | 13 | 1
ASUS | PCI-L3C920 | Link/Activity | Не поддерживается | Кроватка | 3Com 920-ST03 | 32 | 1
CompuShack | Fastline II PCI UTP DEC-Chip | Link-FDX/Coll/SPD-100/Act | Разъем/кабель в комплекте | Кроватка | Intel (DEC) 21143-PD | 33,6 | 3
 | Fastline PCI UTP Realtek-Chip | Link/Activity | Разъем/кабель в комплекте | Кроватка | Realtek RTL8139C | 11,2 | 3
D-Link | DFE-528TX | Link/Activity | Не поддерживается | Не поддерживается | D-Link DL10038C | 13,6 | Пожизн.
 | DFE-550TX | Link/100/FDX | Разъем/кабель в комплекте | Кроватка | D-Link DL10050B | 22,3 | Пожизн.
Intel | InBusiness 10/100 | Link/Activity/100Tx | Не поддерживается | Не поддерживается | Intel GD82559 | 25 | 1
 | Pro/100 M Desktop Adapter | Link/Activity/100Tx | Не поддерживается | Предустановлена | Intel 82551QM | 29 | Пожизн.
 | Pro/100 S Desktop Adapter | Link/Activity/100Tx | Разъем/кабель в комплекте | Предустановлена | Intel 82550EY | 31 | Пожизн.
Lantech | FastLink/TX | 10/100/FDX/Activity | Разъем/кабель в комплекте | Кроватка | Intel (DEC) 21143-PD | 27 | 2
 | FastNet/TX | Link/Activity/FDX | Не поддерживается | Кроватка | Realtek RTL8139D | 6,5 | 2
LG | LNIC-10/100Aw | Link/Activity | Разъем/кабель в комплекте | Кроватка | Realtek RTL8139D | 6,2 | 1
Planet | ENW-9504 | 10-100/Activity | Не поддерживается | Не поддерживается | Realtek RTL8139D | 9,5 | 3
SMC | EtherPower II 10/100 | Link/FDX/Tx/Rx | Разъем/кабель в комплекте | Кроватка | SMC 83С172ABQF | 42 | 5
Surecom | EP-320X-R | Link/Activity | Не поддерживается | Кроватка | Realtek RTL8139C | 9 | 2
 | EP-320X-S | Link/Activity | Не поддерживается | Кроватка | Myson MTD803A | 8 | 2

Результаты тестов

Для начала объясним, почему несмотря на тестирование сетевых карт в диаграммах можно видеть лишь наименования чипов. Дело в том, что несмотря на вполне «честное» с нашей стороны поведение, выражавшееся в использовании не «generic»-драйверов от производителей чипов, а последних доступных версий от производителей карт — никакой разницы в быстродействии между картами, сделанными на базе одних и тех же микросхем, мы не обнаружили.

Типичная «одночиповая» сетевая карта

Результаты тестов в NetBench приводятся в ограниченном объеме по одной причине — во всех остальных случаях они были попросту... совершенно одинаковыми. Лишь тест с размером пакета 16K выявил некоторые особенности в функционировании нашей тестовой сети, а именно разница в результатах, продемонстрированных сетевыми картами, нас и интересовала более всего. Зато данный подтест с лихвой окупил наши ожидания — средняя пропускная способность каждого из четырех клиентов отличалась иногда в несколько раз! Собрав воедино все «отличившиеся» чипы и попытавшись найти какую-то зависимость, мы обратили внимание на то, что наиболее показательные результаты принадлежат сетевым контроллерам Intel и 3Com, и это сразу навело нас на одну очевидную мысль...

Как одна, так и другая компания не удосуживается простым копированием давно всем известной «образцово-показательной схемы классического сетевого чипа»:

Ethernet чип. Курсовая работа, III курс :).

Дополнительно они используют так называемые «адаптивные технологии», позволяющие регулировать объем передаваемой в сети информации и величину задержки с тем, чтобы максимально полно использовать возможности конкретного окружения и достигать наибольшей общей пропускной способности сети. Похоже, в нашем случае карты, расположенные на «неудобных» (или, корректности ради, оговоримся — сочтенных неудобными согласно заложенному алгоритму анализа) сегментах, «добровольно уступали» часть полосы своим собратьям, находящимся в лучших условиях. Следует заметить, что выигрыша в общем объеме передаваемых данных это все же не принесло — если сложить все значения пропускной способности по каждому из клиентов, их сумма будет примерно такой же, как в случае с более «прямолинейными» картами. В целом же мы пока воздержимся от оценки этой особенности некоторых сетевых чипов на уровне «хорошо/плохо», ибо в зависимости от конкретных условий функционирования сети и решаемых в ней задач она легко может изменяться в каждом конкретном случае на диаметрально противоположную.

Чипы

3Com 920-ST06/03. «Умный» чип, явно поддерживающий технологии адаптации к условиям конкретного кабельного окружения (про «неоднозначность» такого подхода уже достаточно было сказано выше). Демонстрирует самую низкую загрузку центрального процессора и достойную поддержку режима полнодуплексной связи. Классический пример хорошего, но недешевого решения.

3Com 3C905CX-TX-M

ASUS PCI-L3C920

3Com/Lucent 40-04834. Также очень невысокая нагрузка на процессор и достойная поддержка полнодуплексного режима, но несколько более «умеренный» интеллект — что, впрочем, иногда может быть и полезным. Зато и стоимость такого решения ниже в два раза, чем у более нового.

3Com Home Connect 3C450

D-Link DL10050B. А вот это уже классический пример простого, но добротного чипа — никаких попыток учета особенностей конкретной линии, но в то же время полноценный дуплекс и самая низкая среди «брэндов второго уровня» нагрузка на CPU. Условно этот чип с учетом цены карты на его основе можно назвать упрощенным аналогом 3Com/Lucent 40-04834, равным ему практически во всем, но не обладающим адаптационными свойствами и с более высокой нагрузкой на CPU.

D-Link DFE-550TX

Intel (DEC) 21143-PD. Весьма неоднозначный чип, впрочем — при его возрасте... Некие «зачаточные» адаптационные свойства, но неожиданно высокая загрузка процессора и полный провал в тесте на поддержку режима Full Duplex. Стоит при этом упомянуть одну особенность, которую мы заметили при проведении тестов: карта от CompuShack по крайней мере смогла закончить тест на «встречное копирование», хоть и с худшим результатом, а вот Lantech FastLink/TX в середине теста начала просто... регулярно «терять» сеть! Словом, с одной стороны, в системах на основе концентраторов, где поддержка полнодуплексного режима не требуется, карты на 21143-PD вполне могут применяться, с другой же — вряд ли это решение можно назвать оптимальным.

CompuShack Fastline II PCI UTP DEC-Chip

Lantech FastLink/TX

Intel 82550EY. Еще один вариант «сверхинтеллектуального» устройства, отличившийся нелюбовью к длинным сегментам. Поддержка full duplex на высоте, загрузка CPU весьма невысока. По совокупности свойств — ближайший конкурент 3Com 920-ST06/03, но с гораздо более демократичной ценой. Что интересно — уже был однажды случай, когда одна из независимых западных тестовых лабораторий провела сравнительное исследование производительности сетевых чипов Intel и 3Com, после чего обе компании, по-своему трактуя одни и те же цифры... объявили, что по результатам этих тестов их чип лучше, чем у конкурента!

Intel Pro/100S Desktop Adapter
(PCB у Pro/100 M и InBusiness 10/100 аналогична)

Intel 82551QM (карта Intel Pro/100 M). Все сказанное выше об Intel 82550EY может быть повторено и в данном случае, но с одной оговоркой — этот чип «не полюбил» уже другой сегмент нашей тестовой сети. Честно говоря, пока что мы решили просто привести это как факт, как говорится, «as is», поскольку поведение и предпочтения чипов, поддерживающих адаптационные технологии, вполне заслуживают отдельного исследования.

Intel GD82559 (карта InBusiness 10/100). Этому самому дешевому сетевому решению от Intel явно чуть-чуть «убавили сообразительность», впрочем, сохранив все другие положительные свойства чипов этой компании. И даже нагрузка на CPU упала, а поддержка полнодуплексного режима наоборот — лучшая среди всех участников! Вполне удачное решение для «рядовой» машины, как нам кажется.

Myson MTD803A. По дешевизне продукты на базе этого чипа явно конкурируют с основанными на базе микросхем Realtek — и, в общем-то, довольно успешно. Самая низкая среди дешевых чипов нагрузка на процессор, одинаковое с RTL8139C качество поддержки полнодуплексного режима. Однако в последнем чип Myson все же уступает новой версии Realtek — RTL8139D.

Surecom EP-320X-S

Realtek RTL8139C / D-Link DL10038C. Мы объединили эти чипы вместе, так как хоть формально они и разные, но проявили себя совершенно одинаково. При первом же взгляде на результаты тестов на загрузку CPU и поддержку Full Duplex, мы, не сговариваясь, произнесли одно и то же: «Realtek себе не изменил». Вспомнив классиков советской литературы Ильфа и Петрова, можно, перефразировав их изречение, сказать, что «полный дуплекс у этого чипа... какой-то неполный». Впрочем — работают ведь... И стоят недорого.

Allied Telesyn AT-2500TX

CompuShack Fastline PCI UTP Realtek-Chip

D-Link DFE-528TX

Surecom EP-320X-R

Realtek RTL8139D. Вкратце можно просто констатировать, что с точки зрения результатов тестов этот чип является тем же RTL8139C, которому немного «подлечили» поддержку полнодуплексного режима, причем инженерам Realtek не хватило совсем немного, чтобы «дотянуться» до плотной когорты более именитых конкурентов. Однако высокая загрузка центрального процессора — вечная «болячка» чипов этой компании, осталась без изменений.

Lantech FastNet/TX

LG LNIC-10/100Aw

Planet ENW-9504

SMC 83С172ABQF (карта SMC EtherPower II 10/100). Низкая загрузка CPU, высокая скорость полнодуплексного режима, но с увеличением длины сегмента наблюдается некоторое снижение скорости. В целом — добротный и довольно старый сетевой чип без особых претензий, честно выполняющий свою работу. Вот только цену за подобного класса решение хотелось бы видеть немного другой...

SMC EtherPower II 10/100

Заключение

Что ж, надеемся, что этот материал придется по душе «начинающим администраторам и просто интересующимся» — мы постарались органично совместить в нем как теоретические аспекты, так и практические советы, да и результаты тестирования наиболее распространенных на рынке сетевых контроллеров десктопного уровня не будут лишними для «юноши, размышляющего делать сеть из чего». В целом же стоит заметить, что, безусловно, за кадром осталось не то что «не меньше», а даже во много раз больше, чем можно найти в этом материале. Неудивительно — про то, как правильно спроектировать и настроить сеть, пишутся толстые книжки и монографии, а у нас в распоряжении был лишь десяток с небольшим страниц еженедельника. Поэтому не стоит, наверное, рассматривать данную статью как универсальное самодостаточное пособие или, Боже упаси, учебник. Той информации, которая в ней имеется, пожалуй, может хватить только для того, чтобы понять несколько простых истин: во-первых — «не боги горшки обжигают», и кое-что вполне реально научиться делать самостоятельно, во-вторых — перед тем, как это «кое-что» делать, желательно все же получить хотя бы базовый набор знаний о предмете, ну и в-третьих — даже получив этот базовый набор, останавливаться на достигнутом явно не стоит. Невозможно «знать, что такое ЛВС», ее можно только изучать. Сколько? Да хоть всю жизнь!

Тестирование


4_1_TKC

Топология ЛВС

Топология сети определяет размещение узлов и соединений между ними. Вместе с логическим объединением он определяет основные показатели функционирования сети. Различают следующие структуры ЛВС:

1) Звездообразная.

2) Кольцевая.

3) Петлевая.

4) Шинная.

5) Древовидная.

6) Смешанная.

7) Полно связная.

Звездообразная

Содержит центральный узел, к которому присоединяются станции.

Примерами такой сети могу служить сеть с центральной ЭВМ или сеть телефонной системы с коммутатором.

В случае с центральной ЭВМ сеть используется для коллективного доступа к ресурсу.

В локальных сетях такого вида связь может быть обеспечена между устройствами, что не всегда наблюдается в традиционных сетях. Управление сетью осуществляет контроллер - он опрашивает радиальные устройства, чтобы определить наличие данных для передачи. Терминалы могут начать передачу только тогда, когда будет получено разрешение от центрального узла.

Недостатком такого подхода является то, что при передаче данных от одного терминала к другому центральному ЭВМ в центре звезды обычно обрабатывает их.

Сеть телефонной системы свободна от него - здесь коммутация осуществляется непосредственно между радиальными устройствами каналов, либо коммутацией пакетами.

Коммутация каналов в основном применяется в телефонии.

Здесь, на основании номера, полученного от абонента, производится соединение линий. Канал существует до тех пор, пока телефоны не отключатся. К уже существующему каналу другие абоненты подключиться не могут. То одновременный доступ нескольких устройств к одному затруднен. В последние годы в качестве обычного метода передачи данных принята коммутация пакетами. Сообщения разбиваются на блоки и упаковываются в пакет, содержащий адреса отправителя и получателя. Пакеты отправляются на узел коммутации, который рассылает их по адресам. Получатель проверяет пакет на наличие ошибок и запрашивает повторно те пакеты, в которых они есть. При этом способе коммутации любое устройство на радиальной линии может взаимодействовать с несколькими устройствами одновременно.

Узел в центре звезды кроме выполнения функций коммутации и обработки данных может обеспечивать согласование скоростей передачи и приема, преобразовывать протоколы. То имеется возможность использовать для разных различную передающую среду, подключать терминалы П.О. центрального узла обеспечивает хорошую защиту от несанкционированного доступа, высокую степень обнаружения отказов, простую адресацию.

Но следует учитывать, что центральный узел - это дорогое устройство, т.к. даже для простой ЛВС в нем организовано много функций. Такая сеть имеет высокую чувствительность к отказам и требует дублирования наиболее важных компонентов. Расширение сети также является дорогой операцией вследствие необходимости прокладки кабелей.

Достоинства звездообразных ЛВС:

- простой и надежный доступ станции к центральному узлу;

- возможно подключение простейших систем;

- возможно использование на разных радиальных направлениях, различных передающих сред и скоростей передачи;

- высокий уровень защиты информации;

- простые процессы обнаружения и устранения неисправностей;

- простая адресация.

Недостатки:

- высокая стоимость центрального узла;

- высокая степень зависимости работоспособности от надежности центрального узла;

- значительные затраты на монтаж;

- интенсивность потоков в данных ниже, чем в кольце или шине, т.к. требуется обработка в центральном узле.

Другие возможности использования центрального узла.

Кольцевая топология

В такой сети каждый узел подсоединен к двум соседним.

Кольцо состоит из нескольких повторителей (приемопередатчиков), оконечные устройства (станции) присоединяются к повторителям. Узел – монитор используется для запуска и очистки его от мусора (не распакованных пакетов). Идея создания такой топологии связана с желанием уменьшить зависимость сети от такого сложного и дорогого узла, как центральный узел в топологии “звезда”, обеспечив при этом высокую передачу данных. Действительно, вместо коммуникации всего управления сетью в центральном узле, здесь узлы сети с достаточно просто реализуемыми повторителями. Структурная схема повторителя:

Логика повторителя, должна обеспечивать лишь возможность получения и передачи данных и доступ к станции.

В кольцевых сетях передача информации в большинстве случаев является однонаправленной - это объясняется тем, что для такой передачи требуются более простые повторители и протоколы передачи (а как известно, простота приводит к повышению надежности). В отличие от других топологий, маршрутизация в сетях “кольцо”, а так же просто сообщение через каждый повторитель, регенерируясь в нем до тех пор, пока не будут приняты или удалены какие либо из узлов. Обычно за удаление отвечает узел отправитель.

Сеть “кольцо” имеет невысокую стоимость монтажа, поскольку в качестве среды передачи можно использовать даже витую пару (как например в сети Cambridge ring в вычислительной лаборатории Кембриджского университета). Вследствие одно направленности передачи такая сеть идеально подходит и для использования оптоволокна, но это не целесообразно из-за высокой стоимости таких кабелей, необходимости прокладки дополнительных кабелей питания и т.п.

Надежность функционирования сети зависит от надежного повторителя и каждой отдельной линии. Для повышения надежности используют обходные пути.

Но при выходе из строя двух смежных участков этот способ может быть не допустим вследствие превышения длиной обхода максимально допустимой длины кабеля между повторителями.

Для добавления в кольцо новых станций работа кольца временно прекращается вследствие разрыва кольца. Но это время можно минимизировать используя специальные разъемы для быстрого подключения повторителя.

Достоинства кольцевых ЛВС:

- отсутствует зависимость от центрального узла;

- простое обнаружение отказа узлов;

- простая маршрутизация;

- высокая степень передачи;

- малая вероятность ошибок;

- возможность использования смешанной передачи среды.

Недостатки:

- повторители вносят задержку сигнала;

- ограниченное расстояние между повторителями;

- трассировка кабеля может быть сложной.

Петлевая сеть

Петлевая сеть по форме похожа на кольцевую и отличается от нее методом разделения передающей среды.

Здесь один из узлов (контроллер) полностью определят кокой узел может использовать сеть и для каких целей. Это достигается циклическим опросом каждого узла. Петлевые сети наилучшим образом подходит для работы с низкоскоростными устройствами, например с терминалами в системе с разделением времени контроллер сети отвечает за работу терминалов, и может являться частью другой сети, к примеру звезды, располагаясь на одном из радиусов.

Вследствие сконцентрированности управления в одном месте, приоритеты устройств устанавливаются просто. Повторители используются по причине централизованного контроля доступа.

Достоинства:

- удобны для связи устройств с малыми вычислительными возможностями;

- имеют низкую стоимость установки кабеля;

- легко подключаются новые устройства.

Недостатки:

- функционирование сети зависит от контроллера;

- низки скорости передачи;

- взаимодействие типа “устройство-устройство” подменяется взаимодействием “устройство-контроллер”.

Шинная сеть

Эта сеть представляет собой сегмент кабеля не замкнутый в кольцо.

Устройства подключены к шине с некоторыми интервалами. Места врезки в кабель и подключения и подключения устройств называются узлами.

В такой сети существует два способа передачи информации в шину:

- широковещательный (немодулированный сигнал) - информация поступает через узел в шину и распространяется во все стороны со скоростью ¾ скорости света. Ее могут принимать все узлы. То есть шина является как бы “эфиром” куда передатчик передает информацию антенну, а принимает эту передачу настроенный на нее приемник.

- Модулированный сигнал – здесь несколько передатчиков работает в собственных частотных диапазонах. Приемники также настраиваются на определенную волну. Если диапазоны не очень близки, то помехи между ними не существенны.

Шинная сеть с передачей немодулированных сигналов.

В такой сети сигнал не модулируется и сигнал предается в виде серии импульсов (нулей и единиц). Временной интервал разделяется между всеми пользователями, в каждый момент передачу может вести только один узел. Если это не соблюдается, то информация будет искажена. Способ выделения тактов и составляет суть разделения методов, применяемых в таких сетях.

Среда передачи является, полностью пассивной и в ней нет активных элементов, таких как преобразователи, повторители и т.п. На обоих концах кабеля обычно располагаются терминаторы (сопротивления) препятствующих появлению паразитных сопротивлений волны.

Типичный метод подключается с такой сети и имеет вид:

Врезка обеспечивает электрические или электронные подключения к передающей среде. Она является эквивалентом радиоантенны. Интерфейсный модуль выполняет преобразование данных, поступающих от подключенного устройства: помещает их в пакет, снабжает его адресами получателя и отправителя, информацией, позволяющей осуществить контроль ошибок и другой управляющей информацией. Затем в положенное время передает его в сеть. Интерфейс также осуществляет повторную передачу в случае возникновения ошибок. Отправленную таким образом информацию “слышат” все устройства, находящиеся в сети. Интерфейс выделяет адресованные для устройства блоки и игнорирует все остальные.

Предающей средой в таких сетях является обычно коаксиальный кабель, который позволяет производить врезку без разрыва.

Достоинства:

- среда полностью пассивна;

- легко подключаются новые устройства;

- к одному интерфейсному модулю могут быть подключены несколько медленно действующих устройств;

- монтаж сети прост.

Недостатки:

- имеющий соответствующее оборудование может прослушивать передачи, не будучи обнаруженным;

- для связи со средой требуется “интеллектуальное” устройство;

- обычные терминалы подключаются только через сложные модули;

- иногда происходит интерференция сообщений в шине;

- нет автоматического подтверждения приема.

Шинная сеть с передачей модулированных сигналов.

Как уже говорилось ранее, такая сеть очень похожа на радиоканал, в котором для различия служб выделены различные частоты. В сети радио эфир заменяется кабелем, по которому и осуществляется передача на радиочастоте, при соответствующем модулировании радиочастот.

Подобный метод используется в кабельном телевидении. По одному кабелю передается несколько телеканалов. Такая сеть может охватывать широкое пространство, вследствие несложного усиления сигнала. Оборудование для подобных сетей отличается простотой и надежностью, а ширина полосы пропускания может быть разделена для передачи речи, изображений, данных и т.п.

Достоинства:

- может быть охвачена большая территория;

- сеть легко развивать;

- установка и трассировка кабеля легко осуществима;

- возможна совместная передача данных, изображения и речи.

Недостатки:

- радиочастотные модемы дороги;

- линейные усилители или повторители должны быть постоянно обеспечены электроэнергией.

Древовидная сеть

Древовидная сеть представляет собой несколько шин соединенных друг с другом.

Обычно имеется магистральная шина к которой и подключаются боковые. Древовидная шина такого вида наиболее подходит для передача модулированных сигналов. Одна частота используется для передачи, а другая для приема. Средой передачи является коаксиальный кабель.

Значительно сложнее организовать древовидную шину с передачей не модулированных сигналов – не обходим тщательный подбор кабельных ответвлений, поскольку в противном случае сигналы в ответвлениях будут проходить с различными скоростями и отражаться различным образом. Подобная сеть имеет значительно боле низкую скорость передачи, чем сеть с единственной шиной. В качестве передающей среды используют многожильный кабель. Примером немодулированной древовидной сети является Ethernet. Достоинства и недостатки древовидных сетей аналогичным достоинством и подключением сетей с обычной шинной архитектурой.

Смешанная и полно связная сети

Если узлы сети соединены более сложным способом, который нельзя классифицировать как один из вышерассмотренных, то сеть - смешанная:

Если каждый узел сети непосредственно соединен с любым другим узлом каналом, то сеть называют полно связной

Тестирование


Региональные и глобальные сети

Вопросы:

1.История развития региональных (глобальных) сетей.

2.Способы коммутации и маршрутизации информации в сети.

3.Построение региональных сетей на базе ОС NETWARE и других программных продуктов фирмы NOVELL.

4.Общая характеристика модемов. Правила выбора модемов.

1 вопрос.

Глобальные сети в своем развитии прошли три этапа:

I. 60-е годы. Использование существующей телефонной сети.

Две АбС могли взаимодействовать между собой подключаясь к международной телефонной сети (ТС) посредством модема путем набора необходимого телефонного номера (рис.5.1).

Рис.5.1. Использование телефонной сети.

Основные характеристики:

Управление взаимодействием осуществлялось программно.

Использовался асинхронный режим взаимодействия.

Максимальная скорость передачи 800 бит/сек.

Достоинство: повсеместная распространенность телефонной сети обеспечивает универсальную доступность для передачи данных.

Недостатки: жесткая скорость передачи данных. Если машина требует меньшей скорости передачи, то возможности канала не используются. Если большей - то телефонный канал не мог ее удовлетворить.

II.70-е годы. Появление сети передачи данных.

Две АбС взаимодействуют между собой посредством сети передачи данных (рис.5.2).

Рис.5.2. Сеть передачи данных.

Подсоединение абонентской системы к сети (рис.5.3) выполняется через коммутируемую телефонную линию посредством модема (в исключительных случаях - через выделенную линию).

Рис.5.3. Подсоединение абонента к сети.

Основные характеристики:

Управление взаимодействием осуществляется посредством одной из АсС.

Сеть позволяла использовать синхронный режим передачи (в условиях выделенных линий).

МАХ скорость передачи 64 Кбит/сек (по выделенным линиям).

Узлы предназначены для коммутации и маршрутизации цифровой информации поступающей по выделенным каналам и имеют следующую структуру, представленную на рис.5.4.

Рис.5.4. Структура узла.

Достоинства: Относительно большая скорость передачи данных.

Недостатки: Отсутствует возможность передавать по одним и тем же каналам данные и речь.

III. 80-е - 90-е годы. Создание сетей общего пользования, отвечающих модели взаимодействия открытых систем (OSI).

Структура сети общего назначения представлена на рис.5.5.

Рис.5.5. Сеть общего назначения.

Основные характеристики:

Любая ЭВМ подключается к сети передачи через интерфейс (шлюз), обеспечивающей согласование результатных данных.

По одной и той же сети могут быть переданы данные и речь.

2 вопрос.

Одной из основных характеристик узла сети передачи данных является коммутация и маршрутизация информации. Сущность ее заключается в выборе Узлом Связи последовательности каналов, по которым следует передать пакеты (блоки, на которые делится массив информации перед передачей).

На рис.5.6 представлен пример коммутации информации. Здесь представлен узел КС, связывающий абонентские системы А (передающие) с абонентскими системами В (получающие).

Программному обеспечению узла необходимо решить, в каком порядке и по каким каналам направить эти пакеты абонентам В. Об этом процессе говорят, что в узле происходит коммутация информации. Существует два способа коммутации информации: коммутация каналов и коммутация пакетов.

В первом случае (коммутация каналов) коммутация физического канала осуществляется предварительно один раз согласно схеме, представленной на рис.5.6.

Рис.5.6. Коммутация каналов и пакетов.

При коммутации каналов предварительно путем посылки определенного сигнала устанавливается связь абонента А с абонентом В, который с помощью сигнала обратной связи сообщает о готовности принять сообщение. После этого абонент А начинает передавать данные. Время передачи данных зависит от длины передаваемого сообщения, пропускной способности канала (время передачи данных) и времени распространения сигнала по каналу. В момент передачи ни одна из частей канала не может быть использована другой АбС.

Метод коммутации каналов прост, но имеет ряд существенных недостатков:

Время организации линии для передачи информации достаточно велико.

Нерациональное использование каналов связи. Во время сеанса между двумя абонентами могут быть большие паузы, однако каналы связи между этими абонентами в период пауз заняты другими не могут быть.

Низкая достоверность передачи информации. Это связано с тем, что данные, передаваемые по последовательности каналов, нигде не проверяются.

Стремление устранить эти недостатки привело к созданию метода коммутации пакетов. Сущность заключается в том, что здесь каждый пакет имеет адрес назначения и самостоятельно передается через подсеть. При использовании этого метода (рис.5.6) в узле проверяется адрес пакета и по каждому из них принимается решение по какому очередному каналу его передавать. Здесь ни одна пара абонентов во время сеанса взаимодействия не занимает монопольно ни одного канала.

Метод коммутации пакетов имеет ряд существенных преимуществ:

Эффективное использование каналов связи за счет разделения времени работы каналов между различными парами абонентов (мультиплексирование потоков данных). Процесс мультиплексирования данных представлен на рис.5.7. потоки данных, генерируемые абонентами

Рис.5.7. Мультиплексирование потоков данных.

Высокая достоверность передаваемой информации. Достигается за счет выполнения проверки каждого пакета всеми узлами сети.

Почти мгновенное предоставление возможности передачи информации (не нужно ожидать пока освободятся каналы, образующие путь от Аб-отправителя к Аб-получателю.

Метод коммутации каналов при всех своих недостатках имеет одно преимущество перед коммутацией пакетов. Оно заключается в том, что при монопольном владении каналами все пакеты проходят путь за одно и то же время. При коммутации пакетов из-за пиковых нагрузок в узлах могут возникать некоторые задержки.

Учитывая указанное преимущество метода коммутации каналов в настоящее время происходит модернизация метода коммутации пакетов. Его разрабатывают комплексным, обеспечивающим как коммутацию каналов, так и коммутацию пакетов. Такие сети получили название дискретных сетей с интегральным сервисом.

Дискретными эти сети называются потому, что по ним передаются дискретные сигналы. Интегральный сервис означает, что каждая такая сеть в будущем заменит практически все сети связи: телефонную, телеграфную, телетайпную и т.д.

Сущность модернизированного метода передачи пакетов заключается в том, что любой канал передачи данных коммуникационной подсети может работать в 2-х режимах: монопольном и коллективном. Поэтому первый пакет передаваемой последовательности пакетов должен сообщать всем узлам о том, в каком режиме необходимо передавать остальные пакеты этой последовательности.

3 вопрос.

Несколько локальных сетей могут быть объединены между собой. При этом способы объединения зависят от расстояния, на котором ЛВС находятся друг от друга, а также от требуемой скорости обмена информацией между сетями.

При объединении ЛВС, расположенных недалеко друг от друга, используют мосты. Мосты позволяют объединить ЛВС, отличающиеся между собой как по архитектуре, так и по методу доступа в канал. Однако все ЛВС должны быть однородны по характеру ПЭВМ, входящих в их состав. Мосты бывают внутренние и внешние. Внутренние мосты объединяют несколько ЛВС с помощью сетевых плат в файловом сервере (рис.5.8 ), которых может быть не более 4-х.

Рис.5.8. Объединение ЛВС средствами внешнего моста.

В РГЭА с помощью внутреннего моста на сервере в ауд.211 объединены две шинных ЛВС: одна опирается на технологию Ethernet (ауд.209), другая - на технологию Arcnet (ауд.213).

Основным недостатком внутреннего моста является невысокая его надежность и существенное замедление скорости работы файлового сервера.

Внешние мосты предполагают использование рабочей станции с двумя сетевыми адаптерами для объединения однородных (построенных на базе одного типа ЭВМ) ЛВС (рис.5.9 ).

Рис.5.9. Объединение ЛВС по средствам внешнего моста.

Внешний мост может быть выделенным или невыделенным. Рабочая станция в режиме выделенного моста работает только в этой функции. ПЭВМ, находящаяся в режиме невыделенного моста, занимается как пересылкой файлов между ЛВС, так и выполнением пользовательских программ как обычная рабочая станция. Недостаток такой работы заключается в незащищенности моста: любой сбой или неверное функционирование пользовательской программы может вызвать разрушение моста. Кроме того, Прикладная Программа моста занимает довольно большой объем памяти и это ограничивает использование ПЭВМ как рабочей станции.

Для объединения в региональные и глобальные сети ЛВС , находящихся на значительном расстоянии друг от друга, требуются дополнительные аппаратные и программные средства. Комплекс указанных средств зависит от способа объединения ЛВС:

· объединение ЛВС посредством телефонных коммутируемых каналов связи (ТККС);

· объединение ЛВС посредством выделенных телефонных линий.

Особенности сети на базе телефонных коммутируемых каналов связи представлены на рис.5.10.

Рис.5.10. Объединение ЛВС посредством асинхронных коммутируемых телефонных линий связи.

Взаимодействие посредством асинхронных коммутируемых телефонных линий связи осуществляется с помощью внутреннего либо внешнего моста, работающего под управлением программного продукта

Net Ware Asynchcronous Remote Router

(входит в состав NETWARЕ 3.11 или выше, должен приобретаться дополнительно для более ранних версий ОС).

Кроме того, требуется асинхронный модем для подключения к коммутируемым телефонным каналам связи.

Основное достоинство объединения ЛВС на базе ТККС:

1. Использование недорогих асинхронных модемов и разговорных телефонных линий связи.

2. Эффективно при передаче файлов данных средних размеров.

3. Реализация электронной почты.

Недостатки:

1. Неэффективен прямой доступ к файлам другой ЛВС, поскольку ТККС имеют ограниченную пропускную способность и невысокую надежность, небольшую скорость и возможность зависания сети.

Особенности сети на базе выделенных телефонных линий связи представлены на рис.5.11.

Рис.5.11. Объединение ЛВС посредством выделенных синхронных линий связи.

Взаимодействие посредством синхронных выделенных телефонных линий связи осуществляется с помощью внутреннего либо внешнего моста, работающего под управлением программного продукта.

NETWARE LINK/64

Кроме того, подключение к выделенным телефонным каналам связи требует наличие МПД и синхронного модема.

Дополнительно к электронной почте и пересылке файлов сеть обеспечивает прямой доступ к файлам (режим ОN LINЕ). Посредством МПД (выполняет роль узла связи) несколько ЛВС могут быть связаны в региональную или глобальную сеть с помощью узловой коммуникационной подсети.

4 вопрос.

Передача информации между 2-мя компьютерами возможна 3-мя способами:

Модемы используются для преобразования дискретных сигналов в аналоговые (и наоборот) при передаче данных между ПЭВМ посредством телефонных каналов связи.

Соглашения о способе и порядке обмена данными (протокол связи) между ПЭВМ посредством модемов устанавливаются с помощью стандартов. В течении 30 лет разработка общемировых стандартов модемной связи входит в круг задач Международного консультативного комитета по телеграфии и телефонии ( Comite Consultativ International de Telegrahic ef Telephonie, ССITT).

Одной из основных характеристик, определяемой стандартом, является скорость передачи информации. Существуют следующие стандарты скоростей:

Модемы обязаны обмениваться информацией с точностью до байта, и им необходимо защищаться от ошибок связи.

Одно из основных свойств модема - защита от ошибок. Программные средства, позволяющие выполнить защиту от ошибок, могут быть либо встроены в ПЗУ, либо включаются в комплект поставки модема.

В настоящее время получили наибольшее распространение системы коррекции ошибок, определенные стандартом V.42 -1988г (при высокой эффективности не требует большой производительности процессора).

Третьим, основным свойством модема, является сжатие данных. Сжатие данных необходимо для сокращения (уменьшения) времени, необходимого для передачи данных по каналам связи. Сжатие данных может быть как программным, так и аппаратным (предпочтительнее).

В конце 1989г. комитетом CCITT разработан стандарт V.42 bis, который при работе в: полудуплексном режиме (данные передаются в 2-х направлениях, но в различные моменты времени) позволяет сжимать данные в 2-3 раза; дуплексном режиме (данные передаются в одно и то же время) позволяет сжимать данные в 1.5-2 раза; V.42 bis включает в качестве метода коррекции ошибок стандарт V.42.

Основными производителями модемов для телефонных каналов являются компании США, Великобритании, Франции и Германии.

Наличие большого количества модемов, отличающихся по ряду функциональных признаков , требует разработки правил их выбора.

Модемы можно классифицировать по 5-ти признакам:

По функциональному назначению:

модем;

факс-модем.

По конструктивному исполнению:

· внутренние, подключаемые кабелем к разъёму RS-232 персонального компьютера;

· внешние, в виде платы, установленные внутри компьютера.

· По скоростным данным:

· низкоскоростные (300, 600, 1200 и 2400 bps);

· высокоскоростные (9600, 14400, 19200 bps).

· По принципу работы в линии:

· синхронные;

· асинхронные.

· По реализации протоколов коррекции ошибок и сжатия данных:

· поддержка протоколов на аппаратном уровне;

· поддержка протоколов на программном уровне.

Перечисленные признаки являются определяющими при выборе модема.

На первом этапе следует определить: использовать модем или факс-модем? Единственным недостатком факс-модема, по сравнению с модемом, является стоимость (в среднем факс-модем дороже модема на 40$). Помимо чисто коммуникационных функций модема, факс-модем позволяет выполнить следующие операции:

· планирование во времени передачи данных;

· одновременная пересылка нескольких файлов;

· ведение журнала регистрации ошибок;

· возможна пересылка текстовых документов, подготовленных текстовыми процессорами.

На втором этапе следует сделать выбор между внутренним и внешним модемом. Внутренний модем целесообразно использовать в следующих случаях:

· дефицитно место на рабочем столе;

· есть ограничения по подключению дополнительных устройств в сеть питания;

· не требуется использовать модем в различных компьютерах.

Кроме того, внутренние модемы дешевле внешних. Внешний модем целесообразно использовать в следующих ситуациях:

· если компьютер не перегружен периферией;

· есть необходимость переносить модем с одного компьютера на другой.

Недостатки внутреннего модема - необходимость "холодного" перезапуска компьютера при "зависаниях" на линиях, что характерно для "наших" (отечественных) линий связи.

На третьем этапе выполняется выбор модема по скоростным характеристикам. Модемы, использующие протоколы V.32 и V.32 bis, целесообразно иметь только в том случае, если на другом конце также происходит подключение к скоростному модему. Кроме того, опыт эксплуатации модемов на наших телефонных линиях показывает, что, несмотря на применение протокола сжатия, например, V.12 bis вследствие помех и переповторов результирующая эффективная скорость передачи данных оказывается ниже раза в полтора. Например, при использовании модемов со скоростями 2400 bps эффективная скорость получается порядка 1200-1500 bps.

На четвертом этапе делается выбор между синхронным (наиболее высокоскоростной, используется при интенсивном способе взаимодействия) и асинхронным (используется если взаимодействие с сетью не интенсивно) модемом, исходя из характеристик каналов связи: коммутируемые или некоммутируемые.

Наиболее доступными для пользователя модема являются коммутируемые каналы связи, в которых телекоммуникационная информация передается по тем же каналам, что и речевая информация. При работе с коммутируемыми каналами связи требуется асинхронный модем.

Для организации взаимодействия только 2-х ПЭВМ требуются выделенные каналы связи. В этих условиях требуются синхронные модемы, как более высокоскоростные.

На пятом этапе решается вопрос о том, каким образом модем должен поддерживать протоколы сжатия данных и коррекцию ошибок. Здесь следует помнить, что аппаратная реализация более надежна, но и дорогостоящая. Поэтому, если нет жесткой необходимости, можно купить модемы с программной реализацией протоколов.

1 вопрос.

Термин “телематика” применяется для определения двух широких классов услуг, предоставляемых региональными и глобальными сетями - телетекст и видеотекст.

Технология телетекста использует обычные системы широковещательного телевидения для того, чтобы передавать покадрово информацию на терминалы пользователей (рис.6.1). Как видно на рис.6.1 термин телетекст описывает услугу с однонаправленной передачей данных.

Рис.6.1. Технология телетекста.

В условиях телетекста страница текста остается на экране до того, как будет циклически замещена следующей страницей, либо до указания пользователя. Вид услуги “телетекст” относится к самым ранним формам взаимодействия пользователя с удаленной ЭВМ. Для телетекста не требуется дополнительного канала телевидения. Он использует уже существующий. Принцип работы службы телетекста представлен на рис.6.2.

Рис.6.2. Принцип работы широковещательной службы.

Чтобы понять принцип работы телетекста, необходимо рассмотреть, как осуществляется обычная телевизионная передача. Изображение на телевизоре появляется благодаря тому, что по его экрану непрерывно двигается электронный луч. Сначала происходит прямой ход луча слева на право, затем луч движется в обратном направлении (пунктир). Реальная картина, видимая на экране телевизора, несколько отличается от той схемы, которая показана на рис.6.2. Во-первых, участки прямого хода луча располагаются так близко друг от друга, что получается сплошное изображение. Во вторых, во время обратных ходов луч гасится и поэтому на экране не виден.

При широковещании участки обратных ходов луча используются для передачи различной информации. Для этого к телевизору добавляется недорогая микромашина (интерфейс телетекста) с простейшим терминалом в виде клавиатуры.

В отличие от телетекста, видеотекст предполагает двустороннее взаимодействие между пользователем и источником информации (рис.6.3).

Рис.6.3. Технология видеотекста.

Как видно из рис.6.3 для обеспечения видеотекста необходимы модемы и коммутируемые телефонные сети (или коммуникационная подсеть).

Телематика обеспечивает следующие виды услуг:

Новости, погода, спорт.

Реклама через вещание телетекста.

Финансовая информация, например курс акций на бирже.

Покупки через терминал.

Игры и развлечения.

Электронная почта.

Телесовещания и телеконференции.

Функции 1, 2, 3 - обеспечивают телетекстом, а функции 4, 5, 6, 7 - обеспечиваются видеотекстом.

2 вопрос.

Электронная почта (ЭП) является одной из наиболее широко распространенных услуг, предоставляемых пользователям глобальной вычислительной сети. ЭП имеет ряд преимуществ перед обыкновенной:

· более быстрая доставка сообщений;

· более низкая стоимость передачи (для Германии посылка письма - 0,94$, максимум 4$ - страницы текста телексом, 0,19$ - телетекстом).

При помощи электронной почты можно пересылать тексты, изображения, звукограммы. Вся указанная корреспонденция хранится в информационных банках. Это позволяет в любое необходимое время осуществлять поиск, подборку и просмотр полученных при помощи почты документов.

Основные функции, выполняемые ЭП, сводятся к следующим:

· редактирование документов перед передачей;

· пересылка корреспонденции;

· проверка и исправление ошибок, возникающих при передачи информации;

· использование приоритетов для передачи срочной корреспонденции;

· передача подтверждений о получении корреспонденции адресатами.

Простейшая форма электронной почты представлена на рис.6.4.

Рис.6.4. Простейшая схема ЭП.

На рис.6.4 корреспонденция непосредственно передается от одного пользователя к другому через коммуникационную подсеть. Данная схема проста, но имеет один существенный недостаток. Здесь пересылка документации возможна лишь тогда, когда одновременно работают машина - отправитель и машина получатель корреспонденции. Если пользователь находится не на своем месте, либо занят другой работой, корреспонденцию передать нельзя.

Для устранения указанного недостатка в структуру электронной почты вводят одно либо несколько почтовых отделений. Структура ЭП с одним почтовым отделением представлена на рис.6.5.

Рис.6.5. Структура почты с одним почтовым отделением.

Согласно рис.6.5 корреспонденция любого пользователя пересылается и хранится в информационном банке, выполняющем функции почтового отделения. Затем из почтового отделения корреспонденция рассылается адресатам.

В больших информационных сетях наличие одного почтового отделения приводит к большой загрузке каналов передачи данных, ведущих к нему. Поэтому в таких сетях делают по несколько почтовых отделений (рис.6.6). Здесь АбС первоначально пересылают корреспонденцию в ближайшие почтовые отделения, которые пересылают в нужных случаях документы друг другу и рассылают их пользователям.

Рис.6.6. ЭП с несколькими почтовыми отделениями.

Почтовое отделение в ЭП выполняет все необходимые функции, обеспечивающие быструю и качественную доставку корреспонденции:

· управляют сеансами передачи информации;

· проверяют наличие ошибок в переданной корреспонденции и исправляют их;

· хранят корреспонденцию до востребования;

· сообщают пользователям о поступившей для них корреспонденции;

· пересылают документы пользователям;

· регистрируют корреспонденцию и ведут ее учет;

· поддерживают работу справочников почтовых отделений и адресов абонентов;

· выполняют служебные операции, сортировку информации, проверку паролей при запросе корреспонденции, копирование документов.

Международный консультативный комитет по телеграфии и телефонии утвердил стандарт на ЭП, включающий группу рекомендаций, обозначенных шифром х.400.

3 вопрос.

Для проведения телесовещания или телеконференции одна из рабочих станций региональной или глобальной сети выступает в качестве банка и, одновременно, организатором совещания (рис.6.7).

Рис.6.7. Схема организации телесовещания.

Предварительно банк объявляет о проведении телесовещания на определенную тему и рассылает пользователям извещения об этом. Для проведения совещания в банке открывается специальный файл, в который вкладывается первоначальный текст и иллюстрирующий его материал (доклад). В течение суток или другого заранее установленного времени все участники совещания, обращаясь к банку, читают этот доклад и записывают в файл банка свои замечания и предложения. С ними знакомится руководитель банка и все лица, участвующие в дискуссии. После этого руководитель и остальные желающие лица вновь выступают по обсуждаемому предмету (посылают материалы в банк). С их выступлениями знакомятся участники дискуссии. Так продолжается до тех пор, пока будет сформулировано и принято решение совещания.

4 вопрос.

Кроме телетекста и видеотекста в последние несколько лет появилась другая технология, которая по мнению многих специалистов, станет массовым стандартом сетевых систем на базе терминалов.

Для определения этой технологии используется термин “телекс”. Это обслуживание явилось результатом развития телекса и телетайпа.

Телекс. Примерно 20 лет назад, когда начали появляться электронные пишущие машинки, возникла идея их соединения посредством телефонных каналов связи. В результате возникла служба телекса. Современные системы телекса работают под управлением ЭВМ, реализующих мультиплексирование в цифровых (дискретных) средствах передачи. Кроме того, терминал телекса может иметь средства запоминания данных, что особенно полезно для функций электронной почты. Скорость работы терминала 50 бот. Для кодирования символов используется международный алфавит № 2.

Система телетайпа обеспечивает передачу текста между совместимыми терминалами со скоростью 110 слов в минуту, используя международный алфавит № 5 (код ASCII).

Разработка телетекста началась в конце 70-х годов в ФРГ. Целью данной разработки было создание терминала, который обеспечивал бы генерацию текста одновременно с передающими возможностями и который бы использовал полный набор символов пишущих машинок.

МККТТ (Международный консультационный комитет по телеграфии и телефонии) определил:

Все терминалы телетекста должны использовать стандартный набор графических знаков. Принимающий терминал телетекста должен иметь средства для хранения и использования полного набора этих символов. Это требование разработано для того, чтобы документ, направленный из одной страны в другую, был принят в том же виде несмотря на различие языков и алфавитов.

Служба телетекста требует, чтобы терминал выдерживал загрузку в течение 95% всего времени действия. Также требуется, чтобы он работал на скорости 2400 бит/с как на внутренних линиях, так и на зарубежных.

Все терминалы телетекста должны иметь полностью автоматическую установку вызова и ответов, чтобы исключить все ручные вмешательства.

Каждый терминал должен иметь уникальный код идентификации, включающий 4 части:

· страна или сеть в стране;

· адрес терминала;

· дополнительная информация (определяется МККТТ);

· идентификатор владельца терминала.

Все терминалы телетекста должны иметь следующие форматы страниц:

· печатное поле (210х280 мм);

· горизонтальное размещение - 10 символов на 25,4 мм;

· вертикальное размещение - 0,5; 1; 1,5; 2 строки на 25,4 мм.

1 вопрос.

Создание рабочей группы и ее внутренняя деятельность является первым этапом выбора сети.

Первый этап - выбор председателя созданной рабочей группы и ее внутренняя деятельность (без контактов с поставщиками).

Рабочая группа выбора сети должна включать не более трех специалистов, которые должны обладать высокой квалификацией в области ВТ, телефонной связи, коммуникаций общего назначения.

Функциями рабочей группы на первом этапе являются:

1. Составление плана проводимых мероприятий и сроков их исполнения.

2. Составление перечня требований, которым должна удовлетворять сеть.

3. Составление списка фирм поставщиков.

4. Подготовка перечня предложений.

План проводимых мероприятий составляется на все четыре этапа выбора. При составлении плана необходимо учитывать, что желательное соотношение между этапами должно быть как 2,5:1:1:1.

Перечень требований, которым должна удовлетворять сеть, обычно является ответами на следующие вопросы:

1. Сколько помещений должно обслуживаться сетью?

2. Какое ожидается взаимодействие между этими территориями?

3. В каком виде информация должна передаваться между подразделениями: изображения, речевая информация, данные, текст и т.д?

4. Для каждой пары помещений:

а) каков объем ежедневной порции передаваемой информации?

б) в течении какого периода должно поддерживаться интерактивное взаимодействие?

в) каков объем данных, передаваемых в интерактивном режиме?

5. Существуют ли особые требования к передаче данных (малая задержка ответа, детерминированное время передачи)?

6. Необходима ли связь с глобальными системами?

Третьей функцией групп является составление списка фирм-поставщиков ЛВС. Далее возможный список сужается до 3-4-х на основе анализа ответов по следующим критериям:

1. Насколько высок авторитет поставщика среди специалистов в области передачи данных?

2. Может ли поставщик сопровождать свой продукт собственными силами или через посредников?

3. Насколько охотно поставщики вступают в контакт?

4. В какой мере поставщик готов выполнить все сформулированные требования, особенно наиболее трудные (организацию шлюзов, высокая надежность и др.)

На 4-ом шаге первого этапа выполняется подготовка проекта ориентировочного перечня предложений поставщиков. Это необходимо для упрощения дальнейшей работы с поставщиками.

В перечне указывается, что поступающие от поставщиков предложения должны быть оформлены как ответы, например, по следующим разделам:

1. Общая часть.

2. Прокладка кабелей и передача данных.

3. Интерфейсы с устройствами.

4. Алгоритм доступа к каналу.

5. Мосты.

6. Шлюзы.

7. Управление сетью.

8. Стратегия развития.

В разделе 1 должен приводиться подробный обзор предлагаемой сети, а также результаты внедрения сети в других организациях.

В разделе 2 определена необходимость к типу кабеля, который требуется при установке предлагаемой сети.

В разделе 3 определяется какие устройства могут быть подключены к сети.

В разделе 4 указывается какой алгоритм доступа к каналу может реализовать сеть.

В разделе 5 определяется каким образом возможно в условиях данной сети реализовать связь между ЛВС на различных территориях с помощью мостов.

В разделе 6 содержится информация о том, каким образом предлагаемая сеть позволяет осуществить связь с разнотипными ЭВМ или сетями при помощи шлюзов.

В разделе 7 включены вопросы по управлению сетью и ее обслуживанию, помогающие рабочей группе распределить ответственность за управление сетью и установить требуемую численность обслуживающего персонала.

В разделе 8 поставщик излагает свои представления о будущих сетевых разработках фирмы. Эта информация обычно сопоставляется с собственными планами фирмы-заказщика.

Сформировав план работы, а также определив требования к сети и потенциальным поставщикам и составив проект предложений, рабочая группа начинает непосредственно взаимодействовать с поставщиками.

2 вопрос.

Вторым этапом выбора ЛВС является взаимодействие с поставщиками.

Взаимодействие с поставщиками включает короткие совещания, демонстрации и заканчивается получением предложений поставщика. На этом этапе представителю фирмы-поставщика представляют требования, которые предъявляются к будущей сети и проект предложений. В процессе взаимодействия часто выясняется, что предложения поставщиков более скромные, нежели требования, предъявляемые заказчиком.

Наличие ряда конкурентных предложений, каждое из которых полностью не удовлетворяет требованиям заказчика, требует оценки предложений.

3 вопрос.

Оценка предложений.

Таблица 7.1

ПРИМЕР СОПОСТАВЛЕНИЯ ПРЕДЛОЖЕНИЙ

В табл.7.1 приведен ряд предложений поставщиков согласно требованиям, которые могут быть предъявлены заказчиком(см. табл. 7.1).

Как видно из табл.7.1 ни одно предложение не опережает остальные по всем показателям. В приведенном примере предложение 2 наилучшее по Основным требованиям, предложение 3 - по Дополнительным требованиям, предложение 1 - по Стоимости.

Поэтому, выбор будет зависеть от того, что наиболее важно для конкретного пользователя.

Традиционный подход к оценке предложений заключается в следующем.

На первом этапе вводятся количественные оценки предложений по всем параметрам (критериям) сравнения (табл. 7.2). При этом оцениваются только элементарные критерии (параметры, имеющие непосредственные значения).

Таблица 7.2

ОЦЕНКИ ПРЕДЛОЖЕНИЙ

В отличие от количественной оценки предложений, важность критериев для конкретного заказчика определяется как по групповым (Основные требования, Дополнительные требования, Стоимость), так и по элементарным критериям. Для расчета весовых коэффициентов важности критериев необходим экспертный опрос. Для этой цели привлекается 8-12 экспертов.

Каждый эксперт заполняет таблицу, графы которой соответствуют критериям оценки, а строки содержат значения их важности для конкретного заказчика.

Оценка критериев должна производиться путем их ранжирования, которое заключается в расположении объектов в пронумерованной последовательности в соответствии с убыванием важности критериев (значение ранга "1" должен иметь критерий с максимальной важностью).

Результаты ранжирования критериев представлены в табл.7.3-7.6.

Таблица 7.6

Таблица 7.3

Таблица 7.4

Таблица 7.5

На основе результатов ранжирования определяются веса критериев оценки Wi по следующему алгоритму.

Вычисляется сумма рангов для каждого критерия Ri

Ri=åRki

где Rki - ранг, поставленный i-му критерию k-ым экспертом; RÎ1, k - количество экспертов.

2. Выбирается наименьшее значение Ri = Rmin и рассчитываются вспомогательные величины

Результат вычислений в таблицах 7.7-7.9 является количественной оценкой групповых критериев "Основные требования", "Дополнительные требования" и "Стоимость".

Таблица 7.7

Эффективность предложений по критерию "Основные требования"

Таблица 7.8

Эффективность предложений по критерию "Дополнительные требования"

Таблица 7.9

Эффективность предложений по критерию "Стоимость"

На последнем этапе рассчитывается эффективность каждого предложения по всем критериям (табл. 7.10), как сумма произведений полученной оценки на важность соответствующего класса критерия (табл. 7.3).

Таблица 7.10

Эффективность предложений по всем критериям

· наиболее

· выигрышное

· предложение

Как следует из табл. 7.10 наилучшим предложением является 2, имеющее общую оценку 0,5. Именно это предложение и должно быть рекомендовано для внедрения.

Тема 8. Надёжность и безопасность в ЛВС

1 вопрос.

Наряду с повышением производительности ЛВС первоочередными являются задачи обеспечения надежности сети. Основными причинами, влияющими на бесперебойную работу ЛВС, являются:

Сбои оборудования, вызванные:

· нарушениями работы сетевого кабеля;

· отключением электропитания;

· отказом дисковых систем и систем архивации данных;

· нарушением работы серверов, рабочих станций.

Некорректная работа программного обеспечения (ПО), приводящая к потере или порче данных из-за:

· ошибок в прикладном или сетевом ПО;

· заражения систем компьютерными вирусами.

Несанкционированный доступ, копирование или изменение информации (случайные или умышленные), приводящие к:

· искажению, либо уничтожению данных;

· ознакомлению посторонних лиц с информацией, составляющей тайну.

Ошибки обслуживающего персонала.

Универсального решения, исключающего все перечисленные причины, нет. Однако разработаны и применяются технические средства и административные меры, позволяющие риск потери данных или несанкционированного доступа свести к минимуму.

2 вопрос.

Средства мониторинга ЛВС и обнаружения в ее работе “узких мест” можно подразделить на два основных класса: стратегические и тактические.

Назначение стратегических средств состоит в контроле за параметрами функционирования всей сети и решения проблем конфигурирования ЛВС.

Назначение тактических средств — мониторинг и устранение неисправностей сетевых устройств и сетевого кабеля.

К стратегическим средствам относятся:

· системы управления сетью;

· встроенные системы диагностики;

· распределенные системы мониторинга;

· средства диагностики серверов.

К тактическим средствам относят различные виды тестирующих устройств (тестеры и сканеры сетевого кабеля), а также устройства для комплексного анализа работы сети - анализаторы протоколов.

Тестирующие устройства помогают администратору обнаружить неисправности сетевого кабеля и разъёмов, а анализаторы протоколов — получать информацию об обмене данными в сети. Кроме того, к этой категории средств относят специальное ПО, позволяющее в режиме реального времени получать подробные отчеты о состоянии работы ЛВС.

3 вопрос.

Причину и место повреждения кабельной системы позволяют установить сканеры сетевого кабеля. Наиболее универсальными являются сканеры фирмы Microtest, с помощью которых можно тестировать основные виды сетевых кабелей следующих стандартов:

IEEE 802.3 Ethernet (10BASE-5 — толстый кабель, 10BASE-2 — тонкий кабель, 10BASE-T — витая пара);

IEEE 802.4 Arcnet

IEEE 802.5 Token Ring.

Надежность кабельной системы зависит и от качества самого сетевого кабеля. В соответствии с международным стандартом ANSI/EIA/TIA -568 в современных ЛВС рекомендуется использовать сетевые кабели 3-х уровней (кабель уровня 1 — телефонный, уровня 2 — используется для передачи малых объемов данных с небольшой скоростью).

4 вопрос.

В настоящее время наиболее надежным средством предотвращения потерь информации является установка источников бесперебойного питания. На российском рынке наибольшее распространение получили источники бесперебойного питания фирмы American Power Conversion (APC). Такие мощные модели, как Smart-UPS 2000 фирмы APC, поддерживают работу ПК в течение 3-4 часов после отключения электроэнергии.

За рубежом крупные компании устанавливают резервные линии электропитания, подключенные к разным подстанциям, и при выходе из строя одной из них, электричество подается с другой.

5 вопрос.

Согласно исследованиям, проведенным в США, при полной потери информации на магнитных носителях вследствие сбоя компьютерной системы в первые три дня, из общего числа потерпевших объявляют о своем банкротстве 60% фирм и в течение года — 90% из оставшихся. В России пока не существует полностью безбумажных технологий и последствия сбоя не будут столь трагическими. Однако системам восстановления данных уделяется достаточно большое внимание.

В настоящее время для восстановления данных при сбоях применяется два способа:

· использование дублирующих друг друга зеркальных дисков;

· организация надежной и эффективной системы архивации.

Использование зеркальных дисков иначе называют RAID - архитектурой (Redundant Arrays of Inexpensive Disks), которая предусматривает хранение избыточной информации (Parity), используемой для быстрого восстановления данных при сбое любого из дисков. Для реализации Raid - архитектуры используется специальная плата Raid - контроллера, соединяющего с помощью специального интерфейса с МД и снабженного специальной системой диагностики контроля данных, а также быстрого восстановления данных после сбоя. В производстве Raid - контроллеров лидирующее положение занимают фирмы Micropolis, Dynatek.

Организация надежной и эффективной системы архивации — еще одна важная задача по обеспечению сохранности информации в сети. В больших ЛВС для организации резервного копирования используют специализированный архивационный сервер. Одной из наиболее эффективных аппаратных систем является семейство архивационных серверов Storage Express фирмы Intel.

Сервер Storage Express подключается непосредственно к сетевому кабелю и служит для архивации данных, поступающих с любого из сетевых серверов и рабочих станций. При архивации выполняется двукратное сжатие данных. Соответствующее сетевое ПО — пакет Central Console — позволяет администратору управлять режимом копирования.

6 вопрос.

Особую опасность работе сети представляют компьютерные вирусы. По оценке специалистов инженерного корпуса армии США, при обнаружении и уничтожении в вычислительных сетях военного ведомства вируса “Сатанинский жук” затраты составляли 12000$ в час. Наиболее часто для борьбы с компьютерными вирусами применяются антивирусные программы, реже аппаратные средства.

Одним из самых мощных программных средств защиты от вирусов в ЛВС является ПО LANDest Visus Protect фирмы Intel, базирующееся на сетевом сервере. Устанавливаемая на рабочих станциях резидентная программа занимает всего 4 Кбайта. Сканирование файлов происходит в режиме реального времени. При обнаружении вируса LANDest Visus Protect в автоматическом режиме регулярно связывается со специальной BBS фирмы Intel, откуда получает информацию о шаблонах новых вирусов.

Вероятность занесения компьютерного вируса снижает применение бездисковых рабочих станций, особенно без НГМД.

7 вопрос.

Распространенным средством ограничения доступа в ЛВС является система паролей. Однако оно ненадежно, так как такую защиту достаточно легко взломать, либо подсмотреть пароль, либо войти в систему путем перебора паролей. Более надежное решение состоит в организации контроля доступа в помещения или к конкретному компьютеру в ЛВС с помощью различных видов идентификационных пластиковых карточек. Существует два вида карточек:

· с магнитной полосой;

· микропроцессорные карточки.

Использование карточек с магнитной полосой нецелесообразно, так как имея недорогое считывающее устройство для перенесения информации на “чистую” карточку, ее можно легко подделать.

Более высокую надежность имеют микропроцессорные карточки. Их надежность обусловлена в первую очередь невозможностью копирования или подделки кустарным способом. Установка специального считывающего устройства МП-карточек возможна не только на входе в помещение, где расположены компьютеры, но и на рабочих станциях и серверах ЛВС. Стоимость изготовления таких карточек составляет 4-6 $ (карточек с магнитной полосой 0,3-0,5$), а стоимость устройства считывания — порядка 150 - 200$.

8 вопрос.

Для предотвращения ознакомления с компьютерной информацией лиц, не имеющих к ней доступа, чаще всего используется шифрование данных при помощи определенных ключей.

Существуют следующие виды шифрования:

Шифрование с помощью личных ключей :

· подстановочные;

· перестановочные.

Стандарт шифрования данных.

Шифрование с ключами общего назначения.

Подстановочные методы шифрования:

Моноалфавитный. Суть — буквы алфавита заменяются буквами другого алфавита.

Например : А Б В Г Д Ж З И К

ж з к л м н о п р

Полиалфавитный шифр. Предполагает использование множества шифрующих алфавитов, которые используются циклически. При этом используется ключ длинее, нежели исходный текст.

Перестановочные шифры. Суть перестановочных шифров заключается в том, что в слове (сообщении), полученном в результате шифрования, буквы остаются прежними, а меняется только порядок.

Пример. Слово “море” используется как ключ. Ключ использован для нумерации колонок. Колонка один помещается под ключом, буква которого ближе всего к началу алфавита. Исходный текст затем записывается как последовательность строк под ключом. Шифр далее читается по колонкам, начиная с колонки ключ которой наименьший в алфавите. Фраза “изучай шифры” размещается следующим образом:

м о р е

2 3 4 1

и з у ч

а й ш

и ф р ы

Получается следующая шифровка:

чшыиаизйфу р

в реальных сетях подстановочные и перестановочные методы шифрования используются одновременно. Причем при формировании шифрованных данных подстановка и перестановка могут использоваться неоднократно. Эта идея использована в стандарте шифрования данных (СШД), разработанным в 1977 году министерством торговли и Национальным бюро стандартов США.

Еще одним широко распространенным способом шифрования является шифрование данных с ключами общего назначения. Сеть способа заключается в том, что для шифрования данных используются два положительных простых числа Е и N. На основе Е и N можно вычислить D, которое используется для дешифрации текста в исходный.

Сейчас на рынке представлено большое разнообразие устройств шифрования данных. Приблизительно 50% всех устройств ориентировано на использование стандарта СШД, достаточно много используют ключи общего назначения.

Процесс шифрования выполняется на уровне представления данных.

Сравнительная характеристика методов шифрования представлена в таблице 8.1.

Таблица 8.1

Сравнительная характеристика методов шифрования

Параметры сравнений | Наименование метода
 | DES | ГОСТ 28147-89 | RSA
Длина ключа | 56 бит | 256 бит | 300-600 бит
Скорость шифрования | 10-20 Кбайт/с | 50-70 Кбайт/с | 300-500 Кбайт/с
Криптостойкость операции | 1017 | 1017 | 1023
Реализация | программная и аппаратная | в основном аппаратная | программная и аппаратная

9 вопрос.

Для обеспечения надежной и безопасной работы сложных ЛВС необходимо комплексное применение всех мер безопасности с учетом специфики задач конкретной организации.

Согласно обследованию, проведенному DataPro Information Service Group в 1992 году среди 1153 американских и канадских фирм, использующих ЛВС на базе ПК с числом пользователей от 20 до 500, наиболее часто (84% всех фирм) для обеспечения безопасности применяются антивирусные программы. Значительно реже используются более дорогие виды защиты — автоматическое резервное копирование (27%), контроль доступа (27%) и шифрование данных (22%).

Приведенные цифры являются средними, их значение может существенно колебаться, в зависимости от сферы применения ЛВС. На рис. 8.1 представлена сравнительная характеристика частоты использования средств безопасности данных в сетях Североамериканских банков.

Рис.8.1.

Тестирование


6_1_TKC

Услуги предоставляемые сетью

Все услуги предоставляемые сетью Internet можно условно поделить на две категории: обмен информацией между абонентами сети и использование баз данных сети.

К числу услуг связи между абонентами принадлежат.
Telnet - удаленный доступ. Дает возможность абоненту работать на любой ЭВМ сети Internet как на своей собственной. То есть запускать программы, менять режим работы и т.д.
NFS (Network File System) - распределенная файловая система. Дает возможность абоненту пользоваться файловой системой удаленного компьютера, как своей собственной.
Электронная почта - обмен почтовыми сообщениями с любым абонентом сети Internet. Существует возможность отправки как текстовых, так и двоичных файлов. На размер почтового сообщения в сети Internet накладывается следующее ограничение - размер почтового сообщения не должен превышать 64 килобайт.
Talk - дает возможность открытия "разговора" с пользователем удаленной ЭВМ. При этом на экране одновременно виден вводимый текст и ответ удаленного пользователя.
Iptunnel - дает возможность доступа к серверу ЛВС NetWare с которым нет непосредственной связи по ЛВС, а имеется лишь связь по сети Internet.
Whois - адресная книга сети Internet. По запросу абонент может получить информацию о принадлежности удаленного компьютера, о пользователях.
Finger - получение информации о пользователях удаленного компьютера.
Кроме вышеперечисленных услуг, сеть Internet предоставляет также следующие специфические услуги.

К системам автоматизированного поиска информации в сети Internet принадлежат следующие системы.

Gopher - наиболее широко распространенное средство поиска информации в сети Internet, позволяющее находить информацию по ключевым словам и фразам. Работа с системой Gopher напоминает просмотр оглавления, при этом пользователю предлагается пройти сквозь ряд вложенных меню и выбрать нужную тему. В Internet в настоящее время свыше 2000 Gopher-систем, часть из которых является узкоспециализированной, а часть содержит более разностороннюю информацию.

WAIS - еще более мощное средство получения информации, чем Gopher, поскольку оно осуществляет поиск ключевых слов во всех текстах документов. Запросы посылаются в WAIS на упрощенном английском языке. Это значительно легче, чем формулировать их на языке алгебры логики, и это делает WAIS более привлекательной для пользователей-непрофессионалов .

WWW - система для работы с гипертекстом. Потенциально она является наиболее мощным средством поиска. Гипертекст соединяет различные документы на основе заранее заданного набора слов. Например, когда в тексте встречается новое слово или понятие, система, работающая с гипертекстом, дает возможность перейти к другому документу, в котором это слово или понятие рассматривается более подробно.

Естественная потребность людей высказаться в толпу, обратиться с просьбой ко всем сразу, быть услышанным, самому услышать чужой призыв и тут же откликнуться на него, встрять в спор, такая интереснейшая Интернет-служба как USENET NEWS. По- русски она называется телеконференцией.

Телеконференции (группы новостей)представляют собой сборники коротких статей, заметок(news articles) на определенную тему. Телеконференции заводятся по иерархическому принципу.Это отражается в их многосложных названиях , напоминающих по виду доменные адреса:части названия отделяются точками, слова более старшего уровня стоят слева. По ним можно догадаться, какова направленность данной телеконференции, на какую страну и какой язык она ориентированна. Или с какой компанией, с какой сетью данная иерархия связана.Если слева стоят слова RELCOM, FIDO7, или MICROSOFT, то говорят, что данная конференция относится к иерархии RELCOM, FIDO7 или MICROSOFT.

Заключение.

Вот что такое услуги Интернет, если взглянуть на него поверх паутины проводов и вычислительных машин. Понятно,что существование в этой среде, насыщенной информацией и пронизанной коммуникационными связями, будет комфортным и доставит массу приятных ощущений и радостных открытий только при выполнении определенных условий.А именно, надо представлять строение этой среды, понимать принципы, по которым она организованна, законы которыми она управляется. Тогда можно извлечь максимальную пользу от выхода во внешний мир и в значительной мере оправдать затраты на подключение Интернет.

Тестирование


Содержание:

Введение: компьютерные сети.

Локальная сеть представляет собой набор компьютеров, периферийных устройств (принтеров и т. п.) и коммутационных устройств, соединенных кабелями. В качестве кабеля используются «толстый» коаксиальный кабель, «тонкий» коаксиальный кабель, витая пара, волоконно-оптический кабель. «Толстый» кабель, в основном, используется на участках большой протяженности при требованиях высокой пропускной способности. Волоконно-оптический кабель позволяет создавать протяженные участки без ретрансляторов при недостижимой с помощью других кабелей скорости и надежности. Однако стоимость кабельной сети на его основе высока, и поэтому он не нашел пока широкого распространения в локальных сетях. В основном локальные компьютерные сети создаются на базе «тонкого» кабеля или витой пары.

Первоначально сети создавались по принципу "тонкого" Ethernet. В основе его — несколько компьютеров с сетевыми адаптерами, соединенные последовательно коаксиальным кабелем, причем все сетевые адаптеры выдают свой сигнал на него одновременно. Недостатки этого принципа выявились позже.

С ростом размеров сетей параллельная работа многих компьютеров на одну единую шину стала практически невозможной: очень велики стали взаимные влияния друг на друга. Случайные выходы из строя коаксиального кабеля (например, внутренний обрыв жилы) надолго выводили всю сеть из строя. А определить место обрыва или возникновения программной неисправности, "заткнувшей" сеть, становилось практически невозможно.

Поэтому дальнейшее развитие компьютерных сетей происходит на принципах структурирования. В этом случае каждая сеть складывается из набора взаимосвязанных участков — структур.

Каждая отдельная структура представляет собой несколько компьютеров с сетевыми адаптерами, каждый из которых соединен отдельным проводом — витой парой — с коммутатором. При необходимости развития к сети просто добавляют новую структуру.

При построении сети по принципу витой пары можно проложить больше кабелей, чем установлено в настоящий момент компьютеров. Кабель проводится не только на каждое рабочее место, независимо от того, нужен он сегодня его владельцу или нет, но даже и туда, где сегодня рабочего места нет, но возможно появление в будущем. Переезд или подключение нового пользователя в итоге потребует лишь изменения коммутации на одной или нескольких панелях.

Структурированная система несколько дороже традиционной сети за счет значительной избыточности при проектировании. Но зато она обеспечивает возможность эксплуатации в течение многих лет.

Локальные сети.

Подавляющая часть компьютеров западного мира объединена в ту или иную сеть. Опыт эксплуатации сетей показывает, что около 80% всей пересылаемой по сети информации замыкается в рамках одного офиса. Поэтому особое внимание разработчиков стали привлекать так называемые локальные вычислительные сети (LAN). Локальные вычислительные сети отличаются от других сетей тем, что они обычно ограничены умеренной географической областью (одна комната, одно здание, один район).

Существует два типа компьютерных сетей: одноранговые сети и сети с выделенным сервером. Одноранговые сети не предусматривают выделение специальных компьютеров, организующих работу сети. Каждый пользователь, подключаясь к сети, выделяет в сеть какие-либо ресурсы (дисковое пространство, принтеры) и подключается к ресурсам, предоставленным в сеть другими пользователями. Такие сети просты в установке, налаживании; они существенно дешевле сетей с выделенным сервером. В свою очередь сети с выделенным сервером, несмотря на сложность настройки и относительную дороговизну, позволяют осуществлять централизованное управление.

Глобальные сети.

Для подключения к удаленным компьютерным сетям используются телефонные линии.

Процесс передачи данных по телефонным линиям должен происходить в форме электрических колебаний - аналога звукового сигнала, в то время как в компьютере информация хранится в виде кодов. Для того чтобы передать информацию от компьютера через телефонную линию, коды должны быть преобразованы в электрические колебания. Этот процесс носит название модуляции. Для того чтобы адресат смог прочитать на своем компьютере то, что ему отправлено, электрические колебания должны быть обратно превращены в машинные коды - демодуляция. Устройство, которое осуществляет преобразование данных из цифровой формы, в которой они хранятся в компьютере в аналоговую (электрические колебания), в которой они могут быть преданы по телефонной линии, и обратно называется модем (сокращенно от МОдулятор-ДЕМодулятор). Компьютер в этом случае должен иметь специальную телекоммуникационную программу, которая управляет модемом, а также отправляет и получает последовательности сигналов передаваемой информации.

Что такое Internet?

История сети Internet.

В 1961 году Defence Advanced Research Agency (DARPA) по заданию министерства обороны США приступило к проекту по созданию экспериментальной сети передачи пакетов. Эта сеть, названная ARPANET, предназначалась первоначально для изучения методов обеспечения надежной связи между компьютерами различных типов. Многие методы передачи данных через модемы были разработаны в ARPANET. Тогда же были разработаны и протоколы передачи данных в сети - TCP/IP. TCP/IP - это множество коммуникационных протоколов, которые определяют, как компьютеры различных типов могут общаться между собой.

Эксперимент с ARPANET был настолько успешен, что многие организации захотели войти в нее, с целью использования для ежедневной передачи данных. И в 1975 году ARPANET превратилась из экспериментальной сети в рабочую сеть. Ответственность за администрирование сети взяло на себя Defence Communication Agency (DCA), в настоящее время называемое Defence Information Systems Agency (DISA). Но развитие ARPANET на этом не остановилось; Протоколы TCP/IP продолжали развиваться и совершенствоваться.

В 1983 году вышел первый стандарт для протоколов TCP/IP, вошедший в Military Standards (MIL STD), т.е. в военные стандарты, и все, кто работал в сети, обязаны были перейти к этим новым протоколам. Для облегчения этого перехода DARPA обратилась с предложением к руководителям фирмы Berkley Software Design - внедрить протоколы TCP/IP в Berkley (BSD) UNIX. С этого и начался союз UNIX и TCP/IP.

Спустя некоторое время TCP/IP был адаптирован в обычный, то есть в общедоступный стандарт, и термин Internet вошел во всеобщее употребление. В 1983 году из ARPANET выделилась MILNET, которая стала относиться к Defence Data Network (DDN) министерства обороны США. Термин Internet стал использоваться для обозначения единой сети: MILNET плюс ARPANET. И хотя в 1991 году ARPANET прекратила свое существование, сеть Internet существует, ее размеры намного превышают первоначальные, так как она объединила множество сетей во всем мире. Рисунок 1 иллюстрирует рост числа хостов, подключенных к сети Internet с 4 компьютеров в 1969 году до 3,2 миллионов в 1994. Хостом в сети Internet называются компьютеры, работающие в многозадачной операционной системе (Unix, VMS), поддерживающие протоколы TCP\IP и предоставляющие пользователям какие-либо сетевые услуги.

Рисунок 1. Рост числа хостов, подключенных к сети Internet.

Из чего состоит Internet?

Это довольно сложный вопрос, ответ на который всё время меняется. Пять лет назад ответ был прост: Internet – это все сети, которые, взаимодействуя с помощью протокола IP, образуют «бесшовную» сеть для своих коллективных пользователей. Сюда относятся различные федеральные сети, совокупность региональных сетей, университетские сети и некоторые зарубежные сети.

В последнее время появилась заинтересованность в подсоединении к Internet сетей, которые не используют протокол IP. Для того чтобы предоставлять клиентам этих сетей услуги Internet, были разработаны методы подключения этих «чужих» сетей (например, BITNET, DECnets и др.) к Internet. Сначала эти подключения, названные шлюзами, предназначались просто для пересылки электронной почты между двумя сетями, но некоторые из них выросли до возможности обеспечения и других услуг на межсетевой основе. Являются ли они частью Internet? И да и нет – всё зависит от того, хотят ли они того сами.

В настоящее время в сети Internet используются практически все известные линии связи от низкоскоростных телефонных линий до высокоскоростных цифровых спутниковых каналов. Операционные системы, используемые в сети Internet, также отличаются разнообразием. Большинство компьютеров сети Internet работают под ОС Unix или VMS. Широко представлены также специальные маршрутизаторы сети типа NetBlazer или Cisco, чья ОС напоминает ОС Unix.

Фактически Internet состоит из множества локальных и глобальных сетей, принадлежащих различным компаниям и предприятиям, связанных между собой различными линиями связи. Internet можно представить себе в виде мозаики сложенной из небольших сетей разной величины, которые активно взаимодействуют одна с другой, пересылая файлы, сообщения и т.п.

Кто управляет Internet?

Во многих отношениях Internet похожа на религиозную организацию: в ней есть совет старейшин, каждый пользователь сети может иметь своё мнение о принципах её работы и принимать участие в управлении сетью. В Internet нет ни президента, ни главного инженера, ни Папы. Президенты и прочие 1целом же в Internet нет единственной авторитарной фигуры.

Направление развития Internet в основном определяет «Общество Internet», или ISOC (Internet Society). ISOC – это организация на общественных началах, целью которой является содействие глобальному информационному обмену через Internet. Она назначает совет старейшин, который отвечает за техническое руководство и ориентацию Internet.

Совет старейшин IAB (Internet Architecture Board или «Совет по архитектуре Internet») представляет собой группу приглашённых лиц, которые добровольно изъявили принять участие в его работе. IAB регулярно собирается, чтобы утверждать стандарты и распределять ресурсы (например, адреса). Internet работает благодаря наличию стандартных способов взаимодействия компьютеров и прикладных программ друг с другом. Наличие таких стандартов позволяет без проблем связывать между собой компьютеры производства разных фирм. IAB несёт ответственность за эти стандарты, решает, нужен ли тот или иной стандарт и каким он должен быть. Если возникает необходимость в каком-нибудь стандарте, IAB рассматривает проблему, принимает этот стандарт и объявляет об этом по сети. Кроме того, IAB следит за разного рода номерами (и другими вещами), которые должны оставаться уникальными. Например, каждый компьютер Internet имеет свой уникальный 32-х разрядный адрес; такого адреса больше ни у одного компьютера нет. Как присваивается этот адрес, решает IAB. Точнее, сам этот орган присвоением адресов не занимается, он устанавливает правила присвоения адресов.

У каждого пользователя в Internet имеется своё мнение относительно того, как должна функционировать сеть. Пользователи Internet выражают свои мнения на заседаниях инженерной комиссии IETF (Internet Engineering Task Force). IETF – ещё один общественный орган; он собирается регулярно для обсуждения текущих технических и организационных проблем Internet. Если возникает достаточно важная проблема, IETF формирует рабочую группу для дальнейшего её изучения. (На практике «достаточно важная» означает, как правило, что находится достаточно добровольцев для создания рабочей группы.) Посещать заседания IETF и входить в состав рабочих групп может любой; важно, чтобы он работал. Рабочие группы выполняют много различных функций – от выпуска документации и принятия решений о том, как сети должны взаимодействовать между собой в специфических ситуациях, до изменения значений битов в определённом стандарте. Рабочая группа обычно составляет доклад. Это может быть либо предоставляемая всем желающим документация с рекомендациями, которым следовать не обязательно, либо предложение, которое направляется в IAB для принятия в качестве стандарта.

Кто платит?

Старое правило для запутанных ситуаций гласит: «ищите денежный интерес». Это правило, однако не годится для Internet. Никто за неё не платит; нет никакой компании Internet, Inc. или другой, подобной ей, которая бы собирала со всех пользователей Internet взносы. Здесь каждый платит за свою часть. Национальный научный фонд платит за NSFNET, НАСА – за NASA Science Internet т т.д. Представители сетей собираются и решают, как соединяться и как финансировать эти взаимные соединения. Колледж или корпорация платит за подключение к региональной сети, которая, в свою очередь, платит за доступ к Internet поставщику на уровне государства.

То, что Internet – бесплатная сеть, не более чем миф. Каждое подключение к ней кем-то оплачивается. Во многих случаях эти взносы не доводятся до фактических пользователей, что создает иллюзию «бесплатного доступа». Но есть и большое число пользователей, которые хорошо знают, что Internet не бесплатная сеть: многие пользователь вносят ежемесячную или почасовую плату за доступ к Internet с домашних компьютеров по линиям со скоростью до 56 Кбайт в секунду (так же, как в базовых сетях). В настоящее время наиболее быстро растёт число пользователей Internet, относящихся к таким категориям, как малые предприятия и частные лица, а они очень хорошо знают цену своим деньгам.

Протоколы сети Internet.

Основное, что отличает Internet от других сетей - это ее протоколы - TCP/IP. Вообще, термин TCP/IP обычно означает все, что связано с протоколами взаимодействия между компьютерами в Internet. Он охватывает целое семейство протоколов, прикладные программы, и даже саму сеть. TCP/IP - это технология межсетевого взаимодействия, технология Internet. Сеть, которая использует технологию internet, называется "internet". Если речь идет о глобальной сети, объединяющей множество сетей с технологией internet, то ее называют Internet.

Свое название протокол TCP/IP получил от двух коммуникационных протоколов (или протоколов связи). Это Transmission Control Protocol (TCP) и Internet Protocol (IP). Несмотря на то, что в сети Internet используется большое число других протоколов, сеть Internet часто называют TCP/IP-сетью, так как эти два протокола, безусловно, являются важнейшими.

Как и во всякой другой сети в Internet существует 7 уровней взаимодействия между компьютерами: физический, логический, сетевой, транспортный, уровень сеансов связи, представительский и прикладной уровень. Соответственно каждому уровню взаимодействия соответствует набор протоколов (т.е. правил взаимодействия).

Протоколы физического уровня определяют вид и характеристики линий связи между компьютерами. В Internet используются практически все известные в настоящее время способы связи от простого провода (витая пара) до волоконно-оптических линий связи (ВОЛС).

Для каждого типа линий связи разработан соответствующий протокол логического уровня, занимающийся управлением передачей информации по каналу. К протоколам логического уровня для телефонных линий относятся протоколы SLIP (Serial Line Interface Protocol) и PPP (Point to Point Protocol). Для связи по кабелю локальной сети - это пакетные драйверы плат ЛВС.

Протоколы сетевого уровня отвечают за передачу данных между устройствами в разных сетях, то есть занимаются маршрутизацией пакетов в сети. К протоколам сетевого уровня принадлежат IP (Internet Protocol) и ARP (Address Resolution Protocol).

Протоколы транспортного уровня управляют передачей данных из одной программы в другую. К протоколам транспортного уровня принадлежат TCP (Transmission Control Protocol) и UDP (User Datagram Protocol).

Протоколы уровня сеансов связи отвечают за установку, поддержание и уничтожение соответствующих каналов. В Internet этим занимаются уже упомянутые TCP и UDP протоколы, а также протокол UUCP (Unix to Unix Copy Protocol).

Протоколы представительского уровня занимаются обслуживанием прикладных программ. К программам представительского уровня принадлежат программы, запускаемые, к примеру, на Unix-сервере, для предоставления различных услуг абонентам. К таким программам относятся: telnet-сервер, FTP-сервер, Gopher-сервер, NFS-сервер, NNTP (Net News Transfer Protocol), SMTP (Simple Mail Transfer Protocol), POP2 и POP3 (Post Office Protocol) и т.д. К протоколам прикладного уровня относятся сетевые услуги и программы их предоставления.

О том, как работает Internet.

Перемещая биты с одного места на другое.

Современные сети создаются по многоуровневому принципу. Передача сообщений в виде последовательности битов начинается на уровне линий связи и аппаратуры, причём линии связи не всегда высокого качества. Затем добавляется уровень базового программного обеспечения, управляющего работой аппаратуры. Следующий уровень программного обеспечения позволяет наделить базовые программные средства дополнительными необходимыми возможностями. Расширение функциональных возможностей сети путём добавления уровня за уровнем приводит к тому, что Вы в конце концов получаете по-настоящему дружественный и полезный инструментарий.

Сети с коммутацией пакетов.

Когда Вы пытаетесь представить себе, что же такое Internet и как она работает, вполне естественно, что у Вас возникают ассоциации с телефонной сетью. В конце концов, обе эти структуры используют электронные средства передачи, обе позволяют устанавливать соединение и передавать информацию; кроме того, в Internet в основном используются выделенные телефонные линии. К сожалению, это неверное представление, и оно является причиной непонимания принципов работы Internet. Телефонная сеть – это сеть с коммутацией каналов. Когда Вы производите вызов, Вам выделяется некоторая часть это сети. Даже если Вы не используете ее (например, находитесь в режиме удержания), она остается недоступной для других абонентов, которым в этот момент нужно позвонить. Это приводит к тому, что такой дорогой ресурс, как сеть, используется неэффективно.

Более соответствующая действительному положению вещей модель Internet – почтовое ведомство США. Почтовое ведомство представляет собой сеть с коммутацией пакетов. Здесь у Вас нет выделенного участка сети. Ваша корреспонденция смешивается с другими письмами, отправляется в почтовое отделение и сортируется. Несмотря на то, что технологии абсолютно разные, служба доставки почты представляет собой удивительно точный аналог сети; мы будем продолжать пользоваться этой моделью во всех остальных разделах данной главы.

Межсетевой протокол (IP).

С помощью линий связи обеспечивается доставка данных из одного пункта в другой. Но Вы уже знаете, что Internet может доставлять данные во многие точки, разбросанные по всему земному шару. Как это происходит?

Различные участки Internet связываются с помощью системы компьютеров (называемых маршрутизаторами) соединяющих между собой сети. Это могут быть сети Internet, сети с маркерным доступом, телефонные линии (см. рис.2).

Рисунок 2. Аппаратные средства Internet.

Телефонные линии и сети Ethernet эквивалентны автомобилям и самолетам службы доставки почты. Маршрутизаторы – это почтовые подстанции; они принимают решения о том, куда направлять данные («пакеты»), так же, как почтовая подстанция решает, куда направлять конверты с почтой. Каждая подстанция, или маршрутизатор, не имеет связи с остальными станциями. Если Вы опустили письмо в почтовый ящик в Нью-Хэмпшире, а адресат живет в Калифорнии, то местное почтовое отделение не будет бронировать самолет, чтобы доставить Ваше письмо в Калифорнию. Местное почтовое отделение посылает письмо на подстанцию, подстанция посылает его на другую подстанцию и так далее, пока письмо не дойдет до адресата. Таким образом, каждой подстанции нужно знать только, какие имеются соединения и какой из «следующих скачков» будет лучшим для перемещения пакета ближе к пункту назначения. Похожая ситуация складывается и в Internet: маршрутизатор смотрит, куда адресованы Ваши данные, и решает, куда их посылать.

Откуда Internet знает, куда следует направить Ваши данные? Если Вы отправляете письмо, то, просто опустив его в почтовый ящик без конверта, Вы не можете рассчитывать, что корреспонденция будет доставлена по назначению. Письмо нужно вложить в конверт, написать на конверте адрес и наклеить марку. Точно так же, как почтовое отделение следует по правилам, которые определяют порядок работы почтовой сети, определенные правила регламентируют порядок работы Internet. Эти правила называют протоколами. Межсетевой протокол (Internet Protocol, IP) отвечает за адресацию, т.е. гарантирует, что маршрутизатор знает, что делать с Вашими данными, когда они поступят. Следуя нашей аналогии с почтовым ведомством, можно сказать, что межсетевой протокол выполняет функции конверта.

Некоторая адресная информация приводится в начале Вашего сообщения. Она даёт сети достаточно сведений для доставки пакета данных.

Internet - адреса состоят из четырёх чисел, каждое из которых не превышает 256. При записи числа отделяются одно от другого точками, например:

192.112.36.5

128.174.5.6

Адрес фактически состоит из нескольких частей. Поскольку Internet – это сеть сетей, то начало адреса содержит информацию для маршрутизаторов о том, к какой сети относится Ваш компьютер. Правая часть адреса служит для того, чтобы сообщить сети, какой компьютер должен получить этот пакет.[1] Каждый компьютер в Internet имеет свой уникальный адрес. Здесь нам опять поможет аналогия со службой доставки почты. Возьмем адрес «50 Kelly Road, Hamden, CT». Элемент «Hamden, CT» похож на адрес сети. Благодаря этому конверт попадает в необходимое почтовое отделение, то, которое знает об улицах в определенном районе. Элемент «Kelly Road» похож на адрес компьютера; он указывает на конкретный почтовый ящик в районе, который обслуживает данное почтовое отделение. Почтовое ведомство выполнило свою задачу, доставив почту в нужное местное отделение, а это отделение положило письмо в соответствующий почтовый ящик. Аналогичным образом, Internet выполнила свою задачу, когда ее маршрутизаторы направили данные в соответствующую сеть, а эта локальная сеть – в соответствующий компьютер.

По целому ряду технических причин (в основном это аппаратные ограничения) информация, посылаемая по IP- сетям, разбивается на порции, называемые пакетами. В одном пакете обычно посылается от одного до 1500 символов информации. Это не дает возможности одному пользователю монополизировать сеть, однако позволяет каждому рассчитывать на своевременное обслуживание. Это также означает, что в случае перегрузки сети качество ее работы несколько ухудшается для всех пользователей: она не умирает, если ее монополизировали несколько солидных пользователей.

Одно из достоинств Internet состоит в том, что для работы на базовом уровне достаточно только межсетевого протокола. Сеть будет не очень дружественной, но если Вы будете вести себя достаточно разумно, то решите свои задачи. Поскольку Ваши данные помещаются в IP- конверт, то сеть имеет всю информацию, необходимую для перемещения этого пакета из Вашего компьютера в пункт назначения. Здесь, однако, возникает сразу несколько проблем.

· Во-первых, в большинстве случаев объем пересылаемой информации превышает 1500 символов. Если бы почта принимала только открытки, Вас бы это, естественно, разочаровало.

· Во-вторых, может произойти ошибка. Почтовое ведомство иногда теряет письма, а сети иногда теряют пакеты или повреждают их при передаче. Вы увидите, что в отличие от почтовых отделений Internet успешно решает такие проблемы.

· В-третьих, последовательность доставки пакетов может быть нарушена. Если Вы послали по одному адресу одно за другим два письма, то нет никакой гарантии, что они пойдут по одному маршруту или придут в порядке их отправления. Такая же проблема существует и в Internet.

Поэтому следующий уровень сети даст нам возможность пересылать более крупные порции информации и позаботиться об устранении тех искажений, которые вносит сама сеть.

Протокол управления передачей (ТСР).

Для решения упомянутых выше проблем используется «протокол управления передачей» (Transmission Control Protocol, TCP), который часто упоминают вместе с протоколом IP. Как следовало бы поступить в случае, если Вы хотите послать кому-нибудь книгу, а почта принимает только письма? Выход один: вырвать из книги все страницы, вложить каждую в отдельный конверт и бросить все конверты в почтовый ящик. Получателю пришлось бы собирать все страницы (при условии, что ни одно письмо не пропало) и склеивать обратно в книгу. Вот эти задачи и выполняет ТСР.

Информацию, которую Вы хотите передать, ТСР разбивает на порции. Каждая порция нумеруется, чтобы можно было проверить, вся ли информация получена, и расположить данные в правильном порядке. Для передачи этого порядкового номера по сети у протокола есть свой собственный «конверт», на котором «написана» необходимая информация . Порция Ваших данных помещается в конверт ТСР. Конверт ТСР, в свою очередь, помещается в конверт IP и передается в сеть.

На принимающей стороне программное обеспечение протокола ТСР собирает конверты, извлекает из них данные и располагает их в правильном порядке. Если каких-нибудь конвертов нет, программа просит отправителя передать их еще раз. После размещения всей информации в правильном порядке эти данные передаются той прикладной программе, которая использует услуги ТСР.

Как сделать сеть дружественной?

Для этого необходимо настроить программное обеспечение на конкретную задачу и при обращении к компьютерам использовать не адреса, а имена.

Прикладные программы.

Большинство пользователей не испытывают интереса к потоку битов между компьютерами, какими бы скоростными не были линии и какой бы экзотической не была технология, которая позволила его получить. Они хотят быстро использовать этот поток битов для каких-то полезных задач, будь то перемещение файла, доступ к данным или просто игра. Прикладные программы – это части программного обеспечения, которые позволяют удовлетворить эти потребности. Такие программы составляют еще один уровень программного обеспечения, надстраиваемый над сервисом ТСР или UDP. Прикладные программы предоставляют пользователю средства для решения конкретной задачи.

Диапазон прикладных программ широк: от доморощенных до патентованных, поставляемых крупными фирмами-разработчиками. В Internet есть три стандартные прикладные программы (удаленный доступ, пересылка файлов и электронная почта), а также другие, широко используемые, но не стандартизированные программы. В главах 5-14 показано, как использовать самые распространенные прикладные программы Internet.

Когда речь идет о прикладных программах, следует учесть одну особенность: Вы воспринимаете прикладную программу так, как она выглядит в Вашей локальной системе. Команды, сообщения, приглашения и т.д., появляющиеся у Вас на экране, могут несколько отличаться от тех, которые Вы увидите в книге или на экране у своего друга. Не стоит волноваться, если в книге приводится сообщение «connection refused», а компьютер выдает «Unable to connect to remote host: refused»; это одно и то же. Не цепляйтесь к словам, а попытайтесь понять суть сообщения. Не беспокойтесь, если некоторые команды имеют другие имена; большинство прикладных программ снабжены достаточно солидными справочными подсистемами, которые помогут найти необходимую команду.

Доменная система имён.

Цифровые адреса – и это стало понятно очень скоро – хороши при общении компьютеров, а для людей предпочтительнее имена. Неудобно говорить, используя цифровые адреса, и ещё труднее запоминать их. Поэтому компьютерам в Internet присвоены имена. Все прикладные программы Internet позволяют использовать имена систем вместо числовых адресов компьютеров.

Конечно, использование имён имеет свои недостатки. Во-первых, нужно следить, чтобы одно и то же имя не было случайно присвоено двум компьютерам. Кроме того, необходимо обеспечить преобразование имён в числовые адреса, ведь имена хороши для людей, а компьютеры всё-таки предпочитают числа. Вы можете указать программе имя, но у неё должен быть способ поиска этого имени и преобразования его в адрес.

На этапе становления, когда Internet была маленькой общностью, использовать имена было легко. Центр сетевой информации (NIC) создавал специальную службу регистрации. Вы посылали заполненный бланк (конечно, электронными средствами), и NIC вносил Вас в свой список имён и адресов. Этот файл, называемый hosts (список узловых компьютеров), регулярно рассылался на все компьютеры сети. В качестве имён использовались простые слова, каждое из которых обязательно являлось уникальным. Когда Вы указывали имя, Ваш компьютер искал его в этом файле и подставлял соответствующий адрес.

Когда Internet разрослась, к сожалению, размер этого файла тоже увеличился. Стали возникать значительные задержки при регистрации имён, поиск уникальных имён усложнился. Кроме того, на рассылку этого большого файла на все указанные в нём компьютеры уходило много сетевого времени. Стало очевидно, что такие темпы роста требуют наличия распределённой интерактивной системы. Эта система называется «доменной системой имён» (Domain Name System, DNS).

Структура доменной системы.

Доменная система имён представляет собой метод назначения имён путём возложения на разные группы пользователей ответственности за подмножества имён. Каждый уровень в этой системе называется доменом. Домены отделяются один от другого точками:

ux.cso.uiuc.edu

nic.ddn.mil

yoyodyne.com

В имени может быть любое число доменов, но более пяти встречается редко. Каждый последующий домен в имени (если смотреть слева направо) больше предыдущего. В имени ux.cso.uiuc.edu элемент ux – имя реального компьютера с IP - адресом. (См. рисунок).

Рисунок 3. Структура доменного имени.

Имя этого компьютера создано и курируется группой cso, которая есть не что иное, как отдел, в котором стоит этот компьютер. Отдел cso является отделом университета штата Иллинойс (uiuc). uiuc входит в национальную группу учебных заведений (edu). Таким образом, домен edu включает в себя все компьютеры учебных заведений США; домен uiuc.edu – все компьютеры университета штата Иллинойс и т.д.

Каждая группа может создавать и изменять все имена, находящиеся под её контролем. Если uiuc решит создать новую группу и назвать её ncsa, она может ни у кого не спрашивать разрешения. Всё, что нужно сделать – это добавить новое имя в свою часть всемирной базы данных, и рано или поздно тот, кому нужно, узнает об этом имени (ncsa.uius.edu). Аналогичным образом cso может купить новый компьютер, присвоить ему имя и включить в сеть, не спрашивая ни у кого разрешения. Если все группы, начиная с edu и ниже, будут соблюдать правила, и обеспечивать уникальность имён, то никакие две системы в Internet не будут иметь одинакового имени. У Вас могут быть два компьютера с именем fred, но лишь при условии, что они находятся в разных доменах (например, fred.cso.uiuc.edu и fred.ora.com).

Легко узнать, откуда берутся домены и имена в организации типа университета или предприятия. Но откуда берутся домены «верхнего уровня» типа edu? Они были созданы, когда была изобретена доменная система. Изначально было шесть организационных доменов высшего уровня.

№ | Домен | Использование
1. | com | Коммерческие организации
2. | edu | Учебные заведения (университеты, средние школы и т.д.)
3. | gov | Правительственные учреждения (кроме военных)
4. | mil | Военные учреждения (армия, флот и т.д.)
5. | org | Прочие организации
6. | net | Сетевые ресурсы

Таблица 1. Первоначальные домены верхнего уровня.

Когда Internet стала международной сетью, возникла необходимость предоставить зарубежным странам возможность контроля за именами находящихся в них систем. Для этой цели создан набор двухбуквенных доменов, которые соответствуют доменам высшего уровня для этих стран. Поскольку ca – код Канады, то компьютер на территории Канады может иметь такое имя:

hockey.guelph.ca

Общее число кодов стран – 300; компьютерные сети существуют приблизительно в 170 из них.

Окончательный план расширения системы присвоения имён ресурсов в Internet был наконец-то объявлен комитетом IAHC (International Ad Hoc Committee). [2] Согласно новым решениям, к доменам высшего уровня, включающим сегодня com, net, org, прибавятся:

· firm – для деловых ресурсов Сети;

· store – для торговли;

· web – для организаций, имеющих отношение к регулированию деятельности в WWW;

· arts – для ресурсов гуманитарного образования;

· rec – игры и развлечения;

· info – предоставление информационных услуг;

· nom – для индивидуальных ресурсов, а также тех, кто ищет свои пути реализации, которые отсутствуют в приведённом убогом списке.

Кроме того, в решениях IAHC сказано, что учреждается 28 уполномоченных агентств по присвоению имён во всём мире. Как заявлено, новая система позволит успешно преодолеть монополию, которая была навязана единственным уполномоченным – компанией Network Solutions. Все новые домены будут распределены между новыми агентствами, а прежние будут отслеживаться совместно Network Solutions и National Science Foundation до конца 1998 года.

В настоящее время ежемесячно регистрируется примерно 85 тысяч новых имён. Годовая оплата имени составляет 50 долларов. Новые регистрационные агентства должны будут представлять семь условных географических регионов. Для претендентов на роль агентств из каждого региона будут устроены лотереи. Компании, желающие участвовать в них, должны внести вступительный взнос в размере 20 тысяч долларов и иметь страховку на сумму не менее 500 тысяч долларов на случай неспособности справиться с ролью регистратора доменных имён.

Поиск доменных имён.

Теперь, когда понятно, как домены связаны между собой и как создаются имена, можно задуматься и над тем, как же применить эту чудесную систему. Вы используете её автоматически всякий раз, когда задаёте какое-то имя «знакомому» с ней компьютеру. Вам не нужно ни искать это имя вручную, ни давать для поиска нужного компьютера специальную команду, хотя при желании это также можно сделать. Все компьютеры в Internet могут пользоваться доменной системой, и большинство из них это делают.

Когда Вы используете имя, например, ux.cso.uiuc.edu, компьютер должен преобразовать его в адрес. Чтобы это сделать, Ваш компьютер начинает просить помощи у серверов (компьютеров) DNS, начиная с правой части имени и двигаясь влево. Сначала она просит локальные серверы DNS найти адрес. Здесь существуют три возможности:

· Локальный сервер знает адрес, потому что этот адрес находится в той части всемирной базы данных, которую курирует данный сервер. Например, если Вы работаете в НГТУ, то у Вашего локального сервера, вероятно, есть информация обо всех компьютерах НГТУ.

· Локальный сервер знает адрес, потому что кто-то недавно уже спрашивал о нём. Когда Вы спрашиваете об адресе, сервер DNS некоторое время держит его «под рукой» на тот случай, если чуть позже о нём спросит ещё кто-нибудь. Это значительно повышает эффективность работы системы.

· Локальный сервер не знает адрес, но знает, как его определить.

Как локальный сервер определяет адрес? Его программное обеспечение знает, как связаться с корневым сервером, который знает адреса серверов имён домена высшего уровня (крайней правой части имени, например, edu). Ваш сервер запрашивает у корневого сервера адрес компьютера, отвечающего за домен edu. Получив информацию, он связывается с этим компьютером и запрашивает у него адрес сервера uiuc. После этого Ваше программное обеспечение устанавливает контакт с этим компьютером и спрашивает у него адрес сервера домена cso. Наконец, от сервера cso он получает адрес ux, компьютера, который и был целью данной прикладной программы.

Некоторые компьютеры до сих пор имеют конфигурацию, рассчитанную на использование старомодного файла hosts. Если Вы работаете на одном из них, Вам, возможно, придётся попросить его администратора найти нужный Вам адрес вручную (либо сделать это самому). Администратор должен будет ввести имя нужного компьютера в локальный файл hosts. Намекните ему, что не мешало бы поставить на компьютер программное обеспечение DNS, чтобы избежать подобных осложнений в дальнейшем.

Что можно делать в Internet?

Что можно делать в Internet – сложный вопрос. Internet – не просто сеть, а сеть сетей, каждая из которых может иметь свою собственную политику и собственные правила. Поэтому здесь следует учитывать правовые и этические нормы, а также политические соображения. Взаимосвязь этих факторов и степень их важности не всегда одинаковы.

Для того, чтобы чувствовать себя вполне уверенно, достаточно запомнить несколько основных принципов. К счастью, эти принципы не сильно ограничивают пользователя; если не выходить за установленные пределы, можно делать всё, что угодно. Если Вы оказались в затруднительной ситуации, обратитесь к своему поставщику услуг, чтобы точно определить, что можно делать и чего нельзя. Вполне возможно, что то, что Вы хотите, делать разрешается, но Ваша обязанность – выяснить, так ли это. Рассмотрим некоторые принципы, чтобы определить границы допустимого.

Правовые нормы.

При работе в Internet должны соблюдаться три правовые нормы:

· Значительная часть Internet финансируется за счёт федеральных субсидий, вследствие чего исключается чисто коммерческое использование сети.

· Internet – интернациональная сеть. При отправке чего-либо, в том числе и битов, через государственную границу следует руководствоваться законами, регулирующими экспорт, а не правовыми нормами данного государства.

· В случае доставки программного обеспечения (или, например, просто идеи) из одного места в другое следует учитывать региональные правовые нормы, касающиеся интеллектуальной собственности и лицензий

Коммерческое использование.

Когда Ваша организация договаривалась о подключении к Internet, кто-то должен был сообщить поставщику сетевых услуг о том, для каких целей будет использоваться подключение: для научных исследований и образования или для коммерческих целей. В первом варианте Ваш трафик будет направляться по субсидированным маршрутам NREN, во втором – по частным каналам. Плата за доступ к сети для Вашей организации будет зависеть от выбора варианта; коммерческое использование сети обычно стоит дороже, т.к. оно не субсидируется государством. Допускается ли решение коммерческих задач через Ваше соединение, Вам могут сказать только сотрудники Вашей сетевой администрации. Проверьте это перед тем, как использовать подключение в коммерческих целях.

Конечно, многие корпорации присоединятся к Internet как центры исследований и обучения – и это допустимо, так как мотивом для подключения часто являются научные исследования. Например, компания по производству семян намерена проводить совместно с университетом исследования свойств семян сои. Многие юридические отделы корпораций, наоборот, объявляют свои подключения коммерческими. Это обеспечивает отсутствие правовой ответственности в будущем, когда, например, какой-нибудь неинформированный служащий запустит по предназначенному для передачи данных о научных исследованиях подсоединению коммерческую информацию.

В Internet существует ряд коммерческих поставщиков, например Advanced Networks and Service (ANS), Performance Systems International (PSI) и UUNET. У каждой из этих компаний есть своя собственная ниша рынка и своя собственная сеть в пределах государства для предоставления коммерческих услуг в Internet. Кроме того, сети штатов и региональные сети предоставляют коммерческие услуги своим членам. Имеются подключения между каждой из этих сетей и федеральными сетями. Взаимодействие всех этих сетей между собой с соблюдением всех законов и норм осуществляется посредством использования этих подключений и заключения определенных соглашений по учету.

Экспортное законодательство.

Знаете ли Вы, что экспорт битов подпадает под действие экспортных ограничений Министерства торговли? [3] То, что Internet, по сути дела, является целостной глобальной сетью, делает возможным экспорт информации без Вашего ведома. Поскольку я не юрист, не буду вдаваться в технические детали, но попытаюсь кратко рассказать, что нужно для соблюдения закона. Если, ознакомившись с этими замечаниями, Вы все-таки сочтете, что для Вас существует риск нарушить закон, обратитесь за компетентной юридической помощью.

Экспертное законодательство построено на двух положениях:

I. Экспорт чего-либо требует наличия лицензии.

II. Экспорт услуги считается приблизительно эквивалентным экспорту компонентов, необходимых для предоставления этой услуги.

Первый пункт в пояснениях не нуждается: если Вы отгружаете, перевозите, пересылаете файл или отправляете что-либо по электронной почте за пределы страны, то для этого необходимо получить экспортную лицензию. К счастью, здесь имеется лазейка – генеральная лицензия, область применения которой весьма обширна. Генеральная лицензия разрешает экспорт всего, на что не существует явных запретов на экспорт и что может открыто обсуждаться в США. Таким образом, все, что Вы можете узнать на конференции или в аудитории, скорее всего, подпадает под действие генеральной лицензии, если эта информация не является секретной.

Тем не менее, в перечне того, на что распространяются ограничения, содержится множество сюрпризов. Например, во время войны в Персидском заливе иракскую военную сеть было гораздо сложнее вывести из строя, чем планировалось. Оказалось, что Ирак использовал коммерческие IP-маршрутизаторы, которые очень быстро находили альтернативные маршруты. Поэтому экспорт всех маршрутизаторов, которые могли находить альтернативные маршруты, был срочно запрещён. [4]

Второй пункт ещё проще. Если экспорт определённых аппаратных средств, например суперкомпьютеров, запрещён, то дистанционный доступ к этим аппаратным средствам, находящимся в пределах данного государства, также не разрешается. Поэтому будьте осторожны с предоставлением доступа к «особым» ресурсам (типа суперкомпьютеров) иностранным пользователям. Характер этих ограничений зависит, естественно, от конкретной зарубежной страны и (как Вы можете судить на основании событий последних лет) может претерпевать значительные изменения.

Анализируя свою потенциальную правовую ответственность, консорциум, который управляет сетью Bitnet (CREN), пришёл к следующим выводам. Оператор сети несёт ответственность за незаконный экспорт лишь в том случае, если он знал о нарушении и не проинформировал об этом соответствующие органы. Оператор сети не несёт ответственности за действия пользователя и в его обязанности не входит определение их соответствия или несоответствия закону. Поэтому обслуживающим персоналом сети не производится проверка содержимого пакетов, которые Вы посылаете за границу. Но если оператор обнаруживает в Ваших пакетах какие-либо нарушения требований закона, он обязан проинформировать правительственные органы.

Права собственности.

Ещё один фактор, который необходимо учитывать при отправке чего-либо кому-либо, – это право собственности. Проблема осложняется, когда данные передаются через государственные границы. Законодательство в области авторских прав и патентов в разных странах может иметь большие различия. Вы можете обнаружить в сети любопытный сборник, содержащий основы забытого учения, срок действия авторских прав на который в США уже истек. Отправка этих файлов в Англию может привести к нарушению британского законодательства. Обязательно узнавайте, кому принадлежат права на то, что Вы передаете по сети, и в случае необходимости не забудьте получить соответствующее разрешение.

Законы, регламентирующие электронную передачу данных, не поспевают за техническим прогрессом. Если у Вас есть книга, журнал или личное письмо, то практически любой юрист или библиотекарь сможет ответить на ваш вопрос, можно ли снять с него копию или каким-либо образом использовать его. Они проинформируют Вас о том, имеете ли Вы право это сделать, или чье разрешение необходимо для этого получить. Задав такой же вопрос о статье в электронном бюллетене, сообщении, полученном по электронной почте, или файле, Вы не получите точного ответа. Даже если бы Вы знали, чье разрешение нужно получить, и получили его по электронной почте, все равно непонятно, каким образом можно с помощью сообщений, полученных по электронной почте, обеспечить реальную защиту информации. В этой части законодательство является достаточно туманным, и к нормальному виду его удастся привести, видимо, не раньше, чем в следующем десятилетии.

С правами собственности могут возникнуть проблемы даже при использовании общедоступных файлов. На некоторые программные средства, доступ к которым в Internet является открытым, необходимо получить лицензию поставщика. Например, поставщик рабочей станции вносит дополнения в свою операционную систему, доступную через анонимный FTR. Вы можете легко получить это программное обеспечение, но для законного его использования необходимо иметь лицензию на сопровождение программного обеспечения. Сам по себе факт наличия файла в сети не означает, что взяв его, Вы не нарушите закон.

Сетевая этика.

Сеть порождает множество этических проблем, однако этика здесь несколько отличается от общепринятой. Для того чтобы понять это, рассмотрим термин «законы первопроходцев». Когда Запад только начали осваивать, законы Соединённых Штатов западнее реки Миссисипи трактовались иначе, чем к востоку от неё. Сеть находится на переднем крае внедрения новых технологий, поэтому по отношению к ней справедливо будет применить вышеупомянутый термин. Вы можете углубляться в неё без опаски, если знаете, чего можно ожидать.

Сетевая этика основана на двух главных принципах:

¨ Индивидуализм уважается и поощряется.

¨ Сеть – хорошая и её следует защищать.

Обратите внимание: эти правила очень близки этике первопроходцев Запада, где индивидуализм и сохранение жизненного уклада были главенствующими. Рассмотрим, как же эти принципы проявляются в деятельности Internet.

Этические нормы и частная коммерческая Internet.

C каждым днем доля финансирования Internet из федерального бюджета все уменьшается, поскольку возрастает доля финансирования за счет коммерческого использования сети. Цель правительства – выйти из сетевого бизнеса и передать функции предоставления услуг частному капиталу. Возникает очевидный вопрос: если правительство выходит из сетевого бизнеса, должен ли я продолжать играть по его правилам? Есть два аспекта данной проблемы: личный и коммерческий.

С одной стороны, даже несмотря на прекращение финансирования сети федеральным правительством, многие хотели бы, чтобы расходы на подключения оплачивались бы не из их кармана. Поэтому если Вы пользуетесь подсоединением в школе, офисе, в бесплатной сети и т.д. от Вас могут потребовать продолжать соблюдать определенные правила. «Свобода – это когда Вам нечего терять», [5] и Вам, возможно, придется пожертвовать частью своей свободы, лишь бы сохранить субсидируемое подключение. Следует выяснить, что подразумевает Ваш сетевой поставщик под словами «допустимое использование».

С другой стороны, коммерческий аспект проблемы подразумевает, что Ваши дела должны вестись так, как это принято в Internet. Хотя культура взаимоотношений в Internet находится в стадии становления и нормы поведения постоянно меняются, в сети еще живы традиции неприятия откровенной меркантильности. Отправка по электронной почте всем пользователям Internet сообщения с рекламой какого-нибудь изделия большинством из них будет расценена как публичное оскорбление. В результате спрос на это изделие может даже сократиться, потому что образуется большая группа людей, не желающих иметь дела с нарушившей правила приличия компанией.

Правила поведения в Internet не исключают рекламу, но требуют, чтобы последняя выступала в качестве информационной услуги. Допускается вбрасывать в сеть маркетинговую информацию, но нельзя принуждать людей знакомиться с ней. С точки зрения сетевой политики и культуры не будет никакой крамолы, если компания по производству автомобилей создаст сервер с изображениями своих автомобилей, техническими данными и информацией о возможностях покупки. Пользователь Internet, желающий приобрести машину, мог бы «пройтись по магазину» со своего терминала, определить, что ему нужно, и в результате вместо трех визитов к агентам по продаже обойтись с одним. Такая услуга понравилась бы многим, и некоторые ресурсы уже начинают предоставлять ее. [6] В будущем Вы сможете даже совершить пробную поездку с помощью программ моделирования виртуальной реальности, не отходя от своего компьютера. Но вполне понятно желание избежать лавины несанкционированной электронной почты с предложениями купить все что угодно, от пластинок до сексуального нижнего белья.

Соображения безопасности.

Подключение компьютера к Internet само по себе не создает проблем обеспечения безопасности, отличных от тех, которая существует при работе двух компьютеров через модем. Проблема одна и та же, меняется только степень ее важности. Если у Вас модем подключен на прием к коммутируемой линии передачи, то любой может набрать номер и попробовать вломиться к Вам в компьютер. Есть три ограничивающих такую возможность фактора: во-первых, номер телефона компьютера, вероятно, известен немногим; во-вторых, если взломщик находится за пределами Вашей местной телефонной зоны, ему придется платить за эксперимент; в-третьих, есть только один интерфейс, который можно атаковать.

Если работать в Internet, этих факторов попросту нет. Общий адрес Вашей сети можно найти очень легко, а для определения адреса действующего компьютера нужно попробовать лишь несколько номеров. В принципе это все равно не хуже, чем в случае компьютерных служб, доступных по телефонной сети по коду 800. Однако эти службы имеют специальный отдел обеспечения безопасности, и существует только одна точка возможного прорыва: порт ASCII - терминала. В Internet же злоумышленник может попытаться прорваться через порт интерактивного терминала, порт пересылки файлов, порт электронной почты и т.д. Можно, конечно, не думать о безопасности вообще: просто вытащить компьютер из коробки, поставить его на стол, подключиться к Internet и работать. Но работать Вы будете до тех пор, пока кто-нибудь не вломится в компьютер и не сделает какую-нибудь пакость. В конечном счете гораздо выгоднее побеспокоиться о безопасности заранее, чем потом, когда неприятность уже произойдет.

Начать можно с выработки правильного отношения к проблеме безопасности. Нужно поверить в то, что защита – обязанность Вашей рабочей станции, но никак не функция сети. Сетевой поставщик может ограничить перечень лиц, которые могут пользоваться Вашим подключением. Это, однако, не совсем то, что Вам нужно, потому что таким образом отсекаются главные достоинства Internet. Большая часть нашей книги посвящена тому, чтобы научить Вас забираться в разные далекие места и находить там всякие хорошие вещи. Сетевые разговоры – это двусторонний канал. Если удаленный компьютер не может говорить с Вами, то и Вы не сможете с ним разговаривать. И если на этом компьютере есть ресурс, который Вам понадобиться в следующем месяце, Вы окажетесь в проигрыше. Для того чтобы воспользоваться преимуществами Internet, нужно стать ее частью. Это подвергает Ваш компьютер некоторому риску, поэтому следует позаботиться о его защите.

Безопасность в Internet поддерживается общими усилиями. Один из методов, который взломщики-любители взяли на вооружение, заключается в прорыве в цепочку компьютеров (например, вломиться в A, оттуда – в B, затем с помощью B прорваться в C и т.д.). Это позволяет им заметать следы с большей тщательностью. Если Вы думаете, что Ваш маленький старенький компьютер не может стать объектом насилия, потому что он ну очень маленький, то глубоко заблуждаетесь. Даже если на нем нет ничего стоящего, его вполне можно использовать для взлома другой, более важной системы Есть такие охотники, которые делают зарубки на клавиатуре, подсчитывая, сколько компьютеров они взломали. Размеры при этом значения не имеют.

Обсуждение безопасности и слухи на тему безопасности тоже представляют собой часть проблемы безопасности. Можете ли Вы представить себе такую новость:

На сегодняшней пресс-конференции официальные лица компании ACME объявили, что их замки открываются любой комбинацией…

Для решения задачи устранения возможных проблем, поискам решения и информирования правительство финансирует организацию под названием CERT(Computer Emergence Response Team, «Аварийная бригада по компьютерам»). СERT выполняет целый ряд функций: занимается изучением проблем, связанных с безопасностью, работает с фирмами-изготовителями над их устранением и распространяет соответствующую информацию. Кроме того, эта организация производит средства, которые позволяют пользователям оценивать степень защищенности своих компьютеров. Сотрудники CERT предпочитают контактировать с теми, кто отвечает за безопасность, но в аварийных ситуациях отвечают на вопросы любых пользователей. Если Вам необходимо обсудить с кем-нибудь проблемы безопасности, можете связаться с CERT по электронной почте:

cert@cert.sei.cmu.edu

Существуют четыре источника возникновения угрозы для сетевых компьютеров. Мы перечислим их в порядке убывания вероятности: [7]

1. Выбор законным пользователем неудачного пароля.

2. Привнос (импорт) разрушающего программного обеспечения.

3. Проникновение в системы незаконных пользователей, которое происходит вследствие ошибок в конфигурации программных средств.

4. Проникновение в системы незаконных пользователей, которое происходит вследствие дефектов в средствах обеспечения безопасности операционных систем.

Сколь велика Internet сейчас?

Марк Лоттор (Mark Lottor), бывший научный сотрудник Стэндфордского исследовательского института (Stanford Research Institute), а ныне президент консультационной компании Network Wizard, опубликовал полугодовой отчёт о состоянии Internet. [8] Согласно новейшим данным, Сеть состоит из 828 тысяч доменов, в неё подключено 16,1 млн. конечных устройств в 176 странах мира. Как справедливо предупредил Лоттор, совершенно невозможно определить число пользователей Internet, поскольку существует неопределённое количество многопользовательских компьютеров, шлюзов в корпоративные сети и специальных приложений, которые выглядят извне как единичные компьютеры. Кроме того, хотя за прошедший год отмечен рост количества подключённых к Сети устройств на 70%, на самом деле это значительно меньше реальных изменений, поскольку многие системы скрываются за брандмауэрами и недоступны для прощупывания и учёта.

В Internet больше всего ресурсов, которые включают в состав имени «WWW». Их количество в январе 1997 года составило 408382 по сравнению с 75000 в январе 1996 года. Самым большим доменом высшего уровня является «COM», который имеют 3,96 млн. сайтов, что составляет 25% их общего количества. Наиболее быстро расширяются домены COM, EDU, NET, Japan и MIL. Как сообщает Лоттор, глобальные домены высшего уровня и домены 89 стран показали годовой рост, превышающий 100%.

Услуги, предоставляемые сетью.

Все услуги предоставляемые сетью Internet можно условно поделить на две категории: обмен информацией между абонентами сети и использование баз данных сети.

К числу услуг связи между абонентами принадлежат:

Telnet - удаленный доступ. Дает возможность абоненту работать на любой ЭВМ сети Internet как на своей собственной. То есть запускать программы, менять режим работы и т.д.

FTP (File Transfer Protocol) - протокол передачи файлов. Дает возможность абоненту обмениваться двоичными и текстовыми файлами с любым компьютером сети. Установив связь с удаленным компьютером, пользователь может скопировать файл с удаленного компьютера на свой или скопировать файл со своего компьютера на удаленный.

NFS (Network File System) - распределенная файловая система. Дает возможность абоненту пользоваться файловой системой удаленного компьютера, как своей собственной.

Электронная почта - обмен почтовыми сообщениями с любым абонентом сети Internet. Существует возможность отправки как текстовых, так и двоичных файлов. На размер почтового сообщения в сети Internet накладывается следующее ограничение - размер почтового сообщения не должен превышать 64 килобайт.

Новости - получение сетевых новостей и электронных досок объявлений сети и возможность помещения информации на доски объявлений сети. Электронные доски объявлений сети Internet формируются по тематике. Пользователь может по своему выбору подписаться на любые группы новостей.

Rsh (Remote Shell) - удаленный доступ. Аналог Telnet, но работает только в том случае, если на удаленном компьютере стоит ОС UNIX.

Rexec (Remote Execution) - выполнение одной команды на удаленной UNIX-машине.

Lpr - сетевая печать. Отправка файла на печать на удаленном (сетевом) принтере.

Lpq - сетевая печать. Показывает файлы стоящие в очереди на печать на сетевом принтере.

Ping - проверка доступности удаленной ЭВМ по сети.

Talk - дает возможность открытия "разговора" с пользователем удаленной ЭВМ. При этом на экране одновременно виден вводимый текст и ответ удаленного пользователя.

Iptunnel - дает возможность доступа к серверу ЛВС NetWare с которым нет непосредственной связи по ЛВС, а имеется лишь связь по сети Internet.

Whois - адресная книга сети Internet. По запросу абонент может получить информацию о принадлежности удаленного компьютера, о пользователях.

Finger - получение информации о пользователях удаленного компьютера.

Кроме вышеперечисленных услуг, сеть Internet предоставляет также следующие специфические услуги:

Webster - сетевая версия толкового словаря английского языка.

Факс-сервис - дает возможность пользователю отправлять сообщения по факсимильной связи, пользуясь факс - сервером сети.

Электронный переводчик - производит перевод присланного на него текста с одного языка на другой. Обращение к электронным переводчикам происходит посредством электронной почты.

Шлюзы - дают возможность абоненту отправлять сообщения в сети, не работающие с протоколами TCP\IP (Fido, Goldnet, AT50).

К системам автоматизированного поиска информации в сети Internet принадлежат следующие системы.

Gopher - наиболее широко распространенное средство поиска информации в сети Internet, позволяющее находить информацию по ключевым словам и фразам. Работа с системой Gopher напоминает просмотр оглавления, при этом пользователю предлагается пройти сквозь ряд вложенных меню и выбрать нужную тему. В Internet в настоящее время свыше 2000 Gopher-систем, часть из которых является узкоспециализированной, а часть содержит более разностороннюю информацию.

Gopher позволяет получить информацию без указания имен и адресов авторов, благодаря чему пользователь не тратит много времени и нервов. Он просто сообщит системе Gopher, что именно ему нужно, и система находит соответствующие данные. Gopher-серверов свыше двух тысяч, поэтому с их помощью не всегда просто найти требуемую информацию. В случае возникших затруднений можно воспользоваться службой VERONICA. VERONICA осуществляет поиск более чем в 500 системах Gopher, освобождая пользователя от необходимости просматривать их вручную.

WAIS - еще более мощное средство получения информации, чем Gopher, поскольку оно осуществляет поиск ключевых слов во всех текстах документов. Запросы посылаются в WAIS на упрощенном английском языке. Это значительно легче, чем формулировать их на языке алгебры логики, и это делает WAIS более привлекательной для пользователей-непрофессионалов.

При работе с WAIS пользователям не нужно тратить много времени, чтобы найти необходимые им материалы.

В сети Internet существует более 300 WAIS - библиотек. Но поскольку информация представляется преимущественно сотрудниками академических организаций на добровольных началах, большая часть материалов относится к области исследований и компьютерных наук.

WWW - система для работы с гипертекстом. Потенциально она является наиболее мощным средством поиска. Гипертекст соединяет различные документы на основе заранее заданного набора слов. Например, когда в тексте встречается новое слово или понятие, система, работающая с гипертекстом, дает возможность перейти к другому документу, в котором это слово или понятие рассматривается более подробно.

WWW часто используется в качестве интерфейса к базам данных WAIS, но отсутствие гипертекстовых связей ограничивает возможности WWW до простого просмотра, как у Gopher.

Пользователь со своей стороны может задействовать возможность WWW работать с гипертекстом для связи между своими данными и данными WAIS и WWW таким образом , чтобы собственные записи пользователя как бы интегрировались в информацию для общего доступа. На самом деле этого, конечно, не происходит, но воспринимается именно так.

WWW - это относительно новая и динамично развивающаяся система. Установлены несколько демонстрационных серверов, в том числе Vatican Exibit в библиотеке Конгресса США и мультфильм о погоде "Витки спутника" в Мичиганском государственном университете. В качестве демонстрационных также работают серверы into.funet.fi (Финляндия); into.cern.ch. (Швейцария) и eies2.njit.edu (США).

Практически все услуги сети построены на принципе клиент-сервер. Сервером в сети Internet называется компьютер способный предоставлять клиентам (по мере прихода от них запросов) некоторые сетевые услуги. Взаимодействие клиент-сервер строится обычно следующим образом. По приходу запросов от клиентов сервер запускает различные программы предоставления сетевых услуг. По мере выполнения запущенных программ сервер отвечает на запросы клиентов.

Все программное обеспечение сети также можно поделить на клиентское и серверное. При этом программное обеспечение сервера занимается предоставлением сетевых услуг, а клиентское программное обеспечение обеспечивает передачу запросов серверу и получение ответов от него.

Элементы охраны труда и защиты информации.

Пользователи решившие подключить свой компьютер к сети должны обратить особое внимание на защиту информации. Строгие требования к защите информации связаны с тем, что подключенный к сети компьютер становится доступным из любой точки сети, и поэтому несравнимо более подвержен поражению вирусами и несанкционированному доступу.

Так несоблюдение режима защиты от несанкционированного доступа может привести к утечке информации, а несоблюдение режима защиты от вирусов может привести к выходу из строя важных систем и уничтожению результатов многодневной работы.

Компьютеры работающие в многозадачных операционных системах (типа Unix, VMS) мало подвержены заражению вирусами, но их следует особо тщательно защищать от несанкционированного доступа. В связи с этим пользователи многозадачных операционных систем должны выполнять следующие требования.

Каждый пользователь должен иметь свое индивидуальное имя входа в Unix-сервер и пароль.

Установленный для него пароль пользователь не должен сообщать другим лицам.

Смену пароля пользователь должен производить не реже одного раза в квартал, а также во всех случаях утечки информации о пароле.

Администраторам и пользователям файл-серверов ЛВС NetWare необходимо также следовать приведенным выше требованиям в рамках своей ЛВС. Это связано с тем, что если в файл-сервере, подключенном к сети, загружена утилита Iptunnel, то файл-сервер также становится доступным из любой точки сети.

ПЭВМ работающие в однозадачных операционных системах (типа MS-DOS), достаточно защищены от несанкционированного доступа (в силу их однозадачности), но их следует особенно тщательно защищать от поражения вирусами.

Для защиты от вирусов рекомендуется применять программные средства защиты (типа aidstest), а также аппаратно-программные (типа Sheriff).

Заключение.

Это далеко не всё, что можно рассказать об Internet, но всё же достаточно для формирования первоначального взгляда. Объяснять можно много, но лучше всё же один раз попробовать самому, чем сто раз услышать, как это здорово.

Internet – постоянно развивающаяся сеть, у которой ещё всё впереди, будем надеяться, что наша страна не отстанет от прогресса и достойно встретит XXI век.

Словарь терминов.

Английские термины.

Archie - архив. Система для определения местонахождения файлов в публичных архивах сети Internet.

ARP (Address Resolution Protocol) - протокол определения адреса, преобразует адрес компьютера в сети Internet в его физический адрес.

ARPA (Advanced Research Projects Agency) - бюро проектов передовых исследований министерства обороны США.

ARPANET - экспериментальная сеть, работавшая в семидесятые годы, на которой проверялись теоретическая база и программное обеспечение, положенные в основу Internet. В настоящее время не существует.

Bps (bit per second) - бит в секунду. Единица измерения пропускной способности линии связи. Пропускная способность линии связи определяется количеством информации, передаваемой по линии за единицу времени.

Cisco - маршрутизатор, разработанный фирмой Cisco-Systems.

DNS (Domain Name System) - доменная система имен. распределенная система баз данных для перевода имен компьютеров в сети Internet в их IP-адреса.

Ethernet - тип локальной сети. Хороша разнообразием типов проводов для соединений, обеспечивающих пропускные способности от 2 до 10 миллионов bps (2-10 Mbps). Довольно часто компьютеры, использующие протоколы TCP/IP, через Ethernet подсоединяются к Internet.

FTP (File Transfer Protocol)

Þ протокол передачи файлов.

Þ протокол, определяющий правила пересылки файлов с одного компьютера на другой.

Þ прикладная программа, обеспечивающая пересылку файлов согласно этому протоколу.

FAQ (Frequently Asked Questions) - часто задаваемые вопросы. Раздел публичных архивов сети Internet в котором хранится информация для "начинающих" пользователей сетевой инфраструктуры.

Gopher - интерактивная оболочка для поиска, присоединения и использования ресурсов и возможностей Internet. Интерфейс с пользователем осуществлен через систему меню.

HTML (Hypertext Markup Language)- язык для написания гипертекстовых документов. Основная особенность - наличие гипертекстовых связей между документами находящимися в различных архивах сети; благодаря этим связям можно непосредственно во время просмотра одного документа переходить к другим документам.

Internet - глобальная компьютерная сеть.

internet - технология сетевого взаимодействия между компьютерами разных типов.

IP (Internet Protocol) - протокол межсетевого взаимодействия, самый важный из протоколов сети Internet, обеспечивает маршрутизацию пакетов в сети.

IР-адрес - уникальный 32-битный адрес каждого компьютера в сети Internet.

Iptunnel - одна из прикладных программ сети Internet. Дает возможность доступа к серверу ЛВС NetWare с которым нет непосредственной связи по ЛВС, а имеется лишь связь по сети Internet.

Lpr - сетевая печать. Команда отправки файла на печать на удаленном принтере.

Lpq - сетевая печать. Показывает файлы стоящие в очереди на печать.

NetBlazer - маршрутизатор, разработанный фирмой Telebit.

NetWare - сетевая операционная система, разработанная фирмой Novell; позволяет строить ЛВС основанную на принципе взаимодействия клиент-сервер. Взаимодействие между сервером и клиентом в ЛВС NetWare производится на основе собственных протоколов (IPX), тем не менее протоколы TCP/IP также поддерживаются.

NFS (Network File System) - распределенная файловая система. Предоставляет возможность использования файловой системы удаленного компьютера в качестве дополнительного НЖМД.

NNTP (Net News Transfer Protocol) - протокол передачи сетевых новостей. Обеспечивает получение сетевых новостей и электронных досок объявлений сети и возможность помещения информации на доски объявлений сети.

Ping - утилита проверка связи с удаленной ЭВМ.

POP (Post Office Protocol) - протокол "почтовый офис". Используется для обмена почтой между хостом и абонентами. Особенность протокола - обмен почтовыми сообщениями по запросу от абонента.

PPP (Point to Point Protocol) - протокол канального уровня позволяющий использовать для выхода в Internet обычные модемные линии. Относительно новый протокол, является аналогом SLIP.

RAM (Random Acsess Memory) - оперативная память.

RFC (Requests For Comments) - запросы комментариев. Раздел публичных архивов сети Internet в котором хранится информация о всех стандартных протоколах сети Internet.

Rexec (Remote Execution) - выполнение одной команды на удаленной UNIX-машине.

Rsh (Remote Shell) - удаленный доступ. Аналог Telnet, но работает только в том случае, если на удаленном компьютере стоит ОС UNIX.

SLIP (Serial Line Internet Protocol) - протокол канального уровня позволяющий использовать для выхода в Internet обычные модемные линии.

SMTP (Simple Mail Transfer Protocol) - простой протокол передачи почты. Основная особенность протокола SMTP - обмен почтовыми сообщениями происходит не по запросу одного из хостов, а через определенное время (каждые 20 - 30 минут). Почта между хостами в Internet передается на основе протокола SMTP.

Talk - одна из прикладных программ сети Internet. Дает возможность открытия "разговора" с пользователем удаленной ЭВМ. При этом на экране одновременно печатается вводимый текст и ответ удаленного пользователя.

Telnet - удаленный доступ. Дает возможность абоненту работать на любой ЭВМ сети Internet как на своей собственной.

TCP\IP - под TCP\IP обычно понимается все множество протоколов поддерживаемых в сети Internet.

TCP (Transmission Control Protocol) - протокол контроля передачи информации в сети. TCP - протокол транспортного уровня, один из основных протоколов сети Internet. Отвечает за установление и поддержание виртуального канала (т.е. логического соединения), а также за безошибочную передачу информации по каналу.

UDP (User Datagram Protocol) - протокол транспортного уровня, в отличие от протокола TCP не обеспечивает безошибочной передачи пакета.

Unix - многозадачная операционная система, основная операционная среда в сети Internet. Имеет различные реализации: Unix-BSD, Unix-Ware, Unix-Interactive.

UUCP - протокол копирования информации с одного Unix-хоста на другой. UUCP - не входит в состав протоколов TCP/IP, но тем не менее все еще широко используется в сети Internet. На основе протокола UUCP - построены многие системы обмена почтой, до сих пор используемые в сети.

VERONICA (Very Easy Rodent-Oriented Netwide Index to Computer Archives) - система поиска информации в публичных архивах сети Internet по ключевым словам.

WAIS (Wide Area Information Servers) - мощная система поиска информации в базах данных сети Internet по ключевым словам.

WWW (World Wide Web) - всемирная паутина. Система распределенных баз данных, обладающих гипертекстовыми связями между документами.

Whois - адресная книга сети Internet.

Webster - сетевая версия толкового словаря английского языка.

Приложение.

Допустимое использование.

Ниже приведён перечень принципов официальной политики «допустимого использования» для сети NSFNET, датированный июнем 1992 года. Обновлённые версии можно получить по анонимному FTP с сервера nic.merit.edu (файл /nsfnet/acceptable.use.policies/nsfnet.txt). Этот каталог также содержит тексты с изложением принципов допустимого использования для других сетей.

Хотя первый параграф этого документа звучит довольно категорично, не стоит падать духом. Как указывалось в главе «О том, как работает Internet», «поддержка» исследований и обучения трактуется довольно свободно. Помните о том, что NSFNET – это не вся Internet, а лишь её часть, и политика ограничений допустимости использования здесь одна из самых жёстких. С течением времени политика NSFNET всё больше и больше утрачивает своё значение. Основная цель последних мероприятий по приватизации – создание «сети сетей» без ограничений допустимого использования, т.е. сети, в которой не будет ограничений в использовании её в коммерческих, любительских и других целях.

Следовательно, в сети, с которой Вы устанавливаете соединение, может действовать несколько иная политика; некоторые входящие в Internet сети активно поощряют коммерческое использование. С подобными вопросами обращайтесь к своему поставщику сетевых услуг, который определит, что приемлемо для Вашего соединения. Если Вам необходимо Internet - подключение исключительно для коммерческих или личных целей, Вы легко найдёте соответствующего поставщика.

Политика допустимого использования базовых услуг сети NSFNET.

Общий принцип:

à Базовые услуги NSFNET предоставляются для поддержки исследований и обучения в научно-исследовательских институтах и учебных заведениях США, а также в научно-исследовательских подразделениях фирм, которые занимаются выполнением научно-исследовательских работ и информационным обменом. Использование в других целях не допускается.

Конкретные направления допустимого использования:

à Обмен информацией с зарубежными учёными и педагогами для обеспечения научно-исследовательской деятельности и образования при условии, что сеть, которую использует зарубежный пользователь для такого обмена, обеспечивает эквивалентный доступ учёным и педагогам Соединённых Штатов.

à Обмен и передача данных в целях профессионального развития, поддержки профессионального уровня и научных дискуссий в любой области знаний.

à Использование сети в целях поддержки связей между культурными и научными обществами, в совместной деятельности университетов, правительственно-консультативной работе, стандартизации, если такая деятельность связана с научной и учебной работой пользователя.

à Использование сети для подачи заявлений на стипендии, назначения таковых, оформления контрактов на научно-исследовательскую или учебную деятельность, но не для другой деятельности, направленной на привлечение средств, или деятельности в рамках общественных связей.

à Другие административные коммуникации, направленные на прямое обеспечение научных исследований и обучения.

à Сообщение о новых продуктах и услугах для использования в научных исследованиях и системе образования, исключая все виды рекламы.

à Все виды трафика из сети другого ведомства – члена Федерального совета по сетям, если трафик соответствует принципам политики допустимого использования данного ведомства.

à Передача данных, связанная с другими видами допустимого использования, за исключением незаконного и недопустимого использования.

Недопустимое использование:

à Использование с целью получения прибыли, если оно не соответствует указанному в параграфах «Общий принцип» и «Конкретные направления допустимого использования».

à Интенсивное использование в частных коммерческих целях.

Данные положения распространяются только на базовые услуги сети NSFNET. Национальный научный фонд надеется, что сети, соединённые с NSFNET, будут формулировать свои собственные принципы допустимого использования. Все вопросы по данной политике и трактовке её принципов решает отдел NSF по исследованию и инфраструктуре сетей и коммуникаций.

[1] Провести границу между подадресом сети и подадресом компьютера довольно сложно. Эта граница устанавливается по соглашению между соседними маршрутизаторами. К счастью, как пользователю, Вам никогда не придётся беспокоиться об этом. Это имеет значение только при создании сети.

[2] Данные от 24 февраля 1997 года.

[3] Эти замечания относятся только к США. В других странах на серверы распространяются другие законы.

[4] Вполне возможно, что эта история – одна из «сетевых легенд». Все в Internet говорили об этом случае, но когда я попытался проверить достоверность этой информации, то не смог найти ни одного надёжного источника.

[5] Kris Kristofferson and Fred Foster, «Me and Bobby McGee», 1969.

[6] Например, это делает система Global Network Navigator. Получить информацию можно, послав по электронной почте сообщение по адресу info@gnn.com.

[7] Если Вы хотите быть более осведомлённым в вопросах безопасности, обратитесь к документу RFC1244 и серверу CERT. Кроме того, можно ознакомиться с общим обзором проблем безопасности в книге «Computer Security Basics» (Russell and Gangemi). Вопросы администрирования UNIX - систем освещаются в книге «Practical UNIX Security» (Garfinkel and Spafford).

[8] Ранее, работая в Стэндфордском исследовательском институте, Лоттор занимался вопросами выработки метрик для Internet, что теперь успешно применяет на практике. Регулярные отчёты о состоянии Internet, подготовленные Network Wizard, распространяются через подразделение Internet Business Development компании General Magic.


7_1_TKC

E-mail электронная почта

Электронная почта - обмен почтовыми сообщениями с любым абонентом сети Internet. Существует возможность отправки как текстовых, так и двоичных файлов. На размер почтового сообщения в сети Internet накладывается следующее ограничение - размер почтового сообщения не должен превышать 64 килобайт. Она позволяет пересылать сообщения практически с любой машины на любую, так как большинство известных машин, работающих в разных системах, ее поддерживают. Электронная почта во многом похожа на обычную почту. С ее помощью письмо - текст, снабженный стандартным заголовком (конвертом) - доставляется по указанному адресу, который определяет местонахождение машины и имя адресата, и помещается в файл, называемый почтовым ящиком адресата, с тем, чтобы адресат мог его достать и прочесть в удобное время. При этом между почтовыми программами на разных машинах существует соглашение о том, как писать адрес, чтобы все его понимали. Электронная почта оказалась во многом удобнее обычной, "бумажной". Не говоря уже о том, что Вам не приходится вставать из-за компьютера и идти до почтового ящика, чтобы получить или отправить письмо.

Характеристика

-электронной почтой сообщение в большинстве случаев доставляется гораздо быстрее, чем обычной;
-стоит это дешевле;
-для отправки письма нескольким адресатам не нужно печатать его во многих экземплярах, достаточно однажды ввести текст в компьютере;
-если нужно перечитать, исправить полученное или составленное Вами письмо, или использовать выдержки из него, это сделать легче, поскольку текст уже находится в машине;
-удобнее хранить большое количество писем в файле на диске, чем в ящике стола; в файле легче и искать;
-и, наконец, экономится бумага.
Надежность электронной почты сильно зависит от того, какие используются почтовые программы, насколько удалены друг от друга отправитель и адресат письма, и особенно от того, в одной они сети, или в разных. В наших условиях, пожалуй, лучше полагаться на электронную почту, чем на простую. Если письмо все-таки потерялось, Вы об этом сможете узнать достаточно скоро и послать новое.
В мире имеется более 50 миллионов пользователей электронной почты. В целом же в мире трафик электронной почты (протокол smtp) занимает только 3.7% всего сетевого. Популярность ее объясняется, как насущными требованиями, так и тем, что большинство подключений - подключения класса ``доступ по вызову'' (с модема), а у нас в России, вообще, в подавляющем большинстве случаев - доступ UUCP. E-mail доступна при любом виде доступа к Internet .

Использование электронной почты

Использование электронной почты же более подходит для направления документов к исполнителям. Системой, обеспечивающей маршрутизацию документов является система электронной почты, которая осуществляет параллельное распространение документов. Маршрутизация отличается от распространения или рассылки тем, что маршрутизируемый документ возвращается в начало маршрута, например к инициатору, а рассылаемый документ уходит к исполнителю без контроля факта возврата. С помощью дополнительных приложений система электронной почты может обеспечивать последовательную маршрутизацию документов.

Для каждого пользователя создается почтовый ящик. Передачу сообщений между почтовыми ящиками внутри локальной сети осуществляет программный модуль-марштуризатор. Но пользователи должны иметь возможность не только работать с электронной почтой в пределах интрасети, но и обмениваться сообщениями через Internet.Итак, электронная почта выполняет следующие функции:

обмен сообщениями между пользователями;
обмен документами между пользователями;
обмен данными между приложениями;
оповещение пользователей о наступлении определенных событий.

Адресация в системе электронной почты

Для того, чтобы ваше электронное письмо дошло до своего адресата, необходимо, чтобы оно было оформлено в соответствии с международными стандартами и имело стандартизованный почтовый электронный адрес. Общепринятый формат послания определяется документом под названием "Standard for the Format of ARPA - Internet Text messages", сокращенно - Request for Comment, и имеет заголовок и непосредственно сообщение. Заголовок выглядит приблизительно так:
From: почтовый электронный адрес - от кого пришло послание
To: почтовый электронный адрес - кому адресовано
Cc: почтовые электронные адреса - кому еще направлено
Subject: тема сообщения (произвольной формы)
Date: дата и время отправки сообщения
Строки заголовка From: и Date: формируются, как правило, автоматически, программными средствами. Помимо этих строк заголовка, послание может содержать и другие, например:
Message-Id: уникальный идентификатор послания, присвоенный ему почтовой машиной. Reply-To: обычно адрес абонента, которому вы отвечаете на присланное вам письмо

Заключение

В заключении можно сказать, что E-mail является отличным средством общения людей ( хотя и ограни- ченного круга, т.е. обладателей ПК с соответствующим обеспечением). Можно с уверенностью сказать, что электронную почту ждёт большое будущее во всех его проявлениях, и что она будет постоянно развиваться и совершенствоваться, что будет приводить к более удобному её использованию.
Тестирование


8_1_TKC

Введение в Outlook

Приложение Microsoft Outlook Express обеспечивает удобную связь со всем миром. Вам предоставляются все необходимые средства для работы с электронной почтой и группами новостей.

Чтение сообщений

После того, как программа Outlook Express загрузит сообщения, или после нажатия кнопки Доставить почту на панели инструментов, сообщения можно читать либо в области просмотра, либо в отдельном окне. Щелкните значок папки 'Входящие' на панели Outlook или в списке папок. Для просмотра сообщения в области просмотра, щелкните по нему в списке сообщений. Для просмотра сообщения в отдельном окне, дважды щелкните по нему в списке сообщений.

Отправка сообщений

Чтобы отправить сообщение по электронной почте, выполните следующие действия На панели инструментов нажмите кнопку Создать сообщение. В поле Кому и/или Копия введите адреса электронной почты всех получателей, разделяя их запятыми или точками с запятой ( ; ). Чтобы выбрать получателей из адресной книги, щелкните по значку с книгой, находящемуся рядом с полями Кому, Копия и СК в окне создаваемого сообщения, и выберите нужные адреса. Чтобы можно было использовать поле СК (слепая копия), в меню Вид выберите Все заголовки. В поле Тема укажите тему сообщения. Введите текст сообщения и нажмите кнопку Отправить на панели инструментов создаваемого сообщения.

Вставка файла в сообщение

Вставка файла в сообщение Щелкните по любому месту в окне создаваемого сообщения. В меню Вставка выберите Вложение файла. Выберите файл и нажмите кнопку Вложить. Имя вложенного файла появится в поле Вложить, находящемся в заголовке сообщения.

Как справится с большим количеством сообщений

Если вы получаете массу сообщений, вам может не понравиться, что ваша папка 'Входящие' все время переполняется. Группы новостей, особенно популярные, также могут затруднить работу из-за большого количества сообщений, содержащихся в них. В программе Outlook Express имеется набор представлений, облегчающих работу с новостями и почтовыми сообщениями. Применяя представления, можно отображать только нужные сообщения. Cоответствующие представления можно настроить, пользуясь "Диспетчером представлений". ----- В меню Вид укажите на Текущее представление и выберите один из следующих вариантов: Отобразить все сообщения. Отображаются все сообщения в папке (например, в папке Входящие) — старые и новые, прочитанные и непрочитанные. Скрыть прочитанные сообщения. Отображаются только непрочитанные сообщения. Отобразить загруженные сообщения (применимо только к группам новостей и почте по протоколу IMAP). Отображаются сообщения, загруженные в ходе последнего сеанса. Отобразить ответы на мои сообщения (применимо только к группам новостей). Отображаются только сообщения, являющиеся ответами на сообщение пользователя, помещенное в группу новостей. Скрыть прочитанные или пропущенные сообщения. Не отображаются прочитанные сообщения, а также сообщения, к которым была применена команда Пропустить обсуждение. В папке 'Входящие' можно упорядочить сообщения по их теме. Для этого необходимо выбрать Сгруппировать сообщения по теме обсуждения в меню Текущее представление.

Хранение сообщений на почтовых серверах

Хранение сообщений на серверах электронной почты Сообщения целесообразно хранить на почтовом сервере при необходимости иметь доступ к ним из разных мест. При входе с другого компьютера программа Outlook Express загружает в него сообщения в соответствии с заданными параметрами. Сообщения можно хранить на сервере POP3. Если вы пользуетесь почтой по протоколу HTTP (например, Hotmail) или по протоколу IMAP, ваши сообщения всегда хранятся на сервере. Выберите Учетные записи в меню Сервис. Выберите учетную запись для почты и нажмите Свойства. Выберите вкладку Дополнительно и выберите Оставлять копии сообщений на сервере.

Работа с сообщениями на почтовых серверах

Работа с почтовыми сообщениями на сервере Протоколы IMAP (Internet Message Access Protocol - протокол доступа к сообщениям в Интернете) и HTTP (Hypertext Transfer Protocol - протокол передачи гипертекста) используются для доступа через Интернет к сообщениям, хранящимся на сервере. Пользуясь данными протоколами, можно читать почту при помощи любого компьютера, имеющего выход в Интернет. После настройки учетной записи протокола IMAP можно указать, какие папки следует отображать, а какие - скрывать. При использовании учетной записи протокола HTTP отображаются все имеющиеся папки. Наличие учетной записи для работы с сообщениями на сервере позволяет сэкономить время работы в сети, т.к. вы можете загрузить сначала только заголовки сообщений, выбрать нужные, и пометить их для последующей загрузки. При работе в автономном режиме можно читать сообщения и отвечать на них, как если бы вы работали в сети. При следующем подключении будет произведена синхронизация почты, имеющейся в компьютере и на сервере. Во время синхронизации на сервере будут произведены все сделанные вами операции.

Специальные возможности Outlook

Специальные возможности в программе Microsoft Outlook Express Дополнительно к специальным возможностям, имеющимся в операционных системах Microsoft Windows 95, Windows 98 и Windows 2000, в программе Microsoft Outlook Express предусмотрены следующие функции, облегчающие работу людям с ограниченной подвижностью, нарушениями зрения или слуха. Звуковое уведомление о приходе новых сообщений Можно задать воспроизведение звукового фрагмента при появлении новых сообщений. Изменение размера списков папок и сообщений Можно настраивать способ отображения сообщений и списков сообщений. Можно отображать сообщения в области просмотра и задать горизонтальное либо вертикальное разбиение окна для отображения списка сообщений и области просмотра. Можно также задавать отображение только списка сообщений. Настройка панелей инструментов Можно изменить размер значков и способ отображения надписей на кнопках панели инструментов, а также можно указать, какие кнопки должны отображаться на ней. Использование клавиатуры в управлении Все функции программы Microsoft Outlook Express можно запускать при помощи клавиатуры или мыши. Программа Outlook Express поддерживает раскладку Дворжака для клавиатуры, облегчающую доступ к наиболее часто используемым символам.

Тестирование


9_1_TKC

Internet Explorer

Введение и история развития Internet Explorer

Для работы со службой WWW(World Wide Web) надо иметь ее клиентскую программу. Официально она именуется Средством просмотра Web, а в быту ее называют просто браузером. Те, кто работает с ОС Windows 98SE, Windows ME, Windows 2000 и Windows XP, могут не заниматься поисками браузера - он уже установлен на компьютерах и даже настроен. Штатный системный браузер – программа Microsoft Internet Explorer, которую сама фирма-создатель называет Обозревателем. К разнообразным ОС прилагается разные версии Обозревателя: Internet Explorer 3.0 – к Windows95, Internet Explorer 4.0 – к Windows 98, Internet Explorer 5.0 – к Windows 98SE, Internet Explorer 5.5 – к Windows 95, Windows ME, Windows 2000 и Internet Explorer 6,0 – к Windows XP.

От браузера зависит личная безопасность при работе в Internet. Браузер постоянно находится на связи: что-то записывает, что-то получает, что-то пишет на жесткий диск. История развития браузеров насчитывает всего лишь несколько лет, но уже можно сделать вывод о том, что неуязвимых браузеров не бывает. До сих пор в каждом браузере находили ошибки, благодаря которым удаленный сервер имеет возможность получать о клиенте и его компьютере дополнительную информацию. Кто подходит к Интернету как потребители, защищаются пассивно путем своевременного обновления браузера. При первой возможности они заменяют его версию на более передовую, свободную от известных уязвимостей, хотя понимают, что неизвестные «дыры» в нем наверняка имеются.

Возможности программы Internet Explorer

ОС рассматривают компьютер как неотъемлемую часть Интернета. Первоочередное назначение программы – это просмотр Web-страниц. Полномасштабная работа в Сети требует использования и других возможностей обозревателя. Он позволяет загружать из Интернета произвольные файлы: программы, архивы и т. п. Передачей файлов через Интернет занимается служба FTP.
Обозреватель можно использовать и для навигации по файловой структуре автономного (не подключаясь к сети) компьютера. В этом случае он действует как проводник.

Связь Internet Explorer c другими стандартными программами системы Windows

Панель инструментов Internet Explorer

Панель инструментов программы Internet Explorer подразделяется на 3 группы:
1) служит для управления навигацией. Эти кнопки используют для перехода к предыдущей или следующей Web-страницы, для остановки загрузки страницы или для ее обновления, для перехода к основной Web-странице, которая по умолчанию появляется при запуске Internet Explorer;

2) Используют для открытия специальных панелей обозревателя. Эти панели позволяют проводить поиск нужной информации в Интернете, обеспечивают доступ к набору избранных Web-страницы, дают возможность вернуться к одной из недавно просматривавшихся страниц и использовать каналы.

3) Используют для выполнения служебных функций. Эти кнопки позволяют перейти в полноэкранный режим, отправить сообщение электронный почты, изменить шрифт или язык, распечатать Web-страницу на бумаге и отредактировать ее исходный текст с помощью заданного редактора Web-страниц.

Просмотр Web-страниц в Internet Explorer

В окне обозревателя отображается обычно одна Web-страница. Как правило Web-страницы представляют собой сложные комбинированные документы, содержащие как текстовую информацию, так и встроенные объекты. В качестве иллюстрации используют как изображения, так и звуки, видеоролики и другие объекты относящихся к мультимедиа. Разнообразие встроенных объектов постоянно увеличивается. По умолчанию обозреватель Internet Explorer воспринимает всю информацию, имеющуюся на Web-странице. Если же по какой-то причине отобразить включенные в Web-документ объекты не удается, программа помечает соответствующие места пустыми рамками или специальными знаками.

Гипертекстовые ссылки

Для перехода к заданной Web-странице достаточно ввести ее адрес в поле адреса и нажать на клавишу ENTER. Но ввод длинных адресов с помощью клавиатуры не только неудобен, но и чреват ошибками. При работе с Web-страницами имеется удобная возможность перехода без явного ввода адреса страницы. К счастью, большинство Web-документов содержат гипертекстовые ссылки или просто гиперссылки. В качестве такого объекта обычно выступает фрагмент текста, выделенный цветом и подчеркнутый, или графическая иллюстрация, выделенная цветной рамкой.

Пример графической гиперссылки

Графика и мультимедиа

Современное разнообразие Web-страниц и постоянное появление новых типов объектов, включаемых в их состав, приводит к тому, что средства просмотра Web-страниц не всегда могут правильно воспроизвести объекты. Первые броузеры были способны воспроизводить только текст. Проблемы воспроизведения на Web-страницах разнообразных видов объектов решается либо путем подключения дополнительных приложений, либо путем расширения возможностей обозревателя.

Загрузка файлов из Интернета

На серверах всемирной сети хранится множество файлов, представляющих массовый интерес. Это программы, архивы, справочные документы. Эти файлы могут храниться как на обычных Web-узлах, содержащих Web-страницы, так и на специальных узлах FTP, содержащих только файлы. Для приема файлов обозреватель Internet Explorer запускает Мастер загрузки файла. Первое, что надо сделать, - это выбрать, следует ли открывать указанный файл или сохранить его на локальном диске. Ход загрузки файла отображается в специальном диалоговом окне. В большинстве случаев это окно позволяет оценить продолжительность загрузки и отказаться от нее, если время загрузки окажется неприемлемым. Обозреватель Internet Explorer позволяет производить одновременную загрузку нескольких файлов, хотя надо понимать, что при приеме нескольких файлов скорость приема каждого файла пропорционально снижается.

Настройка свойств Обозревателя

Команда Вид>Свойства обозревателя открывает диалоговое окно Свойства обозревателя. Это диалоговое окно позволяет произвести все настройки, относящиеся к различным аспектам работы в Интернете.
1. Элементы управления вкладки Общее задают основные параметры работы программы. Здесь можно выбрать страницу, используемую в качестве основной.
2. Панель Временные файлы Интернета определяет срок хранения на HDD временных файлов, принятых из Интернета.
3. На панели Журнал указывают, как долго следует хранить информацию о посещенных Web-страницах

4. Вкладка Подключение позволяет изменить или заново настроить параметры соединения с Интернетом.
5. Другие вкладки обеспечивает специальные возможности настройки, использование которых может оказаться необходимым по указанию постановщика услуг Интернета.
6. Вкладка Программы позволяет выбрать программы, используемые для выполнения операций, недопустимых обычным средствам.


Содержание
Достоинства работы сетей
История возникновение сетей
Назначение сети. Основные функции сети.
Компоненты сети
ЛВС - назначение и типы
Топология локальной сети
Региональные и глобальные сети
Internet. Глобальные компьютерные сети
Виды предлогаемых услуг Internet
E-mail электронная почта
Outlook Express и его основные функции
Internet Explorer - основные функции и назначение
Телеконференции и другие возможности Internet
Установка сети
Этапы установки сети
Hardware необходимое для создания сети
Software или программное обеспечение, необходимое для инсталяции сетевых программных продуктов
Организация сети
Организация информации на сервере
Права доступа к файлам и каталогам. Организация систем защиты
Управление файлами, печатью
WWW – всемирная паутина. Web-сайт и его организация
Banner, гипертекст и другие понятия, используемые при создании Web страниц
Управеление сетью
Одно-ранговые сети
Сети с выделенным сервером
Поиск информации в Internet
Сетевой этикет и сетевая безопасность
Аппаратное обеспечение сетей Модем. Типы модемов и их назначение
Протоколы обмена данными в Internet. Пакетный режим пересылки информации в Internet
Host, Маршрутизатор, Мост и другие понятия в Internet


ТЕЛЕКОММУНИКАЦИОННЫЕ КОМПЬЮТЕРНЫЕ СЕТИ!

В этом разделе Вы узнаете :
что такое сеть?
какие сети бывают?
для чего они предназначены?
как они функционируют?
что нужно для их создания и работы?


HOME

E-MAIL

CREATORS

Учебное пособие
Компьютерные Телекоммуникационные Сети